IOS 12.0 pptp config with Nat (yet another person wants to know)

Discussion in 'Cisco' started by zonkerPro, Jan 13, 2005.

  1. zonkerPro

    zonkerPro Guest

    Sorry for posting this but the stuff I looked at really did not help.
    Sometimes I feel a little dense ; )

    I have a 2000 server behind a 1601r with ios 12.0 This router is doing
    NAT.

    I am trying to have the router simply pass thru the PPTP stuff to the
    win2k server so I can log into that with a VPN Client. I've checked the
    VPN server and it is allowing connections when not going thru the
    Cisco.

    I have 1723 forwarded but can't figure out the GRE.
    I am triing to come in on 199.104.99.99 (example address)

    any help would save me some sleep!

    Here is the config for anyone that would be so kind as to help:



    NMWA#show config
    Using 1585 out of 7506 bytes
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname NMWA

    !
    interface Ethernet0
    description connected to EthernetLAN
    ip address 192.168.0.1 255.255.255.0
    ip access-group 11 in
    no ip directed-broadcast
    ip nat inside


    !


    interface Serial0
    description connected to Internet
    ip address 199.104.xxx.yyy 255.255.255.192
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp


    !


    router rip
    version 2
    passive-interface Serial0
    network 192.168.0.0
    no auto-summary


    !


    ip nat pool NMWA-natpool-1 199.104.xxx.yyy 199.104.xxx.yyy netmask
    255.255.255.0
    ip nat inside source list 1 pool NMWA-natpool-1 overload
    ip nat inside source static tcp 192.168.0.200 1723 199.104.99.99 1723
    extendable

    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip http server


    !


    access-list 1 permit 192.168.0.0 0.0.0.255
    snmp-server community public RO
    snmp-server location Basement
    snmp-server contact Tom Wuthrich,307 690 8324,
    banner motd ^CWelcome to the NMWA Cisco 1601 Router^C


    !

    end
     
    zonkerPro, Jan 13, 2005
    #1
    1. Advertising

  2. zonkerPro

    ex-Zephion Guest

    zonkerPro wrote:
    > Sorry for posting this but the stuff I looked at really did not help.
    > Sometimes I feel a little dense ; )
    >
    > I have a 2000 server behind a 1601r with ios 12.0 This router is doing
    > NAT.
    >
    > I am trying to have the router simply pass thru the PPTP stuff to the
    > win2k server so I can log into that with a VPN Client. I've checked the
    > VPN server and it is allowing connections when not going thru the
    > Cisco.
    >
    > I have 1723 forwarded but can't figure out the GRE.
    > I am triing to come in on 199.104.99.99 (example address)
    >
    > any help would save me some sleep!
    >
    > Here is the config for anyone that would be so kind as to help:
    >
    >
    >
    > NMWA#show config
    > Using 1585 out of 7506 bytes
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname NMWA
    >
    > !
    > interface Ethernet0
    > description connected to EthernetLAN
    > ip address 192.168.0.1 255.255.255.0
    > ip access-group 11 in
    > no ip directed-broadcast
    > ip nat inside
    >
    >
    > !
    >
    >
    > interface Serial0
    > description connected to Internet
    > ip address 199.104.xxx.yyy 255.255.255.192
    > no ip directed-broadcast
    > ip nat outside
    > encapsulation ppp
    >
    >
    > !
    >
    >
    > router rip
    > version 2
    > passive-interface Serial0
    > network 192.168.0.0
    > no auto-summary
    >
    >
    > !
    >
    >
    > ip nat pool NMWA-natpool-1 199.104.xxx.yyy 199.104.xxx.yyy netmask
    > 255.255.255.0
    > ip nat inside source list 1 pool NMWA-natpool-1 overload
    > ip nat inside source static tcp 192.168.0.200 1723 199.104.99.99 1723
    > extendable
    >
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Serial0
    > ip http server
    >
    >
    > !
    >
    >
    > access-list 1 permit 192.168.0.0 0.0.0.255
    > snmp-server community public RO
    > snmp-server location Basement
    > snmp-server contact Tom Wuthrich,307 690 8324,
    > banner motd ^CWelcome to the NMWA Cisco 1601 Router^C
    >
    >
    > !
    >
    > end
    >

    Will this help?
    http://www.cisco.com/warp/public/471/pptp_pat.html
    Ben
     
    ex-Zephion, Jan 13, 2005
    #2
    1. Advertising

  3. zonkerPro

    zonkerPro Guest

    I saw that article when I was initially working on this. My situation
    is just the half that is the "router house" side of the diagram.

    In this example when they 'show ip nat translations' I don't understand
    how the gre lines where added. Without me understanding this better it
    doesn't really help yet.

    tw
     
    zonkerPro, Jan 13, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. zonkerPro
    Replies:
    0
    Views:
    402
    zonkerPro
    Jan 13, 2005
  2. Rogier Mulder
    Replies:
    1
    Views:
    3,014
    Walter Roberson
    Jan 13, 2005
  3. Mike Rahl
    Replies:
    1
    Views:
    1,292
    Trendkill
    May 30, 2007
  4. Elia Spadoni
    Replies:
    15
    Views:
    2,921
  5. lazy person wants A+

    , Oct 18, 2005, in forum: A+ Certification
    Replies:
    8
    Views:
    437
    Tom MacIntyre
    Oct 20, 2005
Loading...

Share This Page