intervlan routing and policy routing C3750 or C 4948

Discussion in 'Cisco' started by Sied@r, Oct 19, 2005.

  1. Sied@r

    Sied@r Guest

    Hi,

    I'm testing before I buy it cisco 3750G.(i'm thinking about 4948 to )

    I want use this switch as L3 router for my network.

    I want to keep intervlan routing on the switch (about 50 vlans with L3
    routing) and for some vlans i need different gateways.

    I tried to run policy routing on incoming vlan

    interface Vlan10
    ip address 10.10.10.1 255.255.255.128
    ip policy route-map test

    interface Vlan11
    ip address 10.10.10.129 255.255.255.128


    interface Vlan100
    ip address 200.200.200.1 255.255.255.252


    access-list 1300 permit 10.10.10.0 0.0.0.127
    route-map test permit 1300
    match ip address 1300
    set ip next-hop 200.200.200.2


    in this scenerio all packets from vlan 10 are policy routed to
    200.200.200.2. even traffic to vlan11.

    I want policy routing for packets that aren't in local routing table.

    I found on newsgroups
    "
    If you use "set ip next-hop" or "set interface," the precedence is: 1)
    route-map, 2) routing table. So if the interface specified in the
    route-map is up, or if the next-hop specified in the route-map appears
    in the routing table, then the packets will be routed according to the
    route-map set statement. If, on the other hand the next-hop is not in
    the routing table/interface is down, then the policy will be ignored and
    the packet will be routed according to the routing table (standard IOS
    routing).
    If you instead use "set ip default next-hop" or "set default interface,"
    the behavior is exact opposite. In this case, the precedence is: 1)
    routing table, 2) route-map. So if the destination matches anything in
    the routing table (including a default route), the route-map will never
    be used. If there is no match in the routing table for the dest IP,
    then the route-map will be used to forward the packet (assuming the
    specified next-hop appears in the routing table/specified interface is up).
    "

    but set ip default next-hop isn't CEF or Fastswitching operation for
    3750G or 4948

    for C 4500 ( I Think it will applay to 4948 - which is based on C4500)
    I found this:


    The Catalyst 4500 switching engine supports matching a "set next-hop"
    route-map action with a packet on a permit ACL. All other route-map
    actions, as well as matches of deny ACLs, are supported by a flow
    switching model. In this model, the first packet on a flow that matches
    a route-map will be delivered to the software for forwarding. Software
    determines the correct destination for the packet and installs an entry
    into the TCAM so that future packets on that flow are switched in
    hardware. The Catalyst 4500 switching engine supports a maximum of 4096
    flows


    for C 3750 I found this:

    IP PBR can now be fast-switched. Prior to Cisco IOS Release 12.0, PBR
    could only be process-switched, which meant that on most platforms the
    switching rate was approximately 1000 to 10,000 packets per second. This
    speed was not fast enough for many applications. Users who need PBR to
    occur at faster speeds can now implement PBR without slowing down the
    router.

    Fast-switched PBR supports all of the match commands and most of the set
    commands, with the following restrictions:

    * The set ip default next-hop and set default interface commands are
    not supported.
    * The set interface command is supported only over point-to-point
    links, unless a route-cache entry exists using the same interface
    specified in the set interface command in the route map. Also, at the
    process level, the routing table is consulted to determine if the
    interface is on a reasonable path to the destination. During fast
    switching, the software does not make this check. Instead, if the packet
    matches, the software blindly forwards the packet to the specified
    interface.



    -------------

    There is posibility to use intervlan routing and pbr for vlans to route
    outside local routing table via separate gateways (no default gateway)
    and do it in hardware ?

    Switch C3750G or C4948.

    Thanks a lot for any good informations

    siedar
    Sied@r, Oct 19, 2005
    #1
    1. Advertising

  2. W artykule <dj6htk$mnb$> Sied@r napisa³(a):

    > There is posibility to use intervlan routing and pbr for vlans to route
    > outside local routing table via separate gateways (no default gateway)
    > and do it in hardware ?


    You may tray to play with ip vrf.


    --
    Freedom violation: http://en1.policejnistat.cz/ , http://www.freetekno.org/
    Tomasz Paszkowski, Oct 20, 2005
    #2
    1. Advertising

  3. Sied@r

    Guest

    > I tried to run policy routing on incoming vlan

    I may be old fashioned however policy routing is
    in my view a band aid. I would be reluctant to
    consider it for a new design. Make that /very/
    reluctant. If someone is telling you that
    they must have the facility provided by it
    why not save a lot of trouble and
    get that new job now:)

    > into the TCAM so that future packets on that flow
    > are switched in hardware

    - The 4500 sounds reasonably promising.


    > but set ip default next-hop isn't CEF or Fastswitching
    > operation for 3750G or 4948


    It is not clear from this if they are talking about
    hardware or software based switching. This is deliberate
    on Cisco's part in the hope that you will buy it anyway.
    Fastswitching is DEFINATELY software so it
    would seem that in this case CEF is software
    which is unlikely to be any use to you.


    > or C 3750 I found this:
    >
    > IP PBR can now be fast-switched. Prior to Cisco IOS Release 12.0, PBR
    > could only be process-switched,


    Neither fast /nor/ process switching use hardware based
    IP routing. The performance will be terrible.


    Avoid PBR - Just don't do it.

    If you /must/ do it get your supplier to state
    in writing that the forwarding rate for PBR is xxxMpps
    where xxx is whatever is in the brochure for your
    chosen model. Get ready to sue.

    Finally I suspect that you will find that not
    many beta testers -oops- ^h^h... customers
    use PBR and so you will need to be on the look
    out for gremlins.

    /* Rant off */

    Have fun. - Sorry Vincent but I like that too.
    , Oct 20, 2005
    #3
  4. Sied@r

    Sied@r Guest

    Tomasz Paszkowski napisa³(a):
    > W artykule <dj6htk$mnb$> Sied@r napisa³(a):
    >
    >
    >>There is posibility to use intervlan routing and pbr for vlans to route
    >>outside local routing table via separate gateways (no default gateway)
    >>and do it in hardware ?

    >
    >
    > You may tray to play with ip vrf.
    >
    >

    How it works ? Are you use it ?
    Sied@r, Oct 20, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mamun Shaheed

    Problem in InterVLAN Routing

    Mamun Shaheed, Nov 29, 2003, in forum: Cisco
    Replies:
    2
    Views:
    631
  2. Peter
    Replies:
    2
    Views:
    4,680
    Walter Roberson
    Jan 6, 2004
  3. Grzegorz Polak
    Replies:
    1
    Views:
    1,444
    Robert
    Aug 10, 2005
  4. Omadon
    Replies:
    0
    Views:
    496
    Omadon
    Nov 6, 2005
  5. davidrwolf

    InterVLAN Routing and Trunks

    davidrwolf, Jul 26, 2006, in forum: Cisco
    Replies:
    0
    Views:
    715
    davidrwolf
    Jul 26, 2006
Loading...

Share This Page