Internet to a 2611 through a Linksys WRT54G

Discussion in 'Cisco' started by tony.dixson@gmail.com, Sep 14, 2006.

  1. Guest

    Hello I am trying to configure a Cisco 2611 router to connect to the
    internet using a Linksys WRT54G as a border router. The reason I would
    like to keep the linksys router on the outside of the Cisco router is
    to prevent wireless clients from accessing my internal network but
    allow them access to the internet. When I use the Config posted below
    I am able to ping both interfaces on the 2611, and both interfaces on
    the Linksys router out to the external interface but I am not able to
    get out to the internet. I am some what new to Cisco routers so any
    help with the Config would be much appreciated.

    The internal network IP is 192.168.x
    The network in between the Cisco router and Linksys router is 10.2.3.x
    with the internal interface on the Linksys router being 10.2.3.1 and
    the external interface on the Cisco router being 10.2.3.5
    The internet connection has a DHCP assigned address

    Using 896 out of 29688 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log daletime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    ip audit po max-events 100
    !
    !
    interface Ethernet0/0
    description WAN
    ip address 10.2.3.5 255.255.255.0
    ip nat outside
    full-duplex
    !
    interface Ethernet0/1
    description LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    full-duplex
    !
    ip nat pool crossbones 10.2.3.1 10.2.3.254 netmask 255.255.255.0
    ip nat inside source list 7 pool crossbones overload
    ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    !
    !
    access-list 7 permit 192.168.1.0 0.0.0.255
    access-list 7 permit 10.0.0.0 0.255.255.255
    dialer-list 1 protocol ip permit
    !
    !

    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end
     
    , Sep 14, 2006
    #1
    1. Advertising

  2. James Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    Do you have a route to the inside (192.168.1.0 255.255.255.0) network
    on the Linksys?

    James

    wrote:
    > Hello I am trying to configure a Cisco 2611 router to connect to the
    > internet using a Linksys WRT54G as a border router. The reason I would
    > like to keep the linksys router on the outside of the Cisco router is
    > to prevent wireless clients from accessing my internal network but
    > allow them access to the internet. When I use the Config posted below
    > I am able to ping both interfaces on the 2611, and both interfaces on
    > the Linksys router out to the external interface but I am not able to
    > get out to the internet. I am some what new to Cisco routers so any
    > help with the Config would be much appreciated.
    >
    > The internal network IP is 192.168.x
    > The network in between the Cisco router and Linksys router is 10.2.3.x
    > with the internal interface on the Linksys router being 10.2.3.1 and
    > the external interface on the Cisco router being 10.2.3.5
    > The internet connection has a DHCP assigned address
    >
    > Using 896 out of 29688 bytes
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log daletime msec
    > no service password-encryption
    > !
    > hostname Router
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > !
    > no aaa new-model
    > ip subnet-zero
    > ip cef
    > !
    > !
    > !
    > ip audit po max-events 100
    > !
    > !
    > interface Ethernet0/0
    > description WAN
    > ip address 10.2.3.5 255.255.255.0
    > ip nat outside
    > full-duplex
    > !
    > interface Ethernet0/1
    > description LAN
    > ip address 192.168.1.1 255.255.255.0
    > ip nat inside
    > full-duplex
    > !
    > ip nat pool crossbones 10.2.3.1 10.2.3.254 netmask 255.255.255.0
    > ip nat inside source list 7 pool crossbones overload
    > ip http server
    > no ip http secure-server
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    > !
    > !
    > access-list 7 permit 192.168.1.0 0.0.0.255
    > access-list 7 permit 10.0.0.0 0.255.255.255
    > dialer-list 1 protocol ip permit
    > !
    > !
    >
    > line con 0
    > line aux 0
    > line vty 0 4
    > login
    > !
    > !
    > end
     
    James, Sep 15, 2006
    #2
    1. Advertising

  3. James Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    Sorry ignore that you are NATing on the 2600.

    What happens if you change the default route on the 2600 to:-

    ip route 0.0.0.0 0.0.0.0 10.2.3.1

    wrote:
    > Hello I am trying to configure a Cisco 2611 router to connect to the
    > internet using a Linksys WRT54G as a border router. The reason I would
    > like to keep the linksys router on the outside of the Cisco router is
    > to prevent wireless clients from accessing my internal network but
    > allow them access to the internet. When I use the Config posted below
    > I am able to ping both interfaces on the 2611, and both interfaces on
    > the Linksys router out to the external interface but I am not able to
    > get out to the internet. I am some what new to Cisco routers so any
    > help with the Config would be much appreciated.
    >
    > The internal network IP is 192.168.x
    > The network in between the Cisco router and Linksys router is 10.2.3.x
    > with the internal interface on the Linksys router being 10.2.3.1 and
    > the external interface on the Cisco router being 10.2.3.5
    > The internet connection has a DHCP assigned address
    >
    > Using 896 out of 29688 bytes
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log daletime msec
    > no service password-encryption
    > !
    > hostname Router
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > !
    > no aaa new-model
    > ip subnet-zero
    > ip cef
    > !
    > !
    > !
    > ip audit po max-events 100
    > !
    > !
    > interface Ethernet0/0
    > description WAN
    > ip address 10.2.3.5 255.255.255.0
    > ip nat outside
    > full-duplex
    > !
    > interface Ethernet0/1
    > description LAN
    > ip address 192.168.1.1 255.255.255.0
    > ip nat inside
    > full-duplex
    > !
    > ip nat pool crossbones 10.2.3.1 10.2.3.254 netmask 255.255.255.0
    > ip nat inside source list 7 pool crossbones overload
    > ip http server
    > no ip http secure-server
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    > !
    > !
    > access-list 7 permit 192.168.1.0 0.0.0.255
    > access-list 7 permit 10.0.0.0 0.255.255.255
    > dialer-list 1 protocol ip permit
    > !
    > !
    >
    > line con 0
    > line aux 0
    > line vty 0 4
    > login
    > !
    > !
    > end
     
    James, Sep 15, 2006
    #3
  4. VeeDub Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    Yes, I would agree with James that you first should look at the default
    route and use a next hop as opposed to an interface (e0/0). Interface
    in my experience should only be used on point-to-point links not
    multiaccess links like what you have in this case (ethernet). In
    addition to this, do you need to have an address pool for your NATing
    if you are overloading? Could you not just use the "interface" keyword
    so that all devices behind the 2600 at NATed to the IP of the external
    2600 interface. Could test this by putting a computer on the network
    between th 2600 and Linksys and set up a web server on it. See if you
    can browse this serve then atleast. This will test your NATing, and
    client default gateways etc are correct.




    James wrote:
    > Sorry ignore that you are NATing on the 2600.
    >
    > What happens if you change the default route on the 2600 to:-
    >
    > ip route 0.0.0.0 0.0.0.0 10.2.3.1
    >
    > wrote:
    > > Hello I am trying to configure a Cisco 2611 router to connect to the
    > > internet using a Linksys WRT54G as a border router. The reason I would
    > > like to keep the linksys router on the outside of the Cisco router is
    > > to prevent wireless clients from accessing my internal network but
    > > allow them access to the internet. When I use the Config posted below
    > > I am able to ping both interfaces on the 2611, and both interfaces on
    > > the Linksys router out to the external interface but I am not able to
    > > get out to the internet. I am some what new to Cisco routers so any
    > > help with the Config would be much appreciated.
    > >
    > > The internal network IP is 192.168.x
    > > The network in between the Cisco router and Linksys router is 10.2.3.x
    > > with the internal interface on the Linksys router being 10.2.3.1 and
    > > the external interface on the Cisco router being 10.2.3.5
    > > The internet connection has a DHCP assigned address
    > >
    > > Using 896 out of 29688 bytes
    > > !
    > > version 12.3
    > > service timestamps debug datetime msec
    > > service timestamps log daletime msec
    > > no service password-encryption
    > > !
    > > hostname Router
    > > !
    > > boot-start-marker
    > > boot-end-marker
    > > !
    > > !
    > > no aaa new-model
    > > ip subnet-zero
    > > ip cef
    > > !
    > > !
    > > !
    > > ip audit po max-events 100
    > > !
    > > !
    > > interface Ethernet0/0
    > > description WAN
    > > ip address 10.2.3.5 255.255.255.0
    > > ip nat outside
    > > full-duplex
    > > !
    > > interface Ethernet0/1
    > > description LAN
    > > ip address 192.168.1.1 255.255.255.0
    > > ip nat inside
    > > full-duplex
    > > !
    > > ip nat pool crossbones 10.2.3.1 10.2.3.254 netmask 255.255.255.0
    > > ip nat inside source list 7 pool crossbones overload
    > > ip http server
    > > no ip http secure-server
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    > > !
    > > !
    > > access-list 7 permit 192.168.1.0 0.0.0.255
    > > access-list 7 permit 10.0.0.0 0.255.255.255
    > > dialer-list 1 protocol ip permit
    > > !
    > > !
    > >
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > login
    > > !
    > > !
    > > end
     
    VeeDub, Sep 15, 2006
    #4
  5. Merv Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    what are you NATing on the 2600 ?
     
    Merv, Sep 15, 2006
    #5
  6. Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    Merv wrote:
    > what are you NATing on the 2600 ?

    I have several workstations behind the 2600, I also have a web server
    that I will be using for personal use, but would like to get to it from
    the internet as well as RDP on that server. My plan is also to use NAT
    and access lists to allow only my wifes and my laptop wireless access
    back through the 2600 to access our internal resources, but I would
    like all other wireless clients to only have access to the internet;
    however for now if I can just get internet up I would be happy. I am
    able to access the internet with my wireless clients who connect
    directly to the Linksys. I can also get to the web page that is served
    by the linksys router for configuration from behind the 2600. I will
    try changing the default route tonigt to see if that helps. I have
    several docs for setting up a 2600 to connect to the internet through a
    cable modem, all of them differ a bit but none of them have a NAT pool
    configured. Thanks for giving me some idea's on this.
     
    , Sep 15, 2006
    #6
  7. Merv Guest

    Re: Internet to a 2611 through a Linksys WRT54G

    AFAIK the Linksys WRT54G is capable of perform dynamic routing ( needs
    to be enabled) so I would try that out.

    It undoubleted use RIP

    so config RIP routing on the 2611
    config t
    router rip
    network 10.0.0.0
    end

    wri mem


    Then disable NAT on 2611 and see if WRT54G will perform NAT based on
    dynamically learned networks ie your LAN behind teh 2611. If so then
    you will not need to configure NAT on 2611 which would result in double
    NATting
     
    Merv, Sep 16, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David Lipetz
    Replies:
    2
    Views:
    2,405
    David Lipetz
    Aug 26, 2004
  2. Marcel Bernards
    Replies:
    4
    Views:
    4,767
    Marcel Bernards
    Sep 11, 2004
  3. David Lipetz
    Replies:
    20
    Views:
    3,035
    Chris H.
    Sep 7, 2004
  4. Replies:
    7
    Views:
    25,653
  5. Replies:
    3
    Views:
    1,226
Loading...

Share This Page