Inter VLAN Routing.

Discussion in 'Cisco' started by Mamun Shaheed, Oct 22, 2003.

  1. Hi,
    I have one cisco 2950 XL switch (Model WS-C2950) and one cisco 2621XM
    Router. I want to configure 4 VLAN on that switch and configure
    interVLAN Routing on that router. I will use 802.1q for trunking.
    Is it posible. If yes, can any one send me a sample configuration.

    ~MS
    Mamun Shaheed, Oct 22, 2003
    #1
    1. Advertising

  2. Mamun Shaheed

    John Gill Guest

    Yes it is possible, here is a sample config using FA 0/5 as the trunk port
    and all vlans are allowed through the trunk up to the router. I made vlans
    10, 20, 30, 40.

    vlan database
    vtp server
    vtp domain [name of your vtp domain]
    vlan 10 name vlan1
    vlan 20 name vlan2
    vlan 30 name vlan3
    vlan 40 name vlan4
    exit
    !
    config t
    !
    hostname DistributionSwitch1
    !
    interface FastEthernet0/1
    description Link to vlan 10 (Host)
    switchport access vlan 10
    switchport mode access
    no ip address
    no shut
    !
    interface FastEthernet0/2
    description Link to vlan 20 (Host)
    switchport access vlan 20
    switchport mode access
    no ip address
    no shut
    !
    interface FastEthernet0/3
    description Link to vlan 30 (Host)
    switchport access vlan 30
    switchport mode access
    no ip address
    no shut
    !
    interface FastEthernet0/4
    description Link to vlan 40 (Host)
    switchport access vlan 40
    switchport mode access
    no ip address
    no shut
    !
    interface FastEthernet0/5
    description Trunk to router
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no shutdown
    !
    interface Vlan1
    description MANAGEMENT VLAN
    ip address 10.0.1.1 255.255.255.0
    no shut

    interface Vlan10
    ip address 10.0.10.1 255.255.255.0
    no shut
    !
    interface Vlan20
    ip address 10.0.20.1 255.255.255.0
    no shut
    !
    interface Vlan30
    ip address 10.0.30.1 255.255.255.0
    no shut
    !
    interface Vlan40
    ip address 10.0.40.1 255.255.255.0
    no shut

    Then on the actual hosts, make sure their ip addresses are in the vlan
    network you specified on the switch.

    Bring up your ethernet interface connected to the switch, make sure it is up
    and you can see the switch in cdp neighbors.

    The router will need to have a routing protocol, say OSPF, running on the
    network of the vlans you want to route.

    router ospf 200
    network 10.0.0.0 0.255.255.255 area 0
    exit

    I believe that is all you need unless I am forgetting something at the
    moment. Let me know how this goes.

    -John

    "Mamun Shaheed" <> wrote in message
    news:...
    > Hi,
    > I have one cisco 2950 XL switch (Model WS-C2950) and one cisco 2621XM
    > Router. I want to configure 4 VLAN on that switch and configure
    > interVLAN Routing on that router. I will use 802.1q for trunking.
    > Is it posible. If yes, can any one send me a sample configuration.
    >
    > ~MS
    John Gill, Oct 22, 2003
    #2
    1. Advertising

  3. Hi,

    First of all, you need IP Plus featurepack on the 2621XM router to support
    trunking.

    Configure the following on the switch:

    interface fastethernet 0/1
    speed 100
    duplex full
    switchport mode trunk
    !
    interface fastethernet 0/2
    switchport access vlan 1
    !
    interface fastethernet 0/3
    switchport access vlan 2
    !
    interface fastethernet 0/4
    switchport access vlan 3
    !
    interface fastethernet 0/5
    switchport access vlan 4
    !

    On the router configure:

    interface fastethernet0/0
    speed 100
    full-duplex
    no ip address
    !
    interface fastethernet0/0.1
    encapsulation dot1q 1 [native]
    ip address 10.0.1.0 255.255.255.0
    !
    interface fastethernet0/0.2
    encapsulation dot1q 2
    ip address 10.0.2.0 255.255.255.0
    !
    interface fastethernet0/0.3
    encapsulation dot1q 3
    ip address 10.0.3.0 255.255.255.0
    !
    interface fastethernet0/0.4
    encapsulation dot1q 4
    ip address 10.0.4.0 255.255.255.0
    !

    And you should be fine

    Erik

    "Mamun Shaheed" <> wrote in message
    news:...
    > Hi,
    > I have one cisco 2950 XL switch (Model WS-C2950) and one cisco 2621XM
    > Router. I want to configure 4 VLAN on that switch and configure
    > interVLAN Routing on that router. I will use 802.1q for trunking.
    > Is it posible. If yes, can any one send me a sample configuration.
    >
    > ~MS
    Erik Tamminga, Oct 22, 2003
    #3
  4. "John Gill" <> wrote:
    >The router will need to have a routing protocol, say OSPF, running on the
    >network of the vlans you want to route.


    No need for that. Static routing works fine too.

    >I believe that is all you need unless I am forgetting something at the


    You need a subinterface for each VLAN configured on the router's
    Ethernet interface, with the appropriate "encapsulation" command.
    And the router must run an IP Plus image to begin with.

    --
    Tilman Schmidt E-Mail:
    Bonn, Germany
    - In theory, there is no difference between theory and practice.
    In practice, there is.
    Tilman Schmidt, Oct 22, 2003
    #4
  5. Mamun Shaheed

    Andre Beck Guest

    "John Gill" <> writes:
    > !
    > interface Vlan1
    > description MANAGEMENT VLAN
    > ip address 10.0.1.1 255.255.255.0
    > no shut
    >
    > interface Vlan10
    > ip address 10.0.10.1 255.255.255.0
    > no shut
    > !
    > interface Vlan20
    > ip address 10.0.20.1 255.255.255.0
    > no shut
    > !
    > interface Vlan30
    > ip address 10.0.30.1 255.255.255.0
    > no shut
    > !
    > interface Vlan40
    > ip address 10.0.40.1 255.255.255.0
    > no shut


    You're sure that this is still speaking of a 2950? I'm doing this all
    the day on 3550s, 3750s, Cat4ks with SupIV and Cat6ks with MSFC2, but
    I was under the impression that 2950s - even the EI ones - just choke
    when given "ip routing" or more than one EtherSVI "vlan x" commands.
    They are L2 switches, after all. But if I'm missing something and there
    are 2950s that actually can route, please detail. Would be a bargain.

    Making the 2621 a "router on a stick", using one trunk to the switch,
    as already described in the other followups, is IMO the only solution
    as long as the 2950 didn't become an L3 switch over night (which may
    happen, as I neither know the exact ASICs they use nor the exact plans
    Cisco have for their IOS an that platform).

    --
    The _S_anta _C_laus _O_peration
    or "how to turn a complete illusion into a neverending money source"

    -> Andre "ABPSoft" Beck +++ ABP-RIPE +++ Dresden, Germany, Spacetime <-
    Andre Beck, Oct 26, 2003
    #5
  6. Mamun Shaheed

    shakeel

    Joined:
    Dec 15, 2007
    Messages:
    1
    default-gateway

    Anyone plz. tell me, y default-gateway is not configured on the switch. i'm reading cisco press icnd1, he writes this command in Global config mode "ip default-gateway a.b.c.d".
    thanks.
    shakeel, Dec 15, 2007
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Gill

    Re: Inter VLAN Routing

    John Gill, Oct 27, 2003, in forum: Cisco
    Replies:
    4
    Views:
    4,375
    Andre Beck
    Nov 1, 2003
  2. Damo
    Replies:
    8
    Views:
    6,623
  3. FeatureBug
    Replies:
    3
    Views:
    14,579
    Ivan Ostres
    Sep 3, 2004
  4. Amy L.
    Replies:
    1
    Views:
    7,228
    Barry Margolin
    Sep 7, 2004
  5. JohnD
    Replies:
    3
    Views:
    4,189
    stephen
    Dec 18, 2007
Loading...

Share This Page