inter vlan routing - What am I doing wrong?

Discussion in 'Cisco' started by Joel M. Baldwin, Dec 15, 2004.

  1. I've been trying to get a test setup working to verify a
    configuration using VLANS before implementing it full scale.

    I'm glad I tried it first because it ISN'T working! :(


    Diagram of the setup:
    > _______________
    > | 3750Core1 |
    > ---------------
    > Gi1/0/5 | | Gi1/0/8
    > _____________| |_______________
    > Gi0/2 | | Gi0/2
    > | |
    > ------------------ ------------------
    >| 2950Switch05 | | 2950Switch07 |
    > ------------------ ------------------
    > Fa0/44 | | Fa0/46 Fa0/31 | | Fa0/33
    > vlan 5 | | vlan 10 vlan 5 | | vlan 10
    > | | | |
    > PC PC PC PC




    Portions of a 'show run' on the 3750
    which is running Version 12.1(19)EA1c:

    > hostname 3750Core1
    > ip subnet-zero
    > ip routing
    > ip classless
    > interface GigabitEthernet1/0/5
    > description Gig Ether to %%Switch05%%
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,5,10
    > switchport mode trunk
    > no ip address
    > !
    > interface GigabitEthernet1/0/8
    > description Gig Ether to %%Switch08%%
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,5,10
    > switchport mode trunk
    > no ip address
    > !
    > interface Vlan5
    > ip address 192.168.5.253 255.255.255.0
    > !
    > interface Vlan10
    > ip address 192.168.10.253 255.255.255.0
    > !
    > ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.254


    Some other commands:

    > 3750Core1#show ip route
    > C 192.168.10.0/24 is directly connected, Vlan10
    > C 192.168.5.0/24 is directly connected, Vlan5
    >
    > 3750Core1#show mac add vlan 5
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 5 0004.5a08.b59b DYNAMIC Gi1/0/8
    > 5 00e0.988c.b5b6 DYNAMIC Gi1/0/5
    >
    > 3750Core1#show mac add vlan 10
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 10 00e0.988c.b5d2 DYNAMIC Gi1/0/8
    > 10 00e0.b849.498a DYNAMIC Gi1/0/5
    > Total Mac Addresses for this criterion: 23
    >
    > 3750Core1#show ip arp vlan 5
    > Protocol Address Age (min) Hardware Addr Type Interface
    > Internet 192.168.5.1 3 0004.5a08.b59b ARPA Vlan5
    > Internet 192.168.5.2 5 00e0.988c.b5b6 ARPA Vlan5
    > Internet 192.168.5.253 - 000d.ed4f.bd45 ARPA Vlan5
    > 3750Core1#show ip arp vlan 10
    > Protocol Address Age (min) Hardware Addr Type Interface
    > Internet 192.168.10.2 0 00e0.b849.498a ARPA Vlan10
    > Internet 192.168.10.1 6 00e0.988c.b5d2 ARPA Vlan10
    > Internet 192.168.10.253 - 000d.ed4f.bd46 ARPA Vlan10


    This all looks right, Both L2 and L3 should be working. ( but aren't :( )




    Portions of a 'show run' on 2950Switch05
    which is running Version 12.1(20)EA1:

    > hostname Switch05_1
    > ip subnet-zero
    > interface FastEthernet0/44
    > switchport access vlan 5
    > switchport mode access
    > spanning-tree portfast
    > !
    > interface FastEthernet0/46
    > switchport access vlan 10
    > switchport mode access
    > spanning-tree portfast
    > !
    > interface GigabitEthernet0/2
    > description Gig Ether to %%3750Core1%%
    > switchport trunk allowed vlan 1,5,10
    > switchport trunk pruning vlan none
    > switchport mode trunk
    > switchport nonegotiate


    Some other commands:

    > Switch05_1#show mac ad vlan 5
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 5 0004.5a08.b59b DYNAMIC Gi0/2
    > 5 000d.ed4f.bd05 DYNAMIC Gi0/2
    > 5 000d.ed4f.bd45 DYNAMIC Gi0/2
    > 5 00e0.988c.b5b6 DYNAMIC Fa0/44
    > Total Mac Addresses for this criterion: 8
    > Switch05_1#show mac ad vlan 10
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 10 000d.ed4f.bd05 DYNAMIC Gi0/2
    > 10 000d.ed4f.bd46 DYNAMIC Gi0/2
    > 10 00e0.988c.b5d2 DYNAMIC Gi0/2
    > 10 00e0.b849.498a DYNAMIC Fa0/46
    > Total Mac Addresses for this criterion: 8
    >
    > Switch05_1#show ip arp
    > Protocol Address Age (min) Hardware Addr Type Interface
    > Internet 192.168.10.2 63 000f.2452.ac00 ARPA Vlan1
    > Internet 192.168.10.1 63 000d.ed4f.bd40 ARPA Vlan1
    > Internet 192.168.5.1 66 000f.2452.ac00 ARPA Vlan1
    > Internet 192.168.5.2 65 000f.2452.ac00 ARPA Vlan1


    L2 looks good, but L3 doesn't!?




    Portions of a 'show run' on 2950Switch08
    which is running Version 12.1(20)EA1:

    > hostname Switch08_1
    > ip subnet-zero
    > !
    > interface FastEthernet0/31
    > switchport access vlan 5
    > switchport mode access
    > spanning-tree portfast
    > !
    > interface FastEthernet0/33
    > switchport access vlan 10
    > switchport mode access
    > spanning-tree portfast
    > !
    > interface GigabitEthernet0/2
    > description Gig Ether to %%3750Core1%%
    > switchport trunk allowed vlan 1,5,10
    > switchport trunk pruning vlan none
    > switchport mode trunk
    > switchport nonegotiate


    Some other commands:

    > Switch08_1#show mac ad vlan 5
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 5 0004.5a08.b59b DYNAMIC Fa0/31
    > 5 000d.ed4f.bd08 DYNAMIC Gi0/2
    > 5 000d.ed4f.bd45 DYNAMIC Gi0/2
    > 5 00e0.988c.b5b6 DYNAMIC Gi0/2
    > Total Mac Addresses for this criterion: 8
    >
    > Switch08_1#show mac ad vlan 10
    > Mac Address Table
    > -------------------------------------------
    > Vlan Mac Address Type Ports
    > ---- ----------- -------- -----
    > 10 000d.ed4f.bd08 DYNAMIC Gi0/2
    > 10 000d.ed4f.bd46 DYNAMIC Gi0/2
    > 10 00e0.988c.b5d2 DYNAMIC Fa0/33
    > 10 00e0.b849.498a DYNAMIC Gi0/2
    > Total Mac Addresses for this criterion: 8
    >
    > Switch08_1#show ip arp
    > Protocol Address Age (min) Hardware Addr Type Interface
    > Internet 192.168.10.2 227 000f.2452.ac00 ARPA Vlan1
    > Internet 192.168.10.1 227 000d.ed4f.bd40 ARPA Vlan1
    > Internet 192.168.5.1 227 000f.2452.ac00 ARPA Vlan1
    > Internet 192.168.5.2 227 000f.2452.ac00 ARPA Vlan1


    Again, L2 looks good, but L3 doesn't!?





    The only PC that seems to be able to be pinged is the *.10.2 machine.



    > 3750Core1#ping 192.168.5.1
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
    > .....
    > Success rate is 0 percent (0/5)
    > 3750Core1#ping 192.168.5.2
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.5.2, timeout is 2 seconds:
    > .....
    > Success rate is 0 percent (0/5)
    > 3750Core1#ping 192.168.10.1
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
    > .....
    > Success rate is 0 percent (0/5)
    > 3750Core1#ping 192.168.10.2
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
    > !!!!!
    > Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    > 3750Core1#exit
    >
    > Switch05_1#ping 192.168.5.1
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
    > U.U.U
    > Success rate is 0 percent (0/5)
    > Switch05_1#ping 192.168.5.2
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.5.2, timeout is 2 seconds:
    > U.U.U
    > Success rate is 0 percent (0/5)
    > Switch05_1#ping 192.168.10.1
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
    > .....
    > Success rate is 0 percent (0/5)
    > Switch05_1#ping 192.168.10.2
    >
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
    > U.U.U
    > Success rate is 0 percent (0/5)
    > Switch05_1#





    Am I missing something obvious?


    ADVthaAnksNCE
     
    Joel M. Baldwin, Dec 15, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mamun Shaheed

    Inter VLAN Routing.

    Mamun Shaheed, Oct 22, 2003, in forum: Cisco
    Replies:
    5
    Views:
    22,805
    shakeel
    Dec 15, 2007
  2. John Gill

    Re: Inter VLAN Routing

    John Gill, Oct 27, 2003, in forum: Cisco
    Replies:
    4
    Views:
    4,412
    Andre Beck
    Nov 1, 2003
  3. Damo
    Replies:
    8
    Views:
    6,692
  4. FeatureBug
    Replies:
    3
    Views:
    14,724
    Ivan Ostres
    Sep 3, 2004
  5. JohnD
    Replies:
    3
    Views:
    4,329
    stephen
    Dec 18, 2007
Loading...

Share This Page