integrating new 3550 with routing into existing routing structure?

Discussion in 'Cisco' started by joeblow, Mar 1, 2005.

  1. joeblow

    joeblow Guest

    Greetings all,

    I've got six 3550-24 switches with three vlans vlan_a vlan_b and vlan_c
    set up across all six 3550s. They are interconnected with gigabit fiber.

    Vlan_a 10.77.11.0/24
    Vlan_b 192.168.11.0/24
    Vlan_c 192.168.0.0/24

    Up until recently we had a router (cisco, not sure what model, but old)
    that was connected between vlan_a and vlan_b (vlan_c is separate, and
    does not factor into this question) and handled routing between the two,
    as well as to the rest of the network.

    Eth0 on the router is 10.77.11.1
    Eth2 on the router is 192.168.11.1

    Both of these ip’s are the gateways for the hosts on their respective
    subnets.

    So a host on vlan_a needs to talk to a host on vlan_b, it sends it’s
    packets out of the box, to the router’s eth0, out the router’s eth2
    back to the 3550 to vlan_b, and vice versa.

    If a host on vlan_a needs to talk to somewhere else, the packet goes out
    of the 3550, up to the router’s eth0, and out one of the router’s
    other ports to wherever.

    I recently got a 3550 with the routing capability. So for various
    reasons, I want to use the 3550 routing to route between vlan_a and
    vlan_b.

    I understand how to do this is to make the vlan_a the subnet’s gateway
    by assigning it the ip of the subnet’s gateway 10.77.11.1.

    Ditto for vlan_b 192.168.11.1

    A few more route and network statements, and presto chango, 3550 is
    routing between 10.77.11.0 and 192.168.11.0. I’ve got that working.

    But now, I’m kinda stuck.

    1. How do I integrate this into the rest of the network, so that packets
    not destined for 10.77.11.0 or 192.168.11.0 go where they are supposed to
    go?

    2. What do I do with the old router’s ip addresses on the eth0 and
    eth2, the previous gateway addresses? I’m assuming I can still leave
    them plugged into their respective cat 5 ports (router eth0 to some 3550
    port on vlan_a, router port eth2 to some 3550 port on vlan_b) to provide
    physical connectivity, but what do I do with the router’s ip’s. Now
    there are two 10.77.11.1 and 192.168.11.1, which I’m pretty sure is a
    bad thing...8)

    I think I’ve probably described this badly, and I apologize. If I can
    clarify, just ask. And I’m sure this is a common problem with an easy
    solution. But I’m stumped. Any pointers? Thanks in advance!
    joeblow, Mar 1, 2005
    #1
    1. Advertising

  2. Hi,

    I would configure the network you describe like this:
    (Pre-condition; all switches already know vlan-a,b and c in their
    vlan-databases.
    commands to do this:
    - vlan database
    vlan 1 name vlan-a
    vlan 2 name vlan-b
    vlan 3 name vlan-c

    - Switch A:
    ip routing
    interface vlan1
    description vlan-a, gateway interface for hosts on vlan-a
    ip address 10.77.11.1 255.255.255.0
    no shutdown
    interface vlan2
    description vlan-b, gateway interface for hosts on vlan-b
    ip address 192.168.11.1 255.255.255.0
    no shutdown
    interface FastEthernet0/1
    switchport mode access
    switchport access vlan 1
    interface FastEthernet0/2
    description ToRouter
    switchport mode access
    switchport access vlan 1
    ...
    interface FastEthernet0/23
    switchport mode access
    switchport access vlan 2
    interface FastEthernet0/24
    switchport mode access
    switchport access vlan 2
    interface GigabitEthernet0/1
    switchport mode trunk
    ip route 0.0.0.0 0.0.0.0 10.77.11.2 ! Direct everything else to the
    router (which is using 10.77.11.2)

    Switch B / C / D / E / F:
    Like switch A, but without the virtual Vlan interfaces. You can
    leave one of them there if you want, for management purposes, but use
    different addresses!. Also don't enable "ip routing"".

    Router:
    interface ethernet0
    description ToSwitchA
    ip address 10.77.11.2 255.255.255.0
    interface ethernet1
    description To Vlan-C
    ip address 192.168.0.1 255.255.255.0 ! Don't specify IP adres and
    shutdown interface if you want to keep vlan-c isolated.
    interface ethernet2
    shutdown ! You don't have to use this port anymore, routing to
    vlan-b is done by switch.
    no ip address
    ip route 192.168.11.0 255.255.255.0 10.77.11.1 ! Direct traffic for
    192.168.11.x to switchA

    Leave the router's default gateway like it is if you have more networks
    that are already connected to this router.

    Hope this is sufficient!?

    Erik

    "joeblow" <> wrote in message
    news:p...
    > Greetings all,
    >
    > I've got six 3550-24 switches with three vlans vlan_a vlan_b and vlan_c
    > set up across all six 3550s. They are interconnected with gigabit fiber.
    >
    > Vlan_a 10.77.11.0/24
    > Vlan_b 192.168.11.0/24
    > Vlan_c 192.168.0.0/24
    >
    > Up until recently we had a router (cisco, not sure what model, but old)
    > that was connected between vlan_a and vlan_b (vlan_c is separate, and
    > does not factor into this question) and handled routing between the two,
    > as well as to the rest of the network.
    >
    > Eth0 on the router is 10.77.11.1
    > Eth2 on the router is 192.168.11.1
    >
    > Both of these ip's are the gateways for the hosts on their respective
    > subnets.
    >
    > So a host on vlan_a needs to talk to a host on vlan_b, it sends it's
    > packets out of the box, to the router's eth0, out the router's eth2
    > back to the 3550 to vlan_b, and vice versa.
    >
    > If a host on vlan_a needs to talk to somewhere else, the packet goes out
    > of the 3550, up to the router's eth0, and out one of the router's
    > other ports to wherever.
    >
    > I recently got a 3550 with the routing capability. So for various
    > reasons, I want to use the 3550 routing to route between vlan_a and
    > vlan_b.
    >
    > I understand how to do this is to make the vlan_a the subnet's gateway
    > by assigning it the ip of the subnet's gateway 10.77.11.1.
    >
    > Ditto for vlan_b 192.168.11.1
    >
    > A few more route and network statements, and presto chango, 3550 is
    > routing between 10.77.11.0 and 192.168.11.0. I've got that working.
    >
    > But now, I'm kinda stuck.
    >
    > 1. How do I integrate this into the rest of the network, so that packets
    > not destined for 10.77.11.0 or 192.168.11.0 go where they are supposed to
    > go?
    >
    > 2. What do I do with the old router's ip addresses on the eth0 and
    > eth2, the previous gateway addresses? I'm assuming I can still leave
    > them plugged into their respective cat 5 ports (router eth0 to some 3550
    > port on vlan_a, router port eth2 to some 3550 port on vlan_b) to provide
    > physical connectivity, but what do I do with the router's ip's. Now
    > there are two 10.77.11.1 and 192.168.11.1, which I'm pretty sure is a
    > bad thing...8)
    >
    > I think I've probably described this badly, and I apologize. If I can
    > clarify, just ask. And I'm sure this is a common problem with an easy
    > solution. But I'm stumped. Any pointers? Thanks in advance!
    Erik Tamminga, Mar 2, 2005
    #2
    1. Advertising

  3. joeblow

    joeblow Guest

    Thanks!

    That's kinda what I suspected. This has to be a common problem, but I
    could not decide whether to :

    1. do it like you described, or

    2. no ip the router ethernet0

    interface ethernet0
    description ToSwitchA
    no ip address

    and then

    switch A:
    ip route 0.0.0.0 0.0.0.0 Gi 0/1.

    That is, send the default route out a port, rather than a destination ip.

    or

    3. Something incredibly easy that I was completely missing.

    And as I said, this has got to be a common problem, so I was wanting to
    know what best practices are.

    Thanks again.
    --------------------------------------


    On Wed, 02 Mar 2005 21:55:46 +0100, Erik Tamminga wrote:

    > Hi,
    >
    > I would configure the network you describe like this:
    > (Pre-condition; all switches already know vlan-a,b and c in their
    > vlan-databases.
    > commands to do this:
    > - vlan database

    <snip>
    joeblow, Mar 8, 2005
    #3
  4. joeblow

    Philip D'Ath Guest

    Only use routing via an interface when it is a point to point link (as
    in, there is only one person on the other end). Otherwise always route
    via an IP.

    Follow this rule and it will hold you in good stead.

    joeblow wrote:
    > Thanks!
    >
    > That's kinda what I suspected. This has to be a common problem, but I
    > could not decide whether to :
    >
    > 1. do it like you described, or
    >
    > 2. no ip the router ethernet0
    >
    > interface ethernet0
    > description ToSwitchA
    > no ip address
    >
    > and then
    >
    > switch A:
    > ip route 0.0.0.0 0.0.0.0 Gi 0/1.
    >
    > That is, send the default route out a port, rather than a destination ip.
    >
    > or
    >
    > 3. Something incredibly easy that I was completely missing.
    >
    > And as I said, this has got to be a common problem, so I was wanting to
    > know what best practices are.
    >
    > Thanks again.
    > --------------------------------------
    >
    >
    > On Wed, 02 Mar 2005 21:55:46 +0100, Erik Tamminga wrote:
    >
    >
    >>Hi,
    >>
    >>I would configure the network you describe like this:
    >>(Pre-condition; all switches already know vlan-a,b and c in their
    >>vlan-databases.
    >>commands to do this:
    >>- vlan database

    >
    > <snip>
    Philip D'Ath, Mar 14, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. gwtc
    Replies:
    1
    Views:
    1,229
    Teh Suck
    Dec 14, 2005
  2. Teh Suck
    Replies:
    0
    Views:
    566
    Teh Suck
    Dec 13, 2005
  3. ufo_hk
    Replies:
    4
    Views:
    339
    Dave Taylor
    Jan 22, 2004
  4. Alan
    Replies:
    6
    Views:
    375
    Gordon
    Jun 25, 2009
  5. Rhino
    Replies:
    7
    Views:
    419
    Lawrence D'Oliveiro
    Jun 24, 2009
Loading...

Share This Page