ima UP and Running but errors on single atm

Discussion in 'Cisco' started by Francesco Lugari Q&S, Sep 27, 2004.

  1. Hi,

    I have a Cisco 3725 with ima interface

    i have to 2Mb lines and I try to configure it to use with ima channel of
    4Mb.

    now Ima is operational but if i start ATM Debug system reply me this error.

    Sep 27 11:44:39.847: ATM(ATM0/0): ATM not active yet
    Sep 27 11:44:39.847: ATM(ATM0/1): ATM not active yet
    Sep 27 11:44:39.847: ATM(ATM0/0): ATM not active yet
    Sep 27 11:44:39.847: ATM(ATM0/1): ATM not active yet

    this error is replicated every 1 minute.

    i don't know why, anyone have a solution?

    bye
    Francesco
     
    Francesco Lugari Q&S, Sep 27, 2004
    #1
    1. Advertising

  2. Francesco Lugari Q&S

    mh Guest

    1 post your config

    2 post output of "sh controller atm x/y" for all atm interfaces im IMA group

    3 post output of "show controllers atmX/imaY fro IMA logical interface
     
    mh, Sep 27, 2004
    #2
    1. Advertising

  3. here there is config and output of controllers
    Building configuration...

    Current configuration : 3465 bytes
    !
    ! Last configuration change at 11:53:22 UTC Mon Sep 27 2004
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Access02
    !
    boot system flash c3725-is-mz.122-15.T14.bin
    logging queue-limit 100
    enable secret
    !
    network-clock-participate wic 1
    network-clock-participate aim 0
    aaa new-model
    !
    !
    aaa authentication login default line
    aaa authentication ppp default if-needed group radius
    aaa authorization network auth-ppp group radius
    aaa accounting update newinfo
    aaa accounting network auth-ppp start-stop group radius
    aaa accounting connection auth-ppp start-stop group radius
    aaa session-id common
    ip subnet-zero
    !
    !
    !
    isdn switch-type primary-dms100
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    mta receive maximum-recipients 0
    !
    !
    controller E1 0/3
    !
    controller E1 0/2
    !
    controller E1 0/1
    mode atm aim 0
    !
    controller E1 0/0
    mode atm aim 0
    !

    !
    !
    !
    interface ATM0/0
    no ip address
    scrambling-payload
    ima-group 1
    no atm oversubscribe
    no atm auto-configuration
    no atm ilmi-keepalive
    no atm address-registration
    no atm ilmi-enable
    !
    interface FastEthernet0/0
    ip address x.x.x.x x.x.x.x
    duplex auto
    speed auto
    !
    interface ATM0/1
    no ip address
    scrambling-payload
    ima-group 1
    no atm oversubscribe
    no atm auto-configuration
    no atm ilmi-keepalive
    no atm address-registration
    no atm ilmi-enable
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface ATM0/IMA1
    no ip address
    no atm auto-configuration
    no atm ilmi-keepalive
    no atm address-registration
    no atm ilmi-enable
    !
    interface ATM0/IMA1.1 point-to-point
    pvc 10/100
    encapsulation aal5snap
    !
    !

    !

    ip classless
    !
    !
    !
    !
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !

    call rsvp-sync
    !
    !
    mgcp profile default
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    password
    line 65 94
     
    Francesco Lugari Q&S, Sep 28, 2004
    #3
  4. Francesco Lugari Q&S

    mh Guest

    Assuming this is an IP network, you need to finish configuring your
    PVC; suggest you use the new IOS command format:


    int ATM0/IMA1.1
    description ???
    bandwidth ????
    ip address x.x.x.x m.m.m.m
    pvc <PVC name> 10/100
    protocol ip <far-end ip address> broadcast
    vbr-nrt <pcr> <scr> <burst> ! assuming you have VBR_NRT
    service
    encapsulation aal5snap
    exit
    exit
     
    mh, Sep 28, 2004
    #4
  5. I finished to configure my PVC, but i have already the error.

    i thinks that the problem isn't ima configuration but atm config..

    i don't know!
     
    Francesco Lugari Q&S, Sep 28, 2004
    #5
  6. Francesco Lugari Q&S

    mh Guest

    I would tend to agree that it looks like the issue is probably not
    with the IMA interface

    Have you verified that framing and linecode match with what your
    carrier is using?


    what does show controller atm 0/0 and show controller atm 1/0 look
    like?



    Cisco CCO document http://cco.cisco.com/en/US/products..._feature_guide09186a0080227e27.html#wp1079244

    shows a command
    Step 19
    connect connection-name atm slot/port [name of PVC/SVC|vpi/vci] E1
    slot/port TDM-group-number

    Example:
    Router(config)# connect alpha-IMA atm0/ima0 5/55 E1 2/0 1

    Establishes the connection between the T1 or E1 controller ports and
    the IMA
     
    mh, Sep 28, 2004
    #6
  7. Hi,

    this is show controller atm0/0

    Interface ATM0/0 is up
    Hardware is ATM AIM E1 connected to AIM slot 0
    hwidb=0x63C9C004, sardb=0x633BF864
    slot 0, unit 0, subunit 0
    MXT5100 versions: Framework 0x20E4, Utils 0x20C0,
    AAL5 0x20C0, AAL2 0x20E3, AAL1 0x20C0,
    IMA 0x20E2, CS 0xFFFF, Frame 0x20C2.
    Current (mxt5100_t)sardb:
    Ind_Q(0x656F2A0), Ind_Q_idx(1319), Ind_Q_size(30000)
    Cmd_Q(0x656A440), Cmd_Q_idx(357), Cmd_Q_size(20000)
    Inpool(0x6534080), Inpool_size(4096)
    Outpool(0x65350C0), Outpool_size(4096)
    Localpool(0x6540000), Localpool_size(256)
    StorBlk(0x63C0000), host_blk(0x63BF824), em_blk(0x63BF8E4)
    tx_buf_desc(0x65633C0), tx_free_desc_idx (1023)
    MXT5100 sub_channel_mode is disabled
    MXT5100 number of buffers in Inpool: 1024, Outpool 0
    FPGA revision 0x2070007
    MXT5100 Port Info:
    Port Number (0), Port ID (0xE05)
    Interface Number (4), Interface ID (0xF660)
    Port Type CELL, Port Open Status SUCCESS
    VCs configured (0)
    Port counters: tx_cells 738626854, rx_cells 738582443,
    rx_hec_errors 0, rx_cell_validation_errors 0

    and this atm0/1

    Interface ATM0/1 is up
    Hardware is ATM AIM E1 connected to AIM slot 0
    hwidb=0x63CCE9E4, sardb=0x633BF864
    slot 0, unit 1, subunit 1
    MXT5100 versions: Framework 0x20E4, Utils 0x20C0,
    AAL5 0x20C0, AAL2 0x20E3, AAL1 0x20C0,
    IMA 0x20E2, CS 0xFFFF, Frame 0x20C2.
    Current (mxt5100_t)sardb:
    Ind_Q(0x656F2A0), Ind_Q_idx(1443), Ind_Q_size(30000)
    Cmd_Q(0x656A440), Cmd_Q_idx(467), Cmd_Q_size(20000)
    Inpool(0x6534080), Inpool_size(4096)
    Outpool(0x65350C0), Outpool_size(4096)
    Localpool(0x6540000), Localpool_size(256)
    StorBlk(0x63C0000), host_blk(0x63BF824), em_blk(0x63BF8E4)
    tx_buf_desc(0x65633C0), tx_free_desc_idx (1023)
    MXT5100 sub_channel_mode is disabled
    MXT5100 number of buffers in Inpool: 1024, Outpool 0
    FPGA revision 0x2070007
    MXT5100 Port Info:
    Port Number (1), Port ID (0xE85)
    Interface Number (5), Interface ID (0xF680)
    Port Type CELL, Port Open Status SUCCESS
    VCs configured (0)
    Port counters: tx_cells 756223316, rx_cells 755968400,
    rx_hec_errors 1, rx_cell_validation_errors 1


    this is ima

    Interface ATM0/IMA1 is up
    Hardware is ATM AIM IMA connected to AIM slot 0
    hwidb=0x63CD8F88, sardb=0x633BF864
    slot 0, unit 1, subunit 0
    MXT5100 versions: Framework 0x20E4, Utils 0x20C0,
    AAL5 0x20C0, AAL2 0x20E3, AAL1 0x20C0,
    IMA 0x20E2, CS 0xFFFF, Frame 0x20C2.
    Current (mxt5100_t)sardb:
    Ind_Q(0x656F2A0), Ind_Q_idx(471), Ind_Q_size(30000)
    Cmd_Q(0x656A440), Cmd_Q_idx(925), Cmd_Q_size(20000)
    Inpool(0x6534080), Inpool_size(4096)
    Outpool(0x65350C0), Outpool_size(4096)
    Localpool(0x6540000), Localpool_size(256)
    StorBlk(0x63C0000), host_blk(0x63BF824), em_blk(0x63BF8E4)
    tx_buf_desc(0x65633C0), tx_free_desc_idx (1023)
    MXT5100 sub_channel_mode is disabled
    MXT5100 number of buffers in Inpool: 1024, Outpool 0
    FPGA revision 0x2070007
    MXT5100 IMA Group Info:
    Group Number (1), Group Port ID (0xF05)
    Group Index (0), Group Open Status SUCCESS
    VCs configured (1)
    IMA group alarms: NONE
    IMA Link(0) alarms: NONE
    IMA Link(1) alarms: NONE
    MXT5100 Channel Info:
    Channel Info (0):
    Chan_ID (0x10A5), Open Status SUCCESS, VC(2)VPI/VCI(10/100),
    Tx SBD(used/max 0/40), Tx PDU(939), Tx PDU discard(0)
    Tx SDU size err(0), Tx cell CLP0(2040), Tx cell CLP1(0)
    Rx PDU(0), Rx PDU discard(0), Rx SDU size err(0)
    Rx CRC err(0), Rx cell CLP0(0), Rx cell CLP1(0)

    framing and linecode are OK CRC4 and HDB3

    "mh" <> ha scritto nel messaggio
    news:...
    > I would tend to agree that it looks like the issue is probably not
    > with the IMA interface
    >
    > Have you verified that framing and linecode match with what your
    > carrier is using?
    >
    >
    > what does show controller atm 0/0 and show controller atm 1/0 look
    > like?
    >
    >
    >
    > Cisco CCO document

    http://cco.cisco.com/en/US/products..._feature_guide09186a0080227e27.html#wp1079244
    >
    > shows a command
    > Step 19
    > connect connection-name atm slot/port [name of PVC/SVC|vpi/vci] E1
    > slot/port TDM-group-number
    >
    > Example:
    > Router(config)# connect alpha-IMA atm0/ima0 5/55 E1 2/0 1
    >
    > Establishes the connection between the T1 or E1 controller ports and
    > the IMA
     
    Francesco Lugari Q&S, Sep 29, 2004
    #7
  8. Francesco Lugari Q&S

    mh Guest

    Interesting because on our 3725 with ATM T1 IMA, I see a LOT more info from
    show controller commands

    xxxxxxx#sh controller atm 1/0

    Interface ATM1/0 is up
    Hardware is ATM T1
    LANE client MAC address is 000c.8538.27a0
    hwidb=0x6332D404, ds=0x6334AF00
    slot 1, unit 0, subunit 0
    rs8234 base 0x3D000000, slave base 0x3D000000
    rs8234 ds 0x6334AF00
    SBDs - avail 2044, guaranteed 1, unguaranteed 2043, starved 0
    Seg VCC table 3D00DD80, Shadow Seg VCC Table 6336787C, VCD Table 6337D8A8
    Schedule table 3D018D80, Shadow Schedule table 633838D4, Size 63D
    RSM VCC Table 3D070D00, Shadow RSM VCC Table 633C7678
    VPI Index Table 3D02E880, VCI Index Table 3D030D00
    Bucket2 Table 3D020A80, Shadow Bucket2 Table 633851F4
    MCR Limit Table 3D020E80, Shadow MCR Table 63386E20
    ABR template 3D021080, Shadow template 62C5E1B0
    RM Cell RS Queue 3D02ED00
    Queue TXQ Addr Pos StQ Addr Pos
    0 UBR CHN0 3D02B080 0 0F7BEFA0 0
    1 UBR CHN1 3D02B480 0 0F7BF7A0 0
    2 UBR CHN2 3D02B880 0 0F7BFFA0 0
    3 UBR CHN3 3D02BC80 0 0F7C07A0 0
    4 VBR/ABR CHN0 3D02C080 46 0F7C0FA0 45
    5 VBR/ABR CHN1 3D02C480 0 0F7C17A0 0
    6 VBR/ABR CHN2 3D02C880 0 0F7C1FA0 0
    7 VBR/ABR CHN3 3D02CC80 0 0F7C27A0 0
    8 VBR-RT CHN0 3D02D080 0 0F7C2FA0 0
    9 VBR-RT CHN1 3D02D480 0 0F7C37A0 0
    10 VBR-RT CHN2 3D02D880 0 0F7C3FA0 0
    11 VBR-RT CHN3 3D02DC80 0 0F7C47A0 0
    12 SIG 3D02E080 0 0F7C4FA0 0
    13 VPD 3D02E480 0 0F7C57A0 0

    Queue FBQ Addr Pos RSQ Addr Pos
    0 OAM 3D07CD00 54 0F7C6060 55
    1 UBR CHN0 3D07DD00 0 0F7C7060 0
    2 UBR CHN1 3D07ED00 0 0F7C8060 0
    3 UBR CHN2 3D07FD00 0 0F7C9060 0
    4 UBR CHN3 3D080D00 0 0F7CA060 0
    5 VBR/ABR CHN0 3D081D00 190 0F7CB060 252
    6 VBR/ABR CHN1 3D082D00 0 0F7CC060 0
    7 VBR/ABR CHN2 3D083D00 0 0F7CD060 0
    8 VBR/ABR CHN3 3D084D00 0 0F7CE060 0
    9 VBR-RT CHN0 3D085D00 0 0F7CF060 0
    10 VBR-RT CHN1 3D086D00 0 0F7D0060 0
    11 VBR-RT CHN2 3D087D00 0 0F7D1060 0
    12 VBR-RT CHN3 3D088D00 0 0F7D2060 0
    13 SIG 3D089D00 0 0F7D3060 0
    SAR Scheduling channels: 0 0 0 -1 -1 -1 -1 -1
    Part of IMA group 0
    Link 0 IMA Info:
    group index is 0
    Tx link id is 0, Tx link state is active
    Rx link id is 0, Rx link state is active
    Rx link failure status is noFailure,
    0 tx failures, 0 rx failures
    Link 0 Framer Info:
    framing is ESF, line code is B8ZS, fdl is ANSI
    cable-length is long, Rcv gain is 26db and Tx gain is 0db,
    clock src is line, payload-scrambling is disabled, no loopback
    line status is 0x1; or no alarm.
    port is active, link is available
    0 idle rx, 0 correctable hec rx, 12 uncorrectable hec rx
    3914770472 cells rx, 3914766495 cells tx, 2 rx fifo overrun.
    Link (0):DS1 MIB DATA:
    Data in current interval (531 seconds elapsed):
    0 Line Code Violations, 0 Path Code Violations
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    Total Data (last 24 hours)
    0 Line Code Violations, 0 Path Code Violations,
    0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
    0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    SAR counter totals across all links and groups:
    388597971 cells output, 0 cells stripped
    421867488 cells input, 738090 cells discarded, 0 AAL5 frames discarded
    0 pci bus err, 0 dma fifo full err, 0 rsm parity err
    0 rsm syn err, 0 rsm/seg q full err, 0 rsm overflow err
    0 hs q full err, 0 no free buff q err, 0 seg underflow err
    0 host seg stat q full err
     
    mh, Sep 29, 2004
    #8
  9. Francesco Lugari Q&S

    mh Guest

    BTW what version of IOS are you using?

    Post sh ver
     
    mh, Sep 29, 2004
    #9
  10. Francesco Lugari Q&S

    mh Guest

    Also post output of sh diag
     
    mh, Sep 29, 2004
    #10
  11. Francesco Lugari Q&S

    mh Guest

    Do you have the right port adapter ?

    Yours shows as "ATM AIM E1"
    mine shows as "IMA 4 port T1 port adapter"


    I believe the product number should be

    NM-4E1-IMA 4-port E1 ATM network module with IMA
     
    mh, Sep 29, 2004
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tim J. Dunn

    7204 IMA ATM DLCI question

    Tim J. Dunn, Oct 16, 2003, in forum: Cisco
    Replies:
    1
    Views:
    588
    Ted Mittelstaedt
    Oct 16, 2003
  2. xxx

    ATM and IMA Question???

    xxx, Feb 2, 2004, in forum: Cisco
    Replies:
    7
    Views:
    3,314
  3. V. Evans
    Replies:
    1
    Views:
    641
    Jayesh Sharma
    Nov 13, 2005
  4. rosario

    ATM-E1 4E1-IMA and AIM-ATM-4E1

    rosario, Jan 7, 2006, in forum: Cisco
    Replies:
    3
    Views:
    1,508
    Erik Tamminga
    Jan 7, 2006
  5. Ivan82
    Replies:
    1
    Views:
    725
    www.BradReese.Com
    Aug 29, 2006
Loading...

Share This Page