IMA Link is flopping every 20 minutes (please help)

Discussion in 'Cisco' started by Forrest, Mar 5, 2004.

  1. Forrest

    Forrest Guest

    Hello all, I posted a post a few days ago, but as usual noone has responded.
    I must be black balled from comp.dcom.sys.cisco. But anyways I have an IMA
    link that is failing every 20 minutes almost on the dot. You can look at my
    previous post to get my config and log output. I have since moved the IMA
    link to another interface and the problem follwed it. I put a loopback plug
    on the original interface and ran some tests and everything came back 100%
    ok, so I don;t think its a problem with the physical interface.

    I tried doing a sh controller atm1/1 when the link drops to get the error
    code, but the link fails and then fails back in less than a second, so I
    can't get an accurate output. But it knocks us offline and takes down our
    vpns and remote server sessions for about a minute each time.

    I have opened a TAC case, but we have yet to resolve the issue.

    I have verified the timing and everything seems to be correct.

    Any ideas please?????
    Forrest, Mar 5, 2004
    #1
    1. Advertising

  2. Forrest

    Hansang Bae Guest

    In article <c28io0$a6bv$>,
    says...
    > Hello all, I posted a post a few days ago, but as usual noone has responded.
    > I must be black balled from comp.dcom.sys.cisco. But anyways I have an IMA
    > link that is failing every 20 minutes almost on the dot. You can look at my
    > previous post to get my config and log output. I have since moved the IMA
    > link to another interface and the problem follwed it. I put a loopback plug
    > on the original interface and ran some tests and everything came back 100%
    > ok, so I don;t think its a problem with the physical interface.
    >
    > I tried doing a sh controller atm1/1 when the link drops to get the error
    > code, but the link fails and then fails back in less than a second, so I
    > can't get an accurate output. But it knocks us offline and takes down our
    > vpns and remote server sessions for about a minute each time.
    >
    > I have opened a TAC case, but we have yet to resolve the issue.
    >
    > I have verified the timing and everything seems to be correct.
    >
    > Any ideas please?????



    If you loop it up towards you and it doesn't fail, that pretty much
    rules out that path. Unless you mean you just looped it up right at the
    serial port. Can you not run some intrusive tests to see why the ckt is
    taking a hit every 20 minutes? Since it's so regular, have the telco on
    the line and have them monitor it.

    I've found that if things break on an accurate schdule (every 20m in
    your case), it's usually not a bug. There are exceptions like timer
    based bugs, but it doesn't sound like that's the case here.


    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Mar 5, 2004
    #2
    1. Advertising

  3. Forrest

    Frank Beider Guest

    Here are some ideas

    Looking at your configuration it appears that this is a two or three T-1
    IMA. Are you actually using two or three T-1s? You say that you "have an
    IMA T1 with 1 link to our ISP" How many T-1s do you have active for the
    IMA.

    Here are some commands to try

    Show controllers ATM
    Show ima interface
    show ima interface atm1/0
    show ima interface atm1/1
    show ima interface atm1/2
    show ima interface atm1/2

    Is this an IMA that goes directly to your ISPs equipment or does this IMA
    group terminate on a carriers ATM switch?

    Regards
    "BitBucket" <> wrote in message
    news:c22uth$7bnm$...
    > Hello all,
    >
    > We have an IMA T1 with 1 link to our ISP. Every 20 minutes the link fails
    > and then comes back up. It stays down for a minute or more. You can

    almost
    > set your watch by it. Sometimes it occurs at 19 minutes, sometimes at 21
    > minutes but almost always at the 20 minute mark +/- a few seconds. My ISP
    > has stress tested the line with a T-bird and said the line was clean.

    Here
    > is my config. Any help will be GREATLY appreciated.
    >
    > bdc_3725_ATM#sh run
    > Building configuration...
    >
    > Current configuration : 2289 bytes
    > !
    > ! Last configuration change at 11:52:51 EST Thu Feb 26 2004
    > ! NVRAM config last updated at 11:42:41 EST Thu Feb 26 2004
    > !
    > version 12.2
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > service password-encryption
    > !
    > hostname bdc_3725_ATM
    > !
    > logging buffered 10000 debugging
    > no logging console
    > enable secret 5 $1$q5i5$Kq2AmBu4o.MBlwAxo.mm40
    > !
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > ip subnet-zero
    > no ip source-route
    > !
    > !
    > no ip domain-lookup
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > !
    > fax interface-type fax-mail
    > mta receive maximum-recipients 0
    > !
    > bridge crb
    > !
    > !
    > !
    > interface FastEthernet0/0
    > no ip address
    > no ip mroute-cache
    > duplex auto
    > speed auto
    > bridge-group 1
    > !
    > interface FastEthernet0/1
    > ip address 205.244.xxx.xxx 255.255.255.224
    > no ip mroute-cache
    > no keepalive
    > duplex auto
    > speed auto
    > !
    > interface ATM1/0
    > no ip address
    > no ip mroute-cache
    > no atm ilmi-keepalive
    > ima-group 0
    > no scrambling-payload
    > cablelength short 133
    > !
    > interface ATM1/1
    > no ip address
    > no ip mroute-cache
    > no atm ilmi-keepalive
    > ima-group 0
    > no scrambling-payload
    > !
    > interface ATM1/2
    > no ip address
    > no ip mroute-cache
    > shutdown
    > no atm ilmi-keepalive
    > ima-group 0
    > no scrambling-payload
    > !
    > interface ATM1/3
    > no ip address
    > no ip mroute-cache
    > shutdown
    > no atm ilmi-keepalive
    > ima-group 0
    > no scrambling-payload
    > !
    > interface ATM1/IMA0
    > no ip address
    > no atm ilmi-keepalive
    > pvc BDC 15/15
    > encapsulation aal5snap
    > !
    > bridge-group 1
    > !
    > ip default-gateway 205.244.xxx.xxx
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 205.244.xxx.xxx
    > ip http server
    > ip pim bidir-enable
    > !
    > !
    > !
    > !
    > bridge 1 protocol dec
    > call rsvp-sync
    > !
    > !
    > mgcp profile default
    > !
    > dial-peer cor custom
    > !
    > !
    > !
    > banner motd ^C
    >
    > And here is the output from the sh controller atm1/0
    >
    > bdc_3725_ATM#sh controller atm1/0
    > Interface ATM1/0 is up
    > Hardware is ATM T1
    > LANE client MAC address is 000b.fdc9.a5f0
    > hwidb=0x62A19ADC, ds=0x62A369E0
    > slot 1, unit 0, subunit 0
    > rs8234 base 0x3D000000, slave base 0x3D000000
    > rs8234 ds 0x62A369E0
    > SBDs - avail 2048, guaranteed 1, unguaranteed 2047, starved 0
    > Seg VCC table 3D00DD80, Shadow Seg VCC Table 62A53B88, VCD Table 62A69BB4
    > Schedule table 3D018D80, Shadow Schedule table 62A6FBE0, Size 63D
    > RSM VCC Table 3D070D00, Shadow RSM VCC Table 62AB3DB0
    > VPI Index Table 3D02E880, VCI Index Table 3D030D00
    > Bucket2 Table 3D020A80, Shadow Bucket2 Table 62A71500
    > MCR Limit Table 3D020E80, Shadow MCR Table 62A7312C
    > ABR template 3D021080, Shadow template 623A1970
    > RM Cell RS Queue 3D02ED00
    > Queue TXQ Addr Pos StQ Addr Pos
    > 0 UBR CHN0 3D02B080 87 063BCDE0 87
    > 1 UBR CHN1 3D02B480 0 063BD5E0 0
    > 2 UBR CHN2 3D02B880 0 063BDDE0 0
    > 3 UBR CHN3 3D02BC80 0 063BE5E0 0
    > 4 VBR/ABR CHN0 3D02C080 0 063BEDE0 0
    > 5 VBR/ABR CHN1 3D02C480 0 063BF5E0 0
    > 6 VBR/ABR CHN2 3D02C880 0 063BFDE0 0
    > 7 VBR/ABR CHN3 3D02CC80 0 063C05E0 0
    > 8 VBR-RT CHN0 3D02D080 0 063C0DE0 0
    > 9 VBR-RT CHN1 3D02D480 0 063C15E0 0
    > 10 VBR-RT CHN2 3D02D880 0 063C1DE0 0
    > 11 VBR-RT CHN3 3D02DC80 0 063C25E0 0
    > 12 SIG 3D02E080 0 063C2DE0 0
    > 13 VPD 3D02E480 0 063C35E0 0
    >
    > Queue FBQ Addr Pos RSQ Addr Pos
    > 0 OAM 3D07CD00 0 063C3EA0 1
    > 1 UBR CHN0 3D07DD00 109 063C4EA0 49
    > 2 UBR CHN1 3D07ED00 0 063C5EA0 0
    > 3 UBR CHN2 3D07FD00 0 063C6EA0 0
    > 4 UBR CHN3 3D080D00 0 063C7EA0 0
    > 5 VBR/ABR CHN0 3D081D00 0 063C8EA0 0
    > 6 VBR/ABR CHN1 3D082D00 0 063C9EA0 0
    > 7 VBR/ABR CHN2 3D083D00 0 063CAEA0 0
    > 8 VBR/ABR CHN3 3D084D00 0 063CBEA0 0
    > 9 VBR-RT CHN0 3D085D00 0 063CCEA0 0
    > 10 VBR-RT CHN1 3D086D00 0 063CDEA0 0
    > 11 VBR-RT CHN2 3D087D00 0 063CEEA0 0
    > 12 VBR-RT CHN3 3D088D00 0 063CFEA0 0
    > 13 SIG 3D089D00 0 063D0EA0 0
    > SAR Scheduling channels: 0 -1 -1 -1 -1 -1 -1 -1
    > Part of IMA group 0
    > Link 0 IMA Info:
    > group index is 0
    > Tx link id is 0, Tx link state is active
    > Rx link id is 0, Rx link state is active
    > Rx link failure status is noFailure,
    > 0 tx failures, 307 rx failures
    > Link 0 Framer Info:
    > framing is ESF, line code is B8ZS, fdl is ANSI
    > cable-length is short 0-133ft,
    > clock src is line, payload-scrambling is disabled, no loopback
    > line status is 0x1; or no alarm.
    > port is active, link is available
    > 35384 idle rx, 0 correctable hec rx, 0 uncorrectable hec rx
    > 1636647749 cells rx, 1637275883 cells tx, 0 rx fifo overrun.
    > Link (0):DS1 MIB DATA:
    > Data in current interval (155 seconds elapsed):
    > 0 Line Code Violations, 0 Path Code Violations
    > 0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
    > 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail

    Secs
    > Total Data (last 24 hours)
    > 0 Line Code Violations, 0 Path Code Violations,
    > 0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
    > 0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail

    Secs
    > SAR counter totals across all links and groups:
    > 13826505 cells output, 17 cells stripped
    > 33316473 cells input, 3234 cells discarded, 0 AAL5 frames discarded
    > 0 pci bus err, 0 dma fifo full err, 0 rsm parity err
    > 0 rsm syn err, 0 rsm/seg q full err, 0 rsm overflow err
    > 0 hs q full err, 0 no free buff q err, 0 seg underflow err
    > 0 host seg stat q full err
    > bdc_3725_ATM#
    >
    >
    Frank Beider, Mar 5, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. francis.gerard

    Re: connection loss every 5 minutes

    francis.gerard, Jul 27, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    3,494
    francis.gerard
    Jul 27, 2004
  2. Rick B.
    Replies:
    3
    Views:
    5,287
    Eric Sorenson
    Jan 16, 2004
  3. BitBucket

    ATM IMA Link Flops like clockwork

    BitBucket, Mar 2, 2004, in forum: Cisco
    Replies:
    1
    Views:
    689
    Frank Beider
    Mar 5, 2004
  4. Replies:
    0
    Views:
    944
  5. Smoking Causes Lung Cancer (SCLC)

    MS Office SP3 and File formats - Microsoft flip-flopping.

    Smoking Causes Lung Cancer (SCLC), Jan 5, 2008, in forum: NZ Computing
    Replies:
    13
    Views:
    583
    Bruce Sinclair
    Jan 8, 2008
Loading...

Share This Page