IIS 6 issues under x64

Discussion in 'Windows 64bit' started by Patrick Bates, Jul 12, 2005.

  1. Trying to install our web application on Windows 2003 x64 for testing. MSI
    install went fine, but when trying to access the web page get the following
    error:
    ---------------
    Server object error 'ASP 0196 : 80040154'
    Cannot launch out of process component

    Only InProc server components should be used. If you want to use LocalServer
    components, you must set the AspAllowOutOfProcComponents metabase setting.
    Please consult the help file for important considerations.

    ----------------------

    I thought this had been handled already under IIS 5 and 6 with 32-bit, and
    was able to verify that this flag is defaulted to True under those versions.
    So somehow it's set back to False by default in x64 (like it was False under
    IIS 4). To make matters worse, I downloaded the IIS 6 Resource Kit only to
    find that Metabase Explorer doesn't want to run in x64.

    Is there another version of the Resource Kit for x64? Maybe some other
    suggestions on how to change this setting? Perhaps more importantly, why
    was the default changed from 32-bit OS?

    Thanks,

    Patrick
     
    Patrick Bates, Jul 12, 2005
    #1
    1. Advertising

  2. Patrick Bates

    Ian Guest

    I too got such and error.
    M$ says that there is a fix but it did not work -
    running .asp net applications in 32 bit mode or
    some such crap.


    "Patrick Bates" <> wrote in message
    news:...
    > Trying to install our web application on Windows 2003 x64 for testing.

    MSI
    > install went fine, but when trying to access the web page get the

    following
    > error:
    > ---------------
    > Server object error 'ASP 0196 : 80040154'
    > Cannot launch out of process component
    >
    > Only InProc server components should be used. If you want to use

    LocalServer
    > components, you must set the AspAllowOutOfProcComponents metabase setting.
    > Please consult the help file for important considerations.
    >
    > ----------------------
    >
    > I thought this had been handled already under IIS 5 and 6 with 32-bit, and
    > was able to verify that this flag is defaulted to True under those

    versions.
    > So somehow it's set back to False by default in x64 (like it was False

    under
    > IIS 4). To make matters worse, I downloaded the IIS 6 Resource Kit only

    to
    > find that Metabase Explorer doesn't want to run in x64.
    >
    > Is there another version of the Resource Kit for x64? Maybe some other
    > suggestions on how to change this setting? Perhaps more importantly, why
    > was the default changed from 32-bit OS?
    >
    > Thanks,
    >
    > Patrick
    >
    >
    >
    >
     
    Ian, Jul 13, 2005
    #2
    1. Advertising

  3. The fix you were referring to must have been:

    adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

    There's more involved after that for ASP.Net, but as I was using VB6 DLLs
    and old ASP this was all I needed.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;894435


    "Ian" <> wrote in message
    news:...
    >I too got such and error.
    > M$ says that there is a fix but it did not work -
    > running .asp net applications in 32 bit mode or
    > some such crap.
    >
    >
    > "Patrick Bates" <> wrote in message
    > news:...
    >> Trying to install our web application on Windows 2003 x64 for testing.

    > MSI
    >> install went fine, but when trying to access the web page get the

    > following
    >> error:
    >> ---------------
    >> Server object error 'ASP 0196 : 80040154'
    >> Cannot launch out of process component
    >>
    >> Only InProc server components should be used. If you want to use

    > LocalServer
    >> components, you must set the AspAllowOutOfProcComponents metabase
    >> setting.
    >> Please consult the help file for important considerations.
    >>
    >> ----------------------
    >>
    >> I thought this had been handled already under IIS 5 and 6 with 32-bit,
    >> and
    >> was able to verify that this flag is defaulted to True under those

    > versions.
    >> So somehow it's set back to False by default in x64 (like it was False

    > under
    >> IIS 4). To make matters worse, I downloaded the IIS 6 Resource Kit only

    > to
    >> find that Metabase Explorer doesn't want to run in x64.
    >>
    >> Is there another version of the Resource Kit for x64? Maybe some other
    >> suggestions on how to change this setting? Perhaps more importantly, why
    >> was the default changed from 32-bit OS?
    >>
    >> Thanks,
    >>
    >> Patrick
    >>
    >>
    >>
    >>

    >
    >
     
    Patrick Bates, Jul 13, 2005
    #3
  4. Patrick Bates

    M. Murcek Guest

    Somebody over at the now-defunct private newsgroup during the CPP had an
    excellent post about installing some dlls in a specific location, or
    somesuch (I just can't recall) to get IIS 6 to behave under x64. Maybe you
    can go back over there and look. Unfortunately, I've deleted the account
    from my machine, or I'd go there for you. Perhaps they'll repost on this
    newsgroup...

    "Ian" <> wrote in message
    news:...
    >I too got such and error.
    > M$ says that there is a fix but it did not work -
    > running .asp net applications in 32 bit mode or
    > some such crap.
    >
    >
    > "Patrick Bates" <> wrote in message
    > news:...
    >> Trying to install our web application on Windows 2003 x64 for testing.

    > MSI
    >> install went fine, but when trying to access the web page get the

    > following
    >> error:
    >> ---------------
    >> Server object error 'ASP 0196 : 80040154'
    >> Cannot launch out of process component
    >>
    >> Only InProc server components should be used. If you want to use

    > LocalServer
    >> components, you must set the AspAllowOutOfProcComponents metabase
    >> setting.
    >> Please consult the help file for important considerations.
    >>
    >> ----------------------
    >>
    >> I thought this had been handled already under IIS 5 and 6 with 32-bit,
    >> and
    >> was able to verify that this flag is defaulted to True under those

    > versions.
    >> So somehow it's set back to False by default in x64 (like it was False

    > under
    >> IIS 4). To make matters worse, I downloaded the IIS 6 Resource Kit only

    > to
    >> find that Metabase Explorer doesn't want to run in x64.
    >>
    >> Is there another version of the Resource Kit for x64? Maybe some other
    >> suggestions on how to change this setting? Perhaps more importantly, why
    >> was the default changed from 32-bit OS?
    >>
    >> Thanks,
    >>
    >> Patrick
    >>
    >>
    >>
    >>

    >
    >
     
    M. Murcek, Jul 13, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. moe_rodrigue

    IIS 6.0 win2003, IIS users

    moe_rodrigue, Apr 1, 2004, in forum: MCSE
    Replies:
    1
    Views:
    1,072
    MikeF
    Apr 1, 2004
  2. =?Utf-8?B?R2lhbmNhcmxv?=

    Windows XP x64 and IIS 6.0?

    =?Utf-8?B?R2lhbmNhcmxv?=, Aug 23, 2005, in forum: Windows 64bit
    Replies:
    2
    Views:
    1,126
    Steve Thompson
    Aug 24, 2005
  3. =?Utf-8?B?S2VuIEZvcmQ=?=

    IIS - PHP - ColdFusion Windows XP Pro x64

    =?Utf-8?B?S2VuIEZvcmQ=?=, Nov 16, 2005, in forum: Windows 64bit
    Replies:
    7
    Views:
    539
    =?Utf-8?B?S2VuIEZvcmQ=?=
    Dec 1, 2005
  4. Galpersonal
    Replies:
    8
    Views:
    1,035
    universal4
    Aug 13, 2006
  5. Ben Liddicott
    Replies:
    0
    Views:
    1,184
    Ben Liddicott
    Jul 29, 2009
Loading...

Share This Page