Ihug's email servers/filters...

Discussion in 'NZ Computing' started by Dave Doe, Jul 2, 2007.

  1. Dave Doe

    Dave Doe Guest

    OK, these folk have been having email trouble since at least Friday last
    week.

    It seems an easy fix to me - just turn off the bloody reverse IP DNS
    lookups that they seems to be doing.

    This is the bounce message back from them (sent to an Ihug recipient)...

    The following message to <<recipient>@ihug.co.nz> was undeliverable.
    The reason for the problem:
    5.1.0 - Unknown address error 550-'Verification failed for <<sender
    (me)>@adrock.com>\nCannot process foreign address; please phone customer
    services quoting code F3 for address <me>@adrock.com on host akl-
    content-mx1.ihug.net\nSender verification failed (Sender verify failed)'

    And in the att't:
    Final-Recipient: rfc822;<recipient>@ihug.co.nz
    Action: failed
    Status: 5.0.0 (permanent failure)
    Remote-MTA: dns; [10.80.48.51]
    Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'Verification
    failed for <<me>@adrock.com>\nCannot process foreign address; please
    phone customer services quoting code F3 for address <me>@adrock.com on
    host akl-content-mx1.ihug.net\nSender verification failed (Sender verify
    failed)' (delivery attempts: 0)
    Reporting-MTA: dns; mx.mailfilter4.ihug.co.nz

    OK, I run my own email server, but use a smarthost (paradise, my ISP).

    Why are they doing this? - and why no fix yet, and why no info on their
    site about it - nothing at all on the Status page.

    There is little more I can do my end - I haven't double-checked my A
    records, but I'm pretty sure they're all good - (I use a smarthost
    anyway).

    What are these people doing???!@#@!?

    --
    Duncan
    Dave Doe, Jul 2, 2007
    #1
    1. Advertising

  2. Dave Doe

    none Guest

    Dave Doe wrote:
    > 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    > (me)>@adrock.com>\nCannot process foreign address; please phone customer
    > services quoting code F3 for address <me>@adrock.com on host akl-
    > content-mx1.ihug.net\nSender verification failed (Sender verify failed)'


    Doesn't immediately look reverse DNS related.

    The person trying to e-mail you should do what the error message says.

    Call support, quote code F3 and find out what the problem is,
    alternately, you call them and do the same.
    none, Jul 2, 2007
    #2
    1. Advertising

  3. Dave Doe

    Dave Doe Guest

    In article <46887044$>, says...
    > Dave Doe wrote:
    > > 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    > > (me)>@adrock.com>\nCannot process foreign address; please phone customer
    > > services quoting code F3 for address <me>@adrock.com on host akl-
    > > content-mx1.ihug.net\nSender verification failed (Sender verify failed)'

    >
    > Doesn't immediately look reverse DNS related.
    >
    > The person trying to e-mail you should do what the error message says.
    >
    > Call support, quote code F3 and find out what the problem is,
    > alternately, you call them and do the same.


    You think I haven't done that? I've phoned them twice now, once Friday,
    and again today - I gave them the details - and got the usual non-
    descript reply.

    --
    Duncan
    Dave Doe, Jul 2, 2007
    #3
  4. >
    > This is the bounce message back from them (sent to an Ihug recipient)...
    >
    > The following message to <<recipient>@ihug.co.nz> was undeliverable.
    > The reason for the problem:
    > 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    > (me)>@adrock.com>\nCannot process foreign address; please phone customer
    > services quoting code F3 for address <me>@adrock.com on host akl-
    > content-mx1.ihug.net\nSender verification failed (Sender verify failed)'


    Email RFC's says that if you send out an email you have to be able to accept
    a bounce email back to it.

    Strangely do you do not have an MX record for adrock.com ? (Please Fix)
    So lets fall back to the A record (we don't really have to do this)

    which is 202.0.50.195. So without knowing the userid at adrock.com can't
    test any futher

    but does your system accept an email from a DSN "<>" to to your email
    account?

    Thanks
    Craig Whitmore, Jul 2, 2007
    #4
  5. Dave Doe

    muppet Guest

    none wrote:
    > Dave Doe wrote:
    >> 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    >> (me)>@adrock.com>\nCannot process foreign address; please phone
    >> customer services quoting code F3 for address <me>@adrock.com on host
    >> akl-
    >> content-mx1.ihug.net\nSender verification failed (Sender verify failed)'

    >
    > Doesn't immediately look reverse DNS related.
    >
    > The person trying to e-mail you should do what the error message says.
    >
    > Call support, quote code F3 and find out what the problem is,
    > alternately, you call them and do the same.


    This seems not to be the only email issues they're having. See my post
    "Slingshot email delays". Phoned them today again since my job has now
    been open a week, and seems they're actually aware of and acknowledging
    the issue now, and that it might be bigger than a single user issue. Duh!
    muppet, Jul 2, 2007
    #5
  6. Dave Doe

    E. Scrooge Guest

    "Dave Doe" <> wrote in message
    news:...
    > OK, these folk have been having email trouble since at least Friday last
    > week.
    >
    > It seems an easy fix to me - just turn off the bloody reverse IP DNS
    > lookups that they seems to be doing.
    >
    > This is the bounce message back from them (sent to an Ihug recipient)...
    >
    > The following message to <<recipient>@ihug.co.nz> was undeliverable.
    > The reason for the problem:
    > 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    > (me)>@adrock.com>\nCannot process foreign address; please phone customer
    > services quoting code F3 for address <me>@adrock.com on host akl-
    > content-mx1.ihug.net\nSender verification failed (Sender verify failed)'
    >
    > And in the att't:
    > Final-Recipient: rfc822;<recipient>@ihug.co.nz
    > Action: failed
    > Status: 5.0.0 (permanent failure)
    > Remote-MTA: dns; [10.80.48.51]
    > Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'Verification
    > failed for <<me>@adrock.com>\nCannot process foreign address; please
    > phone customer services quoting code F3 for address <me>@adrock.com on
    > host akl-content-mx1.ihug.net\nSender verification failed (Sender verify
    > failed)' (delivery attempts: 0)
    > Reporting-MTA: dns; mx.mailfilter4.ihug.co.nz
    >
    > OK, I run my own email server, but use a smarthost (paradise, my ISP).
    >
    > Why are they doing this? - and why no fix yet, and why no info on their
    > site about it - nothing at all on the Status page.
    >
    > There is little more I can do my end - I haven't double-checked my A
    > records, but I'm pretty sure they're all good - (I use a smarthost
    > anyway).
    >
    > What are these people doing???!@#@!?
    >
    > --
    > Duncan


    It's your choice to stay with latest owner of what's left of ihug.

    E. Scrooge
    E. Scrooge, Jul 2, 2007
    #6
  7. Dave Doe

    lolinternet Guest

    E. Scrooge wrote:
    > It's your choice to stay with latest owner of what's left of ihug.
    >
    > E. Scrooge


    As usual your superior intellect shines through.

    He is trying to contact an iHug customer, he is not an iHug customer
    himself.
    lolinternet, Jul 2, 2007
    #7
  8. Dave Doe

    E. Scrooge Guest

    "lolinternet" <> wrote in message
    news:...
    > E. Scrooge wrote:
    >> It's your choice to stay with latest owner of what's left of ihug.
    >>
    >> E. Scrooge

    >
    > As usual your superior intellect shines through.
    >
    > He is trying to contact an iHug customer, he is not an iHug customer
    > himself.


    Fair enough. The ihug customer should be trying to find out what's wrong
    then.

    E. Scrooge
    E. Scrooge, Jul 2, 2007
    #8
  9. Dave Doe

    Richard Guest

    E. Scrooge wrote:

    >> OK, I run my own email server, but use a smarthost (paradise, my ISP).
    >>
    >> Why are they doing this? - and why no fix yet, and why no info on their
    >> site about it - nothing at all on the Status page.
    >>
    >> There is little more I can do my end - I haven't double-checked my A
    >> records, but I'm pretty sure they're all good - (I use a smarthost
    >> anyway).
    >>
    >> What are these people doing???!@#@!?
    >>
    >> --
    >> Duncan

    >
    > It's your choice to stay with latest owner of what's left of ihug.
    >
    > E. Scrooge


    No, he really should sort his DNS out so that he has MX records for his
    mail server, and SPF records for the paradise email server if hes game
    to allow a server that has unauthenticated users on it to be able to
    send for his domain. Looks like ihug are finally sorting stuff out to
    combat spam and hopefully the plethora of phising emails.
    Richard, Jul 2, 2007
    #9
  10. Dave Doe

    Tony Guest


    > There is little more I can do my end - I haven't double-checked my A
    > records, but I'm pretty sure they're all good - (I use a smarthost
    > anyway).
    >
    > What are these people doing???!@#@!?
    >


    You have no mx record, until you fix this Ihug are absolutely correct to
    reject email from your domain -

    (answer: 0 is bad)

    [root@host40 ~]# dig adrock.com mx

    ; <<>> DiG 9.2.4 <<>> adrock.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54041
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;adrock.com. IN MX

    ;; AUTHORITY SECTION:
    adrock.com. 10800 IN SOA PARK5.SECURESERVER.NET.
    dns.jomax.NET. 2005030700 28800 7200 604800 86400

    ;; Query time: 355 msec
    ;; SERVER: 202.170.160.1#53(202.170.160.1)
    ;; WHEN: Tue Jul 3 08:44:11 2007
    ;; MSG SIZE rcvd: 96
    Tony, Jul 2, 2007
    #10
  11. Dave Doe

    Enkidu Guest

    Tony wrote:
    >
    >> There is little more I can do my end - I haven't double-checked my A
    >> records, but I'm pretty sure they're all good - (I use a smarthost
    >> anyway).
    >>
    >> What are these people doing???!@#@!?
    >>

    >
    > You have no mx record, until you fix this Ihug are absolutely correct to
    > reject email from your domain -
    >

    There is no requirement, in the RFCs or anywhere, that a mail server has
    to have an MX record.

    Cheers,

    Cliff

    --

    Have you ever noticed that if something is advertised as 'amusing' or
    'hilarious', it usually isn't?
    Enkidu, Jul 2, 2007
    #11
  12. Dave Doe

    Dave Doe Guest

    In article <>, says...
    > >
    > > This is the bounce message back from them (sent to an Ihug recipient)...
    > >
    > > The following message to <<recipient>@ihug.co.nz> was undeliverable.
    > > The reason for the problem:
    > > 5.1.0 - Unknown address error 550-'Verification failed for <<sender
    > > (me)>@adrock.com>\nCannot process foreign address; please phone customer
    > > services quoting code F3 for address <me>@adrock.com on host akl-
    > > content-mx1.ihug.net\nSender verification failed (Sender verify failed)'

    >
    > Email RFC's says that if you send out an email you have to be able to accept
    > a bounce email back to it.


    That's a what I'm a getting.

    >
    > Strangely do you do not have an MX record for adrock.com ? (Please Fix)
    > So lets fall back to the A record (we don't really have to do this)


    I do...

    See (I hope this works):
    http://www.adrock.com\portals\2\Clip.jpg
    and the bottom half of the screen at:
    http://www.adrock.com\portals\2\Clip_2.jpg

    >
    > which is 202.0.50.195. So without knowing the userid at adrock.com can't
    > test any futher
    >
    > but does your system accept an email from a DSN "<>" to to your email
    > account?


    Yep.

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #12
  13. Dave Doe

    Dave Doe Guest

    In article <>, says...
    > E. Scrooge wrote:
    >
    > >> OK, I run my own email server, but use a smarthost (paradise, my ISP).
    > >>
    > >> Why are they doing this? - and why no fix yet, and why no info on their
    > >> site about it - nothing at all on the Status page.
    > >>
    > >> There is little more I can do my end - I haven't double-checked my A
    > >> records, but I'm pretty sure they're all good - (I use a smarthost
    > >> anyway).
    > >>
    > >> What are these people doing???!@#@!?
    > >>
    > >> --
    > >> Duncan

    > >
    > > It's your choice to stay with latest owner of what's left of ihug.
    > >
    > > E. Scrooge

    >
    > No, he really should sort his DNS out so that he has MX records for his
    > mail server, and SPF records for the paradise email server if hes game
    > to allow a server that has unauthenticated users on it to be able to
    > send for his domain. Looks like ihug are finally sorting stuff out to
    > combat spam and hopefully the plethora of phising emails.


    http://www.adrock.com\portals\2\Clip.jpg
    http://www.adrock.com\portals\2\Clip_2.jpg

    Please let me know if this is not setup correctly (I've been here before
    with Godaddy - they won't support "total DNS control" - but I believe
    I've got it setup correctly.

    Regardless of the A record for mail.adrock.com - any failure drops to
    the domain name itself (which still points to 'me').

    My email server is not an open relay - I think I'd notice if it was.

    The fact that you can connect to it, does not make it available for
    relaying - try this (under: Determine whether the Exchange Server is an
    open SMTP relay):
    http://support.microsoft.com/kb/324958/en-us?spid=2807&sid=887

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #13
  14. Dave Doe

    Dave Doe Guest

    In article <newscache$2fkkkj$tpe$>,
    says...
    >
    > > There is little more I can do my end - I haven't double-checked my A
    > > records, but I'm pretty sure they're all good - (I use a smarthost
    > > anyway).
    > >
    > > What are these people doing???!@#@!?
    > >

    >
    > You have no mx record, until you fix this Ihug are absolutely correct to
    > reject email from your domain -


    See other replies - I DO have an MX record. It's been working for
    years. It's only stopped sending emails to Ihug since last Friday.

    If I have my MX record incorrectly setup - lemme know how to fix it and
    I will (I find some of these "total control DNS" thingies more obscure
    to follow than they should be). However I think it's right. You tell
    me otherwise and I'll fix it.

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #14
  15. >
    > See other replies - I DO have an MX record. It's been working for
    > years. It's only stopped sending emails to Ihug since last Friday.
    >


    You dont' have a MX record for adrock.com at all but you have set up a MX
    record for adrock.com.adrock.com

    When you add the MX in their interface ..don't put anything in the "host"
    field.

    You should of seen the callback from IHUG's mail server. do they show in
    your logs? and what did they say and what did you say back?

    Thanks
    Craig Whitmore, Jul 3, 2007
    #15
  16. Dave Doe

    Dave Doe Guest

    In article <4689ca4e$>, says...
    > >
    > > See other replies - I DO have an MX record. It's been working for
    > > years. It's only stopped sending emails to Ihug since last Friday.
    > >

    >
    > You dont' have a MX record for adrock.com at all but you have set up a MX
    > record for adrock.com.adrock.com
    >
    > When you add the MX in their interface ..don't put anything in the "host"
    > field.
    >
    > You should of seen the callback from IHUG's mail server. do they show in
    > your logs? and what did they say and what did you say back?


    Thanks for that Craig - I will put an "@" in the host field (I believe
    that's what yer meant to do if you want the domain only).

    Yes, I get the bounce message from IHug - email is arriving just fine.

    This is not an MX problem - it's a sending problem - and I'm using a
    smarthost (smtp.paradise.net.nz). Well that's how I see it.

    Will change the MX and get back if I note it has fixed itself.

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #16
  17. Dave Doe

    Dave Doe Guest

    In article <4689ca4e$>, says...
    > >
    > > See other replies - I DO have an MX record. It's been working for
    > > years. It's only stopped sending emails to Ihug since last Friday.
    > >

    >
    > You dont' have a MX record for adrock.com at all but you have set up a MX
    > record for adrock.com.adrock.com
    >
    > When you add the MX in their interface ..don't put anything in the "host"
    > field.
    >
    > You should of seen the callback from IHUG's mail server. do they show in
    > your logs? and what did they say and what did you say back?


    My update at Godaddy now reads:
    Priority Host Goes To TTL
    10 @ mail.adrock.com 1 Hour

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #17
  18. > Thanks for that Craig - I will put an "@" in the host field (I believe
    > that's what yer meant to do if you want the domain only).
    >
    >


    You also might want to get the the RDNS changed to mail.adrock.com and then
    this will give you the ability to send out directly and not use a smarthost.

    Thanks
    Craig Whitmore, Jul 3, 2007
    #18
  19. Dave Doe

    Dave Doe Guest

    In article <4689d8a2$>, says...
    > > Thanks for that Craig - I will put an "@" in the host field (I believe
    > > that's what yer meant to do if you want the domain only).
    > >
    > >

    >
    > You also might want to get the the RDNS changed to mail.adrock.com and then
    > this will give you the ability to send out directly and not use a smarthost.


    Will Godaddy do this for me? - I'd have thought not, and anyway, I have
    no probs using a smarthost.

    Update: Ihug seem to have fixed their email prob.

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #19
  20. Dave Doe

    Dave Doe Guest

    In article <4689d8a2$>, says...
    > > Thanks for that Craig - I will put an "@" in the host field (I believe
    > > that's what yer meant to do if you want the domain only).
    > >
    > >

    >
    > You also might want to get the the RDNS changed to mail.adrock.com and then
    > this will give you the ability to send out directly and not use a smarthost.


    http://www.dnsstuff.com/tools/dnsreport.ch?domain=adrock.com

    Says my reverse DNS is all good.

    --
    Duncan
    Dave Doe, Jul 3, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. iascoot
    Replies:
    5
    Views:
    369
    Vista
    Aug 11, 2006
  2. Anony Mouse

    IHUG Mail servers playing up again.

    Anony Mouse, Nov 11, 2006, in forum: NZ Computing
    Replies:
    1
    Views:
    376
    El Chippy
    Nov 13, 2006
  3. Dave Doe
    Replies:
    5
    Views:
    455
    Ralph Fox
    Apr 11, 2008
  4. Katipo
    Replies:
    2
    Views:
    430
    Geopelia
    Apr 10, 2008
  5. Matty F
    Replies:
    51
    Views:
    1,654
Loading...

Share This Page