IGRP into RIP distribution leads to Inaccessible routes

Discussion in 'Cisco' started by polleke7, Apr 13, 2005.

  1. polleke7

    polleke7 Guest

    Simple setup with big problems and i cant pinpoint it.
    Pleasy help me out with this one guys.

    L1-L3 Topology:
    2 routers called Router6 and Router8
    Router6 ser1 is wired to Router8 ser1 using network 20.0.4.0/24
    Router6 eth0 has network 30.0.0.0/24
    Router8 tokenRing0 has network 20.0.0.0/24

    Routing Topology:
    Router6 has RIPv2
    Router8 runs RIPv2 on its ser1 only
    and runs IGRP on tokenring.
    Router8 redistributes RIP into IGRP and reverse.

    Problem:
    Router6 does all perfect with RIP
    Router8 receives RIP well and redistributes it into IGRP on the other
    interfaces BUT it markes those routes learned from RIP as "Inaccessible"

    see debugoutput on Router8:
    Router8#debug ip rip
    Router8#debug ip igrp transactions
    00:33:53: RIP: sending v2 update to 224.0.0.9 via Serial1 (20.0.4.8)
    00:33:53: RIP: build update entries
    00:33:53: 20.0.0.0/24 via 0.0.0.0, metric 1, tag 0
    00:34:00: RIP: received v2 update from 20.0.4.6 on Serial1
    00:34:00: 30.0.0.0/24 via 0.0.0.0 in 1 hops
    00:34:00: 172.16.0.0/24 via 0.0.0.0 in 1 hops
    00:34:21: RIP: sending v2 update to 224.0.0.9 via Serial1 (20.0.4.8)
    00:34:21: RIP: build update entries
    00:34:21: 20.0.0.0/24 via 0.0.0.0, metric 1, tag 0
    00:34:22: IGRP: sending update to 255.255.255.255 via TokenRing0 (20.0.0.8)
    00:34:22: subnet 20.0.4.0, metric=8476
    00:34:22: network 172.16.0.0, metric=Inaccessible
    00:34:22: network 30.0.0.0, metric=Inaccessible

    WHY?

    Dont tell me to use other routing protocols please, i want to understand the
    inner workings of IGRP for my certification.

    Configs are:

    Router6:
    ip subnet-zero
    !
    interface Loopback1
    ip address 172.16.0.6 255.255.255.0
    !
    interface Ethernet0
    ip address 30.0.0.6 255.255.255.0
    no ip route-cache
    !
    interface Serial1
    ip address 20.0.4.6 255.255.255.0
    no ip route-cache
    !
    router rip
    version 2
    passive-interface Ethernet0
    passive-interface Loopback1
    network 20.0.0.0
    network 30.0.0.0
    network 172.16.0.0
    no auto-summary
    !
    ip classless

    Router8:
    ip subnet-zero
    !
    interface Serial1
    ip address 20.0.4.8 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    clockrate 2000000
    !
    interface TokenRing0
    ip address 20.0.0.8 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    ring-speed 16
    !
    router rip
    version 2
    redistribute igrp 666
    passive-interface TokenRing0
    network 20.0.0.0
    no auto-summary
    !
    router igrp 666
    redistribute rip
    passive-interface Serial1
    network 20.0.0.0
    !
    ip classless
     
    polleke7, Apr 13, 2005
    #1
    1. Advertising

  2. polleke7

    Ivan Ostres Guest

    In article <>,
    says...
    > !
    > router rip
    > version 2
    > redistribute igrp 666
    > passive-interface TokenRing0
    > network 20.0.0.0
    > no auto-summary
    > !
    > router igrp 666
    > redistribute rip
    > passive-interface Serial1
    > network 20.0.0.0
    >


    The metric in IGRP and RIP are totally different so you have to supply
    metric to routes when redistributing like this:

    > router rip
    > version 2

    redistribute igrp 666 metric 1
    > passive-interface TokenRing0
    > network 20.0.0.0
    > no auto-summary
    > !
    > router igrp 666

    redistribute rip metric 10000 1000 255 1 1500
    > passive-interface Serial1
    > network 20.0.0.0


    or supply default metric in routing protocol using 'default-metric'
    command.

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostres, Apr 13, 2005
    #2
    1. Advertising

  3. polleke7

    Kathy White Guest

    can't talk between ethernet port and computer

    Hi,

    I am helping/trying to set up a connection between a FR T1 and ATM OC3.

    We have them talking, but can't ping a computer sitting on the fastethernet
    port. It can telnet in, and ping the interfaces on the local computer but
    from a telenet session within the local router we can't ping back to the
    router. (*.254)

    We are new to this have have been looking at all the reference material we
    can find but are missing what we are sure is an obvious thing.

    If someone could point us inthe right direction we would greatly appreciate
    it. - -Kathy

    This is the config.

    2620t#show run
    Building configuration...

    Current configuration : 993 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname 2620
    !
    enable password
    !
    ip subnet-zero
    !
    !
    no ip domain-lookup
    ip name-server 217.178.3.1
    ip name-server 217.178.3.1
    !
    !
    !
    !
    interface FastEthernet0/0
    description connected to Internet
    ip address 219.168.3.253 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    no ip mroute-cache
    speed auto
    half-duplex
    no cdp enable
    !
    interface Serial0/0
    description Connection 7206 ds3 atm
    ip address 219.168.3.250 255.255.255.252
    encapsulation frame-relay IETF
    frame-relay interface-dlci 16
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 219.168.3.249
    ip http server
    ip pim bidir-enable
    !
    no cdp run
    snmp-server community public RO
    snmp-server location
    !
    line con 0
    exec-timeout 0 0
    password
    login
    line aux 0
    line vty 0 4
    password
    login
    !
    no scheduler allocate
    end
     
    Kathy White, Apr 13, 2005
    #3
  4. polleke7

    John Agosta Guest

    Put in a default metric:

    router rip
    redistribute blahblahblah
    default-metric 1


    "polleke7" <> wrote in message
    news:...
    > Simple setup with big problems and i cant pinpoint it.
    > Pleasy help me out with this one guys.
    >
    > L1-L3 Topology:
    > 2 routers called Router6 and Router8
    > Router6 ser1 is wired to Router8 ser1 using network 20.0.4.0/24
    > Router6 eth0 has network 30.0.0.0/24
    > Router8 tokenRing0 has network 20.0.0.0/24
    >
    > Routing Topology:
    > Router6 has RIPv2
    > Router8 runs RIPv2 on its ser1 only
    > and runs IGRP on tokenring.
    > Router8 redistributes RIP into IGRP and reverse.
    >
    > Problem:
    > Router6 does all perfect with RIP
    > Router8 receives RIP well and redistributes it into IGRP on the other
    > interfaces BUT it markes those routes learned from RIP as "Inaccessible"
    >
    > see debugoutput on Router8:
    > Router8#debug ip rip
    > Router8#debug ip igrp transactions
    > 00:33:53: RIP: sending v2 update to 224.0.0.9 via Serial1 (20.0.4.8)
    > 00:33:53: RIP: build update entries
    > 00:33:53: 20.0.0.0/24 via 0.0.0.0, metric 1, tag 0
    > 00:34:00: RIP: received v2 update from 20.0.4.6 on Serial1
    > 00:34:00: 30.0.0.0/24 via 0.0.0.0 in 1 hops
    > 00:34:00: 172.16.0.0/24 via 0.0.0.0 in 1 hops
    > 00:34:21: RIP: sending v2 update to 224.0.0.9 via Serial1 (20.0.4.8)
    > 00:34:21: RIP: build update entries
    > 00:34:21: 20.0.0.0/24 via 0.0.0.0, metric 1, tag 0
    > 00:34:22: IGRP: sending update to 255.255.255.255 via TokenRing0

    (20.0.0.8)
    > 00:34:22: subnet 20.0.4.0, metric=8476
    > 00:34:22: network 172.16.0.0, metric=Inaccessible
    > 00:34:22: network 30.0.0.0, metric=Inaccessible
    >
    > WHY?
    >
    > Dont tell me to use other routing protocols please, i want to understand

    the
    > inner workings of IGRP for my certification.
    >
    > Configs are:
    >
    > Router6:
    > ip subnet-zero
    > !
    > interface Loopback1
    > ip address 172.16.0.6 255.255.255.0
    > !
    > interface Ethernet0
    > ip address 30.0.0.6 255.255.255.0
    > no ip route-cache
    > !
    > interface Serial1
    > ip address 20.0.4.6 255.255.255.0
    > no ip route-cache
    > !
    > router rip
    > version 2
    > passive-interface Ethernet0
    > passive-interface Loopback1
    > network 20.0.0.0
    > network 30.0.0.0
    > network 172.16.0.0
    > no auto-summary
    > !
    > ip classless
    >
    > Router8:
    > ip subnet-zero
    > !
    > interface Serial1
    > ip address 20.0.4.8 255.255.255.0
    > no ip route-cache
    > no ip mroute-cache
    > clockrate 2000000
    > !
    > interface TokenRing0
    > ip address 20.0.0.8 255.255.255.0
    > no ip route-cache
    > no ip mroute-cache
    > ring-speed 16
    > !
    > router rip
    > version 2
    > redistribute igrp 666
    > passive-interface TokenRing0
    > network 20.0.0.0
    > no auto-summary
    > !
    > router igrp 666
    > redistribute rip
    > passive-interface Serial1
    > network 20.0.0.0
    > !
    > ip classless
    >
    >
     
    John Agosta, Apr 13, 2005
    #4
  5. polleke7

    polleke7 Guest

    thanks a lot Ivan and John
    the metric is indeed overcalculated (delay 16777215 as default) without the
    default-metric or redistribute ..... metrics, and thus marked as
    inaccessible
    thanks for helping me out with this one, i owe you guys a beer ;-)
     
    polleke7, Apr 13, 2005
    #5
  6. polleke7

    Nazgulero Guest

    Re: can't talk between ethernet port and computer

    Hello Kathy,

    when you say that you cannot ping back to the router with IP address
    *.254 I assume that means:

    You have a TELNET session to the router of which you have posted the
    configuration. From there, you are trying to ping a device that is
    connected to the FastEthernet port of that router, and that device has
    IP address 219.168.3.254 255.255.255.252 ?
    Is the line protocol on your FastEthernet interface up ?
    Can you check if the subnet mask on the device with IP address
    219.168.3.254 is correct (255.255.255.252) ?

    Regards,

    GP

    "Kathy White" <> wrote in message news:<>...
    > Hi,
    >
    > I am helping/trying to set up a connection between a FR T1 and ATM OC3.
    >
    > We have them talking, but can't ping a computer sitting on the fastethernet
    > port. It can telnet in, and ping the interfaces on the local computer but
    > from a telenet session within the local router we can't ping back to the
    > router. (*.254)
    >
    > We are new to this have have been looking at all the reference material we
    > can find but are missing what we are sure is an obvious thing.
    >
    > If someone could point us inthe right direction we would greatly appreciate
    > it. - -Kathy
    >
    > This is the config.
    >
    > 2620t#show run
    > Building configuration...
    >
    > Current configuration : 993 bytes
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > !
    > hostname 2620
    > !
    > enable password
    > !
    > ip subnet-zero
    > !
    > !
    > no ip domain-lookup
    > ip name-server 217.178.3.1
    > ip name-server 217.178.3.1
    > !
    > !
    > !
    > !
    > interface FastEthernet0/0
    > description connected to Internet
    > ip address 219.168.3.253 255.255.255.252
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > no ip mroute-cache
    > speed auto
    > half-duplex
    > no cdp enable
    > !
    > interface Serial0/0
    > description Connection 7206 ds3 atm
    > ip address 219.168.3.250 255.255.255.252
    > encapsulation frame-relay IETF
    > frame-relay interface-dlci 16
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 219.168.3.249
    > ip http server
    > ip pim bidir-enable
    > !
    > no cdp run
    > snmp-server community public RO
    > snmp-server location
    > !
    > line con 0
    > exec-timeout 0 0
    > password
    > login
    > line aux 0
    > line vty 0 4
    > password
    > login
    > !
    > no scheduler allocate
    > end
     
    Nazgulero, Apr 14, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGVzcGVyYWRvMjI4?=

    Synch copy inaccessible

    =?Utf-8?B?RGVzcGVyYWRvMjI4?=, Mar 23, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    496
    =?Utf-8?B?RGVzcGVyYWRvMjI4?=
    Mar 23, 2006
  2. jdillman
    Replies:
    8
    Views:
    3,223
  3. Wendell

    converting accuset 1200 HW rip to software rip

    Wendell, Jun 5, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    1,093
    Wendell
    Jun 5, 2004
  4. Luka
    Replies:
    4
    Views:
    792
  5. CCNA Picture Guide

    RIP v/s IGRP

    CCNA Picture Guide, Aug 3, 2008, in forum: Cisco
    Replies:
    1
    Views:
    488
    Jason Tyler Tomasi
    Aug 4, 2008
Loading...

Share This Page