I need to assign a public ip to a client machine

Discussion in 'Cisco' started by Marskarthik, Aug 28, 2006.

  1. Marskarthik

    Marskarthik Guest

    Hi,

    I have a Cisco 2511 router with current configuration below and I need
    to assign a public ip address to my windows machine. So that i can
    access my machine anywhere from the world by remote desktop and vnc.
    How to do that? any one tell me the code to do that.

    My machine ip is 192.168.1.110 and i want to assign public ip
    185.17.1.180

    My current configuration is below.
    __________________________________________________
    Cisco 2511 Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname cisco2
    !
    enable secret 5 $1$6JBL$Fb0.amMsITZx6vtSNm7n3/
    !
    ip subnet-zero
    ip name-server 202.54.6.60
    ip name-server 202.54.1.30
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.2 255.255.255.0 secondary
    ip address 185.17.1.177 255.255.255.240
    no ip directed-broadcast
    ip nat inside
    no ip route-cache
    no ip mroute-cache
    !
    interface Serial0
    ip address 185.17.0.30 255.255.255.252
    no ip directed-broadcast
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    ip nat pool KARTHIK 185.17.1.179 185.17.1.179 netmask 255.255.255.240
    type rotary
    ip nat inside source list 1 pool KARTHIK overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip route 185.17.1.0 255.255.255.0 185.17.1.81
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    line con 0
    transport input none
    line 1 16
    no exec
    exec-timeout 0 0
    transport input all
    line aux 0
    modem InOut
    transport preferred telnet
    transport input all
    speed 38400
    flowcontrol hardware
    line vty 0 4
    password marskarthik
    login
    !
    end
    __________________________________________________________________


    Thanks,
    Karthik
    http://www.marskarthik.com
     
    Marskarthik, Aug 28, 2006
    #1
    1. Advertising

  2. Marskarthik

    Doan Guest

    On 27 Aug 2006, Marskarthik wrote:

    > Hi,
    >
    > I have a Cisco 2511 router with current configuration below and I need
    > to assign a public ip address to my windows machine. So that i can
    > access my machine anywhere from the world by remote desktop and vnc.
    > How to do that? any one tell me the code to do that.
    >
    > My machine ip is 192.168.1.110 and i want to assign public ip
    > 185.17.1.180
    >


    You can use static nat with:
    ip nat outside source static 185.17.1.180 192.168.1.110

    Doan


    > My current configuration is below.
    > __________________________________________________
    > Cisco 2511 Current configuration:
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname cisco2
    > !
    > enable secret 5 $1$6JBL$Fb0.amMsITZx6vtSNm7n3/
    > !
    > ip subnet-zero
    > ip name-server 202.54.6.60
    > ip name-server 202.54.1.30
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.1.2 255.255.255.0 secondary
    > ip address 185.17.1.177 255.255.255.240
    > no ip directed-broadcast
    > ip nat inside
    > no ip route-cache
    > no ip mroute-cache
    > !
    > interface Serial0
    > ip address 185.17.0.30 255.255.255.252
    > no ip directed-broadcast
    > ip nat outside
    > no ip route-cache
    > no ip mroute-cache
    > no fair-queue
    > !
    > interface Serial1
    > no ip address
    > no ip directed-broadcast
    > no ip mroute-cache
    > shutdown
    > !
    > ip nat pool KARTHIK 185.17.1.179 185.17.1.179 netmask 255.255.255.240
    > type rotary
    > ip nat inside source list 1 pool KARTHIK overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Serial0
    > ip route 185.17.1.0 255.255.255.0 185.17.1.81
    > !
    > access-list 1 permit 192.168.1.0 0.0.0.255
    > !
    > line con 0
    > transport input none
    > line 1 16
    > no exec
    > exec-timeout 0 0
    > transport input all
    > line aux 0
    > modem InOut
    > transport preferred telnet
    > transport input all
    > speed 38400
    > flowcontrol hardware
    > line vty 0 4
    > password marskarthik
    > login
    > !
    > end
    > __________________________________________________________________
    >
    >
    > Thanks,
    > Karthik
    > http://www.marskarthik.com
    >
    >
     
    Doan, Aug 28, 2006
    #2
    1. Advertising

  3. Marskarthik

    Marskarthik Guest

    Thanks Doan.... This works.

    Karthik


    Doan wrote:
    > On 27 Aug 2006, Marskarthik wrote:
    >
    > > Hi,
    > >
    > > I have a Cisco 2511 router with current configuration below and I need
    > > to assign a public ip address to my windows machine. So that i can
    > > access my machine anywhere from the world by remote desktop and vnc.
    > > How to do that? any one tell me the code to do that.
    > >
    > > My machine ip is 192.168.1.110 and i want to assign public ip
    > > 185.17.1.180
    > >

    >
    > You can use static nat with:
    > ip nat outside source static 185.17.1.180 192.168.1.110
    >
    > Doan
    >
    >
    > > My current configuration is below.
    > > __________________________________________________
    > > Cisco 2511 Current configuration:
    > > !
    > > version 12.0
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname cisco2
    > > !
    > > enable secret 5 $1$6JBL$Fb0.amMsITZx6vtSNm7n3/
    > > !
    > > ip subnet-zero
    > > ip name-server 202.54.6.60
    > > ip name-server 202.54.1.30
    > > !
    > > !
    > > !
    > > interface Ethernet0
    > > ip address 192.168.1.2 255.255.255.0 secondary
    > > ip address 185.17.1.177 255.255.255.240
    > > no ip directed-broadcast
    > > ip nat inside
    > > no ip route-cache
    > > no ip mroute-cache
    > > !
    > > interface Serial0
    > > ip address 185.17.0.30 255.255.255.252
    > > no ip directed-broadcast
    > > ip nat outside
    > > no ip route-cache
    > > no ip mroute-cache
    > > no fair-queue
    > > !
    > > interface Serial1
    > > no ip address
    > > no ip directed-broadcast
    > > no ip mroute-cache
    > > shutdown
    > > !
    > > ip nat pool KARTHIK 185.17.1.179 185.17.1.179 netmask 255.255.255.240
    > > type rotary
    > > ip nat inside source list 1 pool KARTHIK overload
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 Serial0
    > > ip route 185.17.1.0 255.255.255.0 185.17.1.81
    > > !
    > > access-list 1 permit 192.168.1.0 0.0.0.255
    > > !
    > > line con 0
    > > transport input none
    > > line 1 16
    > > no exec
    > > exec-timeout 0 0
    > > transport input all
    > > line aux 0
    > > modem InOut
    > > transport preferred telnet
    > > transport input all
    > > speed 38400
    > > flowcontrol hardware
    > > line vty 0 4
    > > password marskarthik
    > > login
    > > !
    > > end
    > > __________________________________________________________________
    > >
    > >
    > > Thanks,
    > > Karthik
    > > http://www.marskarthik.com
    > >
    > >
     
    Marskarthik, Aug 28, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page