I need code for nating in ppp multilink environment

Discussion in 'Cisco' started by Marskarthik, Feb 15, 2007.

  1. Marskarthik

    Marskarthik Guest

    I need help from someone to set nating in multilink environment

    My router internal ip address is : 192.168.1.2
    My router external ip address is : 125.117.1.177
    My router multilink ip address is : 125.117.16.58
    IP that i want to appear outside for internet browsing: 125.117.1.178

    All i need is correct code to set nat on this router so that i can
    browse internet from 192.168.1.X series machines. I need this
    badly......

    Below is the code on my Cisco 2610 router
    ************************
    Current configuration : 1605 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ggsairtel
    !
    boot-start-marker
    boot-end-marker
    !
    !
    memory-size iomem 10
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    ip domain name ggsindia.com
    ip name-server 202.56.250.5
    ip name-server 202.56.230.5
    !
    !
    username cisco privilege 15 secret 5 $1$IQtx$IuJCcgVGertyW1jfoGHTK0
    !
    !
    !
    interface Multilink1
    ip address 125.117.16.58 255.255.255.252
    ppp multilink
    ppp multilink group 1
    !
    interface Ethernet0/0
    description *****Local marskarthik Network*****
    ip address 192.168.1.2 255.255.255.0 secondary
    ip address 125.117.1.177 255.255.255.240
    ip nat inside
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    full-duplex
    !
    interface Serial0/0
    bandwidth 2048
    no ip address
    encapsulation ppp
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    interface Serial0/1
    bandwidth 2048
    no ip address
    encapsulation ppp
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    ppp multilink group 1
    !
    !
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 125.117.16.57
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    line con 0
    ......
    **************************************

    Thanks in advance
    Karthik(www.marskarthik.com)
    Marskarthik, Feb 15, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Gerd Thümmler

    ppp multilink lost many fragments

    Gerd Thümmler, Jul 11, 2003, in forum: Cisco
    Replies:
    0
    Views:
    2,813
    Gerd Thümmler
    Jul 11, 2003
  2. Karnov
    Replies:
    1
    Views:
    8,292
    CCIE8122
    May 24, 2004
  3. Marskarthik
    Replies:
    2
    Views:
    426
    Marskarthik
    Feb 17, 2007
  4. Giuen
    Replies:
    0
    Views:
    690
    Giuen
    Sep 12, 2008
  5. Replies:
    4
    Views:
    493
    Vintz
    May 2, 2007
Loading...

Share This Page