I cannot get my damn FTP server to work? Really frustrating.

Discussion in 'Computer Support' started by David Mills, Jan 22, 2006.

  1. David Mills

    David Mills Guest

    Ok, here is my setup.

    -Linksys cable modem and a Linksys router.
    -I have 2 pc's connected to the modem sharing the cable connection.
    -The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    -My Wan/Internet ip address is 69.167.219.111

    I have my IIS server running and setup correctly. I have "Allow IIS to
    control password" checked under security accounts inside IIS.
    On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    21 forwarded to 192.168.1.100
    I checked on Linksys' knowledge base and it says to have the ip address set
    to 192.168.1.3. I tried using that address and it didn't work either.
    I have searched all over Google for FTP setup using port forwarding and they
    all basically say the same thing, but it isn't working.
    The only thing I tried but didn't work at all is setting up a static ip
    address within my router.
    I went into the router and typed in 69.167.219.111 for my static ip address
    and then that killed my internet access.
    I am assuming you can't just type in whatever "static" ip address you want.
    Checking the research I have done, you shouldn't have to have a static ip
    address in order to get this to work.

    If I open up windows explorer and type in ftp://69.167.219.111/ then I get
    this error:
    ------------------------------------------------------
    Windows cannot access this folder. Make sure you typed the file name
    correctly and that you have permission to access the folder.

    Details:
    The connection with the server was reset
    ------------------------------------------------------

    Does anyone have any ideas what I am doing wrong?

    Thanks.

    DM.
    David Mills, Jan 22, 2006
    #1
    1. Advertising

  2. David Mills

    FML Guest

    David Mills wrote:
    > Ok, here is my setup.
    >
    > -Linksys cable modem and a Linksys router.
    > -I have 2 pc's connected to the modem sharing the cable connection.
    > -The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    > -My Wan/Internet ip address is 69.167.219.111
    >
    > I have my IIS server running and setup correctly. I have "Allow IIS to
    > control password" checked under security accounts inside IIS.
    > On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    > 21 forwarded to 192.168.1.100
    > I checked on Linksys' knowledge base and it says to have the ip address set
    > to 192.168.1.3. I tried using that address and it didn't work either.
    > I have searched all over Google for FTP setup using port forwarding and they
    > all basically say the same thing, but it isn't working.
    > The only thing I tried but didn't work at all is setting up a static ip
    > address within my router.
    > I went into the router and typed in 69.167.219.111 for my static ip address
    > and then that killed my internet access.
    > I am assuming you can't just type in whatever "static" ip address you want.
    > Checking the research I have done, you shouldn't have to have a static ip
    > address in order to get this to work.
    >
    > If I open up windows explorer and type in ftp://69.167.219.111/ then I get
    > this error:
    > ------------------------------------------------------
    > Windows cannot access this folder. Make sure you typed the file name
    > correctly and that you have permission to access the folder.
    >
    > Details:
    > The connection with the server was reset
    > ------------------------------------------------------
    >
    > Does anyone have any ideas what I am doing wrong?
    >
    > Thanks.
    >
    > DM.
    >
    >


    Is your ISP blocking port 21? Some ISPs don't allow you to host servers
    unless you pay extra.
    FML, Jan 22, 2006
    #2
    1. Advertising

  3. David Mills

    Donald Guest

    right click logon as
    "David Mills" <> wrote in message
    news:...
    > Ok, here is my setup.
    >
    > -Linksys cable modem and a Linksys router.
    > -I have 2 pc's connected to the modem sharing the cable connection.
    > -The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    > -My Wan/Internet ip address is 69.167.219.111
    >
    > I have my IIS server running and setup correctly. I have "Allow IIS to
    > control password" checked under security accounts inside IIS.
    > On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    > 21 forwarded to 192.168.1.100
    > I checked on Linksys' knowledge base and it says to have the ip address
    > set to 192.168.1.3. I tried using that address and it didn't work either.
    > I have searched all over Google for FTP setup using port forwarding and
    > they all basically say the same thing, but it isn't working.
    > The only thing I tried but didn't work at all is setting up a static ip
    > address within my router.
    > I went into the router and typed in 69.167.219.111 for my static ip
    > address and then that killed my internet access.
    > I am assuming you can't just type in whatever "static" ip address you
    > want.
    > Checking the research I have done, you shouldn't have to have a static ip
    > address in order to get this to work.
    >
    > If I open up windows explorer and type in ftp://69.167.219.111/ then I get
    > this error:
    > ------------------------------------------------------
    > Windows cannot access this folder. Make sure you typed the file name
    > correctly and that you have permission to access the folder.
    >
    > Details:
    > The connection with the server was reset
    > ------------------------------------------------------
    >
    > Does anyone have any ideas what I am doing wrong?
    >
    > Thanks.
    >
    > DM.
    >
    Donald, Jan 22, 2006
    #3
  4. David Mills

    David Mills Guest

    "Donald" <> wrote in message
    news:...
    > right click logon as


    Not sure where "logon as" is located.
    David Mills, Jan 22, 2006
    #4
  5. David Mills

    David Mills Guest

    "FML" <> wrote in message
    news:...

    > Is your ISP blocking port 21? Some ISPs don't allow you to host servers
    > unless you pay extra.


    I didn't know that was possible, I guess I will find out.

    Thanks.
    David Mills, Jan 22, 2006
    #5
  6. David Mills

    Steve Guest

    I had a similar problem a year or so ago connecting to a corporate ftp site.
    I had to change a setting in my Internet Options/Advance tab- I had to check
    or uncheck "Use Passive FTP (for firewall and DSL modem compatibility). Dont
    know if this is your problem but it solved mine.

    Steve

    "David Mills" <> wrote in message
    news:...
    > Ok, here is my setup.
    >
    > -Linksys cable modem and a Linksys router.
    > -I have 2 pc's connected to the modem sharing the cable connection.
    > -The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    > -My Wan/Internet ip address is 69.167.219.111
    >
    > I have my IIS server running and setup correctly. I have "Allow IIS to
    > control password" checked under security accounts inside IIS.
    > On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    > 21 forwarded to 192.168.1.100
    > I checked on Linksys' knowledge base and it says to have the ip address
    > set to 192.168.1.3. I tried using that address and it didn't work either.
    > I have searched all over Google for FTP setup using port forwarding and
    > they all basically say the same thing, but it isn't working.
    > The only thing I tried but didn't work at all is setting up a static ip
    > address within my router.
    > I went into the router and typed in 69.167.219.111 for my static ip
    > address and then that killed my internet access.
    > I am assuming you can't just type in whatever "static" ip address you
    > want.
    > Checking the research I have done, you shouldn't have to have a static ip
    > address in order to get this to work.
    >
    > If I open up windows explorer and type in ftp://69.167.219.111/ then I get
    > this error:
    > ------------------------------------------------------
    > Windows cannot access this folder. Make sure you typed the file name
    > correctly and that you have permission to access the folder.
    >
    > Details:
    > The connection with the server was reset
    > ------------------------------------------------------
    >
    > Does anyone have any ideas what I am doing wrong?
    >
    > Thanks.
    >
    > DM.
    >
    Steve, Jan 22, 2006
    #6
  7. David Mills

    David Mills Guest

    "Steve" <> wrote in message
    news:WpFAf.4357$...
    >I had a similar problem a year or so ago connecting to a corporate ftp
    >site. I had to change a setting in my Internet Options/Advance tab- I had
    >to check or uncheck "Use Passive FTP (for firewall and DSL modem
    >compatibility). Dont know if this is your problem but it solved mine.
    >
    > Steve
    >


    Thanks, I will give it a shot.
    David Mills, Jan 22, 2006
    #7
  8. David Mills

    Duane Arnold Guest

    "David Mills" <> wrote in message
    news:...
    > Ok, here is my setup.
    >
    > -Linksys cable modem and a Linksys router.
    > -I have 2 pc's connected to the modem sharing the cable connection.
    > -The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    > -My Wan/Internet ip address is 69.167.219.111
    >
    > I have my IIS server running and setup correctly. I have "Allow IIS to
    > control password" checked under security accounts inside IIS.
    > On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    > 21 forwarded to 192.168.1.100


    That's OK but if the IP for the machine that has IIS running changes to
    another IP then port forwarding will no longer work as it will be pointing
    to the wrong machine.

    > I checked on Linksys' knowledge base and it says to have the ip address
    > set to 192.168.1.3. I tried using that address and it didn't work either.


    Well, that's the kind of IP on the router you should be using a static IP on
    the router for the machine and not a DHCP IP. The static IP never changes
    for the machine and port forwarding rules would not be broken due to the IP
    pointing to a machine that doesn't have IIS running.

    > I have searched all over Google for FTP setup using port forwarding and
    > they all basically say the same thing, but it isn't working.


    You may have to set the IIS FTP folder and the browser to use the PASV mode
    "passive mode setting".

    > The only thing I tried but didn't work at all is setting up a static ip
    > address within my router.
    > I went into the router and typed in 69.167.219.111 for my static ip
    > address and then that killed my internet access.


    ISP's have a static IP address that they can give a user requesting to use
    the IPS's static IP addresses which also includes two other IPS(s) that must
    be used and are DNS IP(s) for the ISP.

    > I am assuming you can't just type in whatever "static" ip address you
    > want.


    You can use any static IP on the router you want and not the static IP at
    the ISP. Static IP(s) would be any IP that is not issued by the DHCP server
    on the router. 192.168.1.2 through 192.168.1.99 are static IP(s). The DHCP
    IP(s) start at 192.168.100 for the DHCP Issue Count most likely 50 so DHCP
    IP(s) are from 192.168.1.100 to 192.168.1.150 and IP(s) after that are
    static IP(s), since the DHCP server on the router doesn't issue those IP(s)
    dynamically.

    > Checking the research I have done, you shouldn't have to have a static ip
    > address in order to get this to work.


    No you don't. However, for reasons above, it's best that you use a static
    IP on the router.

    >
    > If I open up windows explorer and type in ftp://69.167.219.111/ then I get
    > this error:
    > ------------------------------------------------------
    > Windows cannot access this folder. Make sure you typed the file name
    > correctly and that you have permission to access the folder.
    >
    > Details:
    > The connection with the server was reset
    > ------------------------------------------------------
    >
    > Does anyone have any ideas what I am doing wrong?


    The fact that you're trying to expose a machine that has IIS running to the
    public Internet that I am sure that the O/S, IIS, the registry, file system
    and user accounts are not secured is the problem, which there are books
    explaining how to do this properly and WEB sites that have this information
    by using Google.

    If you do get the machine exposed to the public Internet, then it's going to
    be nothing but *hack* bait as you have not done your homework. IT WEB
    administers have a hard time securing a machine running IIS facing the
    public Internet let alone some clueless home user.

    Duane :)
    Duane Arnold, Jan 22, 2006
    #8
  9. David Mills

    why? Guest

    On Sat, 21 Jan 2006 22:18:30 -0500, David Mills wrote:

    >Ok, here is my setup.
    >
    >-Linksys cable modem and a Linksys router.
    >-I have 2 pc's connected to the modem sharing the cable connection.
    >-The pc's internal ip addresses are 192.168.1.100 and 192.168.1.101
    >-My Wan/Internet ip address is 69.167.219.111
    >
    >I have my IIS server running and setup correctly. I have "Allow IIS to
    >control password" checked under security accounts inside IIS.


    IIS is the worst server to expose that sort of setup. Get something else
    like http://www.bpftpserver.com/ or any of a large number of other
    choices.

    >On my router setup pages, under the "forwarding" tab, I have ports 20 thru
    >21 forwarded to 192.168.1.100
    >I checked on Linksys' knowledge base and it says to have the ip address set


    No link to the KB article to check what it says?

    >to 192.168.1.3. I tried using that address and it didn't work either.


    Which IP address needs to be that, and if you don't have a PC set to
    that you use the addresses you do have.

    >I have searched all over Google for FTP setup using port forwarding and they


    Did you try, http://portforward.com/ ? I have heard a lot of people at
    work using it.

    >all basically say the same thing, but it isn't working.

    <snip>

    Me
    why?, Jan 22, 2006
    #9
  10. David Mills

    jp10558 Guest

    On Sat, 21 Jan 2006 22:59:29 -0500, David Mills wrote:

    > "FML" <> wrote in message
    > news:...
    >
    >> Is your ISP blocking port 21? Some ISPs don't allow you to host servers
    >> unless you pay extra.

    >
    > I didn't know that was possible, I guess I will find out.
    >
    > Thanks.


    Depending on "things" you might be able to just use a high port >1024...
    But there is an issue also, you need to force pasv mode for the FTP client,
    something that Explorer may not support (explicit passive mode?). Active
    mode doesn't seem to work well if at all through a NAT.

    Another option, if this is for limited access (friends and family) is to
    use a VPN, like Hamachi (www.hamachi.cc).
    jp10558, Jan 22, 2006
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mazon
    Replies:
    0
    Views:
    3,788
    Mazon
    Aug 17, 2003
  2. JD

    Cannot connect to my own FTP server

    JD, Jun 12, 2004, in forum: Computer Support
    Replies:
    24
    Views:
    11,759
  3. John

    Cannot get server to work

    John, Oct 21, 2007, in forum: Computer Support
    Replies:
    21
    Views:
    884
    Paige D'Winter
    Oct 23, 2007
  4. Andrew

    cd writer + linux = damn thing wont work

    Andrew, Aug 31, 2005, in forum: NZ Computing
    Replies:
    13
    Views:
    499
    Andrew
    Sep 4, 2005
  5. Rita Berkowitz

    The Damn D3 Is Really Getting To Be A Nut Buster!!

    Rita Berkowitz, Jan 13, 2008, in forum: Digital Photography
    Replies:
    23
    Views:
    585
    William Graham
    Jan 21, 2008
Loading...

Share This Page