HSRP monitor several interfaces switching to standby on failure ofany active interface

Discussion in 'Cisco' started by Daniel-G, May 11, 2008.

  1. Daniel-G

    Daniel-G Guest

    Hello,
    I need some hint
    I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    setup in a failover configuration with HSRP

    The idea is to switch to the backup router if any of the interfaces goes
    down

    On main router :

    interface f0/0
    ip address 10.0.0.2 255.255.255.0
    standby 1 ip 10.0.0.1
    standby 1 preempt
    standby track f0/1

    interface f0/1
    ip address 172.16.0.2 255.255.255.0
    standby 2 ip 172.16.0.1
    standby 2 preempt
    standby track f0/0

    I need some hints because I can't model the configurations
    Thanks in advance
     
    Daniel-G, May 11, 2008
    #1
    1. Advertising

  2. Daniel-G

    Trendkill Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    > Hello,
    > I need some hint
    > I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    > setup in a failover configuration with HSRP
    >
    > The idea is to switch to the backup router if any of the interfaces goes
    > down
    >
    > On main router :
    >
    > interface f0/0
    > ip address 10.0.0.2 255.255.255.0
    > standby 1 ip 10.0.0.1
    > standby 1 preempt
    > standby track f0/1
    >
    > interface f0/1
    > ip address 172.16.0.2 255.255.255.0
    > standby 2 ip 172.16.0.1
    > standby 2 preempt
    > standby track f0/0
    >
    > I need some hints because I can't model the configurations
    > Thanks in advance


    I would also recommend setting a priority on both sides, either to
    ensure your traffic is being equally shared between core routers, or B
    because you want one link preferred downstream (presuming all paths
    are equal). Higher priority wins in this case, opposite of say
    spantree priorities on vlans.
     
    Trendkill, May 11, 2008
    #2
    1. Advertising

  3. Daniel-G

    Merv Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    On May 11, 7:40 am, Trendkill <> wrote:
    > On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >
    >
    >
    > > Hello,
    > > I need some hint
    > > I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    > > setup in a failover configuration with HSRP

    >
    > > The idea is to switch to the backup router if any of the interfaces goes
    > > down



    and do you want to stay on the backup router and move back
    manually ???

    ponder what happens for example if you have a flapping Fast Ethernet
    interface on the main router
     
    Merv, May 11, 2008
    #3
  4. Daniel-G

    Daniel-G Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    Trendkill a écrit :
    > On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >> Hello,
    >> I need some hint
    >> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    >> setup in a failover configuration with HSRP
    >>
    >> The idea is to switch to the backup router if any of the interfaces goes
    >> down
    >>
    >> On main router :
    >>
    >> interface f0/0
    >> ip address 10.0.0.2 255.255.255.0
    >> standby 1 ip 10.0.0.1
    >> standby 1 preempt
    >> standby track f0/1
    >>
    >> interface f0/1
    >> ip address 172.16.0.2 255.255.255.0
    >> standby 2 ip 172.16.0.1
    >> standby 2 preempt
    >> standby track f0/0
    >>
    >> I need some hints because I can't model the configurations
    >> Thanks in advance

    >
    > I would also recommend setting a priority on both sides, either to
    > ensure your traffic is being equally shared between core routers, or B
    > because you want one link preferred downstream (presuming all paths
    > are equal). Higher priority wins in this case, opposite of say
    > spantree priorities on vlans.

    Of course, you're right. I didn't mention priority to make it light.
    I used to

    Actually what I want is having the failover take precedence if any of
    the interfaces of the main router goes down.
    I wonder wether it is possible to have the same standby group for all
    interfaces.
    The problem is that I can't test it as the main router is running and
    the 2nd is in "manual" standby (i.e. stopped).
     
    Daniel-G, May 11, 2008
    #4
  5. Daniel-G

    Daniel-G Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    Merv a écrit :
    > On May 11, 7:40 am, Trendkill <> wrote:
    >> On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >>
    >>
    >>
    >>> Hello,
    >>> I need some hint
    >>> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    >>> setup in a failover configuration with HSRP
    >>> The idea is to switch to the backup router if any of the interfaces goes
    >>> down

    >
    >
    > and do you want to stay on the backup router and move back
    > manually ???
    >
    > ponder what happens for example if you have a flapping Fast Ethernet
    > interface on the main router
    >

    Actually that's an excellent hint. I didn't think of it.
    I have no idea on how to make it.
    Maybe removing the preempt command on the emain router would be enough
    but, then I have to be careful when starting the routers.
    Or maybe I can set the preempt command, just when I want to revert back
    to the main router.
     
    Daniel-G, May 11, 2008
    #5
  6. Daniel-G

    Merv Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    On May 11, 11:14 am, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    > Merv a écrit :
    >
    > > On May 11, 7:40 am, Trendkill <> wrote:
    > >> On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:

    >
    > >>> Hello,
    > >>> I need some hint
    > >>> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    > >>> setup in a failover configuration with HSRP
    > >>> The idea is to switch to the backup router if any of the interfaces goes
    > >>> down

    >
    > > and do you want to stay on the backup router and move back
    > > manually ???

    >
    > > ponder what happens for example if you have a flapping Fast Ethernet
    > > interface on the main router

    >
    > Actually that's an excellent hint. I didn't think of it.
    > I have no idea on how to make it.
    > Maybe removing the preempt command on the emain router would be enough
    > but, then I have to be careful when starting the routers.
    > Or maybe I can set the preempt command, just when I want to revert back
    > to the main router.



    Usually the HSRP tracking feature is used to track the state of WAN
    interfaces.

    Is this how you were intending to use it or are you trying to track
    LAN interfaces.
    If the later I would discourage you from doing so as you will
    unnecessarily complicate your
    operating environment.

    Perhaps you can share a little more info about both router , i.e the
    WAN side of things
    to assist folks in responding to your query.
     
    Merv, May 11, 2008
    #6
  7. Daniel-G

    Daniel-G Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    Merv a écrit :
    > On May 11, 11:14 am, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >> Merv a écrit :
    >>
    >>> On May 11, 7:40 am, Trendkill <> wrote:
    >>>> On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >>>>> Hello,
    >>>>> I need some hint
    >>>>> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    >>>>> setup in a failover configuration with HSRP
    >>>>> The idea is to switch to the backup router if any of the interfaces goes
    >>>>> down
    >>> and do you want to stay on the backup router and move back
    >>> manually ???
    >>> ponder what happens for example if you have a flapping Fast Ethernet
    >>> interface on the main router

    >> Actually that's an excellent hint. I didn't think of it.
    >> I have no idea on how to make it.
    >> Maybe removing the preempt command on the emain router would be enough
    >> but, then I have to be careful when starting the routers.
    >> Or maybe I can set the preempt command, just when I want to revert back
    >> to the main router.

    >
    >
    > Usually the HSRP tracking feature is used to track the state of WAN
    > interfaces.
    >
    > Is this how you were intending to use it or are you trying to track
    > LAN interfaces.
    > If the later I would discourage you from doing so as you will
    > unnecessarily complicate your
    > operating environment.
    >
    > Perhaps you can share a little more info about both router , i.e the
    > WAN side of things
    > to assist folks in responding to your query.
    >

    You're right I didn't tell much
    I thought it was enough.
    Currently there is 1 router in charge of intervlan routing
    It's a 2611xm with sub-interfaces on the only Fast Ethernet
    Fortunately there are only 2 vlans
    Unfortunately the admin vlan is the base vlan for the branch.
    The other router is a 2610 and is supposed to have the same
    configuration except that it has only an ethernet interface. It is kept
    off awaiting that the main router fails.
    My predecessor did it this way, because he didn't know anything about
    fault tolerance.

    I made a configuration similar to the one I want with 3550 L3 long time
    ago and it worked well because they were in charge of both L2 (with
    RPVST) and L3 transport

    Here, as you can see, I don't monitor a wan interface, but by
    extrapolation, I think I can consider 1 interface as the wan interface
    of the other (it'd be the idea)

    RtrA RtrB
    10.0.0.2/24 F0/0.1-------------VL1------------E0/0.1 10.0.0.3/24
    Virtual [VL1] 10.0.0.1
    172.16.0.2/24 F0/0.2-----------VL2------------E0/0.2 172.16.0.3/24
    Virtual [VL2] 172.16.0.1


    from my point of view a basic config could be :

    Rtr A

    interface f0/0.1
    ip address 10.0.0.2 255.255.255.0
    standby 1 ip 10.0.0.1
    standby 1 preempt

    interface f0/0.2
    ip address 172.16.0.2 255.255.255.0
    standby 2 ip 172.16.0.1
    standby 2 preempt


    standby x preempt <-- these lines only for startup to avoid having the
    routeur retaking precedence in case of flapping as you suggested

    Rtr B

    interface E0/0.1
    ip address 10.0.0.3 255.255.255.0
    standby 1 ip 10.0.0.1
    standby 1 priority 90
    standby 1 preempt

    interface E0/0.2
    ip address 172.16.0.2 255.255.255.0
    standby 2 ip 172.16.0.1
    standby 2 priority 90
    standby 2 preempt


    I wonder if it could work assigning the same standby group for each
    interface. Actually I see no reason why it shouldn't work. That would
    avoid tracking the other interface and make the whole "virtual" routeur
    go down
    or maybe it's more secure to add track f0/0.1 on f0/0.2 and track f0/0.2
    on f0/0.1

    A simple modeling could answer quickly, but I can't make it.

    It's a temporary solution.
    The idea is to have quickly both routers up while planning
    reconfiguration of the whole network :
    - move base vlan on another vlan than the administrative vlan
    - setup stp to provide fault tolerance to the whole network
    and many other little things
    btw the switches are HP 4xxx which could be able to provide L3 functions
    later as well as stp.

    I hope I gave details clear enough

    Anyway thanks for your previous answer
     
    Daniel-G, May 11, 2008
    #7
  8. Daniel-G

    Merv Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    On May 11, 4:51 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    > Merv a écrit :
    >
    > > On May 11, 11:14 am, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    > >> Merv a écrit :

    >
    > >>> On May 11, 7:40 am, Trendkill <> wrote:
    > >>>> On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    > >>>>> Hello,
    > >>>>> I need some hint
    > >>>>> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    > >>>>> setup in a failover configuration with HSRP
    > >>>>> The idea is to switch to the backup router if any of the interfaces goes
    > >>>>> down
    > >>> and do you want to stay on the backup router and move back
    > >>> manually ???
    > >>> ponder what happens for example if you have a flapping Fast Ethernet
    > >>> interface on the main router
    > >> Actually that's an excellent hint. I didn't think of it.
    > >> I have no idea on how to make it.
    > >> Maybe removing the preempt command on the emain router would be enough
    > >> but, then I have to be careful when starting the routers.
    > >> Or maybe I can set the preempt command, just when I want to revert back
    > >> to the main router.

    >
    > > Usually the HSRP tracking feature is used to track the state of WAN
    > > interfaces.

    >
    > > Is this how you were intending to use it or are you trying to track
    > > LAN interfaces.
    > > If the later I would discourage you from doing so as you will
    > > unnecessarily complicate your
    > > operating environment.

    >
    > > Perhaps you can share a little more info about both router , i.e the
    > > WAN side of things
    > > to assist folks in responding to your query.

    >
    > You're right I didn't tell much
    > I thought it was enough.
    > Currently there is 1 router in charge of intervlan routing
    > It's a 2611xm with sub-interfaces on the only Fast Ethernet
    > Fortunately there are only 2 vlans
    > Unfortunately the admin vlan is the base vlan for the branch.
    > The other router is a 2610 and is supposed to have the same
    > configuration except that it has only an ethernet interface. It is kept
    > off awaiting that the main router fails.
    > My predecessor did it this way, because he didn't know anything about
    > fault tolerance.
    >
    > I made a configuration similar to the one I want with 3550 L3 long time
    > ago and it worked well because they were in charge of both L2 (with
    > RPVST) and L3 transport
    >
    > Here, as you can see, I don't monitor a wan interface, but by
    > extrapolation, I think I can consider 1 interface as the wan interface
    > of the other (it'd be the idea)
    >
    > RtrA RtrB
    > 10.0.0.2/24 F0/0.1-------------VL1------------E0/0.1 10.0.0.3/24
    > Virtual [VL1] 10.0.0.1
    > 172.16.0.2/24 F0/0.2-----------VL2------------E0/0.2 172.16.0.3/24
    > Virtual [VL2] 172.16.0.1
    >
    > from my point of view a basic config could be :
    >
    > Rtr A
    >
    > interface f0/0.1
    > ip address 10.0.0.2 255.255.255.0
    > standby 1 ip 10.0.0.1
    > standby 1 preempt
    >
    > interface f0/0.2
    > ip address 172.16.0.2 255.255.255.0
    > standby 2 ip 172.16.0.1
    > standby 2 preempt
    >
    > standby x preempt <-- these lines only for startup to avoid having the
    > routeur retaking precedence in case of flapping as you suggested
    >
    > Rtr B
    >
    > interface E0/0.1
    > ip address 10.0.0.3 255.255.255.0
    > standby 1 ip 10.0.0.1
    > standby 1 priority 90
    > standby 1 preempt
    >
    > interface E0/0.2
    > ip address 172.16.0.2 255.255.255.0
    > standby 2 ip 172.16.0.1
    > standby 2 priority 90
    > standby 2 preempt
    >
    > I wonder if it could work assigning the same standby group for each
    > interface. Actually I see no reason why it shouldn't work. That would
    > avoid tracking the other interface and make the whole "virtual" routeur
    > go down
    > or maybe it's more secure to add track f0/0.1 on f0/0.2 and track f0/0.2
    > on f0/0.1
    >
    > A simple modeling could answer quickly, but I can't make it.
    >
    > It's a temporary solution.
    > The idea is to have quickly both routers up while planning
    > reconfiguration of the whole network :
    > - move base vlan on another vlan than the administrative vlan
    > - setup stp to provide fault tolerance to the whole network
    > and many other little things
    > btw the switches are HP 4xxx which could be able to provide L3 functions
    > later as well as stp.
    >
    > I hope I gave details clear enough
    >
    > Anyway thanks for your previous answer



    If the requirement is redundant VLAN routing, then use the basic HSRP
    configs you posted without using tracking

    Keeps things as simple as possible while achieving the desired reduncy
    goals
     
    Merv, May 11, 2008
    #8
  9. Daniel-G

    Daniel-G Guest

    Re: HSRP monitor several interfaces switching to standby on failureof any active interface

    Merv a écrit :
    > On May 11, 4:51 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >> Merv a écrit :
    >>
    >>> On May 11, 11:14 am, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >>>> Merv a écrit :
    >>>>> On May 11, 7:40 am, Trendkill <> wrote:
    >>>>>> On May 10, 7:07 pm, Daniel-G <free-news_no-replyATcasylde.fr> wrote:
    >>>>>>> Hello,
    >>>>>>> I need some hint
    >>>>>>> I have 2 C26xx running IOS 12.1 with several interfaces which I want to
    >>>>>>> setup in a failover configuration with HSRP
    >>>>>>> The idea is to switch to the backup router if any of the interfaces goes
    >>>>>>> down
    >>>>> and do you want to stay on the backup router and move back
    >>>>> manually ???
    >>>>> ponder what happens for example if you have a flapping Fast Ethernet
    >>>>> interface on the main router
    >>>> Actually that's an excellent hint. I didn't think of it.
    >>>> I have no idea on how to make it.
    >>>> Maybe removing the preempt command on the emain router would be enough
    >>>> but, then I have to be careful when starting the routers.
    >>>> Or maybe I can set the preempt command, just when I want to revert back
    >>>> to the main router.
    >>> Usually the HSRP tracking feature is used to track the state of WAN
    >>> interfaces.
    >>> Is this how you were intending to use it or are you trying to track
    >>> LAN interfaces.
    >>> If the later I would discourage you from doing so as you will
    >>> unnecessarily complicate your
    >>> operating environment.
    >>> Perhaps you can share a little more info about both router , i.e the
    >>> WAN side of things
    >>> to assist folks in responding to your query.

    >> You're right I didn't tell much
    >> I thought it was enough.
    >> Currently there is 1 router in charge of intervlan routing
    >> It's a 2611xm with sub-interfaces on the only Fast Ethernet
    >> Fortunately there are only 2 vlans
    >> Unfortunately the admin vlan is the base vlan for the branch.
    >> The other router is a 2610 and is supposed to have the same
    >> configuration except that it has only an ethernet interface. It is kept
    >> off awaiting that the main router fails.
    >> My predecessor did it this way, because he didn't know anything about
    >> fault tolerance.
    >>
    >> I made a configuration similar to the one I want with 3550 L3 long time
    >> ago and it worked well because they were in charge of both L2 (with
    >> RPVST) and L3 transport
    >>
    >> Here, as you can see, I don't monitor a wan interface, but by
    >> extrapolation, I think I can consider 1 interface as the wan interface
    >> of the other (it'd be the idea)
    >>
    >> RtrA RtrB
    >> 10.0.0.2/24 F0/0.1-------------VL1------------E0/0.1 10.0.0.3/24
    >> Virtual [VL1] 10.0.0.1
    >> 172.16.0.2/24 F0/0.2-----------VL2------------E0/0.2 172.16.0.3/24
    >> Virtual [VL2] 172.16.0.1
    >>
    >> from my point of view a basic config could be :
    >>
    >> Rtr A
    >>
    >> interface f0/0.1
    >> ip address 10.0.0.2 255.255.255.0
    >> standby 1 ip 10.0.0.1
    >> standby 1 preempt
    >>
    >> interface f0/0.2
    >> ip address 172.16.0.2 255.255.255.0
    >> standby 2 ip 172.16.0.1
    >> standby 2 preempt
    >>
    >> standby x preempt <-- these lines only for startup to avoid having the
    >> routeur retaking precedence in case of flapping as you suggested
    >>
    >> Rtr B
    >>
    >> interface E0/0.1
    >> ip address 10.0.0.3 255.255.255.0
    >> standby 1 ip 10.0.0.1
    >> standby 1 priority 90
    >> standby 1 preempt
    >>
    >> interface E0/0.2
    >> ip address 172.16.0.2 255.255.255.0
    >> standby 2 ip 172.16.0.1
    >> standby 2 priority 90
    >> standby 2 preempt
    >>
    >> I wonder if it could work assigning the same standby group for each
    >> interface. Actually I see no reason why it shouldn't work. That would
    >> avoid tracking the other interface and make the whole "virtual" routeur
    >> go down
    >> or maybe it's more secure to add track f0/0.1 on f0/0.2 and track f0/0.2
    >> on f0/0.1
    >>
    >> A simple modeling could answer quickly, but I can't make it.
    >>
    >> It's a temporary solution.
    >> The idea is to have quickly both routers up while planning
    >> reconfiguration of the whole network :
    >> - move base vlan on another vlan than the administrative vlan
    >> - setup stp to provide fault tolerance to the whole network
    >> and many other little things
    >> btw the switches are HP 4xxx which could be able to provide L3 functions
    >> later as well as stp.
    >>
    >> I hope I gave details clear enough
    >>
    >> Anyway thanks for your previous answer

    >
    >
    > If the requirement is redundant VLAN routing, then use the basic HSRP
    > configs you posted without using tracking
    >
    > Keeps things as simple as possible while achieving the desired reduncy
    > goals

    Yes I think you're right
    I'll let you know
    Thanks for your help
    Thanks also to trendkil for his answer
     
    Daniel-G, May 11, 2008
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. lfnetworking
    Replies:
    0
    Views:
    745
    lfnetworking
    May 20, 2005
  2. lfnetworking
    Replies:
    0
    Views:
    707
    lfnetworking
    May 20, 2005
  3. Erich Reimberg N.

    Active/standby config for ASA 5510

    Erich Reimberg N., Jul 1, 2005, in forum: Cisco
    Replies:
    0
    Views:
    796
    Erich Reimberg N.
    Jul 1, 2005
  4. Replies:
    2
    Views:
    1,232
  5. UBEST
    Replies:
    0
    Views:
    769
    UBEST
    Apr 24, 2007
Loading...

Share This Page