HSRP did not work when it should have

Discussion in 'Cisco' started by Jowan, Jan 26, 2010.

  1. Jowan

    Jowan Guest

    Hi Guys,

    I have a strange issue on HSRP. Has anyone encountered such an issue
    before ? I had to shutdown the standby switch so I made sure all the
    vlans are active on the primary switch. On reboot of secondary switch,
    Vlan 23 below which was active on the primary switch went from Active
    to Init state and remained in that state till the secondary switch
    came back up.

    Actually there were 12 vlans out of which 4 got stuck in Init, the
    others remained active. I have truncated the config and am focusing
    only on the below 3 vlans which depict the whole scenario else
    mentioning all the 12 Vlans was making the whole explanation below too
    long. Do let me know if you need any more information.


    -------------------------------------------------------------------------
    Before shutting down standby:
    -------------------------------------------------------------------------

    C6509-01# sh standby brief
    P indicates configured to preempt.
    |
    Interface Grp Prio P State Active Standby
    Virtual IP
    Vl21 0 200 P Active local 10.65.33.253
    10.65.33.254
    Vl22 0 200 P Active local 10.65.34.253
    10.65.34.254
    Vl23 0 200 P Active local 10.65.50.3
    10.65.50.1

    -------------------------------------------------------------------------
    When I shut down standby:
    -------------------------------------------------------------------------

    C6509-01#sh standby brief
    P indicates configured to preempt.
    |
    Interface Grp Prio P State Active Standby
    Virtual IP
    Vl21 0 200 P Active local unknown
    10.65.33.254
    Vl22 0 200 P Active local unknown
    10.65.34.254
    Vl23 0 200 P Init unknown unknown
    10.65.50.1

    -------------------------------------------------------------------------
    Configuration on active side:
    -------------------------------------------------------------------------

    interface Vlan21
    ip address 10.65.33.252 255.255.255.0
    ip igmp snooping querier
    standby ip 10.65.33.254
    standby priority 200
    standby preempt
    !
    interface Vlan22
    ip address 10.65.34.252 255.255.255.0
    standby ip 10.65.34.254
    standby priority 200
    standby preempt
    !
    interface Vlan23
    ip address 10.65.50.2 255.255.255.0
    standby ip 10.65.50.1
    standby priority 200
    standby preempt

    -------------------------------------------------------------------------
    Configuration on secondary switch ( which was rebooted ):
    -------------------------------------------------------------------------


    interface Vlan21
    ip address 10.65.33.253 255.255.255.0
    ip igmp snooping querier
    standby ip 10.65.33.254
    standby preempt
    !
    interface Vlan22
    ip address 10.65.34.253 255.255.255.0
    standby ip 10.65.34.254
    standby preempt
    !
    interface Vlan23
    ip address 10.65.50.3 255.255.255.0
    standby ip 10.65.50.1
    standby preempt
    Jowan, Jan 26, 2010
    #1
    1. Advertising

  2. Jowan

    bod43 Guest

    On 26 Jan, 13:37, Jowan <> wrote:
    > Hi Guys,
    >
    > I have a strange issue on HSRP. Has anyone encountered such an issue
    > before ? I had to shutdown the standby switch so I made sure all the
    > vlans are active on the primary switch. On reboot of secondary switch,
    > Vlan 23 below which was active on the primary switch went from Active
    > to Init state and remained in that state till the secondary switch
    > came back up.
    >
    > Actually there were 12 vlans out of which 4 got stuck in Init, the
    > others remained active. I have truncated the config and am focusing
    > only on the below 3 vlans which depict the whole scenario else
    > mentioning all the 12 Vlans was making the whole explanation below too
    > long. Do let me know if you need any more information.
    >
    > -------------------------------------------------------------------------
    > Before shutting down standby:
    > -------------------------------------------------------------------------
    >
    > C6509-01# sh standby brief
    >                      P indicates configured to preempt.
    >                      |
    > Interface   Grp Prio P State    Active          Standby
    > Virtual IP
    > Vl21        0   200  P Active   local           10.65.33.253
    > 10.65.33.254
    > Vl22        0   200  P Active   local           10.65.34.253
    > 10.65.34.254
    > Vl23        0   200  P Active   local           10.65.50.3
    > 10.65.50.1
    >
    > -------------------------------------------------------------------------
    > When I shut down standby:
    > -------------------------------------------------------------------------
    >
    > C6509-01#sh standby brief
    >                      P indicates configured to preempt.
    >                      |
    > Interface   Grp Prio P State    Active          Standby
    > Virtual IP
    > Vl21        0   200  P Active   local           unknown
    > 10.65.33.254
    > Vl22        0   200  P Active   local           unknown
    > 10.65.34.254
    > Vl23        0   200  P Init     unknown         unknown
    > 10.65.50.1
    >
    > -------------------------------------------------------------------------
    > Configuration on active side:
    > -------------------------------------------------------------------------
    >
    > interface Vlan21
    >  ip address 10.65.33.252 255.255.255.0
    >  ip igmp snooping querier
    >  standby ip 10.65.33.254
    >  standby priority 200
    >  standby preempt
    > !
    > interface Vlan22
    >  ip address 10.65.34.252 255.255.255.0
    >  standby ip 10.65.34.254
    >  standby priority 200
    >  standby preempt
    > !
    > interface Vlan23
    >  ip address 10.65.50.2 255.255.255.0
    >  standby ip 10.65.50.1
    >  standby priority 200
    >  standby preempt
    >
    > -------------------------------------------------------------------------
    > Configuration on secondary switch ( which was rebooted ):
    > -------------------------------------------------------------------------
    >
    > interface Vlan21
    >  ip address 10.65.33.253 255.255.255.0
    >  ip igmp snooping querier
    >  standby ip 10.65.33.254
    >  standby preempt
    > !
    > interface Vlan22
    > ip address 10.65.34.253 255.255.255.0
    >  standby ip 10.65.34.254
    >  standby preempt
    > !
    > interface Vlan23
    >  ip address 10.65.50.3 255.255.255.0
    >  standby ip 10.65.50.1
    >  standby preempt


    There is nothing wrong with the config.

    The only thing that springs to mind is that the VLAN 23
    interface itself might be going down when you shutdown the
    "standby" switch since there are no active ports remaining in
    the Vlan. I forget the details but a Vlan with no active physical
    ports (i.e. up up) stops being a Vlan - state is not "active".

    sh vlan - check Vlan 23 is active
    sh int - check int vlan 23 is up up.

    Otherwise maybe a bug?

    http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094afd.shtml#top6

    Mentions just such a bug that affects routers.

    Try shut/no shut of vlan 23 to see if that clears the problem.
    If so it's a bug.
    bod43, Jan 27, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. optimus
    Replies:
    1
    Views:
    662
    Phillip Remaker
    Dec 31, 2003
  2. The Maitch
    Replies:
    0
    Views:
    481
    The Maitch
    Apr 26, 2005
  3. Keith Richmond

    "Skype me" did not work?

    Keith Richmond, Mar 9, 2005, in forum: VOIP
    Replies:
    6
    Views:
    1,112
  4. RichA
    Replies:
    27
    Views:
    337
    Nick Fotis
    Nov 4, 2013
  5. RichA

    Nikon should (should have) made the D9300 40MP

    RichA, May 16, 2014, in forum: Digital Photography
    Replies:
    57
    Views:
    551
    PeterN
    May 23, 2014
Loading...

Share This Page