How to turn off (Disable) Multicast RPF Check (Needs forwarding Non-RPF Packets)

Discussion in 'Cisco' started by meteor713, Dec 5, 2004.

  1. meteor713

    meteor713 Guest

    I have two GRE tunnels connected with other vender's router.
    Multicast Packets come from the two GRE tunnels with same source IP.
    (It's been load-balanced network)

    monitor says "Tunnel 1 xxxxxx Not RPF packet..."
    So I added returning unicast static routing to two tunnels.
    The mcast packets from one of two tunnels forwarded OK.
    but the mcast packets from another tunnel is dropped by "RPF Check"

    Is there any way to turn off RPF check ?
    (There is no VLAN, nor same LAN mcast. so don't worry about looping)
    or any method to "RPF check" can see "two GW for same dst network"

    My config is as below.
    MCAST packet is "2.0.2.1 -> 239.255.12.42" only.

    Thanks!

    ---------------------------------------

    ip subnet-zero
    !
    ip multicast-routing
    !
    interface Tunnel0
    ip address 4.1.1.1 255.255.255.0
    ip pim sparse-dense-mode
    tunnel source FastEthernet0/1
    tunnel destination 5.1.1.211
    !
    interface Tunnel1
    ip address 4.1.2.1 255.255.255.0
    ip pim sparse-dense-mode
    tunnel source FastEthernet0/1
    tunnel destination 5.1.1.212
    !
    interface FastEthernet0/0
    ip address 3.0.1.1 255.255.255.0
    ip pim sparse-dense-mode
    ip igmp static-group 239.255.12.42 -> this is static MCAST IP
    no ip mroute-cache
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 5.1.1.200 255.255.255.0
    no ip mroute-cache
    duplex auto
    speed auto
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 30.0.1.101
    ip route 2.0.2.0 255.255.255.0 Tunnel0
    ip route 2.0.2.0 255.255.255.0 Tunnel1
    !
     
    meteor713, Dec 5, 2004
    #1
    1. Advertising

  2. Re: How to turn off (Disable) Multicast RPF Check (Needs forwardingNon-RPF Packets)

    meteor713 wrote:
    > I have two GRE tunnels connected with other vender's router.
    > Multicast Packets come from the two GRE tunnels with same source IP.
    > (It's been load-balanced network)
    >
    > monitor says "Tunnel 1 xxxxxx Not RPF packet..."
    > So I added returning unicast static routing to two tunnels.
    > The mcast packets from one of two tunnels forwarded OK.
    > but the mcast packets from another tunnel is dropped by "RPF Check"
    >
    > Is there any way to turn off RPF check ?
    > (There is no VLAN, nor same LAN mcast. so don't worry about looping)
    > or any method to "RPF check" can see "two GW for same dst network"
    >
    > My config is as below.
    > MCAST packet is "2.0.2.1 -> 239.255.12.42" only.
    >
    > Thanks!
    >
    > ---------------------------------------
    >
    > ip subnet-zero
    > !
    > ip multicast-routing
    > !
    > interface Tunnel0
    > ip address 4.1.1.1 255.255.255.0
    > ip pim sparse-dense-mode
    > tunnel source FastEthernet0/1
    > tunnel destination 5.1.1.211
    > !
    > interface Tunnel1
    > ip address 4.1.2.1 255.255.255.0
    > ip pim sparse-dense-mode
    > tunnel source FastEthernet0/1
    > tunnel destination 5.1.1.212
    > !
    > interface FastEthernet0/0
    > ip address 3.0.1.1 255.255.255.0
    > ip pim sparse-dense-mode
    > ip igmp static-group 239.255.12.42 -> this is static MCAST IP
    > no ip mroute-cache
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0/1
    > ip address 5.1.1.200 255.255.255.0
    > no ip mroute-cache
    > duplex auto
    > speed auto
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 30.0.1.101
    > ip route 2.0.2.0 255.255.255.0 Tunnel0
    > ip route 2.0.2.0 255.255.255.0 Tunnel1
    > !


    The global command "ip multicast multipath" might help you out,
    although, it is only effective for (s,g)-routes (I believe) and if the
    routes have the same cost.
    Igi.
     
    =?ISO-8859-1?Q?Ignaz_Kr=E4henmann?=, Dec 5, 2004
    #2
    1. Advertising

  3. meteor713

    Hansang Bae Guest

    In article <>,
    says...
    > I have two GRE tunnels connected with other vender's router.
    > Multicast Packets come from the two GRE tunnels with same source IP.
    > (It's been load-balanced network)
    >
    > monitor says "Tunnel 1 xxxxxx Not RPF packet..."
    > So I added returning unicast static routing to two tunnels.
    > The mcast packets from one of two tunnels forwarded OK.
    > but the mcast packets from another tunnel is dropped by "RPF Check"
    >
    > Is there any way to turn off RPF check ?
    > (There is no VLAN, nor same LAN mcast. so don't worry about looping)
    > or any method to "RPF check" can see "two GW for same dst network"



    I don't think you can turn it off but you can fake it with "ip mroute"
    command. Not "ip route" but "ip mroute" It's safer since it can't be
    redistributed etc. It's a kludge, but you really have two choices if
    you *have* to overcome RPF. Add a secondary address in the same range
    as the S or use a static mroute.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Dec 6, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Robert Dohrenburg

    Forwarding multicast packets.

    Robert Dohrenburg, May 21, 2005, in forum: Cisco
    Replies:
    3
    Views:
    3,902
    Robert Dohrenburg
    May 21, 2005
  2. Matthias Schaerer

    Forwarding of Multicast in Cisco 3750

    Matthias Schaerer, Aug 25, 2005, in forum: Cisco
    Replies:
    0
    Views:
    584
    Matthias Schaerer
    Aug 25, 2005
  3. Replies:
    0
    Views:
    916
  4. Replies:
    1
    Views:
    639
  5. Replies:
    6
    Views:
    2,278
Loading...

Share This Page