How to prevent windows xp sp2 from autoconnecting to a network?

Discussion in 'Wireless Networking' started by Mario, Apr 27, 2005.

  1. Mario

    Mario Guest

    hi
    I have my own application which connects a wlan network.
    So I have DISABLED the Wireless Zero Configuration Service.

    The problem is, if I disable the service, windows automatically connects the
    wlan adapter to any of the available wlan networks. I don't know how that
    works, but anyone connects to a network....

    Can anyone tell me how to disable this?
    My app sould be the only thing which connects to a wlan network!!!

    Thanks in advance
    Mario
     
    Mario, Apr 27, 2005
    #1
    1. Advertising

  2. Mario

    Jack \(MVP\) Guest

    Hi
    Do not use the Default SSID make a unique name.
    Switch all the Wireless hardware to channel 11.
    Use the original Utility and look through the menu,might be that there is an entry to
    restrict general logging.
    Jack (MVP-Networking).


    "Mario" <> wrote in message
    news:#lNN$...
    > hi
    > I have my own application which connects a wlan network.
    > So I have DISABLED the Wireless Zero Configuration Service.
    >
    > The problem is, if I disable the service, windows automatically connects the
    > wlan adapter to any of the available wlan networks. I don't know how that
    > works, but anyone connects to a network....
    >
    > Can anyone tell me how to disable this?
    > My app sould be the only thing which connects to a wlan network!!!
    >
    > Thanks in advance
    > Mario
    >
    >
    >
     
    Jack \(MVP\), Apr 27, 2005
    #2
    1. Advertising

  3. Mario

    Mario Guest

    hi
    Perhaps, I sould discribe my problem a litte bit detailed:

    I have disabled the Wireless Zero Configuration, because I have my own
    applicatoin to connect to Wlan networks.

    At XP SP1, when I plug on a wlan adapter nothing happens. No one is
    connecting to a network.

    At XP SP2, when I plug in a wlan adapter, windows is autoconnecting to any
    of the available wlan networks!!!
    The prblem is, I havent found a way to "disable" this autoconnecting from
    windows....
    The only way is to enable Wireless Zero Configuration and set there the
    settings. But this is no possible solution for me, becuase the service MUST
    always be stopped, otherwise I got problems with Ndisuio, which I need for
    my app to connect to wlans....


    You suggested to not using the default SSID, but where sould I set this?
    Wireless Zero Configuration is disabled, so there is nothing to configure in
    windows...

    what do you mean my switch hardware to channel 11?


    thanks for your help...
    mario



    "Jack (MVP)" <Jack(MVP)@discussions.microsoft.com.> wrote in message
    news:...
    > Hi
    > Do not use the Default SSID make a unique name.
    > Switch all the Wireless hardware to channel 11.
    > Use the original Utility and look through the menu,might be that there is
    > an entry to
    > restrict general logging.
    > Jack (MVP-Networking).
    >
    >
    > "Mario" <> wrote in message
    > news:#lNN$...
    >> hi
    >> I have my own application which connects a wlan network.
    >> So I have DISABLED the Wireless Zero Configuration Service.
    >>
    >> The problem is, if I disable the service, windows automatically connects
    >> the
    >> wlan adapter to any of the available wlan networks. I don't know how that
    >> works, but anyone connects to a network....
    >>
    >> Can anyone tell me how to disable this?
    >> My app sould be the only thing which connects to a wlan network!!!
    >>
    >> Thanks in advance
    >> Mario
    >>
    >>
    >>

    >
    >
     
    Mario, Apr 29, 2005
    #3
  4. I'll jump in with two possible theories, let me know if this helps.

    1) A client adapter that recieves a "null" SSID will connect to any network
    within range. If you created a wireless profile in the Microsoft client
    that did not specify a name in the SSID field, you would experience the
    behavior you have described below. From the Wireless networks tab, click in
    the box for "Preferred networks:". If the "Remove" button becomes
    available, click it to delete the invisible profile. Click "OK" at the
    bottom of the property sheet to save the changes.

    Additionally, you can uncheck the box on the same property sheet for the
    field "Use Windows to configure my wireless network settings."

    2) An application on your system may be placing wireless settings to the
    adpater. If a "null" SSID is set, then you will experience the
    auto-connecting behavior. Double check your application to ensure this is
    not happening.

    --
    Jerry Peterson
    Windows Network Services - Wireless

    This posting is provided "AS IS" with no warranties, and confers no rights.
    "Mario" <> wrote in message
    news:...
    > hi
    > Perhaps, I sould discribe my problem a litte bit detailed:
    >
    > I have disabled the Wireless Zero Configuration, because I have my own
    > applicatoin to connect to Wlan networks.
    >
    > At XP SP1, when I plug on a wlan adapter nothing happens. No one is
    > connecting to a network.
    >
    > At XP SP2, when I plug in a wlan adapter, windows is autoconnecting to any
    > of the available wlan networks!!!
    > The prblem is, I havent found a way to "disable" this autoconnecting from
    > windows....
    > The only way is to enable Wireless Zero Configuration and set there the
    > settings. But this is no possible solution for me, becuase the service
    > MUST always be stopped, otherwise I got problems with Ndisuio, which I
    > need for my app to connect to wlans....
    >
    >
    > You suggested to not using the default SSID, but where sould I set this?
    > Wireless Zero Configuration is disabled, so there is nothing to configure
    > in windows...
    >
    > what do you mean my switch hardware to channel 11?
    >
    >
    > thanks for your help...
    > mario
    >
    >
    >
    > "Jack (MVP)" <Jack(MVP)@discussions.microsoft.com.> wrote in message
    > news:...
    >> Hi
    >> Do not use the Default SSID make a unique name.
    >> Switch all the Wireless hardware to channel 11.
    >> Use the original Utility and look through the menu,might be that there is
    >> an entry to
    >> restrict general logging.
    >> Jack (MVP-Networking).
    >>
    >>
    >> "Mario" <> wrote in message
    >> news:#lNN$...
    >>> hi
    >>> I have my own application which connects a wlan network.
    >>> So I have DISABLED the Wireless Zero Configuration Service.
    >>>
    >>> The problem is, if I disable the service, windows automatically connects
    >>> the
    >>> wlan adapter to any of the available wlan networks. I don't know how
    >>> that
    >>> works, but anyone connects to a network....
    >>>
    >>> Can anyone tell me how to disable this?
    >>> My app sould be the only thing which connects to a wlan network!!!
    >>>
    >>> Thanks in advance
    >>> Mario
    >>>
    >>>
    >>>

    >>
    >>

    >
    >
     
    Jerry Peterson[MSFT], May 2, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SmF3cw==?=

    Prevent access to unsecured wireless network

    =?Utf-8?B?SmF3cw==?=, Apr 9, 2005, in forum: Wireless Networking
    Replies:
    3
    Views:
    5,258
    =?Utf-8?B?UmljaGFyZA==?=
    May 1, 2005
  2. Yogi

    Novell Client 4.92 SP2 and Windows XP SP2

    Yogi, Jul 21, 2005, in forum: Computer Support
    Replies:
    1
    Views:
    5,161
    Toolman Tim
    Jul 22, 2005
  3. =?Utf-8?B?QmrDuHJu?=

    Adminpak SP2 , Windows Server x64 SP2

    =?Utf-8?B?QmrDuHJu?=, Aug 29, 2007, in forum: Windows 64bit
    Replies:
    2
    Views:
    3,857
    =?Utf-8?B?QmrDuHJu?=
    Sep 3, 2007
  4. K T T
    Replies:
    8
    Views:
    335
    K T T
    Sep 15, 2004
  5. tasTDasd
    Replies:
    7
    Views:
    680
    §ñühw¤£f
    Sep 22, 2009
Loading...

Share This Page