How to ping the Pix 501 inside interface

Discussion in 'Cisco' started by Gianlu, Jun 15, 2004.

  1. Gianlu

    Gianlu Guest

    Hi,
    I'm a newbye with Pix 501.

    I have the following problem:
    I have a main network in our office with a Cisco Vpn 3005 concentrator
    and a remote office with a Cisco Pix 501.
    We have configured a Lan to lan ipsec tunnel between the 2 networks
    and everything works fine, but I cannot ping from my primary network
    (which is also behind a Checkpoint firewall) the inside interface of
    the pix (10.9.1.1) while I can ping (after that the tunnel goes on)
    every Pc located on the remote office behind the pix.
    Moreover, from every Pc of the remote network I can access the
    services in my Primary network that I have opened on the firewall and
    I can ping the pc in my primary network, but if I try to ping the
    primary network from the inside interface of the pix using the pdm,
    the ping doesn't go!
    Is this a normal behaviour or there is something missconfigured that I
    cannot see in my configuration?
    Thanks for your help.

    Gianluigi

    Here is the Pix configuration with some ip changes:

    Building configuration...
    : Saved
    :
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password xxxxxxxxxxxxxxxx encrypted
    passwd xxxxxxxxxxxxxxx encrypted
    hostname Pix
    domain-name xxxxxxxxxxx
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name xxx.xxx.0.0 NetPrimary
    name 10.9.0.0 NetPix
    access-list inside_outbound_nat0_acl permit ip NetPix 255.255.0.0
    NetPrimary 255.255.0.0
    access-list outside_cryptomap_20 permit ip NetPix 255.255.0.0
    NetPrimary 255.255.0.0
    access-list outside_access_in permit ip NetPrimary 255.255.0.0 NetPix
    255.255.0.0
    pager lines 24
    logging on
    mtu outside 1500
    mtu inside 1500
    ip address outside yyy.yyy.yyy.yyy 255.255.255.248
    ip address inside 10.9.1.1 255.255.0.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    nat (inside) 0 access-list inside_outbound_nat0_acl
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 zzz.zzz.zzz.zzz 1 (comment:
    zzz.zzz.zzz.zzz is the ip address of the router towards internet)
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http ???.???.???.??? 255.255.255.255 outside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer nnn.nnn.nnn.nnn
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address nnn.nnn.nnn.nnn netmask 255.255.255.255
    no-xauth no-config-mode
    isakmp nat-traversal 20
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    terminal width 80
    Cryptochecksum:7e21083b04c2e47e80fa8f7c7de23a66
    : end
    [OK]
    Gianlu, Jun 15, 2004
    #1
    1. Advertising

  2. In article <>,
    Gianlu <> wrote:
    :I'm a newbye with Pix 501.

    :We have configured a Lan to lan ipsec tunnel between the 2 networks
    :and everything works fine, but I cannot ping from my primary network
    :(which is also behind a Checkpoint firewall) the inside interface of
    :the pix (10.9.1.1) while I can ping (after that the tunnel goes on)
    :every Pc located on the remote office behind the pix.

    You can only ever ping the "closest" interface to you, the one where
    the packets enter the PIX. Thus from the outside, you cannot ping
    the inside interface.

    If, for some reason, you *really* need to do this, then you can
    configure a second VPN and designate it as a "management interface".
    There are two modes in which IPSec can operate, "transport" and
    "tunnel". Normal PIX IPSec connections use the mode that allows traffic
    to pass on beyond the "security gateway" (the PIX); when you
    designate a "management interface", you get the other kind of
    connection that treats the PIX as a host that traffic must terminate at,
    and that connection can be used to ping the inside interface of the
    PIX (and do some PDM work, and can't do very much else.)

    --
    "Infinity is like a stuffed walrus I can hold in the palm of my hand.
    Don't do anything with infinity you wouldn't do with a stuffed walrus."
    -- Dr. Fletcher, Va. Polytechnic Inst. and St. Univ.
    Walter Roberson, Jun 15, 2004
    #2
    1. Advertising

  3. Gianlu

    Rik Bain Guest

    On Tue, 15 Jun 2004 07:11:15 -0500, Gianlu wrote:

    > Hi,
    > I'm a newbye with Pix 501.
    >
    > I have the following problem:
    > I have a main network in our office with a Cisco Vpn 3005 concentrator
    > and a remote office with a Cisco Pix 501. We have configured a Lan to
    > lan ipsec tunnel between the 2 networks and everything works fine, but I
    > cannot ping from my primary network (which is also behind a Checkpoint
    > firewall) the inside interface of the pix (10.9.1.1) while I can ping
    > (after that the tunnel goes on) every Pc located on the remote office
    > behind the pix. Moreover, from every Pc of the remote network I can
    > access the services in my Primary network that I have opened on the
    > firewall and I can ping the pc in my primary network, but if I try to
    > ping the primary network from the inside interface of the pix using the
    > pdm, the ping doesn't go!
    > Is this a normal behaviour or there is something missconfigured that I
    > cannot see in my configuration?
    > Thanks for your help.
    >
    > Gianluigi
    >


    To ping the pix inside ip address from the other side of the tunnel, you
    will need to enable "management-access inside".

    As far as pinging from the pix, you would need to create an IPSEC SA that
    contains the pix outside ip address since the source of the ICMP packet will
    be the outside interface address.

    Generally speaking, your are seeing default behavior.


    Rik Bain
    Rik Bain, Jun 15, 2004
    #3
  4. Gianlu

    mh Guest

    mh, Jun 15, 2004
    #4
  5. Gianlu

    Gianlu Guest

    Gianlu, Jun 16, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. eugene123
    Replies:
    4
    Views:
    2,652
    Mark Smythe
    Sep 25, 2003
  2. jonnah
    Replies:
    1
    Views:
    1,103
    mcaissie
    Apr 21, 2004
  3. Al
    Replies:
    1
    Views:
    681
  4. Andre
    Replies:
    7
    Views:
    685
    Andre
    Feb 20, 2005
  5. marti314
    Replies:
    1
    Views:
    2,069
    Walter Roberson
    Aug 5, 2005
Loading...

Share This Page