how to make linux bridge's 802.1q STP packet across cisco switch?

Discussion in 'Cisco' started by hansyin@gmail.com, May 19, 2005.

  1. Guest

    I'm testing linux redhat fedora 3 bridge STP function. don't enable stp
    on cisco switch.
    I found linux send BPDU packet with 802.1Q tag, and then cisco 3550
    switch block the packet. then, if linux had two cable connected to
    cisco switch's same vlan(one is using 802.1q trunk), althrough I have
    STP enabled on linux, linux will let all two ports working as
    forwarding state, then it will cause broadcast storm.
    the problem may be based on two points: one is Linux shouldn't add
    802.1q tag for its BPDU packet although it's using 802.1q trunk,
    another one is that cisco should not block the BPDU packet, it should
    broadcast it after untagging it. which one is the real problem?

    linux use 01:80:c2:00:00:00 as destination mac address for its BPDU
    packets, maybe cisco doesn't recognize this packet in its non-native
    vlan. (according cisco's pvst+ knowledge, it only recognize this mac
    address in its native vlan, in its non-native vlan, it use
    01:00:0c:cc:cc:cd as BPDU's mac address.) how can i workaround this
    problem?

    Thanks.


    Hans Yin
     
    , May 19, 2005
    #1
    1. Advertising

  2. Sounds to me you have a native-vlan mismatch. Try to either change the linux
    or cisco switch to properly tag the vlans.
    If you're not able to change the native-vlan on the linux machine, configure
    the cisco to use an unused vlan as native vlan

    Erik

    <> wrote in message
    news:...
    > I'm testing linux redhat fedora 3 bridge STP function. don't enable stp
    > on cisco switch.
    > I found linux send BPDU packet with 802.1Q tag, and then cisco 3550
    > switch block the packet. then, if linux had two cable connected to
    > cisco switch's same vlan(one is using 802.1q trunk), althrough I have
    > STP enabled on linux, linux will let all two ports working as
    > forwarding state, then it will cause broadcast storm.
    > the problem may be based on two points: one is Linux shouldn't add
    > 802.1q tag for its BPDU packet although it's using 802.1q trunk,
    > another one is that cisco should not block the BPDU packet, it should
    > broadcast it after untagging it. which one is the real problem?
    >
    > linux use 01:80:c2:00:00:00 as destination mac address for its BPDU
    > packets, maybe cisco doesn't recognize this packet in its non-native
    > vlan. (according cisco's pvst+ knowledge, it only recognize this mac
    > address in its native vlan, in its non-native vlan, it use
    > 01:00:0c:cc:cc:cd as BPDU's mac address.) how can i workaround this
    > problem?
    >
    > Thanks.
    >
    >
    > Hans Yin
    >
     
    Erik Tamminga, May 21, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Oli
    Replies:
    3
    Views:
    907
  2. kd

    802.11 to 802.15.4 bridge

    kd, Mar 20, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    546
    S. Pidgorny
    Mar 25, 2005
  3. Joel M. Baldwin

    bridge / layer 2 switch / layer 3 switch

    Joel M. Baldwin, Nov 6, 2003, in forum: Cisco
    Replies:
    2
    Views:
    4,563
    Scooby
    Nov 6, 2003
  4. wr
    Replies:
    1
    Views:
    1,405
    Andrew Riley
    May 24, 2004
  5. Jack Taugher
    Replies:
    2
    Views:
    4,637
Loading...

Share This Page