How to get BT Home Hub to simply forward UDP 5060?

Discussion in 'UK VOIP' started by Mark Carroll, Sep 5, 2013.

  1. Mark Carroll

    Mark Carroll Guest

    I am trying to get a BT Home Hub running software version 8.1.H.U (Type
    A) to forward incoming UDP 5060 to an computer on the LAN running a SIP
    client. Is there a trick to persuading them to do that? Once set in the
    port forwarding configuration, other ports come through unmolested, but
    it seems to be trying to grab 5060 for itself (some SIP-ALG thing
    maybe), which is rather messing up my attempts to get the VoIP client
    working. Do I just have to give up and buy a different modem/router or
    can this one be persuaded to stop messing with the SIP stuff and just
    pass it on?

    (Hmmm, I wonder if it's messing with outbound traffic too...)

    -- Mark
    Mark Carroll, Sep 5, 2013
    #1
    1. Advertising

  2. Mark Carroll

    Roger Guest

    On 05/09/2013 18:41, Mark Carroll wrote:
    > I am trying to get a BT Home Hub running software version 8.1.H.U (Type
    > A) to forward incoming UDP 5060 to an computer on the LAN running a SIP
    > client. Is there a trick to persuading them to do that? Once set in the
    > port forwarding configuration, other ports come through unmolested, but
    > it seems to be trying to grab 5060 for itself (some SIP-ALG thing
    > maybe), which is rather messing up my attempts to get the VoIP client
    > working. Do I just have to give up and buy a different modem/router or
    > can this one be persuaded to stop messing with the SIP stuff and just
    > pass it on?
    >
    > (Hmmm, I wonder if it's messing with outbound traffic too...)
    >
    > -- Mark
    >

    Can you specify a different sip port for your device? - I use 5062,5064
    etc for different devices on my network.
    Roger, Sep 5, 2013
    #2
    1. Advertising

  3. Mark Carroll

    Mark Carroll Guest

    Roger <> writes:

    > Can you specify a different sip port for your device? - I use 5062,5064
    > etc for different devices on my network.


    I tried experimenting with ekiga, setting its SIP listening port to
    5050, and having it use 5061 to 5100 for the other stuff, but it refused
    to register with ekiga.net. (Admittedly, I failed to make much sense of
    the debug log.) Possibly I gave up too easily, or simply misunderstood?

    -- Mark
    Mark Carroll, Sep 5, 2013
    #3
  4. Mark Carroll

    Mark Carroll Guest

    Jono <> writes:

    > What client are you using that needs any ports open at all? Not good.


    I was testing with Ekiga 4.0.1, as I've seen it working before. Is that
    a bad choice?

    -- Mark
    Mark Carroll, Sep 5, 2013
    #4
  5. On 05/09/13 20:54, Jono wrote:
    > on 05/09/2013, Mark Carroll supposed :
    >> I am trying to get a BT Home Hub running software version 8.1.H.U (Type
    >> A) to forward incoming UDP 5060 to an computer on the LAN running a SIP
    >> client. Is there a trick to persuading them to do that? Once set in the
    >> port forwarding configuration, other ports come through unmolested, but
    >> it seems to be trying to grab 5060 for itself (some SIP-ALG thing
    >> maybe), which is rather messing up my attempts to get the VoIP client
    >> working. Do I just have to give up and buy a different modem/router or
    >> can this one be persuaded to stop messing with the SIP stuff and just
    >> pass it on?
    >>
    >> (Hmmm, I wonder if it's messing with outbound traffic too...)
    >>
    >> -- Mark

    >
    > What client are you using that needs any ports open at all? Not good.
    >


    Any SIP server needs ports open, although the router might open them in
    response to an outgoing REGISTER, and the SDP on the 200 OK. Any SIP
    client will need ports open for the duration of the call, although they
    might be opened in response to the outgoing INVITE.

    If you are using Asterisk, it is inadvisable to have the router try
    anything clever, so you really should port forward 5060 and your
    incoming RTP range.

    (You need a SIP server to receive incoming calls, and a SIP client to
    make outgoing ones. Normally the same device acts in both roles.)
    David Woolley, Sep 5, 2013
    #5
  6. Mark Carroll

    Roger Guest

    On 05/09/2013 21:00, Mark Carroll wrote:
    > Jono <> writes:
    >
    >> What client are you using that needs any ports open at all? Not good.

    >
    > I was testing with Ekiga 4.0.1, as I've seen it working before. Is that
    > a bad choice?
    >
    > -- Mark
    >

    Dont know if this applies to your verions of the homehub but try this -

    "I had this problem with Cisco SPA phones using gradwell servers. if you
    go into advanced management of the HH and then look at the connected
    devices you should be able to see your router. Click on it even though
    it doesn't look like a link. A new screen will appear that allows you to
    disable SIP ALG for that router and it works like a charm. Why BT hide
    this so well I don't know, typical BT!!!"
    Roger, Sep 5, 2013
    #6
  7. Mark Carroll

    Mark Carroll Guest

    Jono <> writes:

    > I was refering to your decision to forward ports to the client. It
    > shouldn't be necessary.


    Its NAT seems to be pretty strict / symmetric, I don't want to put the
    computer in the DMZ, and the traffic isn't all going via some third
    proxy machine. So, there's not really any other way to get the incoming
    UDP to the client.

    -- Mark
    Mark Carroll, Sep 7, 2013
    #7
  8. Mark Carroll

    Mark Carroll Guest

    Roger <> writes:

    > "I had this problem with Cisco SPA phones using gradwell servers. if you
    > go into advanced management of the HH and then look at the connected
    > devices you should be able to see your router. Click on it even though
    > it doesn't look like a link. A new screen will appear that allows you to
    > disable SIP ALG for that router and it works like a charm. Why BT hide
    > this so well I don't know, typical BT!!!"


    Thank you! It was worth a try. I did try clicking on it and it told me
    IP addresses and suchlike but alas no SIP ALG option. I guess I don't
    have the right model / version.

    -- Mark
    Mark Carroll, Sep 7, 2013
    #8
  9. Mark Carroll

    Mark Carroll Guest

    Andrew Benham <> writes:

    > Is this the Home Hub which is a rebranded Thomson/Technicolor unit ?
    > If so it probably has the SIP ALG enabled, which you can disable with
    >
    > connection unbind application=SIP port=5060


    Some googling suggests that it's a Thompson TG797N with the telnet
    disabled, although one can still get in via JTAG and reenable it.
    http://www.psidoc.com/showthread.php/7-How-to-hack-or-unlock-your-home-hub-2.0A-via-software.
    describes how to flash it with hacked firmware but hopefully I can avoid
    having to do that.

    Hmmm, I am not sure I tried getting at it via FTP, I'd better check.

    -- Mark
    Mark Carroll, Sep 7, 2013
    #9
  10. Mark Carroll

    Mark Carroll Guest

    Mark Carroll <> writes:

    > Jono <> writes:
    >
    >> What client are you using that needs any ports open at all? Not good.

    >
    > I was testing with Ekiga 4.0.1, as I've seen it working before. Is that
    > a bad choice?


    It does seem to have been a curious choice: it used STUN to detect
    symmetric NAT and a conditional statement thus didn't attempt
    registration. Adjusting the source code and recompiling got it able to
    make a SIP call at last!

    -- Mark
    Mark Carroll, Sep 7, 2013
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom
    Replies:
    2
    Views:
    5,127
  2. Dennis Breithaupt
    Replies:
    9
    Views:
    10,017
    andrewned
    Aug 21, 2007
  3. Ctrl¤/Alt¤/Del¤

    XP Home is simply the best!

    Ctrl¤/Alt¤/Del¤, Feb 5, 2007, in forum: Computer Support
    Replies:
    39
    Views:
    930
    William Poaster
    Feb 6, 2007
  4. Replies:
    1
    Views:
    572
    headsetadapter.com
    Mar 11, 2007
  5. Gordon Henderson

    Re: Inbound UDP port 5060 blocked

    Gordon Henderson, Feb 15, 2009, in forum: UK VOIP
    Replies:
    1
    Views:
    2,157
    Gordon Henderson
    Feb 15, 2009
Loading...

Share This Page