How 2 increase priority of VoIP software in WinXpPro??

Discussion in 'VOIP' started by BigBen, Jan 24, 2006.

  1. BigBen

    BigBen Guest

    Hi All,

    How can I increase then priority that is given by the system to a VoIP
    application?

    I've gone into the Win Task Manager, selected Processes, chosen the
    application file, right mouse clicked over that to open the context
    menu, chosen Set priority, and chosen Above normal, high, etc.

    However, if I go there again later, with or without restarting the OS,
    the priority level is still set as Normal ...

    Any sugestions, please?

    Regards,
    JBR
    BigBen, Jan 24, 2006
    #1
    1. Advertising

  2. BigBen

    David Millen Guest

    On Tue, 24 Jan 2006 12:31:26 GMT, (BigBen)
    wrote:

    >Hi All,
    >
    >How can I increase then priority that is given by the system to a VoIP
    >application?
    >
    >I've gone into the Win Task Manager, selected Processes, chosen the
    >application file, right mouse clicked over that to open the context
    >menu, chosen Set priority, and chosen Above normal, high, etc.
    >
    >However, if I go there again later, with or without restarting the OS,
    >the priority level is still set as Normal ...
    >

    Forgive me if I misunderstand, but it seems to me that if a VOIP app
    is bogging down your PC, something is wrong with either that app or
    your PC - which if it is running the rest of XPP satisfactorily, is
    probably not the case.

    If you mean you are suffering bandwidth issues, possibly as a result
    of not having quite enough of it, or other traffic grabbing too much
    of it, have a look at www.cfos.de - enables you to set priorities.
    Usual disclaimers.
    --
    All the best
    David Millen
    Xativa, Valencia
    www.fincacasablanca.com
    please reply in group
    if you have to email me, remove the obvious:
    David Millen, Jan 24, 2006
    #2
    1. Advertising

  3. BigBen

    BigBen Guest

    On Tue, 24 Jan 2006 20:01:45 +0100, David Millen
    <> wrote:

    >Forgive me if I misunderstand, but it seems to me that if a VOIP app
    >is bogging down your PC, something is wrong with either that app or
    >your PC - which if it is running the rest of XPP satisfactorily, is
    >probably not the case.


    My non-VoIP applications are running fine, my VoIP connections have
    loads of noise, on my speech only (upload).

    I have a high latency connection - CDMA 450.

    I'm trying to have my system give more of its processing power to the
    VoIP application.

    I'm already using cfos speed, and did not notice much improvment, if
    any at all.

    TCP Optimizer, with custom settings, did a marvelous job of improving
    my connection speed, for all types of Internet usage, and to VoIP in
    particular by (finally) reducing my lost sent packets down to 0%

    Presently the people I call hear just about not speech cuts, but the
    "background" noise is insatisfactory.

    Any sugestions (other than switching to ADSL, or giving up VoIP all
    together), pls?

    Regards,
    JBR
    BigBen, Jan 25, 2006
    #3
  4. BigBen

    Rick Merrill Guest

    BigBen wrote:
    > On Tue, 24 Jan 2006 20:01:45 +0100, David Millen
    > <> wrote:
    >
    >
    >>Forgive me if I misunderstand, but it seems to me that if a VOIP app
    >>is bogging down your PC, something is wrong with either that app or
    >>your PC - which if it is running the rest of XPP satisfactorily, is
    >>probably not the case.

    >
    >
    > My non-VoIP applications are running fine, my VoIP connections have
    > loads of noise, on my speech only (upload).
    >
    > I have a high latency connection - CDMA 450.
    >
    > I'm trying to have my system give more of its processing power to the
    > VoIP application.
    >
    > I'm already using cfos speed, and did not notice much improvment, if
    > any at all.
    >
    > TCP Optimizer, with custom settings, did a marvelous job of improving
    > my connection speed, for all types of Internet usage, and to VoIP in
    > particular by (finally) reducing my lost sent packets down to 0%
    >
    > Presently the people I call hear just about not speech cuts, but the
    > "background" noise is insatisfactory.
    >
    > Any sugestions (other than switching to ADSL, or giving up VoIP all
    > together), pls?
    >
    > Regards,
    > JBR


    Did you install the "QoS packet scheduler " in your network connection,
    hmmmmm?
    Rick Merrill, Jan 25, 2006
    #4
  5. "BigBen" <> wrote in message
    news:...
    [...]
    > My non-VoIP applications are running fine, my VoIP connections have
    > loads of noise, on my speech only (upload).
    >
    > I have a high latency connection - CDMA 450.
    >
    > I'm trying to have my system give more of its processing power to the
    > VoIP application.
    >
    > I'm already using cfos speed, and did not notice much improvment, if
    > any at all.
    >
    > TCP Optimizer, with custom settings, did a marvelous job of improving
    > my connection speed, for all types of Internet usage, and to VoIP in
    > particular by (finally) reducing my lost sent packets down to 0%


    VoIP media packets, and usually also its signalling packets, are
    transmitted over UDP: optimizing TCP won't help you much, I'm afraid.

    Together with packet loss, the worst enemy of VoIP is jitter, i.e. random
    changes in the delay of each packet. Usually this is best solved at the
    receiving end, extending the size of the buffer where the packets are
    stored and reordered before being decoded. The larger the buffer, the
    higher the chance of eventually receiving a delayed packet rather than
    declaring it "missing in action" and accepting a short dropout in the
    voice stream; on the other hand, large jitterbuffers also introduce an
    annoying delay in the speech.

    On your side, you might try to increase the priority of the voice packets
    by setting the TOS bits of each IP packet to "Low Delay" (this is usually
    already done by the application or by the VoIP hardware adapter), _AND_
    enforcing some sort of queuing discipline ("qdisc") at the bottleneck of
    the outgoing pipe: that will allow the VoIP data packets to go out through
    a "fast lane", so that, if packets have to be delayed or dropped for lack
    of bandwidth, that destiny will be reserved to competing packets carrying
    non-realtime data: web, e-mail etc. With non-dialup connections, such QoS
    (Quality of Service) enforcement action is normally delegated to the
    router. In your case, probably the PC should do that. I understand that
    WinXP Professional has a built-in QoS scheduler
    (http://www.speedguide.net/read_articles.php?id=158 ) but I never tried it
    as I don't run XP.

    > Presently the people I call hear just about not speech cuts, but the
    > "background" noise is insatisfactory.
    >
    > Any sugestions (other than switching to ADSL, or giving up VoIP all
    > together), pls?


    Passing to ADSL is always a good idea: VoIP over dialup is never going to
    work very well. Which is why the mass deployment of VoIP has began after
    the diffusion of Broadband Internet. Also, I have found that the voice
    quality with hardware adapters or IP phones is much higher than what is
    provided by softphones (I especially recommend the devices from Sipura,
    now Linksys).

    Cheers --

    Enzo
    Enzo Michelangeli, Jan 26, 2006
    #5
  6. BigBen

    BigBen Guest

    On Wed, 25 Jan 2006 13:41:31 -0500, Rick Merrill
    <> wrote:

    >Did you install the "QoS packet scheduler " in your network connection,



    No. I installed cfosspeed. Can't say I noticed any improvment in
    reducing the background noise in my speech. Is there any significant
    diference between them?

    This is why either VoIP Stunt/Buster/Cheap, etc, or Skype. Other VoIP
    systems I've tried still have loads of speech cuts, both inbound and
    outbound.

    Regards,
    JBR
    BigBen, Jan 26, 2006
    #6
  7. BigBen

    Guest

    Hello, visit
    http://v2.tlab404.com/articles/detail.asp?iFaq=221&iType=16


    Cordialmente,
    ________________________
    Voip
    Mizael Longuini de Morais
    Diretor

    São Paulo - Brazil
    tel: VoIP:
    fax: VoIP:
    mobile: 55 19 91546686




    BigBen wrote:
    > Hi All,
    >
    > How can I increase then priority that is given by the system to a VoIP
    > application?
    >
    > I've gone into the Win Task Manager, selected Processes, chosen the
    > application file, right mouse clicked over that to open the context
    > menu, chosen Set priority, and chosen Above normal, high, etc.
    >
    > However, if I go there again later, with or without restarting the OS,
    > the priority level is still set as Normal ...
    >
    > Any sugestions, please?
    >
    > Regards,
    > JBR
    , Jan 27, 2006
    #7
  8. BigBen

    BigBen Guest

    BigBen, Jan 30, 2006
    #8
  9. BigBen

    R-Guy Guest

    "BigBen" <> wrote in message
    news:...
    > On 27 Jan 2006 08:28:20 -0800, ""
    > <> wrote:
    >
    >>Hello, visit
    >>http://v2.tlab404.com/articles/detail.asp?iFaq=221&iType=16

    >
    > I'd like to, but I simply get an error message. Are you sure the link
    > is correct; can you open it?
    >
    > Cumprimentos,
    >
    > JBR
    >


    The link is fine. Here is the text ...


    This tweak is designed for broadband users on Windows XP Pro Edition. For
    Windows Home Edition, consult the forum, as gpedit.msc is not available for
    you. This tweak will only remove an internet reserve of 20%, although this
    is not active unless you are running QoS Aware programs.

    1.Log on as "Administrator".

    2. Run - gpedit.msc

    3. Expand the "Local Computer Policy" branch

    4. Then expand the "Administrative Templates" branch

    5. Expand the "Network" branch

    6. Highlight the "QoS Packet Scheduler" in left pane.

    7. In the right window pane double-click the "Limit Reservable Bandwidth"
    setting

    8. On the settings tab check the "Enabled" item

    9. Change "Bandwidth limit %" to read 0

    10. Then go to your Network connections Start=>Connect to=>Show All
    Connections and
    right-click on your connection. Then under the General or the Networking
    tab,
    (where it lists your protocols) make sure QoS packet scheduler is enabled.
    R-Guy, Jan 31, 2006
    #9
  10. BigBen

    BigBen Guest

    On Tue, 31 Jan 2006 06:22:58 GMT, "R-Guy" <>
    wrote:

    >"BigBen" <> wrote in message
    >news:...
    >> On 27 Jan 2006 08:28:20 -0800, ""
    >> <> wrote:
    >>
    >>>Hello, visit
    >>>http://v2.tlab404.com/articles/detail.asp?iFaq=221&iType=16

    >>
    >> I'd like to, but I simply get an error message. Are you sure the link
    >> is correct; can you open it?
    >>
    >> Cumprimentos,
    >>
    >> JBR
    >>

    >
    >The link is fine. Here is the text ...


    Thank you very much! I have already run the application, and
    configured the parameter at stake.

    Best,

    JBR.
    BigBen, Jan 31, 2006
    #10
  11. BigBen

    Guest

    BigBen wrote:
    > On Tue, 31 Jan 2006 06:22:58 GMT, "R-Guy" <>
    > wrote:
    >
    > >"BigBen" <> wrote in message
    > >news:...
    > >> On 27 Jan 2006 08:28:20 -0800, ""
    > >> <> wrote:
    > >>
    > >>>Hello, visit
    > >>>http://v2.tlab404.com/articles/detail.asp?iFaq=221&iType=16
    > >>
    > >> I'd like to, but I simply get an error message. Are you sure the link
    > >> is correct; can you open it?
    > >>
    > >> Cumprimentos,
    > >>
    > >> JBR
    > >>

    > >
    > >The link is fine. Here is the text ...

    >
    > Thank you very much! I have already run the application, and
    > configured the parameter at stake.
    >
    > Best,
    >
    > JBR.


    Ok! Saudações do Brazil a todos! :)


    Cordialmente,
    ________________________
    Voip
    Mizael Longuini de Morais
    Diretor

    São Paulo - Brazil
    tel: VoIP:
    fax: VoIP:
    mobile: 55 19 91546686
    , Jan 31, 2006
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. roadster3043
    Replies:
    5
    Views:
    494
    Duane Arnold
    Oct 22, 2004
  2. John Edwards

    Question about Aperture priority and Shutter Priority

    John Edwards, Jan 4, 2005, in forum: Digital Photography
    Replies:
    8
    Views:
    487
    Owamanga
    Jan 5, 2005
  3. ½ Confused

    Should I use shutter-priority or appurature-priority?

    ½ Confused, Feb 21, 2006, in forum: Digital Photography
    Replies:
    4
    Views:
    491
    Neil Ellwood
    Feb 22, 2006
  4. Replies:
    13
    Views:
    680
    David Ruether
    Sep 14, 2006
  5. Chico
    Replies:
    21
    Views:
    1,821
    ihary
    Jun 23, 2008
Loading...

Share This Page