Hmmm, why is there a delay when saving files in Fx?

Discussion in 'Firefox' started by Wedge, Feb 21, 2008.

  1. Wedge

    Wedge Guest

    Hi,
    When I click on a link to a file that normally opens in an external
    program, I get a prompt asking me if I want to save the file (I
    assume you are familiar with the dialog box without me having to draw
    it in ASCII).

    This behaviour is what I want. I can click 'OK' and I will get the
    normal 'Save' dialog.

    Recently Fx has begun to add a delay on the 'OK' button so, that not
    only until I have clicked on it once the timer starts, and then it
    takes some three to four seconds before the button gets enabled and I
    can click it (the second time) in order to get this 'Save' dialog box
    to open.

    The whole thing resembles the functionality you get when you try to
    install a new AddOn, a delay until you can install it (for whatever
    reason), but it has gotten much worse.

    Now to my question: Is there a way to turn that thing off?

    I found some setting in config: "security.dialog_enable_delay" which
    was set to 2000, but it did nothing after I set it to 0.

    I have also tried "Safe Mode." No change.

    Any ideas?

    If it matters, I use:
    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12)
    Gecko/20080201 Firefox/2.0.0.12

    TIA
    --
    Wedge
     
    Wedge, Feb 21, 2008
    #1
    1. Advertising

  2. Wedge wrote:
    > Hi,
    > When I click on a link to a file that normally opens in an external
    > program, I get a prompt asking me if I want to save the file (I
    > assume you are familiar with the dialog box without me having to draw
    > it in ASCII).
    >
    > This behaviour is what I want. I can click 'OK' and I will get the
    > normal 'Save' dialog.
    >
    > Recently Fx has begun to add a delay on the 'OK' button so, that not
    > only until I have clicked on it once the timer starts, and then it
    > takes some three to four seconds before the button gets enabled and I
    > can click it (the second time) in order to get this 'Save' dialog box
    > to open.
    >
    > The whole thing resembles the functionality you get when you try to
    > install a new AddOn, a delay until you can install it (for whatever
    > reason), but it has gotten much worse.
    >
    > Now to my question: Is there a way to turn that thing off?
    >
    > I found some setting in config: "security.dialog_enable_delay" which
    > was set to 2000, but it did nothing after I set it to 0.
    >
    > I have also tried "Safe Mode." No change.
    >
    > Any ideas?
    >
    > If it matters, I use:
    > Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12)
    > Gecko/20080201 Firefox/2.0.0.12
    >
    > TIA


    a whole 4 seconds out of your life. Geee, turn off the
    computer and do something else. [being facetious over]

    That 3 or 4 seconds has nothing to do with firefox but your
    operating system.

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Feb 21, 2008
    #2
    1. Advertising

  3. On Thu, 21 Feb 2008 09:40:34 -0600, Wedge <> wrote:

    > Recently Fx has begun to add a delay on the 'OK' button so, that not
    > only until I have clicked on it once the timer starts, and then it
    > takes some three to four seconds before the button gets enabled and I
    > can click it (the second time) in order to get this 'Save' dialog box
    > to open.
    >
    > The whole thing resembles the functionality you get when you try to
    > install a new AddOn, a delay until you can install it (for whatever
    > reason), but it has gotten much worse.
    >
    > Now to my question: Is there a way to turn that thing off?
    >
    > I found some setting in config: "security.dialog_enable_delay" which
    > was set to 2000, but it did nothing after I set it to 0.


    First, set that back to 2000. It prevents certain types of security
    attacks. See the "good reasons for this delay link on this page:
    http://kb.mozillazine.org/Disable_extension_install_delay_-_Firefox

    Since you already tried running in Safe Mode, your problem is probably not
    due to a bad add-on.

    My best guess is that you can fix the problem by going to Tools -> Options
    -> Privacy, and un-checking the "Remember what I've downloaded" option.
    Then restart Firefox to see if the problem is gone. Firefox's download
    manager seems to slow down as the number of previously downloaded files
    grows larger, so the best prevention is to simply tell it to not remember
    what was previously downloaded.

    If that was already not checked, or the problem still remains, exit
    Firefox, go to your Firefox profile, and delete the downloads.rdf file. If
    this file became corrupted, it could easily cause the problem you are
    experiencing. Firefox will create a new downloads.rdf as needed.

    If none of this works, there may be some other type of corruption in your
    profile. In that case, create a new Firefox profile and optionally copy
    your bookmarks, passwords, cookies, history, etc, over to the new one. You
    would also need to install any of your add-ons into the new profile.
    --
    FoxWolfie
     
    FoxWolfie Galen, Feb 22, 2008
    #3
  4. Wedge

    Wedge Guest


    > a whole 4 seconds out of your life. Geee, turn off the
    > computer and do something else. [being facetious over]


    You need a drink, or a good night's sleep, or you've had one too many
    of either.

    > That 3 or 4 seconds has nothing to do with firefox but your
    > operating system.


    Yeah, whatever.
    --
    Wedge
     
    Wedge, Feb 23, 2008
    #4
  5. Wedge

    Wedge Guest

    On 22 feb 2008, FoxWolfie Galen<>, had the
    following to say to the folks in alt.fan.mozilla:

    > First, set that back to 2000. It prevents certain types of
    > security attacks. See the "good reasons for this delay link on
    > this page:
    > http://kb.mozillazine.org/Disable_extension_install_delay_-_Firefox


    Oh, no worries. Already did that since it didn't help. :)

    > Since you already tried running in Safe Mode, your problem is
    > probably not due to a bad add-on.


    My thoughts exactly.

    > My best guess is that you can fix the problem by going to Tools ->
    > Options -> Privacy, and un-checking the "Remember what I've
    > downloaded" option. Then restart Firefox to see if the problem is
    > gone. Firefox's download manager seems to slow down as the number
    > of previously downloaded files grows larger, so the best
    > prevention is to simply tell it to not remember what was
    > previously downloaded.


    This seemed to help a little. There is still an initial delay just
    when the dialog box shows up, maybe 1/10 of a second, but I no longer
    have to click the OK button twice. :)

    Thanks for your help.
    --
    Wedge
     
    Wedge, Feb 23, 2008
    #5
  6. Wedge wrote:
    >> a whole 4 seconds out of your life. Geee, turn off the
    >> computer and do something else. [being facetious over]

    >
    > You need a drink, or a good night's sleep, or you've had one too many
    > of either.
    >
    >> That 3 or 4 seconds has nothing to do with firefox but your
    >> operating system.

    >
    > Yeah, whatever.


    I've told you what the problem is. If you take offensive to
    that, then thats your problem, not mine. I'm done with you.

    --
    *IMPORTANT*: Sorry folks, but I cannot provide email help!!!!

    Warning: Private emails sent to me may become public

    Peter Potamus & His Magic Flying Balloon:
    http://www.toonopedia.com/potamus.htm
     
    Peter Potamus the Purple Hippo, Feb 23, 2008
    #6
  7. Wedge

    JedCrane

    Joined:
    Oct 24, 2008
    Messages:
    1
    Eyy

    Just came across the forum cause I'm having the same problem, only it's like... 30 seconds to a minute.

    I've never done this before, but Peter is such a douchebag, I just wanted to come in and be like "Peter is a douchebag." He has a tiny brain. Don't feel bad, Wedge. He has enough to deal with in his life, coping with his tiny tiny brain. :( Aawww. Stupid stupid Peter and his stupid little tiny brain. Aawawww. Just kiddin Peter. Just kiddin again. Tiny brain.
     
    JedCrane, Oct 24, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?iso-8859-1?Q?Frisbee=AE?=

    OT: Hmmm...

    =?iso-8859-1?Q?Frisbee=AE?=, Jul 13, 2004, in forum: MCSE
    Replies:
    16
    Views:
    910
  2. Dragon

    OT: hmmm

    Dragon, Sep 27, 2004, in forum: MCSE
    Replies:
    21
    Views:
    1,265
    moscow_bob
    Sep 29, 2004
  3. Giorgis

    Hmmm ...

    Giorgis, Oct 3, 2003, in forum: Digital Photography
    Replies:
    10
    Views:
    759
    Steve
    Oct 5, 2003
  4. Stone
    Replies:
    1
    Views:
    15,679
    stephen
    Sep 27, 2006
  5. Delay or failure in saving web pages.

    , Apr 20, 2008, in forum: Computer Support
    Replies:
    6
    Views:
    460
Loading...

Share This Page