high memory useage on a 7507

Discussion in 'Cisco' started by Bob Ross, Jan 24, 2006.

  1. Bob Ross

    Bob Ross Guest

    I seem to be having really high memory usage on my 7507, It has an RSP4 with
    256mb, I have two upstreams that are suppose to be sending me a full bgp
    feed, but right now to save memory I told one of them to not send me routes
    for anything under a /23 until I figure out what do do.. my router is
    running IOS 12.2(25)S7, and I'm wodering if I have something in the config
    that should not be there or something. Below is the current memory usage,
    and bgp info as well as the routers config:



    Head Total(b) Used(b) Free(b) Lowest(b)
    Largest(b)

    Processor 4358B540 212289292 198082448 14206844 9980012
    9722248

    Fast 4356B540 131072 24528 106544
    106544 106520



    BGP router identifier [removed], local AS number [removed]

    BGP table version is 588508, main routing table version 588508

    176348 network entries using 19927324 bytes of memory

    512212 path entries using 26635024 bytes of memory

    103587/32927 BGP path/bestpath attribute entries using 11187396 bytes of
    memory

    46900 BGP AS-PATH entries using 1268268 bytes of memory

    2 BGP community entries using 48 bytes of memory

    0 BGP route-map cache entries using 0 bytes of memory

    0 BGP filter-list cache entries using 0 bytes of memory

    BGP using 59018060 total bytes of memory

    256100 received paths for inbound soft reconfiguration

    BGP activity 181216/4868 prefixes, 530090/17878 paths, scan interval 60 secs



    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
    State/PfxRcd

    [removed] 4 [removed] 104927 1037 588508 0 0 17:10:38 175355

    [removed] 4 [removed] 190859 1020 588477 0 0 16:50:56 80745





    Current configuration : 9077 bytes

    !

    ! Last configuration change at 20:52:51 EST Mon Jan 23 2006 by bob

    ! NVRAM config last updated at 20:50:25 EST Mon Jan 23 2006 by bob

    !

    version 12.2

    service single-slot-reload-enable

    service nagle

    no service pad

    service timestamps debug datetime localtime show-timezone

    service timestamps log datetime localtime show-timezone

    service password-encryption

    !

    hostname router

    !

    boot-start-marker

    boot system flash disk0:rsp-pv-mz.122-25.S7.bin

    boot bootldr slot1:rsp-boot-mz.122-25.S1.bin

    boot-end-marker

    !

    !

    redundancy

    no keepalive-enable

    mode hsa

    logging buffered 262144 debugging

    no logging console

    aaa new-model

    aaa authentication login console local

    enable secret level [removed]

    enable secret [removed]

    enable password [removed]

    !

    username bob password [removed]

    clock timezone EST -5

    clock summer-time EDT recurring

    ip subnet-zero

    no ip source-route

    ip cef distributed

    !

    !

    ip domain-name [removed]

    ip name-server [removed]

    !

    ip multicast cache-headers

    no mpls traffic-eng auto-bw timers frequency 0

    call rsvp-sync

    !

    !

    !

    !

    !

    issu set rollback-timer 2700

    !

    !

    !

    interface FastEthernet0/0/0

    ip address [removed] secondary

    ip address [removed] secondary

    ip address [removed] secondary

    ip address [removed] secondary

    ip address [removed] secondary

    ip address [removed] secondary

    ip address [removed]

    no ip redirects

    no ip proxy-arp

    no ip mroute-cache

    full-duplex

    no clns route-cache

    !

    interface FastEthernet0/1/0

    ip address [removed]

    no ip redirects

    no ip proxy-arp

    no ip mroute-cache

    full-duplex

    no clns route-cache

    !

    interface POS1/0/0

    ip address [removed]

    ip access-group 110 in

    ip access-group 110 out

    encapsulation ppp

    no ip mroute-cache

    no clns route-cache

    !

    interface FastEthernet4/1/0

    ip address [removed]

    ip access-group 110 in

    ip access-group 110 out

    no ip redirects

    no ip proxy-arp

    no ip mroute-cache

    full-duplex

    no clns route-cache

    !

    router bgp [removed]

    no synchronization

    bgp always-compare-med

    no bgp log-neighbor-changes

    network [removed] mask 255.255.224.0

    aggregate-address [removed]

    redistribute connected route-map static-to-bgp

    redistribute static route-map static-to-bgp

    neighbor [removed] remote-as [removed]

    neighbor [removed] description [removed]

    neighbor [removed] version 4

    neighbor [removed] send-community

    neighbor [removed] soft-reconfiguration inbound

    neighbor [removed] route-map bgp-from-as[removed]-primary in

    neighbor [removed] route-map bgp-to-as[removed]-new out

    neighbor [removed] remote-as [removed]

    neighbor [removed] description [removed]

    neighbor [removed] version 4

    neighbor [removed] soft-reconfiguration inbound

    neighbor [removed] route-map bgp-from-as[removed]-primary in

    neighbor [removed] route-map bgp-to-as[removed]-primary out

    no auto-summary

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 [removed]

    !

    no ip http server

    !

    ip bgp-community new-format

    ip community-list standard no-announce-upstream permit [removed]:1000

    ip community-list standard no-announce-upstream permit [removed]:10000

    ip community-list standard no-announce-upstream permit [removed]:2000

    ip community-list standard no-announce-as[removed] permit [removed]:10020

    ip community-list standard prepend1-as[removed] permit [removed]:10021

    ip community-list standard prepend2-as[removed] permit [removed]:10022

    ip community-list standard prepend3-as[removed] permit [removed]:10023

    ip community-list standard prepend1-upstream permit [removed]:10001

    ip community-list standard prepend2-upstream permit [removed]:10002

    ip community-list standard prepend3-upstream permit [removed]:10003

    ip community-list standard no-announce-customer permit [removed]:40000

    ip community-list standard no-announce-iix permit [removed]:20010

    ip community-list standard no-announce-peer permit [removed]:1000

    ip community-list standard no-announce-peer permit [removed]:2000

    ip community-list standard no-announce-peer permit [removed]:20000

    ip community-list standard prepend1-customer permit [removed]:40001

    ip community-list standard prepend1-iix permit [removed]:20011

    ip community-list standard prepend1-peer permit [removed]:20001

    ip community-list standard prepend2-customer permit [removed]:40002

    ip community-list standard prepend2-iix permit [removed]:20012

    ip community-list standard prepend2-peer permit [removed]:20002

    ip community-list standard prepend3-customer permit [removed]:40003

    ip community-list standard prepend3-iix permit [removed]:20013

    ip community-list standard prepend3-peer permit [removed]:20003

    ip community-list standard local-pref-high permit [removed]:220

    ip community-list standard local-pref-low permit [removed]:200

    ip community-list standard local-pref-normal permit [removed]:210

    ip community-list standard no-announce-peercust permit [removed]:1000

    ip community-list standard no-announce-peercust permit [removed]:40000

    ip community-list standard as[removed]-customer permit [removed]:4000

    ip community-list standard as[removed]-originated permit [removed]:5000

    ip as-path access-list 1 permit ^$

    ip as-path access-list 10 permit .*

    ip as-path access-list 150 deny .*

    ip as-path access-list 180 permit ^[removed]$

    ip as-path access-list 180 permit ^[removed]_[removed]$

    ip as-path access-list 181 permit ^[removed]$

    !

    !

    ip prefix-list external-routes description nets to be announced outside our
    ASN

    ip prefix-list external-routes seq 10 permit [removed]/23

    !

    ip prefix-list internal-routes description nets to be announced inside our
    ASN

    ip prefix-list internal-routes seq 10 permit [removed]/23

    !

    ip prefix-list long-prefixes seq 5 permit 0.0.0.0/0 ge 25

    !

    ip prefix-list upstream-links description /30s to our upstreams

    ip prefix-list upstream-links seq 10 permit [removed]/30

    !

    logging trap debugging

    access-list 110 deny tcp any any eq 6667

    access-list 110 deny udp any any eq 6667

    access-list 110 deny tcp any any eq 135

    access-list 110 deny tcp any any eq 139

    access-list 110 deny udp any any eq 135

    access-list 110 deny udp any any eq netbios-ss

    access-list 110 permit ip any any

    !

    route-map bgp-from-as[removed]-primary permit 10

    match as-path 10

    set metric 100

    set local-preference 110

    !

    route-map bgp-from-as[removed]-primary permit 20

    match as-path 180

    set metric 1

    set local-preference 120

    !

    route-map bgp-to-blackhole deny 10

    !

    route-map bgp-to-as[removed]-primary permit 10

    match as-path 1

    !

    route-map bgp-to-as[removed]-new permit 10

    match as-path 1

    !

    route-map bgp-to-as[removed]-primary deny 10

    match community no-announce-upstream

    !

    route-map bgp-to-as[removed]-primary deny 20

    match community no-announce-as[removed]

    !

    route-map bgp-to-as[removed]-primary permit 110

    match community prepend1-as[removed]

    set as-path prepend [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 120

    match community prepend2-as[removed]

    set as-path prepend [removed] [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 130

    match community prepend3-as[removed]

    set as-path prepend [removed] [removed] [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 210

    match community prepend1-upstream

    set as-path prepend [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 220

    match community prepend2-upstream

    set as-path prepend [removed] [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 230

    match community prepend3-upstream

    set as-path prepend [removed] [removed] [removed]

    set community [removed]:125

    !

    route-map bgp-to-as[removed]-primary permit 990

    set community [removed]:125

    !

    route-map bgp-from-as[removed]-primary permit 30

    set metric 100

    set local-preference 110

    set community [removed]:1000 [removed]:1002 additive

    !

    route-map static-to-bgp permit 10

    match ip address prefix-list internal-routes

    set local-preference 300

    set origin igp

    set community [removed]:5000 local-AS

    !

    route-map static-to-bgp permit 20

    match ip address prefix-list external-routes

    set local-preference 300

    set origin igp

    set community [removed]:5000

    !

    route-map static-to-bgp permit 30

    match ip address prefix-list exchange-point-routes

    set local-preference 300

    set origin igp

    set community [removed]:1000

    !

    route-map bgp-to-noannounce permit 10

    match as-path 150

    !

    snmp-server view novacm internet included

    snmp-server view novacm internet.6.3.16 excluded

    snmp-server community [removed] view novacm RW 69

    snmp-server community [removed] view novacm RO 69

    snmp-server enable traps sonet

    !

    !

    control-plane

    !

    !

    banner motd

    router^C

    !

    line con 0

    session-timeout 10

    password [removed]

    transport preferred none

    escape-character 3

    line aux 0

    password [removed]

    line vty 0 4

    session-timeout 120

    exec-timeout 120 0

    password [removed]

    escape-character 3

    !

    ntp clock-period 17180137

    ntp server 192.5.41.209

    ntp server 129.250.35.250

    ntp server 164.67.62.194

    !

    end
     
    Bob Ross, Jan 24, 2006
    #1
    1. Advertising

  2. Bob Ross

    Guest

    > I seem to be having really high memory usage on my 7507

    sh proc mem

    May help you to identify errant processes.
    If there is one you may be able to turn it off.

    I don't know anything about BGP so I can't say if this is normal
    or not however Free is substantially greater than
    Largest which indicates some fragmentation.

    The router has no means of merging fragmented memory
    blocks.
     
    , Jan 25, 2006
    #2
    1. Advertising

  3. Bob Ross

    Bob Ross Guest

    <> wrote in message
    news:...
    > > I seem to be having really high memory usage on my 7507

    >
    > sh proc mem
    >
    > May help you to identify errant processes.
    > If there is one you may be able to turn it off.
    >
    > I don't know anything about BGP so I can't say if this is normal
    > or not however Free is substantially greater than
    > Largest which indicates some fragmentation.
    >
    > The router has no means of merging fragmented memory
    > blocks.


    Well, these are the processes using the most memory:

    Total: 212289292, Used: 198144672, Free: 14144620
    PID TTY Allocated Freed Holding Getbufs Retbufs Process
    178 0 167307304 29102144 130669664 0 0 BGP Router
    99 0 41323816 7131840 41333488 0 0 IP RIB
    Update
    0 0 29694776 4067544 23881880 0 0 *Init*
    17 0 595592 430576 138432 0 0 IPC
    Seat Manager

    I do not think the memory usage I'm seeing is normal, I know someone else
    who has a more complicated config then I do, as well as two upstreams
    sending them a full bgp table, and they have over 100mb free. I just do not
    have access to compare there config with mine. So either the IOS I'm using
    is not as efficent as the older 12 releases, or I'm missing something
    somwhere.

    Thanks,

    Bob
     
    Bob Ross, Jan 25, 2006
    #3
  4. Bob Ross

    Merv Guest

    There are at least two BGP related memory leaks in the release you are
    using:

    CSCeh16989 and CSCec52695

    You may want to consider moving to 12.2(32) to see if your issue is
    still present. As usual do a bug scrub on any new planned release.


    If problem persists, open a case with the Cisco TAC
     
    Merv, Jan 26, 2006
    #4
  5. Bob Ross

    Bob Ross Guest

    "Merv" <> wrote in message
    news:...
    > There are at least two BGP related memory leaks in the release you are
    > using:
    >
    > CSCeh16989 and CSCec52695
    >
    > You may want to consider moving to 12.2(32) to see if your issue is
    > still present. As usual do a bug scrub on any new planned release.
    >


    thanks, I'm trying to get cisco to give me 12.2(32), but so far they have
    only offered me 12.2(25)S8, don't know if that is fixed or not, still
    waiting for a reply back from them.

    Thanks,

    Bob
     
    Bob Ross, Jan 27, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Christian Lox

    7507/rsp2/high availability

    Christian Lox, Dec 3, 2004, in forum: Cisco
    Replies:
    1
    Views:
    524
    Christian Lox
    Dec 5, 2004
  2. gencode

    Bandwidth useage PIX 506

    gencode, Sep 13, 2005, in forum: Cisco
    Replies:
    2
    Views:
    516
    gencode
    Sep 16, 2005
  3. Home Theatre Guy

    Firefox using 2 hundred megs memmory useage ????

    Home Theatre Guy, Jul 26, 2006, in forum: Firefox
    Replies:
    15
    Views:
    1,727
    Mozilla Champion (Dan)
    Jul 30, 2006
  4. jasee
    Replies:
    0
    Views:
    451
    jasee
    Oct 23, 2006
  5. Seby
    Replies:
    1
    Views:
    917
Loading...

Share This Page