Help with Vlan trunking across a p2p t1

Discussion in 'Cisco' started by elementaladmins@gmail.com, Aug 16, 2007.

  1. Guest

    Hello,


    I am hoping someone can shed some light on this for me as I seem to
    be swimming in possibilities, but not sure of the correct path to
    follow to achieve the desired outcome. We are implementing a VOIP
    based PBX system in our main location. The Voip system and IP phones
    at the main location will be communicating on a dedicated VLAN within
    the existing network but will all be part of a non routed network
    segment. We also have a remote location that will be connected by a
    point to point T1 which will be also utilizing IP phones. My question
    is this. Can I have the IP Phones at the remote location participate
    in the same vlan that the main location will be using going over the
    point to point t1? I have come across bridging and irb, but I am not
    totally sure that it will do what I am looking for. I do have a test
    environment to play with, so any suggestions I can quickly apply them
    and test them out.
    My only other question (as of right now) is what the best way to
    facilitate working with voip across a point to point line, whether to
    keep the voip traffic segmented in it's own vlan and pass that back,
    or whether it is more advisable to just route it across the point to
    point and route it when it gets back to the main network. I am not
    sure what limitations there are with bridging and if you can still do
    QOS across the point to point line.

    Thanks,

    Ted
     
    , Aug 16, 2007
    #1
    1. Advertising

  2. Trendkill Guest

    On Aug 16, 3:40 pm, wrote:
    > Hello,
    >
    > I am hoping someone can shed some light on this for me as I seem to
    > be swimming in possibilities, but not sure of the correct path to
    > follow to achieve the desired outcome. We are implementing a VOIP
    > based PBX system in our main location. The Voip system and IP phones
    > at the main location will be communicating on a dedicated VLAN within
    > the existing network but will all be part of a non routed network
    > segment. We also have a remote location that will be connected by a
    > point to point T1 which will be also utilizing IP phones. My question
    > is this. Can I have the IP Phones at the remote location participate
    > in the same vlan that the main location will be using going over the
    > point to point t1? I have come across bridging and irb, but I am not
    > totally sure that it will do what I am looking for. I do have a test
    > environment to play with, so any suggestions I can quickly apply them
    > and test them out.
    > My only other question (as of right now) is what the best way to
    > facilitate working with voip across a point to point line, whether to
    > keep the voip traffic segmented in it's own vlan and pass that back,
    > or whether it is more advisable to just route it across the point to
    > point and route it when it gets back to the main network. I am not
    > sure what limitations there are with bridging and if you can still do
    > QOS across the point to point line.
    >
    > Thanks,
    >
    > Ted


    I would create a new /x network in the new location, route it, and
    just create the new segment in call manager or whatever you are
    using. Trunking l2 across a t1 is usually not a good idea in my
    opinion, for various reasons from broadcast traffic, to not being well-
    planned for future expansion, etc. Give it its own range, and that
    way you can always add more later and not have to re-address or get
    into trunking, etc. You can also then keep QoS as you need it, as
    well as l3 redundancy via something like isdn or dial if you needed it.
     
    Trendkill, Aug 16, 2007
    #2
    1. Advertising

  3. Thrill5 Guest

    The biggest issue with VoIP is voice quality. Adequate voice quality can
    only be achieved if you have QoS on your WAN links, and you can't do QoS if
    you configure it as a layer 2 link. Having your VoIP traffic going over a
    WAN link with existing data connection is going to be you biggest issue and
    you will have to get QoS enabled and working on that link even if it's not
    utilized that much. If you don't prioritize the voice traffic, the jitter
    alone will cause voice quality issues.

    Scott
    "Trendkill" <> wrote in message
    news:...
    > On Aug 16, 3:40 pm, wrote:
    >> Hello,
    >>
    >> I am hoping someone can shed some light on this for me as I seem to
    >> be swimming in possibilities, but not sure of the correct path to
    >> follow to achieve the desired outcome. We are implementing a VOIP
    >> based PBX system in our main location. The Voip system and IP phones
    >> at the main location will be communicating on a dedicated VLAN within
    >> the existing network but will all be part of a non routed network
    >> segment. We also have a remote location that will be connected by a
    >> point to point T1 which will be also utilizing IP phones. My question
    >> is this. Can I have the IP Phones at the remote location participate
    >> in the same vlan that the main location will be using going over the
    >> point to point t1? I have come across bridging and irb, but I am not
    >> totally sure that it will do what I am looking for. I do have a test
    >> environment to play with, so any suggestions I can quickly apply them
    >> and test them out.
    >> My only other question (as of right now) is what the best way to
    >> facilitate working with voip across a point to point line, whether to
    >> keep the voip traffic segmented in it's own vlan and pass that back,
    >> or whether it is more advisable to just route it across the point to
    >> point and route it when it gets back to the main network. I am not
    >> sure what limitations there are with bridging and if you can still do
    >> QOS across the point to point line.
    >>
    >> Thanks,
    >>
    >> Ted

    >
    > I would create a new /x network in the new location, route it, and
    > just create the new segment in call manager or whatever you are
    > using. Trunking l2 across a t1 is usually not a good idea in my
    > opinion, for various reasons from broadcast traffic, to not being well-
    > planned for future expansion, etc. Give it its own range, and that
    > way you can always add more later and not have to re-address or get
    > into trunking, etc. You can also then keep QoS as you need it, as
    > well as l3 redundancy via something like isdn or dial if you needed it.
    >
     
    Thrill5, Aug 16, 2007
    #3
  4. Guest

    Thanks for the advice both of you guys and I will abandon the effort
    to extend the network across the point to point line. I can find a lot
    of information on QOS with regard to a network, but not about running
    qos across a point to point (and 2 routers). Are there any special
    caveats to keep in mind when setting this up or things that just won't
    work?

    Thanks,

    Ted
     
    , Aug 21, 2007
    #4
  5. turnip Guest

    On Aug 21, 10:38 am, wrote:
    > Thanks for the advice both of you guys and I will abandon the effort
    > to extend the network across the point to point line. I can find a lot
    > of information on QOS with regard to a network, but not about running
    > qos across a point to point (and 2 routers). Are there any special
    > caveats to keep in mind when setting this up or things that just won't
    > work?
    >
    > Thanks,
    >
    > Ted


    I am using a policy map across a point to point to route voice
    traffic.

    on main office router:

    class-map voice
    match access-group 105

    policy-map voip
    class voice
    priority 96
    class class-default
    fair-queue

    interface Serial0/1 /* to our warehouse router via 1.54m t1 */
    service-policy output voip

    access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority
    (5)
    access-list 105 permit udp any any eq 4569
    access-list 105 permit udp any any eq 5004
    access-list 105 permit udp any any eq 5036
    access-list 105 permit udp any any eq 5060
    access-list 105 permit ip host 10.0.0.254 any
    access-list 105 permit ip any host 10.0.0.254 <--- asterisk SIP
    server


    router at other end:


    class-map voice
    match access-group 105

    policy-map voip
    class voice
    priority 96
    class class-default
    fair-queue

    interface Serial0/ 0 /* to our main office router via 1.54m t1 */
    service-policy output voip

    access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority
    (5)
    access-list 105 permit udp any any eq 4569
    access-list 105 permit udp any any eq 5004
    access-list 105 permit udp any any eq 5036
    access-list 105 permit udp any any eq 5060
    access-list 105 permit ip host 10.0.0.254 any
    access-list 105 permit ip any host 10.0.0.254 <--- asterisk SIP
    server

    this works well for us, we don't have a whole lot of phones in use in
    our warehouse, and their are no issues with large transfers are
    occuring.
     
    turnip, Aug 28, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. BG
    Replies:
    4
    Views:
    12,500
  2. Jarek Jarzebowski
    Replies:
    1
    Views:
    1,229
  3. Rob
    Replies:
    5
    Views:
    8,072
  4. Trouble
    Replies:
    1
    Views:
    1,196
    genki
    Aug 18, 2006
  5. infamousone

    Trunking Across Routers.

    infamousone, Sep 27, 2006, in forum: Cisco
    Replies:
    6
    Views:
    3,982
    infamousone
    Sep 28, 2006
Loading...

Share This Page