Help with IGMP

Discussion in 'Cisco' started by John Oliver, Oct 27, 2008.

  1. John Oliver

    John Oliver Guest

    I'm facing some issues with IGMP, but unfortunately know next to nothing
    about it. The extent of my knowledge is that adding and removing
    verious iterations of 'ip igmp snooping' globally or per VLAN sometimes
    results in a working config :)

    We have several 2960s that feed small streaming networks, with one or
    more VOD or other streaming video server. Those servers have various
    test clips, video sent by customers for troubleshooting, etc. We just
    got in a big satellite dish that has feeds for several channels, and i'm
    trying to reliably get the video from it.

    Behind the receivers for the dish is a 48 port 2960. Someone added a
    crossconnect from that switch to one of the streaming networks. It
    looked like traffic from the streaming network was flooding onto the
    satellite distribution switch... Wireshark showed a lot of stuff with
    source addresses that I recognized as being on that streaming network.
    I thought that, with IGMP, you had to specifically "join" a "channel",
    so I'm not sure why this happened. All of that traffic seemed to bring
    the satellite switch to it's knees... no hosts on it could ping each
    other, and we could not play any video signals with VLC on a laptop
    connected directly to that switch.

    Once I removed that crossconnect, things improved. One laptop with VLC
    was able to play Animal Planet HD, but it was extremely choppy...
    horrible pixelation, short "freezes", etc.

    I connected another laptop, and if I start to play Animal Planet HD, I
    can see 8.9 Mb/s of traffic coming in, but it just sits on one frame. I
    cannot play any othere channels. After a few minutes, VLC bombs out and
    wants to send it's useless error report of into the ether.

    I realize I'm not giving a lot of useful info here, but I have no idea
    what else could be pertinent. I can find my way around IOS, but I know
    nothing about multicast. I could use any suggestions on how to
    correctly set up a Cisco switch for multicast, or any pointers to
    material that might help.

    --
    * John Oliver http://www.john-oliver.net/ *
    John Oliver, Oct 27, 2008
    #1
    1. Advertising

  2. John Oliver

    Thrill5 Guest

    IGMP is only one half of the equation when configuring multicast. IGMP is
    the layer 2 protocol to allow switch interfaces to join multcast streams.
    If the multicast source is on a different subnet/VLAN you must also have PIM
    (Protocol Independent Multicast), and multicast routing enabled on your
    layer 3 routers. You also need to configure an RP ("Rendezvous Point")
    somewhere on your network. Without knowing more details of your network, I
    can't offer any configurations, but is pretty simple to configure. Search
    PIM, and auto-RP for more info.

    "John Oliver" <> wrote in message
    news:...
    > I'm facing some issues with IGMP, but unfortunately know next to nothing
    > about it. The extent of my knowledge is that adding and removing
    > verious iterations of 'ip igmp snooping' globally or per VLAN sometimes
    > results in a working config :)
    >
    > We have several 2960s that feed small streaming networks, with one or
    > more VOD or other streaming video server. Those servers have various
    > test clips, video sent by customers for troubleshooting, etc. We just
    > got in a big satellite dish that has feeds for several channels, and i'm
    > trying to reliably get the video from it.
    >
    > Behind the receivers for the dish is a 48 port 2960. Someone added a
    > crossconnect from that switch to one of the streaming networks. It
    > looked like traffic from the streaming network was flooding onto the
    > satellite distribution switch... Wireshark showed a lot of stuff with
    > source addresses that I recognized as being on that streaming network.
    > I thought that, with IGMP, you had to specifically "join" a "channel",
    > so I'm not sure why this happened. All of that traffic seemed to bring
    > the satellite switch to it's knees... no hosts on it could ping each
    > other, and we could not play any video signals with VLC on a laptop
    > connected directly to that switch.
    >
    > Once I removed that crossconnect, things improved. One laptop with VLC
    > was able to play Animal Planet HD, but it was extremely choppy...
    > horrible pixelation, short "freezes", etc.
    >
    > I connected another laptop, and if I start to play Animal Planet HD, I
    > can see 8.9 Mb/s of traffic coming in, but it just sits on one frame. I
    > cannot play any othere channels. After a few minutes, VLC bombs out and
    > wants to send it's useless error report of into the ether.
    >
    > I realize I'm not giving a lot of useful info here, but I have no idea
    > what else could be pertinent. I can find my way around IOS, but I know
    > nothing about multicast. I could use any suggestions on how to
    > correctly set up a Cisco switch for multicast, or any pointers to
    > material that might help.
    >
    > --
    > * John Oliver http://www.john-oliver.net/ *
    Thrill5, Oct 27, 2008
    #2
    1. Advertising

  3. John Oliver

    John Oliver Guest

    On Mon, 27 Oct 2008 19:27:55 -0400, Thrill5 wrote:
    > IGMP is only one half of the equation when configuring multicast. IGMP is
    > the layer 2 protocol to allow switch interfaces to join multcast streams.
    > If the multicast source is on a different subnet/VLAN you must also have PIM
    > (Protocol Independent Multicast), and multicast routing enabled on your
    > layer 3 routers. You also need to configure an RP ("Rendezvous Point")
    > somewhere on your network. Without knowing more details of your network, I
    > can't offer any configurations, but is pretty simple to configure. Search
    > PIM, and auto-RP for more info.


    All of this multicast traffic is on a single segment / subnet. At least
    for now, there is no routing between them. There are some switches
    where this "just works".

    Another issue I've run into before is where a given network "doesn't
    work" when plugged into a Cisco 2960, but "does work" when plugged into
    a dumb Dell 2724. Clearly, there's a config issue on the Cisco side.

    An example:

    TestSwitch#sh run
    Building configuration...

    Current configuration : 4501 bytes
    !
    ! Last configuration change at 13:43:36 PDT Fri Aug 8 2008 by user
    ! NVRAM config last updated at 13:43:45 PDT Fri Aug 8 2008 by user
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname TestSwitch
    !
    enable secret 5 ******************************
    !
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    !
    aaa session-id common
    clock timezone PST -8
    clock summer-time PDT recurring
    system mtu routing 1500
    ip subnet-zero
    !
    ip domain-name domain.com
    ip igmp snooping tcn query solicit
    ip igmp snooping querier
    !
    !
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2-24
    switchport access vlan 2
    !
    interface Vlan1
    ip address 10.99.16.33 255.255.248.0
    no ip route-cache
    !
    ip default-gateway 10.99.16.1
    ip http server
    ip http secure-server
    snmp-server community public RO
    radius-server source-ports 1645-1646
    !
    control-plane
    !
    !
    line con 0
    line vty 0 4
    password 7 **********************
    transport input ssh
    line vty 5 15
    !
    ntp clock-period 36029036
    ntp server 10.99.16.5
    end


    --
    * John Oliver http://www.john-oliver.net/ *
    John Oliver, Oct 27, 2008
    #3
  4. John Oliver

    Thrill5 Guest

    You "dumb" Dell switch probably doesn't run IGMP, and is forwarding your
    multicast streams to all ports.

    Your running an IGMP snooping quierier on the switch, which is using the IP
    address you have configured on VLAN 1, but your switch ports are in VLAN 2.
    Can you ping the hosts that are receiving the multicast traffic from the
    switch? If not, this is why multicast is not working.


    "John Oliver" <> wrote in message
    news:...
    > On Mon, 27 Oct 2008 19:27:55 -0400, Thrill5 wrote:
    >> IGMP is only one half of the equation when configuring multicast. IGMP
    >> is
    >> the layer 2 protocol to allow switch interfaces to join multcast streams.
    >> If the multicast source is on a different subnet/VLAN you must also have
    >> PIM
    >> (Protocol Independent Multicast), and multicast routing enabled on your
    >> layer 3 routers. You also need to configure an RP ("Rendezvous Point")
    >> somewhere on your network. Without knowing more details of your network,
    >> I
    >> can't offer any configurations, but is pretty simple to configure.
    >> Search
    >> PIM, and auto-RP for more info.

    >
    > All of this multicast traffic is on a single segment / subnet. At least
    > for now, there is no routing between them. There are some switches
    > where this "just works".
    >
    > Another issue I've run into before is where a given network "doesn't
    > work" when plugged into a Cisco 2960, but "does work" when plugged into
    > a dumb Dell 2724. Clearly, there's a config issue on the Cisco side.
    >
    > An example:
    >
    > TestSwitch#sh run
    > Building configuration...
    >
    > Current configuration : 4501 bytes
    > !
    > ! Last configuration change at 13:43:36 PDT Fri Aug 8 2008 by user
    > ! NVRAM config last updated at 13:43:45 PDT Fri Aug 8 2008 by user
    > !
    > version 12.2
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > !
    > hostname TestSwitch
    > !
    > enable secret 5 ******************************
    > !
    > aaa new-model
    > aaa authentication login default local
    > aaa authorization exec default local
    > !
    > aaa session-id common
    > clock timezone PST -8
    > clock summer-time PDT recurring
    > system mtu routing 1500
    > ip subnet-zero
    > !
    > ip domain-name domain.com
    > ip igmp snooping tcn query solicit
    > ip igmp snooping querier
    > !
    > !
    > no file verify auto
    > spanning-tree mode pvst
    > spanning-tree extend system-id
    > !
    > vlan internal allocation policy ascending
    > !
    > interface GigabitEthernet0/1
    > !
    > interface GigabitEthernet0/2-24
    > switchport access vlan 2
    > !
    > interface Vlan1
    > ip address 10.99.16.33 255.255.248.0
    > no ip route-cache
    > !
    > ip default-gateway 10.99.16.1
    > ip http server
    > ip http secure-server
    > snmp-server community public RO
    > radius-server source-ports 1645-1646
    > !
    > control-plane
    > !
    > !
    > line con 0
    > line vty 0 4
    > password 7 **********************
    > transport input ssh
    > line vty 5 15
    > !
    > ntp clock-period 36029036
    > ntp server 10.99.16.5
    > end
    >
    >
    > --
    > * John Oliver http://www.john-oliver.net/ *
    Thrill5, Nov 1, 2008
    #4
  5. John Oliver

    pat Guest

    By default it should forward multicast traffic to all port. Which is not
    good, it clog the network. It switch is has no VLAN or single VLAN and all
    port are part of that VLAN.
    "John Oliver" <> wrote in message
    news:...
    > On Mon, 27 Oct 2008 19:27:55 -0400, Thrill5 wrote:
    >> IGMP is only one half of the equation when configuring multicast. IGMP
    >> is
    >> the layer 2 protocol to allow switch interfaces to join multcast streams.
    >> If the multicast source is on a different subnet/VLAN you must also have
    >> PIM
    >> (Protocol Independent Multicast), and multicast routing enabled on your
    >> layer 3 routers. You also need to configure an RP ("Rendezvous Point")
    >> somewhere on your network. Without knowing more details of your network,
    >> I
    >> can't offer any configurations, but is pretty simple to configure.
    >> Search
    >> PIM, and auto-RP for more info.

    >
    > All of this multicast traffic is on a single segment / subnet. At least
    > for now, there is no routing between them. There are some switches
    > where this "just works".
    >
    > Another issue I've run into before is where a given network "doesn't
    > work" when plugged into a Cisco 2960, but "does work" when plugged into
    > a dumb Dell 2724. Clearly, there's a config issue on the Cisco side.
    >
    > An example:
    >
    > TestSwitch#sh run
    > Building configuration...
    >
    > Current configuration : 4501 bytes
    > !
    > ! Last configuration change at 13:43:36 PDT Fri Aug 8 2008 by user
    > ! NVRAM config last updated at 13:43:45 PDT Fri Aug 8 2008 by user
    > !
    > version 12.2
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > !
    > hostname TestSwitch
    > !
    > enable secret 5 ******************************
    > !
    > aaa new-model
    > aaa authentication login default local
    > aaa authorization exec default local
    > !
    > aaa session-id common
    > clock timezone PST -8
    > clock summer-time PDT recurring
    > system mtu routing 1500
    > ip subnet-zero
    > !
    > ip domain-name domain.com
    > ip igmp snooping tcn query solicit
    > ip igmp snooping querier
    > !
    > !
    > no file verify auto
    > spanning-tree mode pvst
    > spanning-tree extend system-id
    > !
    > vlan internal allocation policy ascending
    > !
    > interface GigabitEthernet0/1
    > !
    > interface GigabitEthernet0/2-24
    > switchport access vlan 2
    > !
    > interface Vlan1
    > ip address 10.99.16.33 255.255.248.0
    > no ip route-cache
    > !
    > ip default-gateway 10.99.16.1
    > ip http server
    > ip http secure-server
    > snmp-server community public RO
    > radius-server source-ports 1645-1646
    > !
    > control-plane
    > !
    > !
    > line con 0
    > line vty 0 4
    > password 7 **********************
    > transport input ssh
    > line vty 5 15
    > !
    > ntp clock-period 36029036
    > ntp server 10.99.16.5
    > end
    >
    >
    > --
    > * John Oliver http://www.john-oliver.net/ *
    pat, Nov 10, 2008
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ross
    Replies:
    0
    Views:
    4,267
  2. Konrad

    IGMP configuration

    Konrad, Nov 13, 2003, in forum: Cisco
    Replies:
    2
    Views:
    6,678
    Andre Beck
    Nov 15, 2003
  3. darko

    IGMP? Please help im freaked!

    darko, Sep 7, 2003, in forum: Computer Security
    Replies:
    5
    Views:
    4,404
  4. Salmonaxe
    Replies:
    0
    Views:
    509
    Salmonaxe
    Nov 2, 2006
  5. dlyyang

    Help with IGMP Accounting~

    dlyyang, Dec 6, 2008, in forum: Cisco
    Replies:
    0
    Views:
    402
    dlyyang
    Dec 6, 2008
Loading...

Share This Page