Help with configuring cisco 831 router

Discussion in 'Cisco' started by northstar1805@comcast.net, Aug 20, 2005.

  1. Guest

    I am a hobbyst with a cisco router. I would like to ask for help in
    configuring my cisco 831 router so i can hook 4 computers to the
    internet. Right now i have a cable dsl modem hooked up but i would like
    to have other computers run off the one connection. For now i dont care
    about networking the computers together. I just care about having all
    the computers have internet access.

    And regarding firewalls i have a software one so i dont care about that
    just yet either...

    Andrew
     
    , Aug 20, 2005
    #1
    1. Advertising

  2. John Guest

    Are you able to connect a console cable to the router?


    <> wrote in message
    news:...
    >I am a hobbyst with a cisco router. I would like to ask for help in
    > configuring my cisco 831 router so i can hook 4 computers to the
    > internet. Right now i have a cable dsl modem hooked up but i would like
    > to have other computers run off the one connection. For now i dont care
    > about networking the computers together. I just care about having all
    > the computers have internet access.
    >
    > And regarding firewalls i have a software one so i dont care about that
    > just yet either...
    >
    > Andrew
    >
     
    John, Aug 20, 2005
    #2
    1. Advertising

  3. Guest

    Yes, its been a few years since i worked with routers and did any kind
    of this work but yes. I looked online to recal what to do.
    I connected a cable and i can get to enable mode.

    Now its just a matter of entering the right commands and ip addresses i
    think.

    Andrew

    John wrote:
    > Are you able to connect a console cable to the router?
    >
    >
    > <> wrote in message
    > news:...
    > >I am a hobbyst with a cisco router. I would like to ask for help in
    > > configuring my cisco 831 router so i can hook 4 computers to the
    > > internet. Right now i have a cable dsl modem hooked up but i would like
    > > to have other computers run off the one connection. For now i dont care
    > > about networking the computers together. I just care about having all
    > > the computers have internet access.
    > >
    > > And regarding firewalls i have a software one so i dont care about that
    > > just yet either...
    > >
    > > Andrew
    > >
     
    , Aug 20, 2005
    #3
  4. www.BradReese.Com, Aug 20, 2005
    #4
  5. John Guest

    Once your in "enable" mode, type "config t" to get in to "config mode". Once
    there, paste in the following text:



    ip subnet-zero
    !
    ip dhcp pool DHCP
    import all
    network 172.16.1.0 255.255.255.0
    default-router 172.16.2.1
    lease infinite
    !
    interface Ethernet0
    description Internal LAN
    ip address 172.16.1.1 255.255.255.0
    !
    interface Ethernet1
    description Internet
    ip address dhcp
    !
    ip classless
    !
    ip nat inside source list 100 interface Ethernet1 overload
    !
    access-list 100 permit ip any any








    <> wrote in message
    news:...
    > Yes, its been a few years since i worked with routers and did any kind
    > of this work but yes. I looked online to recal what to do.
    > I connected a cable and i can get to enable mode.
    >
    > Now its just a matter of entering the right commands and ip addresses i
    > think.
    >
    > Andrew
    >
    > John wrote:
    >> Are you able to connect a console cable to the router?
    >>
    >>
    >> <> wrote in message
    >> news:...
    >> >I am a hobbyst with a cisco router. I would like to ask for help in
    >> > configuring my cisco 831 router so i can hook 4 computers to the
    >> > internet. Right now i have a cable dsl modem hooked up but i would like
    >> > to have other computers run off the one connection. For now i dont care
    >> > about networking the computers together. I just care about having all
    >> > the computers have internet access.
    >> >
    >> > And regarding firewalls i have a software one so i dont care about that
    >> > just yet either...
    >> >
    >> > Andrew
    >> >

    >
     
    John, Aug 20, 2005
    #5
  6. Guest

    John,
    Say....now some code...that helps alot! thanks....

    ip subnet-zero
    !
    ip dhcp pool DHCP
    import all
    network 172.16.1.0 255.255.255.0 <- the isp network address?
    default-router 172.16.2.1 <-default gate way?
    lease infinite
    !
    interface Ethernet0
    description Internal LAN
    ip address 172.16.1.1 255.255.255.0
    !
    ! So i can add the following code for my other ethernet connections i
    want to add?
    !
    interface Ethernet1
    description Internet
    ip address dhcp <- what is this for?
    !

    interface Ethernet2
    description Internal LAN
    ip address 172.16.1.2 255.255.255.0
    !
    interface Ethernet3
    description Internal LAN
    ip address 172.16.1.3 255.255.255.0
    !

    ip classless
    !
    ip nat inside source list 100 interface Ethernet0 overload
    ip nat inside source list 100 interface Ethernet1 overload
    ip nat inside source list 100 interface Ethernet2 overload
    ip nat inside source list 100 interface Ethernet3 overload
    !
    access-list 100 permit ip any any

    Andrew
     
    , Aug 21, 2005
    #6
  7. Guest

    Brad,
    Hey, thanks for the info. I found that poking around the cisco
    website....But some code snippets help alot too. I am like a person who
    has a hammer and saw but cant build a house.

    I have a few questions?

    What kind of connection does a typical DSL provider give? i thought it
    was ppp or in this case does it matter? For me i want to use my cable
    DSL connection to share with 4 PC's.

    Andrew
     
    , Aug 21, 2005
    #7
  8. repherb

    Joined:
    Jan 23, 2010
    Messages:
    1
    Could use a bit of a hand too please?

    I've been given a cisco 831 (32MB model, IOS 12.2) from a good friend as a gift. I have been able to figure out how to get DHCP working but i want to be able to have the unit initiate a PPPoE session over my DSL via Ethernet1 (username and password need to be provided), then take the DHCP assigned dynamic IP from my provider and internally DHCP via 192.168.1.XXX the 4 ethernet ports on Ethernet0. here's my config so far:

    Router# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.1.0/24 is directly connected, Ethernet0
    Router# sh run
    Building configuration...

    Current configuration : 1438 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    logging queue-limit 100
    !
    clock timezone EST -5
    ip subnet-zero
    no ip source-route
    ip dhcp excluded-address 192.168.1.0 192.168.1.100
    !
    ip dhcp pool DHCP
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 4.2.2.1 8.8.8.8 68.2.16.30
    lease infinite
    !
    ip dhcp pool DHCP_LAN0
    network 172.16.45.0 255.255.255.0
    dns-server 4.2.2.1 8.8.8.8 68.2.16.30
    default-router 192.168.0.1
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    !
    !
    interface Ethernet0
    description Internal LAN
    ip address 192.168.1.100 255.255.255.0
    no ip redirects
    no ip proxy-arp
    ip nat inside
    no cdp enable
    hold-queue 100 out
    !
    interface Ethernet1
    description Internet
    ip address dhcp
    ip access-group infilter in
    ip access-group outfilter out
    ip nat outside
    duplex auto
    !
    ip nat inside source list 100 interface Ethernet1 overload
    ip classless
    no ip http server
    no ip http secure-server
    !
    access-list 100 permit ip any any
    !
    line con 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    !
    end

    If someone could help me by re-writing/defining the config, i'd greatly appreciate it!

    Thanks!!
     
    repherb, Jan 24, 2010
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jimmyzshack
    Replies:
    1
    Views:
    565
    Claude LeFort
    Nov 19, 2003
  2. Mirek
    Replies:
    1
    Views:
    7,277
    Alan Strassberg
    Jan 18, 2004
  3. sw
    Replies:
    2
    Views:
    2,871
  4. Joe
    Replies:
    0
    Views:
    599
  5. Yajesh Shanker
    Replies:
    7
    Views:
    2,815
    Trendkill
    Mar 29, 2007
Loading...

Share This Page