Help understanding how this routing setup works

Discussion in 'Cisco' started by David Requena, Jan 23, 2011.

  1. Hi All,

    While having a basic understanding of how routing stuff works I don't
    seem to be able get my head around this one.

    I have a branch router with 2 FE interfaces connected like this:


    FE0/0 ---> WAN access device (192.168.1.105)
    FE0/1 ---> LAN (192.168.1/24)


    Then relevant configuration is like this:

    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto

    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto

    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip unnumbered FastEthernet0/0

    ip route 0.0.0.0 0.0.0.0 192.168.1.105
    ip route 192.168.1.105 255.255.255.255 FastEthernet0/1.1

    When the las t route is not present the WAN cannot be reached. Why is
    it needed?
    I can see some VLAN config on FE0/1.1. Is it really needed?

    In general how does this work? show ip route shows:

    ip route 0.0.0.0 0.0.0.0 192.168.1.105
    ip route 192.168.1.105 255.255.255.255 FastEthernet0/1.1

    Here is how I (don't) understand it. Say a packet arrives at FE0/1.1
    for some WAN destination. Then it is forwarded to 192.168.1.105 as per
    default route. But there is a host route which puts this packet
    through FE0/1.1. So how does it reach the WAN if it is phisically
    connected to FE0/0 and not to FE0/1?? More, why this packet does not
    reach the WAN if not forced through the (wrong) phisical interface?

    And last. Why should such a setup be preferable over a simpler one
    like:

    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto

    interface FastEthernet0/1
    ip address 192.168.1.2 255.255.255.0
    duplex auto
    speed auto

    ip route 0.0.0.0 0.0.0.0 192.168.1.105
    ip route 192.168.1.105 255.255.255.255 FastEthernet0/0
    ip route 192.168.1.0 255.255.255.0 FastEthernet0/1

    Thanks in advance!
     
    David Requena, Jan 23, 2011
    #1
    1. Advertising

  2. David Requena

    bod43 Guest

    On Jan 23, 3:32 pm, David Requena <> wrote:
    > Hi All,
    >
    > While having a basic understanding of how routing stuff works I don't
    > seem to be able get my head around this one.
    >
    > I have a branch router with 2 FE interfaces connected like this:
    >
    > FE0/0   --->  WAN access device (192.168.1.105)
    > FE0/1   --->  LAN (192.168.1/24)
    >
    > Then relevant configuration is like this:
    >
    > interface FastEthernet0/0
    >  ip address 192.168.1.1 255.255.255.0
    >  duplex auto
    >  speed auto
    >
    > interface FastEthernet0/1
    >  no ip address
    >  duplex auto
    >  speed auto
    >
    > interface FastEthernet0/1.1
    >  encapsulation dot1Q 1 native
    >  ip unnumbered FastEthernet0/0
    >
    > ip route 0.0.0.0 0.0.0.0 192.168.1.105
    > ip route 192.168.1.105 255.255.255.255 FastEthernet0/1.1
    >
    > When the las t route is not present the WAN cannot be reached. Why is
    > it needed?
    > I can see some VLAN config on FE0/1.1. Is it really needed?
    >
    > In general how does this work? show ip route shows:
    >
    > ip route 0.0.0.0 0.0.0.0 192.168.1.105
    > ip route 192.168.1.105 255.255.255.255 FastEthernet0/1.1
    >
    > Here is how I (don't) understand it. Say a packet arrives at FE0/1.1
    > for some WAN destination. Then it is forwarded to 192.168.1.105 as per
    > default route. But there is a host route which puts this packet
    > through FE0/1.1. So how does it reach the WAN if it is phisically
    > connected to FE0/0 and not to FE0/1?? More, why this packet does not
    > reach the WAN if not forced through the (wrong) phisical interface?
    >
    > And last. Why should such a setup be preferable over a simpler one
    > like:
    >
    > interface FastEthernet0/0
    >  ip address 192.168.1.1 255.255.255.0
    >  duplex auto
    >  speed auto
    >
    > interface FastEthernet0/1
    >  ip address 192.168.1.2 255.255.255.0
    >  duplex auto
    >  speed auto
    >
    > ip route 0.0.0.0 0.0.0.0 192.168.1.105
    > ip route 192.168.1.105 255.255.255.255 FastEthernet0/0
    > ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
    >
    > Thanks in advance!


    The reason that you cannot figure it out is that no
    sensible person would ever use such a configuration.

    It must have been done for a workaround of some sort.

    you say:-

    "And last. Why should such a setup be preferable over a simpler one
    like:

    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto

    interface FastEthernet0/1
    ip address 192.168.1.2 255.255.255.0
    duplex auto
    speed auto


    Well this is actually the FIRST question.

    No Cisco router will accept this invalid configuration.

    Different interfaces MUST be on different networks so the
    router will not accept such a configuration.


    IP unnumbered is not intended to be used on broadcast media
    such as Ethnernet. It is valid on point to point links
    such as serial interfaces.

    If it is working then I salute the original implementor.
    I cannot figure it out. It looks as if the router has been
    configured to wedge in where a bridge is actually what is needed.
    You can of course configure the router as a bridge if required.

    Perhaps the rest of the config might have some clues. Please
    post the whole config. Also perhaps describe the rest of the network.
    Perhaps the router can simply be removed?
     
    bod43, Jan 24, 2011
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Smith
    Replies:
    1
    Views:
    28,970
    Robert
    Sep 4, 2005
  2. niicko
    Replies:
    1
    Views:
    1,080
    niicko
    Sep 11, 2003
  3. Adriano
    Replies:
    1
    Views:
    937
    mark mandel
    Dec 15, 2003
  4. Fogar
    Replies:
    1
    Views:
    722
    Erick
    Jan 17, 2006
  5. pfisterfarm
    Replies:
    4
    Views:
    2,224
    Stephen
    Oct 12, 2010
Loading...

Share This Page