Help needed configuring voip.co.uk

Discussion in 'UK VOIP' started by Matt, Mar 3, 2007.

  1. Matt

    Matt Guest

    Hi. I'm struggling to get my Siemens Gigaset working with Voip.co.uk's
    settings. I've tried an old account with Voiptalk and that works.

    The handset says "Not available" when I try to make a call. I also can't
    receive a call. I've entered the settings in the browser, and it appears to
    find the servers ok. I know this because if I get something wrong, it quite
    correctly says "SIP Registration Failed".

    I would be really grateful if someone could take a quick look at my settings
    below...

    SIP ****** Authentication Name:
    ******** Authentication password:
    ******** Confirm authentication password:
    ****** Username:
    proxy.voip.co.uk Domain:
    Matt Display name:
    proxy.voip.co.uk Proxy server address:
    5060 Proxy server port:
    registrar.voip.co.uk Registrar server:
    5060 Registrar server port:
    Listen ports 5060 SIP port
    5004 RTP port
    NO Use random ports

    Network NO STUN enabled
    STUN server:
    3478 STUN port:
    120 (seconds) NAT refresh time:
    Auto Outbound proxy mode
    proxy.voip.co.uk Outbound proxy:
    5060 Outbound proxy port:

    Voice codecs Normal VoIP Volume: (Low Normal High)
    NO Enable Annex B for G729: (Yes No)
     
    Matt, Mar 3, 2007
    #1
    1. Advertising

  2. Matt

    Herman Guest

    "Matt" <> wrote in message
    news:...
    > Hi. I'm struggling to get my Siemens Gigaset working with Voip.co.uk's
    > settings. I've tried an old account with Voiptalk and that works.
    >
    > The handset says "Not available" when I try to make a call. I also can't
    > receive a call. I've entered the settings in the browser, and it appears
    > to find the servers ok. I know this because if I get something wrong, it
    > quite correctly says "SIP Registration Failed".
    >
    > I would be really grateful if someone could take a quick look at my
    > settings below...
    >
    > SIP ****** Authentication Name:
    > ******** Authentication password:
    > ******** Confirm authentication password:
    > ****** Username:
    > proxy.voip.co.uk Domain:
    > Matt Display name:
    > proxy.voip.co.uk Proxy server address:
    > 5060 Proxy server port:
    > registrar.voip.co.uk Registrar server:
    > 5060 Registrar server port:
    > Listen ports 5060 SIP port
    > 5004 RTP port
    > NO Use random ports
    >
    > Network NO STUN enabled
    > STUN server:
    > 3478 STUN port:
    > 120 (seconds) NAT refresh time:
    > Auto Outbound proxy mode
    > proxy.voip.co.uk Outbound proxy:
    > 5060 Outbound proxy port:
    >
    > Voice codecs Normal VoIP Volume: (Low Normal High)
    > NO Enable Annex B for G729: (Yes No)



    Can't see anything particularly wrong with that. Assuming there are no
    other settings you haven't given us (e.g. AuthID and UseAuthID IIRC) then
    have you checked your user name and password? Perhaps download x-lite and
    try and register with that. If it is a registration problem, that already
    narrows down the possibilities. For example, I don't think it is a
    firewall/STUN issue.
     
    Herman, Mar 3, 2007
    #2
    1. Advertising

  3. Matt

    Tim Guest

    Matt wrote:
    > Hi. I'm struggling to get my Siemens Gigaset working with Voip.co.uk's
    > settings. I've tried an old account with Voiptalk and that works.


    The Siemens handsets are known to work fine with voip.co.uk


    >


    > SIP ****** Authentication Name:


    Make sure you have your username in `Authentication name` as well as
    `username`.

    Yes you have to put it in twice, even if they are the same thing.

    > ******** Authentication password:
    > ******** Confirm authentication password:
    > ****** Username:
    > proxy.voip.co.uk Domain:
    > Matt Display name:
    > proxy.voip.co.uk Proxy server address:
    > 5060 Proxy server port:
    > registrar.voip.co.uk Registrar server:
    > 5060 Registrar server port:


    You need to have the same thing in `Domain`, `Proxy server address`,
    `registrar server`


    If you don't have an identical server in all three, it doesn't work.
    Yes it is nuts.

    So make them all registrar.voip.co.uk or proxy.voip.co.uk

    I'm not quite sure which one is correct - suspect either will work
    providing it is the same in all 3 boxes.

    Yes, you really have to put it in 3 times.


    > Auto Outbound proxy mode
    > proxy.voip.co.uk Outbound proxy:
    > 5060 Outbound proxy port:


    Change auto to always. I've never ever had a Siemens phone work with
    the setting on auto. Always Always or Never.

    Tim
     
    Tim, Mar 4, 2007
    #3
  4. Matt

    Matt Guest

    > If you don't have an identical server in all three, it doesn't work. Yes
    > it is nuts.
    >
    > So make them all registrar.voip.co.uk or proxy.voip.co.uk


    Hi - many thanks for that information. It looks like I'm doing everything
    correctly. I have tried both of the above in all three places.

    > Change auto to always. I've never ever had a Siemens phone work with the
    > setting on auto. Always Always or Never.


    I've tried all three, both no good (always, auto and never).

    My phone is registering ok - it shows on the telephony screen. Since my
    original post, I've upgraded the firmware. Having done that, the message I
    get when making a call is "VOIP Status code: 400". Before the upgrade is
    was "Not available".

    I'm getting really frustrated with it - I think it must be due to
    Voip.co.uk. I don't think they support anyone during the weekend.
     
    Matt, Mar 4, 2007
    #4
  5. Matt

    Matt Guest

    > Can't see anything particularly wrong with that. Assuming there are no
    > other settings you haven't given us (e.g. AuthID and UseAuthID IIRC) then
    > have you checked your user name and password? Perhaps download x-lite and
    > try and register with that. If it is a registration problem, that already
    > narrows down the possibilities. For example, I don't think it is a
    > firewall/STUN issue.


    I have tried setting up the phone with an old voiptalk.org account and that
    works fine for outgoing calls. I couldn't receive any incoming calls but at
    least I proved a point.
     
    Matt, Mar 4, 2007
    #5
  6. Matt

    Tim Guest

    Matt wrote:
    > My phone is registering ok - it shows on the telephony screen. Since my
    > original post, I've upgraded the firmware. Having done that, the message I
    > get when making a call is "VOIP Status code: 400". Before the upgrade is
    > was "Not available".



    400 means bad request.

    What kind of router do you have?

    Maybe there is a SIP ALG in your router that is mangling the SIP on the
    way through.

    Tim
     
    Tim, Mar 4, 2007
    #6
  7. Matt

    Matt Guest

    > 400 means bad request.
    >
    > What kind of router do you have?


    Many thanks. It's a netgear DG834.

    > Maybe there is a SIP ALG in your router that is mangling the SIP on the
    > way through.


    I don't think there is anything in the router's configuration about SIP. I
    don't understand what ALG is.
     
    Matt, Mar 4, 2007
    #7
  8. Matt

    Roger Guest

    "Matt" <> wrote in message
    news:...
    >> Can't see anything particularly wrong with that. Assuming there are no
    >> other settings you haven't given us (e.g. AuthID and UseAuthID IIRC) then
    >> have you checked your user name and password? Perhaps download x-lite
    >> and try and register with that. If it is a registration problem, that
    >> already narrows down the possibilities. For example, I don't think it is
    >> a firewall/STUN issue.

    >
    > I have tried setting up the phone with an old voiptalk.org account and
    > that works fine for outgoing calls. I couldn't receive any incoming calls
    > but at least I proved a point.
    >

    I really struggled with a Netgear router and my sipuras with one way voice
    and no connections and had to forward ports - something I never have to
    worry about with the Linksys router. Have you tried configuring STUN just to
    see if that helps the issue?
     
    Roger, Mar 4, 2007
    #8
  9. Matt

    Matt Guest

    > I really struggled with a Netgear router and my sipuras with one way voice
    > and no connections and had to forward ports - something I never have to
    > worry about with the Linksys router. Have you tried configuring STUN just
    > to see if that helps the issue?


    No, I haven't. Voip.co.uk's notes say to not use STUN. I could easily
    forward the packets using my router though. I wouldn't have thought that
    was the reason for outbound calls not working, but I may be wrong.

    Is there is long list of ports, or is it just the ones listed in the Siemens
    phone's configuration page?
     
    Matt, Mar 4, 2007
    #9
  10. Matt

    Linker3000 Guest

    Matt wrote:
    > Hi. I'm struggling to get my Siemens Gigaset working with Voip.co.uk's
    > settings. I've tried an old account with Voiptalk and that works.


    For what it's worth, I got a Gigaset in for evaluation and had it up and
    running with voip.co.uk within about 10 mins.

    Regrettably, I now have to go into 'useless mode' as I do not have the
    phone to hand to check its settings for you - but have some cheer that
    it *should* work!
     
    Linker3000, Mar 4, 2007
    #10
  11. Matt

    J Clavox Guest

    On Sun, 04 Mar 2007 16:04:49 +0000, Linker3000
    <> wrote:


    >For what it's worth, I got a Gigaset in for evaluation and had it up and
    >running with voip.co.uk within about 10 mins.


    For what it's worth my UTstarcom refused to connect with voip.co.uk
    when I first bought it but would connect with others I gave up in the
    end and just left it on the desk picked up again 30 minutes later and
    all was working. Chris at ukvoip told me the other day that sometimes
    their systems need a little time to think about things :)))) .
     
    J Clavox, Mar 4, 2007
    #11
  12. Matt

    Matt Guest

    > Chris at ukvoip told me the other day that sometimes
    > their systems need a little time to think about things :)))) .


    Is that voip.co.uk? If so, then it may be some consolation. I really feel
    that since the system is finding the server, it must be the other end that's
    causing the problem.
     
    Matt, Mar 4, 2007
    #12
  13. Matt

    Tim Guest

    Roger wrote:
    > I really struggled with a Netgear router and my sipuras with one way
    > voice and no connections and had to forward ports - something I never
    > have to worry about with the Linksys router. Have you tried configuring
    > STUN just to see if that helps the issue?



    You don't have to forward ports on voip.co.uk.

    Using stun with voip.co.uk is definitely going to cause you problems.

    Tim
     
    Tim, Mar 4, 2007
    #13
  14. Matt

    Tim Guest

    Matt wrote:
    > I don't think there is anything in the router's configuration about SIP. I
    > don't understand what ALG is.


    ALG - application layer gateway. Software in the the router that is
    meant to help SIP work through the NAT.

    In practice, most SIP ALG's are fundamentally broken and do more bad
    than good.

    Tim
     
    Tim, Mar 4, 2007
    #14
  15. Matt

    Matt Guest

    Just to let everyone know that this problem is now fixed, thanks to the
    people at voip.co.uk. The reason was because our local LAN uses IP
    addresses in the range 192.1.1.x and these aren't private addresses
    apparently.

    It's a historic thing and one that's difficult for me to change. So, I've
    set the phone to use a its default static address of 192.168.2.2 and
    adjusted to router to use 255.0.0.0 as the network mask, to allow it to
    route everthing on the network.

    Thanks for all your help - it's much appreciated.
     
    Matt, Mar 4, 2007
    #15
  16. Matt

    J Clavox Guest

    On Sun, 4 Mar 2007 16:37:17 -0000, "Matt"
    <> wrote:

    >> Chris at ukvoip told me the other day that sometimes
    >> their systems need a little time to think about things :)))) .

    >
    >Is that voip.co.uk? If so, then it may be some consolation. I really feel
    >that since the system is finding the server, it must be the other end that's
    >causing the problem.
    >

    Pleased you have now got it sorted Matt .
     
    J Clavox, Mar 4, 2007
    #16
  17. Matt

    Roger Guest

    "Tim" <> wrote in message
    news:45eb0b40$0$764$...
    > Roger wrote:
    >> I really struggled with a Netgear router and my sipuras with one way
    >> voice and no connections and had to forward ports - something I never
    >> have to worry about with the Linksys router. Have you tried configuring
    >> STUN just to see if that helps the issue?

    >
    >
    > You don't have to forward ports on voip.co.uk.
    >
    > Using stun with voip.co.uk is definitely going to cause you problems.
    >
    > Tim

    sorry but its been working fine here for over 6 moths with STUN
     
    Roger, Mar 5, 2007
    #17
  18. Matt

    Guest

    On Mon, 05 Mar 2007 08:19:50 GMT, "Roger" <>
    wrote:


    >sorry but its been working fine here for over 6 moths with STUN

    And it has been working fine here for over 12 months now without
    STUN .
     
    , Mar 5, 2007
    #18
  19. Matt

    Roger Guest

    <> wrote in message
    news:...
    > On Mon, 05 Mar 2007 08:19:50 GMT, "Roger" <>
    > wrote:
    >
    >
    >>sorry but its been working fine here for over 6 moths with STUN

    > And it has been working fine here for over 12 months now without
    > STUN .

    you've missed the point - the comment that was made was that STUN was sure
    to cause problems with voip.co.uk.
     
    Roger, Mar 5, 2007
    #19
  20. Matt

    Guest

    On Mon, 05 Mar 2007 15:25:47 GMT, "Roger" <>
    wrote:

    >
    ><> wrote in message
    >news:...
    >> On Mon, 05 Mar 2007 08:19:50 GMT, "Roger" <>
    >> wrote:
    >>
    >>
    >>>sorry but its been working fine here for over 6 moths with STUN

    >> And it has been working fine here for over 12 months now without
    >> STUN .

    >you've missed the point - the comment that was made was that STUN was sure
    >to cause problems with voip.co.uk.

    And I was told by voip.co.uk that using stun CAN cause problems with
    their service .
     
    , Mar 5, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Phil Rothwell

    Configuring VOIP through a VPN

    Phil Rothwell, Nov 16, 2004, in forum: Cisco
    Replies:
    2
    Views:
    685
    Phil Rothwell
    Nov 16, 2004
  2. sexton1

    Configuring fax Help Needed

    sexton1, Dec 30, 2003, in forum: Computer Support
    Replies:
    4
    Views:
    1,783
    ┬░Mike┬░
    Dec 31, 2003
  3. antgoodlife

    VOIP QOS Configuring w/Linksys

    antgoodlife, Mar 24, 2006, in forum: VOIP
    Replies:
    4
    Views:
    23,436
    Esteban Nunez
    Mar 25, 2006
  4. sparticle
    Replies:
    3
    Views:
    1,210
  5. balaluscia
    Replies:
    0
    Views:
    483
    balaluscia
    Jan 25, 2008
Loading...

Share This Page