Help! I screwed up my uBR924

Discussion in 'Cisco' started by TJ, Nov 8, 2003.

  1. TJ

    TJ Guest

    It seems I have gotten myself in a huge bind and need some trustworthy
    advice in terms even an idiot can understand. I bought my uBR
    modem/router on the "grey market" with the assurance it was plug n
    play out of the box. Boy was that wrong. I wanted the unit to function
    as a DOCSIS compliant modem compatible with my cable internet
    connection, which assigns my IP through dhcp. However, I also wanted
    it to function as a router to assign addresses to the PCs connected to
    my hub, and some internet security along the way.

    The unit came originally with ios 12.1 installed, and I read on the
    posts that 12.2 or later was preferred to do what I wanted to do. So I
    obtained a copy of the binery file ubr920-k8v6y5-mz.122-10b.bin, which
    I flashed using a tftp server and a Cisco console cable (light blue
    flat cable with a db9 on one end and rj45 on the other). However, like
    an idiot, I erased the other image and when it attempted to reload, it
    had an unexpected config error. Since then it reloads from a bootstrap
    version. I can no longer get an internet connection to my PC and I can
    no longer ping the router. I really need Help. My "show flash"
    indicates that the flash file was successfully loaded and still
    resides ther, but I can not figure out how to make it work. If you are
    willing to help, I would really appreciate it. --


    Here is some copies of my configs through hyperterminal:



    router(boot)>show flash

    System flash directory:

    File Length Name/status

    1 182091 ubr920-k8o3v6y5-mz.122-10b.bin

    [182156 bytes used, 3881076 available, 4063232 total]

    3968K bytes of processor board System flash (Read/Write)





    router(boot)>enable

    router(boot)#show startup-config

    Using 848 out of 131072 bytes

    !

    ! Last configuration change at 16:37:30 - Thu Nov 6 2003

    ! NVRAM config last updated at 16:37:49 - Thu Nov 6 2003

    !

    version 12.1

    service config

    no service pad

    service timestamps debug uptime

    service timestamps log uptime

    no service password-encryption

    !

    hostname router

    !

    !

    !

    !

    !

    !

    clock timezone - -6

    ip subnet-zero

    !

    !

    interface Ethernet0

    ip address 10.1.0.25 255.255.0.0

    no ip route-cache

    !

    interface cable-modem0

    ip address negotiated

    no ip route-cache

    cable-modem boot admin 2

    cable-modem boot oper 5

    cable-modem downstream saved channel 735000000 27 4

    cable-modem mac-timer t2 40000

    cable-modem dhcp-proxy interface Ethernet0

    !

    ip default-gateway 10.x.x.x

    no ip http server

    ip http cable-monitor advance 192.168.100.1 255.255.255.0

    ip classless

    !

    snmp-server manager

    !

    line con 0

    transport input none

    line vty 0 4

    login

    !

    end
     
    TJ, Nov 8, 2003
    #1
    1. Advertising

  2. Hi TJ,

    Robert here.

    A config error may have been due to a number of commands in the
    startup-config that are no longer valid under the new IOS. It could be more
    serious, but since the error wasn't mentioned, it's hard to say. I suspect
    that your modem is booting under config-register 0x2101 which would cause it
    to "(boot)" as your modem is doing.
    Do this to see if it helps:

    router(boot)>enable
    router(boot)#config term
    router(boot)(config)#conf 0x2102
    router(boot)(config)#exit
    router(boot)#reload

    Allow the unit to reload and see if it comes up under the new IOS.

    If it does, consider doing the following:

    By the looks of the config, it appears that an attempt was being made
    (perhads by the previous owner) to make this unit act as a router instead of
    the default DOCSIS cable modem (bridge mode). I would suggest losing this
    config as it won't be functional anyway under the newer IOS. It's usually
    best to make sure that the modem works in default DOCSIS bridging mode first
    anyway.

    To get back to a default config, go back into config mode

    router>config term
    router#write erase
    rouer#reload

    Let the modem reboot and see if your connectivity to the Internet is
    restored.

    To use the 924 in router mode, I think you'll need to get a different IOS
    image as 12.2(10b) has been reported to have serious problems with the
    'cable-modem dhcp-proxy'. 12.2.(7b) works as well as most other revisions.

    The following is a working config for routing, NAT and local DHCP services
    for your inside network:

    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname cable
    !
    logging buffered 20480 debugging
    !
    username xxxxx privilege 15 password 0 yyyyy
    clock timezone - -8
    ip subnet-zero
    ip tftp source-interface cable-modem0
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool inside
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    domain-name broadbandISP.com
    dns-server zzz.zzz.zzz.zzz yyy.yyy.yyy.yyy
    lease 30
    !
    ip audit notify log
    ip audit po max-events 100
    ip ssh time-out 120
    ip ssh authentication-retries 3
    call rsvp-sync
    !
    !
    !interface Loopback0********THIS INTERFACE WILL BE CREATED AUTOMATICALLY -
    no need to configure***********
    ! ip address xxx.xxx.xxx.xxx 255.255.255.255
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    no ip mroute-cache
    !
    interface cable-modem0
    ip nat outside
    no ip mroute-cache
    no cable-modem compliant bridge
    cable-modem dhcp-proxy nat testpool
    !
    !******THE FOLLOWING 2 LINES WILL BE CREATED AUTOMATICALLY - no need to
    configure********************
    !ip nat pool testpool xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx netmask 255.255.240.0
    !ip nat inside source list 99 pool testpool overload
    ip classless
    no ip pim bidir-enable
    no ip domain-lookup
    no ip http server
    no ip http cable-monitor
    !
    access-list 99 permit 192.168.1.0 0.0.0.255
    snmp-server packetsize 2053
    snmp-server manager
    !
    voice-port 0
    input gain -2
    output attenuation 0
    !
    voice-port 1
    input gain -2
    output attenuation 0
    !
    alias exec c config terminal
    alias exec s show run
    alias exec ib show ip interface brief
    alias exec ir show ip route
    alias exec sc show contr c0 mac state
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    exec-timeout 0 0
    logging synchronous
    login local
    !
    scheduler max-task-time 5000
    end


    "TJ" <> wrote in message
    news:...
    > It seems I have gotten myself in a huge bind and need some trustworthy
    > advice in terms even an idiot can understand. I bought my uBR
    > modem/router on the "grey market" with the assurance it was plug n
    > play out of the box. Boy was that wrong. I wanted the unit to function
    > as a DOCSIS compliant modem compatible with my cable internet
    > connection, which assigns my IP through dhcp. However, I also wanted
    > it to function as a router to assign addresses to the PCs connected to
    > my hub, and some internet security along the way.
    >
    > The unit came originally with ios 12.1 installed, and I read on the
    > posts that 12.2 or later was preferred to do what I wanted to do. So I
    > obtained a copy of the binery file ubr920-k8v6y5-mz.122-10b.bin, which
    > I flashed using a tftp server and a Cisco console cable (light blue
    > flat cable with a db9 on one end and rj45 on the other). However, like
    > an idiot, I erased the other image and when it attempted to reload, it
    > had an unexpected config error. Since then it reloads from a bootstrap
    > version. I can no longer get an internet connection to my PC and I can
    > no longer ping the router. I really need Help. My "show flash"
    > indicates that the flash file was successfully loaded and still
    > resides ther, but I can not figure out how to make it work. If you are
    > willing to help, I would really appreciate it. --
    >
    >
    > Here is some copies of my configs through hyperterminal:
    >
    >
    >
    > router(boot)>show flash
    >
    > System flash directory:
    >
    > File Length Name/status
    >
    > 1 182091 ubr920-k8o3v6y5-mz.122-10b.bin
    >
    > [182156 bytes used, 3881076 available, 4063232 total]
    >
    > 3968K bytes of processor board System flash (Read/Write)
    >
    >
    >
    >
    >
    > router(boot)>enable
    >
    > router(boot)#show startup-config
    >
    > Using 848 out of 131072 bytes
    >
    > !
    >
    > ! Last configuration change at 16:37:30 - Thu Nov 6 2003
    >
    > ! NVRAM config last updated at 16:37:49 - Thu Nov 6 2003
    >
    > !
    >
    > version 12.1
    >
    > service config
    >
    > no service pad
    >
    > service timestamps debug uptime
    >
    > service timestamps log uptime
    >
    > no service password-encryption
    >
    > !
    >
    > hostname router
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > !
    >
    > clock timezone - -6
    >
    > ip subnet-zero
    >
    > !
    >
    > !
    >
    > interface Ethernet0
    >
    > ip address 10.1.0.25 255.255.0.0
    >
    > no ip route-cache
    >
    > !
    >
    > interface cable-modem0
    >
    > ip address negotiated
    >
    > no ip route-cache
    >
    > cable-modem boot admin 2
    >
    > cable-modem boot oper 5
    >
    > cable-modem downstream saved channel 735000000 27 4
    >
    > cable-modem mac-timer t2 40000
    >
    > cable-modem dhcp-proxy interface Ethernet0
    >
    > !
    >
    > ip default-gateway 10.x.x.x
    >
    > no ip http server
    >
    > ip http cable-monitor advance 192.168.100.1 255.255.255.0
    >
    > ip classless
    >
    > !
    >
    > snmp-server manager
    >
    > !
    >
    > line con 0
    >
    > transport input none
    >
    > line vty 0 4
    >
    > login
    >
    > !
    >
    > end
     
    Bob by The Bay, Nov 9, 2003
    #2
    1. Advertising

  3. TJ

    TJ Guest

    Robert:
    I read one of your earlier posts to someone with similar (boot)
    problems so I exhausted your current suggestion earlier. It appears
    that I have dug myself in well above my axles and need a BIG towtruck.
    I believed I was purchasing this unit legitimately with at least some
    downloadable support, but I have learned that is not true. In my
    desparation and while waiting for anybody to post some advice here, I
    have been asking everybody I know if they can help me, and have
    reached the conclusion that the file I flashed with is likely corrupt
    and it has nuked the old ios, leaving me with only the bootstrap to
    work with. Cisco is no help to me, since I refuse to pay a year's
    salary just to be able to download a working ios one time. I will, at
    this point, be happy to put the thing back into bridging mode and run
    it just as a cable access, and use an inexpensive router on my end,
    ignoring all the incredible potential features of this unit. I have
    tried using sample simple bridging configs from the Cisco website, but
    some of the commands just refuse to work. I need some very simple
    "idiot-proof" advice on how to do this in the bootstrap, or I will
    have to dumpster it. If anybody knows the Router God, my hands are
    lifted up at this time.
     
    TJ, Nov 9, 2003
    #3
  4. Unfortunately the boot helper image alone doesn't provide enough
    functionality for the unit to operate as a DOCSIS cable modem. It does
    still allow an IP address to be assigned to the Ethernet interface and
    allows the "copy tftp flash" command to be used.

    Robert

    "TJ" <> wrote in message
    news:...
    > Robert:
    > I read one of your earlier posts to someone with similar (boot)
    > problems so I exhausted your current suggestion earlier. It appears
    > that I have dug myself in well above my axles and need a BIG towtruck.
    > I believed I was purchasing this unit legitimately with at least some
    > downloadable support, but I have learned that is not true. In my
    > desparation and while waiting for anybody to post some advice here, I
    > have been asking everybody I know if they can help me, and have
    > reached the conclusion that the file I flashed with is likely corrupt
    > and it has nuked the old ios, leaving me with only the bootstrap to
    > work with. Cisco is no help to me, since I refuse to pay a year's
    > salary just to be able to download a working ios one time. I will, at
    > this point, be happy to put the thing back into bridging mode and run
    > it just as a cable access, and use an inexpensive router on my end,
    > ignoring all the incredible potential features of this unit. I have
    > tried using sample simple bridging configs from the Cisco website, but
    > some of the commands just refuse to work. I need some very simple
    > "idiot-proof" advice on how to do this in the bootstrap, or I will
    > have to dumpster it. If anybody knows the Router God, my hands are
    > lifted up at this time.
     
    Bob by The Bay, Nov 10, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. troll

    UBR924

    troll, Oct 25, 2003, in forum: Cisco
    Replies:
    2
    Views:
    615
    troll
    Oct 27, 2003
  2. ctech

    UBR924

    ctech, Nov 19, 2003, in forum: Cisco
    Replies:
    5
    Views:
    874
    Bob by The Bay
    Nov 19, 2003
  3. Replies:
    4
    Views:
    610
    B.M. Wright
    Jul 22, 2005
  4. enlaces

    ubr924 - disregard cable

    enlaces, Jul 10, 2003, in forum: VOIP
    Replies:
    1
    Views:
    1,651
    Peter
    Jul 12, 2003
  5. Cisco uBR924

    , Mar 7, 2004, in forum: VOIP
    Replies:
    0
    Views:
    605
Loading...

Share This Page