GRE, importance of IP address for tunnel interface

Discussion in 'Cisco' started by Prasanna, Sep 1, 2006.

  1. Prasanna

    Prasanna Guest

    Hi All,

    Setup is as follows

    Net1 Router Our glob network Router Net2
    40.40.40.0/24 |Router1| 10.203.118.0/24 |Router2| 40.40.41.0/24

    I was trying to establish a tunnel between Net1 to Net2
    In Router2(Cisco) I need to give totally 3 addresses
    Tunnel src=10.203.118.181 Tunnel.dst=10.203.118.182 and
    tunnel.IP=40.40.41.12/24
    If I give the tunnel Ip mentioned it gives error saying it overlaps
    with the interface connected to Net2 network, obviously it overlaps,
    but how to get out of this error? what IP I need to configure? What
    sense it makes when we have already tunnel source and destination
    addresses(because GRE needs only those two addresses)?

    Earlier reply would really help.

    Thanks and Regards,
    Prasanna.
    Prasanna, Sep 1, 2006
    #1
    1. Advertising

  2. Prasanna

    Guest

    Prasanna wrote:
    > Hi All,
    >
    > Setup is as follows
    >
    > Net1 Router Our glob network Router Net2
    > 40.40.40.0/24 |Router1| 10.203.118.0/24 |Router2| 40.40.41.0/24
    >
    > I was trying to establish a tunnel between Net1 to Net2
    > In Router2(Cisco) I need to give totally 3 addresses
    > Tunnel src=10.203.118.181 Tunnel.dst=10.203.118.182 and
    > tunnel.IP=40.40.41.12/24
    > If I give the tunnel Ip mentioned it gives error saying it overlaps
    > with the interface connected to Net2 network, obviously it overlaps,
    > but how to get out of this error? what IP I need to configure? What
    > sense it makes when we have already tunnel source and destination
    > addresses(because GRE needs only those two addresses)?
    >
    > Earlier reply would really help.


    A tunnel /creates/ a new interface and it needs an address.
    You also need to specify the tunnel soure and destination
    addresses so that the tunnel (GRE) traffic can flow.

    You can typically use /any/ addresses for the tunnel
    interfaces themselves as long as there is no conflict
    with existing addresses in your net.


    Router1#
    interface Tunnel200
    ip address 192.168.3.133 255.255.255.252
    tunnel source FastEthernet0/0
    tunnel destination 7.24.241.226

    interface FastEthernet0/0
    description Internet Facing Link
    ip address 8.50.7.34 255.255.255.224


    Router2#
    interface Tunnel2
    ip address 192.168.3.134 255.255.255.252
    tunnel source BVI1
    tunnel destination 8.50.7.34

    interface BVI1
    description Internet Facing Link
    ip address 7.24.241.226 255.255.255.0


    I find this quite confusing, draw pictures.
    , Sep 1, 2006
    #2
    1. Advertising

  3. Prasanna

    Prasanna Guest

    Thanks Bod,

    I have found the answer in other way

    Router1(Proprietary):
    interface Tunnel1
    Source:10.203.118.181 destination: 10.203.118.182
    Route entry:
    40.40.41.0/24 tunnel1

    Interface1 ethernet
    ip address 40.40.40.1 255.255.255.0

    Interface2
    ip address 10.203.118.181 255.255.255.0

    Router2(cisco)#
    interface Tunnel1
    ip address 40.40.40.12 255.255.255.0
    tunnel source FastEthernet0/0
    tunnel destination 10.203.118.181

    interface FastEthernet0/0
    description Internet Facing Link
    ip address 10.203.118.182 255.255.255.0

    interface FastEthernet0/1
    ip address 40.40.41.1 255.255.255.0



    In Cisco whatever the address we configure that subnet packets are
    directed to that tunnel. Eg. If we configure tunnel ip address as
    40.40.40.13 255.255.255.0 then route entry 40.40.40.0 255.255.255.0
    tunnel1, will be created in the routing table dynamically.
    Thats why it was not allowing to assign IP address falling in any
    subnet of the existing interfaces.
    After configuring IP address which falls in destination network, it
    started working.

    Regards,
    Prasanna.
    Prasanna, Sep 4, 2006
    #3
  4. Prasanna

    slyubski

    Joined:
    Jan 31, 2009
    Messages:
    1
    Hi Prasanna.
    I am trying to understand how tunnel works.
    Let me ask few questions.

    1. Why in your successful setup you don't
    assign IP adress to tunnel interface?

    2. Route entry:
    40.40.41.0/24 tunnel

    Where this route entry came from.?
    When it showed up in the routing table for the first time?
    Could you please post what isexact format of your NEW routing
    tables entries on both routers.


    Thanks.
    slyubski, Jan 31, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Ireland
    Replies:
    1
    Views:
    1,042
    Claude LeFort
    Nov 11, 2003
  2. Replies:
    1
    Views:
    3,993
    Walter Roberson
    Dec 7, 2004
  3. Darren Green

    GRE - Tunnel Interface

    Darren Green, Mar 15, 2005, in forum: Cisco
    Replies:
    5
    Views:
    33,001
    prateek
    Oct 4, 2010
  4. Replies:
    6
    Views:
    29,178
  5. Giuen
    Replies:
    0
    Views:
    725
    Giuen
    Sep 12, 2008
Loading...

Share This Page