Getting WPA to work using Netgear WG511T adapter on Windows 98SE system

Discussion in 'Wireless Networking' started by Jim Bennett, Jan 23, 2005.

  1. Jim Bennett

    Jim Bennett Guest

    I am posting this here in the hopes that it helps someone who is trying to
    get WPA working on Windows 98SE if you have a Netgear WG511T. I tried for
    many hours to get this set up and finally found the answer in a post on
    alt.internet.wireless which was titled "HOWTO: enable WPA-PSK in Windows for
    SMC2802W V.2 PCI card" by Adriaan I tried Netgear technical support and to
    say the least, they either are clueless or don't want to deal with the
    problem. I may never buy Netgear again after this experience even though I
    have used their products for years.

    Supposedly the WG511T client software supports WPA using driver version 3.6
    and above but I found that this is not the case. During the install of the
    driver, you will get a GPF for Drinst.exe but you will still be able to
    complete the install and reboot. (NOTE: the failure of Drinst.exe is
    important! more on that below) Everything will go fine after the reboot and
    after inserting your WG511T it will be detected and you have to put the
    Windows 98SE disk in to install files. You will then pick the region you
    live in and you can configure the client for WEP and it works fine.

    WPA problems! When you try to enable WPA you will get this message after
    you click apply:

    " the supplicant support has not been installed correctly. you need to run
    setup again to fix this problem. if instead you need to continue, 802.1x and
    wpa will be disabled. (1) "

    Which means the Windows 98SE supplicant did not get installed correctly.
    Note: Windows 98SE apparently does not have kernal support for 802.1x and
    this is why the client software needs to install a supplicant for WPA.
    Reinstalling the software will just crash at the Drinst.exe everytime so
    that is no help. There is apparently a bug in the install program for the
    client and the Drinst.exe file is the part of the install that is supposed
    to install the Aegis protocol to allow for WPA.

    Since you cannot get the supplicant installed with the Netgear client you
    have to find an alternate way to get the protocol installed. There are two
    alternatives to purchase software that will enable WPA, Funk Software
    Odyssey client or Aegis but you have to pay! for those after you paid for a
    client that supposedly already supports it.

    That didn't sit well with me but thanks to Adriaans post I found that the
    Dlink WPA supplicant works with the Netgear card! So in the end I installed
    Dlinks Aegis protocol. Its located here:
    ftp://ftp.dlink.com/Wireless/dwlg520/Apps/dwlg520_WPAsupplicant_236.zip

    Unzip the D-Link ZIP file and run AegisI2.exe, once that is done you will
    see a confirmation message showing which files were installed that includes
    the Drinst that failed with Netgears software!! and then you need to reboot.
    Once you reboot you should then be able to set WPA up in the Netgear client
    and no more error messages! Obviously you know which vendor I will be
    using for my routers in the future and its not Netgear. In the end using
    Dlinks software to fix Netgears flawed install is very telling!

    I hope this helps someone else out there!

    Jim
     
    Jim Bennett, Jan 23, 2005
    #1
    1. Advertising

  2. Jim Bennett

    Malke Guest

    "Jim Bennett" <jim1192ATcomcastDOTnet> wrote:

    > I am posting this here in the hopes that it helps someone who is
    > trying to get WPA working on Windows 98SE if you have a Netgear
    > WG511T. I tried for many hours to get this set up and finally found
    > the answer in a post on alt.internet.wireless which was titled "HOWTO:
    > enable WPA-PSK in Windows for
    > SMC2802W V.2 PCI card" by Adriaan I tried Netgear technical support
    > and to
    > say the least, they either are clueless or don't want to deal with
    > the
    > problem. I may never buy Netgear again after this experience even
    > though I have used their products for years.
    >
    > Supposedly the WG511T client software supports WPA using driver
    > version 3.6
    > and above but I found that this is not the case. During the install
    > of the driver, you will get a GPF for Drinst.exe but you will still be
    > able to
    > complete the install and reboot. (NOTE: the failure of Drinst.exe is
    > important! more on that below) Everything will go fine after the
    > reboot and after inserting your WG511T it will be detected and you
    > have to put the
    > Windows 98SE disk in to install files. You will then pick the region
    > you live in and you can configure the client for WEP and it works
    > fine.
    >
    > WPA problems! When you try to enable WPA you will get this message
    > after you click apply:
    >
    > " the supplicant support has not been installed correctly. you need
    > to run
    > setup again to fix this problem. if instead you need to continue,
    > 802.1x and wpa will be disabled. (1) "
    >
    > Which means the Windows 98SE supplicant did not get installed
    > correctly. Note: Windows 98SE apparently does not have kernal support
    > for 802.1x and this is why the client software needs to install a
    > supplicant for WPA. Reinstalling the software will just crash at the
    > Drinst.exe everytime so that is no help. There is apparently a bug in
    > the install program for the client and the Drinst.exe file is the part
    > of the install that is supposed to install the Aegis protocol to allow
    > for WPA.
    >
    > Since you cannot get the supplicant installed with the Netgear client
    > you have to find an alternate way to get the protocol installed. There
    > are two alternatives to purchase software that will enable WPA, Funk
    > Software Odyssey client or Aegis but you have to pay! for those after
    > you paid for a client that supposedly already supports it.
    >
    > That didn't sit well with me but thanks to Adriaans post I found that
    > the
    > Dlink WPA supplicant works with the Netgear card! So in the end I
    > installed Dlinks Aegis protocol. Its located here:
    >

    ftp://ftp.dlink.com/Wireless/dwlg520/Apps/dwlg520_WPAsupplicant_236.zip
    >
    > Unzip the D-Link ZIP file and run AegisI2.exe, once that is done you
    > will see a confirmation message showing which files were installed
    > that includes the Drinst that failed with Netgears software!! and then
    > you need to reboot. Once you reboot you should then be able to set WPA
    > up in the Netgear client
    > and no more error messages! Obviously you know which vendor I will
    > be
    > using for my routers in the future and its not Netgear. In the end
    > using Dlinks software to fix Netgears flawed install is very telling!
    >
    > I hope this helps someone else out there!
    >
    > Jim


    Awesome post, Jim! I don't use this hardware, but I've saved the post
    for my clients who might. You are a prince to have taken the time to
    post this in order to help others.

    Kudos and cheers,

    Malke
    --
    MS MVP - Windows Shell/User
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
     
    Malke, Jan 23, 2005
    #2
    1. Advertising

  3. Re: Getting WPA to work using Netgear WG511T adapter on Windows 98

    Anyway, supporting win98 is no longer a top priority for most hardware
    vendors.
    And very few of them still provide drivers for NT4, DOS and so on.
    --PA

    "Malke" wrote:
    > "Jim Bennett" <jim1192ATcomcastDOTnet> wrote:
    >
    > > I am posting this here in the hopes that it helps someone who is
    > > trying to get WPA working on Windows 98SE if you have a Netgear
    > > WG511T. I tried for many hours to get this set up and finally found
    > > the answer in a post on alt.internet.wireless which was titled "HOWTO:
    > > enable WPA-PSK in Windows for
    > > SMC2802W V.2 PCI card" by Adriaan I tried Netgear technical support
    > > and to
    > > say the least, they either are clueless or don't want to deal with
    > > the
    > > problem. I may never buy Netgear again after this experience even
    > > though I have used their products for years.
    > >
    > > Supposedly the WG511T client software supports WPA using driver
    > > version 3.6
    > > and above but I found that this is not the case. During the install
    > > of the driver, you will get a GPF for Drinst.exe but you will still be
    > > able to
    > > complete the install and reboot. (NOTE: the failure of Drinst.exe is
    > > important! more on that below) Everything will go fine after the
    > > reboot and after inserting your WG511T it will be detected and you
    > > have to put the
    > > Windows 98SE disk in to install files. You will then pick the region
    > > you live in and you can configure the client for WEP and it works
    > > fine.
    > >
    > > WPA problems! When you try to enable WPA you will get this message
    > > after you click apply:
    > >
    > > " the supplicant support has not been installed correctly. you need
    > > to run
    > > setup again to fix this problem. if instead you need to continue,
    > > 802.1x and wpa will be disabled. (1) "
    > >
    > > Which means the Windows 98SE supplicant did not get installed
    > > correctly. Note: Windows 98SE apparently does not have kernal support
    > > for 802.1x and this is why the client software needs to install a
    > > supplicant for WPA. Reinstalling the software will just crash at the
    > > Drinst.exe everytime so that is no help. There is apparently a bug in
    > > the install program for the client and the Drinst.exe file is the part
    > > of the install that is supposed to install the Aegis protocol to allow
    > > for WPA.
    > >
    > > Since you cannot get the supplicant installed with the Netgear client
    > > you have to find an alternate way to get the protocol installed. There
    > > are two alternatives to purchase software that will enable WPA, Funk
    > > Software Odyssey client or Aegis but you have to pay! for those after
    > > you paid for a client that supposedly already supports it.
    > >
    > > That didn't sit well with me but thanks to Adriaans post I found that
    > > the
    > > Dlink WPA supplicant works with the Netgear card! So in the end I
    > > installed Dlinks Aegis protocol. Its located here:
    > >

    > ftp://ftp.dlink.com/Wireless/dwlg520/Apps/dwlg520_WPAsupplicant_236.zip
    > >
    > > Unzip the D-Link ZIP file and run AegisI2.exe, once that is done you
    > > will see a confirmation message showing which files were installed
    > > that includes the Drinst that failed with Netgears software!! and then
    > > you need to reboot. Once you reboot you should then be able to set WPA
    > > up in the Netgear client
    > > and no more error messages! Obviously you know which vendor I will
    > > be
    > > using for my routers in the future and its not Netgear. In the end
    > > using Dlinks software to fix Netgears flawed install is very telling!
    > >
    > > I hope this helps someone else out there!
    > >
    > > Jim

    >
    > Awesome post, Jim! I don't use this hardware, but I've saved the post
    > for my clients who might. You are a prince to have taken the time to
    > post this in order to help others.
    >
    > Kudos and cheers,
    >
    > Malke
    > --
    > MS MVP - Windows Shell/User
    > Elephant Boy Computers
    > www.elephantboycomputers.com
    > "Don't Panic!"
    >
     
    =?Utf-8?B?UGF2ZWwgQS4=?=, Jan 25, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter Geddes

    Netgear WG511T

    Peter Geddes, Aug 12, 2005, in forum: Wireless Networking
    Replies:
    5
    Views:
    5,438
    stokestack
    May 5, 2007
  2. M-80

    Problems with WG511T and WGT624 v3

    M-80, Sep 30, 2005, in forum: Wireless Networking
    Replies:
    13
    Views:
    7,316
  3. hax3
    Replies:
    10
    Views:
    4,866
  4. =?Utf-8?B?bXdhcmR0ZWw=?=

    BT Total and Netgear WG511T wireless card

    =?Utf-8?B?bXdhcmR0ZWw=?=, Aug 3, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    472
    =?Utf-8?B?bXdhcmR0ZWw=?=
    Aug 3, 2006
  5. ChrisPC

    Netgear FWG11vPv2, can't get WPA / WPA2 to work

    ChrisPC, Sep 22, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    562
    ChrisPC
    Sep 22, 2006
Loading...

Share This Page