FreePBX outbound routes

Discussion in 'UK VOIP' started by Jono, Jul 24, 2007.

  1. Jono

    Jono Guest

    I'm getting in a muddle!

    I have set up the following trunks:

    mobile - making use of an SPA3102 & a GSM gateway
    ZAP - 4 channels of BRI

    I can make/receive calls on any of the 5 lines.

    I am wanting to force the first 07 call over the mobile trunk. Any
    other simultaneous 07 calls should then go out via the ISDN.

    In addition, any calls that do not begin 07, should always go over the
    ISDN.

    I have two outbound routes as follows:

    Mobile with 907. being the Dial Pattern
    Trunk sequence being mobile then Zap

    In the mobile trunk, the dial rule is 9|. which strips the 9 and dials
    the rest of the mobile number over the GSM & it works fine.

    ISND2e with 9|. being the Dial Pattern
    Trunk sequence being just Zap

    In the ZAP trunk, the dial rules are . and 9|.

    So, any calls starting 07 go out correctly on the GSM gateway. Any
    other calls go out correctly on the ISDN........BUT.......if a second
    simultaneous call to a mobile is made, I get engaged.

    It seems, even though I have set the maximum channels to 1 in the
    mobile trunk, FreePBX trys sending the 2nd 07 number over (the already)
    in use trunk. Either that, or I've got the outbound routes' Dial
    Patterns &/or trunk Dial Rules wrong....

    Unfortunately, I don't have access to the CLI, & I'm remote from the
    machine & just have web access to FreePBX...

    Anyone able to shed any light on my predicament?
    Jono, Jul 24, 2007
    #1
    1. Advertising

  2. Jono

    Linker3000 Guest

    Jono wrote:
    > I'm getting in a muddle!
    >
    > I have set up the following trunks:
    >
    > mobile - making use of an SPA3102 & a GSM gateway
    > ZAP - 4 channels of BRI
    >
    > I can make/receive calls on any of the 5 lines.
    >
    > I am wanting to force the first 07 call over the mobile trunk. Any other
    > simultaneous 07 calls should then go out via the ISDN.
    >
    > In addition, any calls that do not begin 07, should always go over the
    > ISDN.
    >
    > I have two outbound routes as follows:
    >
    > Mobile with 907. being the Dial Pattern
    > Trunk sequence being mobile then Zap
    >
    > In the mobile trunk, the dial rule is 9|. which strips the 9 and dials
    > the rest of the mobile number over the GSM & it works fine.
    >
    > ISND2e with 9|. being the Dial Pattern
    > Trunk sequence being just Zap
    >
    > In the ZAP trunk, the dial rules are . and 9|.
    >
    > So, any calls starting 07 go out correctly on the GSM gateway. Any other
    > calls go out correctly on the ISDN........BUT.......if a second
    > simultaneous call to a mobile is made, I get engaged.
    >
    > It seems, even though I have set the maximum channels to 1 in the mobile
    > trunk, FreePBX trys sending the 2nd 07 number over (the already) in use
    > trunk. Either that, or I've got the outbound routes' Dial Patterns &/or
    > trunk Dial Rules wrong....
    >
    > Unfortunately, I don't have access to the CLI, & I'm remote from the
    > machine & just have web access to FreePBX...
    >
    > Anyone able to shed any light on my predicament?
    >
    >

    Can you not have a look at the 'last 2000 lines' of the log to see
    what's happening?

    Not a CODEC issue is it? <--- Wild guess!
    Linker3000, Jul 25, 2007
    #2
    1. Advertising

  3. On Tue, 24 Jul 2007 22:57:06 +0100, Jono <>
    wrote:

    >I'm getting in a muddle!


    I've only been playing for a few weeks, so am no expert.

    But in your Outoing Zap trunk do you have the Group or just a Channel
    set in Zap Identifier (trunk name)

    "ZAP channels are referenced either by a group number or channel
    number (which is defined in zapata.conf).

    The default setting is g0 (group zero)."
    --
    Locate your Mobile phone: <http://www.bizorg.co.uk/news.html>
    Great gifts: <http://www.ThisBritain.com/ASOS_popup.html>
    David Quinton, Jul 25, 2007
    #3
  4. Jono

    Paul Hayes Guest

    Jono wrote:
    [snip]
    >
    > Anyone able to shed any light on my predicament?
    >
    >


    You dial rules need to be more specific. I have a feeling that your
    dial rule of . followed by 9|. in the ZAP trunk is trying to dial (for
    example) 907454555667 because you strip the 9 off the number in the ISDN
    Outbound route but not the mobile route.

    The usual way I'd set this is:

    Mobile Outbound Route:

    - Dialling rules: 07xxxx. and 9|07xxxx.
    - trunk seq: mobile followed by ISDN

    Mobile Trunk (to GSM gateway):

    - dial rule: 07xxxx.
    - max channels: 1

    Other numbers Outbound Route:

    - Dialling rules: 0zxxxxxx. and 9|0zxxxxxx.
    - trunk seq: ISDN

    ISDN trunk:

    - dial rule: 0zxxxxxx.
    - max channels 8 (assuming all 4 BRI lines are active).

    Which will cover dialling mobile and other 11 digit UK numbers.

    cheers,
    Paul.

    --
    Working Email:

    paul-at-polog40-dot-co-dot-uk
    Paul Hayes, Jul 25, 2007
    #4
  5. Jono

    Jono Guest

    Paul Hayes pretended :
    > Jono wrote:
    > [snip]
    >>
    >> Anyone able to shed any light on my predicament?
    >>
    >>

    >
    > You dial rules need to be more specific. I have a feeling that your dial
    > rule of . followed by 9|. in the ZAP trunk is trying to dial (for example)
    > 907454555667 because you strip the 9 off the number in the ISDN Outbound
    > route but not the mobile route.
    >
    > The usual way I'd set this is:
    >
    > Mobile Outbound Route:
    >
    > - Dialling rules: 07xxxx. and 9|07xxxx.
    > - trunk seq: mobile followed by ISDN
    >
    > Mobile Trunk (to GSM gateway):
    >
    > - dial rule: 07xxxx.
    > - max channels: 1
    >
    > Other numbers Outbound Route:
    >
    > - Dialling rules: 0zxxxxxx. and 9|0zxxxxxx.
    > - trunk seq: ISDN
    >
    > ISDN trunk:
    >
    > - dial rule: 0zxxxxxx.
    > - max channels 8 (assuming all 4 BRI lines are active).
    >
    > Which will cover dialling mobile and other 11 digit UK numbers.


    Thanks Paul (& David & Linker3000)

    You are quite right.

    What was wrong, after all, was my tired eyes. Something I thought I'd
    entered (a 9|.) hadn't saved, or I'd forgotten to click the red bar.

    PBKC, when all's said & done.
    Jono, Jul 25, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. linker3000
    Replies:
    1
    Views:
    760
    paul123
    Jul 25, 2006
  2. Brian A
    Replies:
    3
    Views:
    2,035
    Desk Rabbit
    Feb 2, 2007
  3. Brian A

    Settings for Freepbx / Trixbox ??

    Brian A, Feb 2, 2007, in forum: UK VOIP
    Replies:
    5
    Views:
    6,040
    Brian A
    Feb 3, 2007
  4. Replies:
    8
    Views:
    1,302
  5. Dave
    Replies:
    25
    Views:
    864
Loading...

Share This Page