Fixed: The machine-default permission settings do not grant Local Activation permission for the COM

Discussion in 'Windows 64bit' started by Skybuck Flying, May 27, 2007.

  1. Hello,

    Since I was busy fixing as many event log problems, I also decided to fix
    this problem finally:

    Been seeing this problem since I got the new computer.

    Here is my short description followed by microsoft's long description:

    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10016
    Date: 27-5-2007
    Time: 5:56:24
    User: NT AUTHORITY\LOCAL SERVICE
    Computer: CP1098857-A
    Description:
    The machine-default permission settings do not grant Local Activation
    permission for the COM Server application with CLSID
    {555F3418-D99E-4E51-800A-6E89CFD8B1D7}
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19). This security
    permission can be modified using the Component Services administrative tool.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.

    Went into registry at:

    HKEY_CLASSES_ROOT\CLSID\{555F3418-D99E-4E51-800A-6E89CFD8B1D7}

    Copied the key:

    AppId:

    {B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}

    To clipboard and pasted it into text editor so I can "savely view it".

    Started:

    Start->Run->dcomcnfg


    ComponentServices->DCOM Config

    Properties->Changed view to details.

    Found match for:

    {B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}

    Properties->Security->Launch and Activation Permissions->Custom->Add local
    activation for local service account.

    (looked into event viewer to see which account did not have the right
    persmissions, account: local_service


    Detailed instructions at:

    http://www.planetamd64.com/lofiversion/index.php/t16537.html

    copy of:

    http://support.microsoft.com/kb/899965

    Copy&paste:

    "
    Quick Links | Home | Worldwide


    Search Microsoft.com for:



    Help and Support Home | Select a Product | Search Knowledge Base

    Event 10016 may be logged in the System log on a computer that is running
    Windows XP Professional x64 Edition
    View products that this article applies to.
    Article ID : 899965
    Last Review : December 28, 2006
    Revision : 1.2
    Important This article contains information about how to modify the
    registry. Make sure to back up the registry before you modify it. Make sure
    that you know how to restore the registry if a problem occurs. For more
    information about how to back up, restore, and modify the registry, click
    the following article number to view the article in the Microsoft Knowledge
    Base:
    256986 (http://support.microsoft.com/kb/256986/) Description of the
    Microsoft Windows registry
    On This Page

    SYMPTOMS

    CAUSE

    RESOLUTION

    Grant the user permissions to start the COM component

    Grant the correct permissions to the Network Service account

    STATUS

    MORE INFORMATION
    SYMPTOMS
    On a computer that is running Microsoft Windows XP Professional x64 Edition,
    events that are similar to the following may be logged in the System log:
    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10016
    Date: Date
    Time: Time
    User: NT AUTHORITY\LOCAL SERVICE

    Description: The application-specific permission settings do not grant Local
    Launch permission for the COM Server application with CLSID {AppGUID} to the
    user User_Name SID User_SID. This security permission can be modified using
    the Component Services administrative tool.

    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10016
    Date: Date
    Time: Time
    User: Network services

    Description: The application-specific permission settings do not grant Local
    Launch permission for the COM Server application with CLSID {AppGUID} to the
    user User_Name SID User_SID. This security permission can be modified using
    the Component Services administrative tool.

    Back to the top

    CAUSE
    This problem may occur if either of the following conditions is true: . A
    program with the class ID (CLSID) that appears in the message tries to start
    the COM component by using the DCOM infrastructure. However, the user does
    not have the required permissions to start the COM component.
    .. The Network Service account does not have the correct permissions.

    Back to the top

    RESOLUTION
    Warning Serious problems might occur if you modify the registry incorrectly
    by using Registry Editor or by using another method. These problems might
    require that you reinstall your operating system. Microsoft cannot guarantee
    that these problems can be solved. Modify the registry at your own risk.

    To resolve this problem, use one of the following methods, depending on the
    cause of the problem.
    Back to the top

    Grant the user permissions to start the COM component
    Grant the user permissions to start the COM component. To do this, follow
    these steps: 1. Click Start, click Run, type regedit in the Open box, and
    then click OK.
    2. Locate and then click the following registry subkey:
    HKEY_CLASSES_ROOT\CLSID\CLSID value
    Note In this subkey, "CLSID value" is a placeholder for the CLSID
    information that appears in the message.
    3. In the right pane, double-click AppID.

    The Edit String dialog box appears. Leave this dialog box open and continue
    to the next step.
    4. Click Start, click Run, type dcomcnfg in the Open box, and then click OK.

    If a Windows Security Alert message prompts you to keep blocking the
    Microsoft Management Console program, click to unblock the program.
    5. In Component Services, double-click Component Services, double-click
    Computers, double-click My Computer, and then click DCOM Config.
    6. In the details pane, locate the program by using the friendly name.

    If the AppGUID identifier is listed instead of the friendly name, locate the
    program by using this identifier.
    7. Right-click the program, and then click Properties.
    8. Click the Security tab.
    9. In the Launch and Activation Permissions area, click Customize, and then
    click Edit.
    10. Click Add, type the user's account name, and then click OK.
    11. While the user is selected, click to select the Allow check boxes for
    the following items: . Local Launch
    .. Remote Launch
    .. Local Activation
    .. Remote Activation

    12. Click OK two times.
    13. Quit Registry Editor.

    Back to the top

    Grant the correct permissions to the Network Service account
    To grant the correct permissions to the Network Service account, follow
    these steps: 1. Click Start, click Run, type dcomcnfg in the Open box, and
    then click OK.
    2. In Component Services, double-click Component Services, and then
    double-click Computers.
    3. Right-click My Computer, and then click Properties.
    4. Click the COM Security tab.
    5. In the Launch and Activation Permissions area, click Edit Default.
    6. Click Add, type Network Service, and then click OK.
    7. While Network Service is selected, click to select the Allow check boxes
    for the following items: . Local Launch
    .. Remote Launch
    .. Local Activation
    .. Remote Activation
    Click OK two times.

    Back to the top

    STATUS
    Microsoft has confirmed that this is a problem in the Microsoft products
    that are listed in the "Applies to" section.
    Back to the top

    MORE INFORMATION
    For more information about the x64-based versions of Windows Server 2003 and
    about Windows XP Professional x64 Edition, click the following article
    number to view the article in the Microsoft Knowledge Base:
    888733 (http://support.microsoft.com/kb/888733/) A description of the
    x64-based versions of Windows Server 2003 and of Windows XP Professional x64
    Edition
    Back to the top


    --------------------------------------------------------------------------------

    APPLIES TO
    .. Microsoft Windows XP Professional x64 Edition

    Back to the top

    Keywords: kbtshoot KB899965

    "

    Thanks, error message now gone from log after reboot ;)

    Bye,
    Skybuck.
    Skybuck Flying, May 27, 2007
    #1
    1. Advertising

  2. Skybuck Flying

    itexperience Guest

    Re: Fixed: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    Thank you for posting your problem and solution. Excellent post. In
    combination with the following site I made it to solve this problem too
    :) 'The application-specific permission settings do not grant Local
    Launch permission for the COM Server application'
    (http://www.itexperience.net/2008/03...ch-permission-for-the-com-server-application/)


    --
    itexperience
    ------------------------------------------------------------------------
    itexperience's Profile: http://forums.techarena.in/members/67359.htm
    View this thread: http://forums.techarena.in/windows-x64-edition/754746.htm

    http://forums.techarena.in
    itexperience, Jun 29, 2009
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. mentalguy2004

    update on my local settings folder permission block

    mentalguy2004, Sep 10, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    545
    mentalguy2004
    Sep 10, 2004
  2. Pentax Fan

    A grant, a grant, my Pentax for a grant.....

    Pentax Fan, Apr 8, 2006, in forum: Digital Photography
    Replies:
    17
    Views:
    557
    JTS Brown
    Apr 11, 2006
  3. Spin
    Replies:
    0
    Views:
    640
  4. Spin
    Replies:
    5
    Views:
    1,076
  5. Giuen
    Replies:
    0
    Views:
    744
    Giuen
    Sep 12, 2008
Loading...

Share This Page