First try at IOS programing

Discussion in 'Cisco' started by mmm00k@yahoo.com, Nov 18, 2003.

  1. Guest

    Below is my first go at configuring a cisco 1601r router. I'm trying
    to use Serial0 to connect to my ISP and eth0 to connect to my lan. Any
    pointers or corrections are appreciated. I attached the router to the
    network and I immediately started receiving duplicate address messages
    on the router and on on at least a couple of the PC's that I tried to
    set up to use NAT. For example 192.168.1.5. Is this because our
    production router is still online and providing NAT to 192.168.1.5 ?



    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname mycompany
    !
    enable secret 5 *****************
    enable password *************
    !
    username myname password
    ip subnet-zero
    no ip source-route
    no ip finger
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.2 255.255.255.0
    no ip directed-broadcast
    no ip proxy-arp
    ip nat inside
    no cdp enable
    !
    interface Serial0
    ip address 10.10.10.1 255.255.255.248
    encapsulation frame-relay ietf
    frame-relay interface-dlci 16
    frame-relay lmi-type ansi
    ip access-group 102 in
    no ip directed-broadcast
    no ip proxy-arp
    ip nat outside
    encapsulation lapb multi
    no ip route-cache
    shutdown
    no fair-queue
    !

    ip nat pool mycompany 10.10.10.1 10.10.10.1 netmask 255.255.255.248
    ip nat inside source list 100 pool mycompany overload

    ip nat inside source static 10.10.10.5 192.168.1.5 extendable
    ip nat inside source static 10.10.10.6 192.168.1.6 extendable
    ip nat inside source static 10.10.10.7 192.168.1.7 extendable
    ip nat inside source static 10.10.10.8 192.168.1.8 extendable
    ip nat inside source static 10.10.10.9 192.168.1.9 extendable
    ip nat inside source static 10.10.10.10 192.168.1.10 extendable
    ip classless
    no ip forward-protocol udp bootpc
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip route 192.168.3.0 255.255.255.0 192.168.1.17
    ip route 192.168.5.0 255.255.255.0 192.168.1.17
    !
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any

    no cdp run
    snmp-server community public RO
    !
    line con 0
    exec-timeout 120 0
    transport input none
    line vty 0 4
    exec-timeout 0 0
    password **************
    login
    !
    end
    , Nov 18, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Truty
    Replies:
    2
    Views:
    933
  2. =?Utf-8?B?TVNfbmV3Ymll?=

    Would like to learn MS programing for embeded applications

    =?Utf-8?B?TVNfbmV3Ymll?=, Apr 27, 2006, in forum: Microsoft Certification
    Replies:
    1
    Views:
    551
    Gorm Braarvig
    Apr 27, 2006
  3. Bill Schowengerdt

    Logitech "iTouch) key programing paste text?

    Bill Schowengerdt, Jan 13, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    517
    Bill Schowengerdt
    Jan 13, 2004
  4. Try, Try, Try, again...

    , Jan 29, 2005, in forum: Computer Support
    Replies:
    3
    Views:
    625
  5. Collector»NZ
    Replies:
    14
    Views:
    522
    Gavin Tunney
    Dec 5, 2004
Loading...

Share This Page