Firefox tries to 'play' RPM files.

Discussion in 'Firefox' started by Andy J., Sep 17, 2005.

  1. Andy J.

    Andy J. Guest

    When I use Firefox to access ftp archives and click on a .RPM file,
    rather than opening a 'save' dialog Firefox switches to a media
    player. I've had a look around in the preferences but can't find
    anything about file extensions. How do I stop it trying to play a .RPM
    and just let me save it?

    Andy J.
     
    Andy J., Sep 17, 2005
    #1
    1. Advertising

  2. Andy J.

    Jedi Fans Guest

    Andy J. wrote:
    > When I use Firefox to access ftp archives and click on a .RPM file,
    > rather than opening a 'save' dialog Firefox switches to a media
    > player. I've had a look around in the preferences but can't find
    > anything about file extensions. How do I stop it trying to play a .RPM
    > and just let me save it?
    >
    > Andy J.

    uninstall realplayer... or right click on the link and "save as..."
    If you have mozplugger IIRC you can configure it for different filetypes ;)

    --
    Hope This Helped and MTFBWY...
    Kieren aka JediFans - <URL:http://jedifans.com/>
    The Force Is With Me, SuSE Linux Professional 9.3, Mozilla Firefox
    1.0.6, Mozilla Thunderbird 1.5 Alpha 2 and Revenge Of The Sith!
     
    Jedi Fans, Sep 17, 2005
    #2
    1. Advertising

  3. Andy J.

    Doug G Guest

    Andy J. wrote:
    > When I use Firefox to access ftp archives and click on a .RPM file,
    > rather than opening a 'save' dialog Firefox switches to a media
    > player. I've had a look around in the preferences but can't find
    > anything about file extensions. How do I stop it trying to play a .RPM
    > and just let me save it?
    >
    > Andy J.


    Look in Tools > Options > Downloads > File Types.

    Click "Save Link As" on the link's context (right click) menu.
     
    Doug G, Sep 17, 2005
    #3
  4. Andy J.

    Andy J. Guest

    Doug G wrote:
    > Andy J. wrote:
    >
    >> When I use Firefox to access ftp archives and click on a .RPM file,
    >> rather than opening a 'save' dialog Firefox switches to a media
    >> player. I've had a look around in the preferences but can't find
    >> anything about file extensions. How do I stop it trying to play a
    >> .RPM and just let me save it?
    >>
    >> Andy J.

    >
    >
    > Look in Tools > Options > Downloads > File Types.
    >
    > Click "Save Link As" on the link's context (right click) menu.


    Not quite, but you've sent me the right direction and it's now working.
    Edit -> Preferences -> Downloads and there's a File Types section with a
    'Plug-Ins' button. I found one plug-in associated to RPMs, no idea how
    it got there but I disabled it and can now save RPMs, cheers all.

    Andy J.
     
    Andy J., Sep 18, 2005
    #4
  5. Andy J.

    GWTC Guest

    Andy J. wrote:

    > Doug G wrote:
    >
    >> Andy J. wrote:
    >>
    >>> When I use Firefox to access ftp archives and click on a .RPM file,
    >>> rather than opening a 'save' dialog Firefox switches to a media
    >>> player. I've had a look around in the preferences but can't find
    >>> anything about file extensions. How do I stop it trying to play a
    >>> .RPM and just let me save it?
    >>>
    >>> Andy J.

    >>
    >>
    >>
    >> Look in Tools > Options > Downloads > File Types.
    >>
    >> Click "Save Link As" on the link's context (right click) menu.

    >
    >
    > Not quite, but you've sent me the right direction and it's now working.
    > Edit -> Preferences -> Downloads and there's a File Types section with a
    > 'Plug-Ins' button. I found one plug-in associated to RPMs, no idea how
    > it got there but I disabled it and can now save RPMs, cheers all.
    >
    > Andy J.

    Maybe I missed something, but Edit, Preferences is a Mozilla the Suite
    option, and you were asking about Firefox.
     
    GWTC, Sep 18, 2005
    #5
  6. GWTC wrote:
    > Andy J. wrote:
    >
    >> Doug G wrote:
    >>
    >>> Andy J. wrote:
    >>>
    >>>> When I use Firefox to access ftp archives and click on a .RPM file,
    >>>> rather than opening a 'save' dialog Firefox switches to a media
    >>>> player. I've had a look around in the preferences but can't find
    >>>> anything about file extensions. How do I stop it trying to play a
    >>>> .RPM and just let me save it?
    >>>>
    >>>> Andy J.
    >>>
    >>>
    >>>
    >>> Look in Tools > Options > Downloads > File Types.
    >>>
    >>> Click "Save Link As" on the link's context (right click) menu.

    >>
    >>
    >> Not quite, but you've sent me the right direction and it's now
    >> working. Edit -> Preferences -> Downloads and there's a File Types
    >> section with a 'Plug-Ins' button. I found one plug-in associated to
    >> RPMs, no idea how it got there but I disabled it and can now save
    >> RPMs, cheers all.
    >>
    >> Andy J.

    > Maybe I missed something, but Edit, Preferences is a Mozilla the Suite
    > option, and you were asking about Firefox.


    On Windows, yes. On Linux versions, the options for both Firefox and
    Thunderbird are in Edit>>Preferences.

    Lee
     
    Leonidas Jones, Sep 18, 2005
    #6
  7. Andy J.

    Andy J. Guest

    Leonidas Jones wrote:
    > GWTC wrote:
    >
    >> Andy J. wrote:
    >>
    >>> Doug G wrote:
    >>>
    >>>> Andy J. wrote:
    >>>>
    >>>>> When I use Firefox to access ftp archives and click on a .RPM file,
    >>>>> rather than opening a 'save' dialog Firefox switches to a media
    >>>>> player. I've had a look around in the preferences but can't find
    >>>>> anything about file extensions. How do I stop it trying to play a
    >>>>> .RPM and just let me save it?
    >>>>>
    >>>>> Andy J.
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> Look in Tools > Options > Downloads > File Types.
    >>>>
    >>>> Click "Save Link As" on the link's context (right click) menu.
    >>>
    >>>
    >>>
    >>> Not quite, but you've sent me the right direction and it's now
    >>> working. Edit -> Preferences -> Downloads and there's a File Types
    >>> section with a 'Plug-Ins' button. I found one plug-in associated to
    >>> RPMs, no idea how it got there but I disabled it and can now save
    >>> RPMs, cheers all.
    >>>
    >>> Andy J.

    >>
    >> Maybe I missed something, but Edit, Preferences is a Mozilla the Suite
    >> option, and you were asking about Firefox.

    >
    >
    > On Windows, yes. On Linux versions, the options for both Firefox and
    > Thunderbird are in Edit>>Preferences.
    >
    > Lee


    And I am indeed using Linux. Sorry, but I didn't explain that as I
    assumed people would realise that I was working with RPM files
    (something I believe doesn't exist in Windows). I forgot Firefox was
    also available in Windows, but I'd have thought the menus were the same,
    sorry.

    Andy J.
     
    Andy J., Sep 18, 2005
    #7
  8. Andy J.

    Moz Champion Guest

    Andy J. wrote:
    > Leonidas Jones wrote:
    >
    >> GWTC wrote:
    >>
    >>> Andy J. wrote:
    >>>
    >>>> Doug G wrote:
    >>>>
    >>>>> Andy J. wrote:
    >>>>>
    >>>>>> When I use Firefox to access ftp archives and click on a .RPM file,
    >>>>>> rather than opening a 'save' dialog Firefox switches to a media
    >>>>>> player. I've had a look around in the preferences but can't find
    >>>>>> anything about file extensions. How do I stop it trying to play a
    >>>>>> .RPM and just let me save it?
    >>>>>>
    >>>>>> Andy J.
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>> Look in Tools > Options > Downloads > File Types.
    >>>>>
    >>>>> Click "Save Link As" on the link's context (right click) menu.
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> Not quite, but you've sent me the right direction and it's now
    >>>> working. Edit -> Preferences -> Downloads and there's a File Types
    >>>> section with a 'Plug-Ins' button. I found one plug-in associated to
    >>>> RPMs, no idea how it got there but I disabled it and can now save
    >>>> RPMs, cheers all.
    >>>>
    >>>> Andy J.
    >>>
    >>>
    >>> Maybe I missed something, but Edit, Preferences is a Mozilla the
    >>> Suite option, and you were asking about Firefox.

    >>
    >>
    >>
    >> On Windows, yes. On Linux versions, the options for both Firefox and
    >> Thunderbird are in Edit>>Preferences.
    >>
    >> Lee

    >
    >
    > And I am indeed using Linux. Sorry, but I didn't explain that as I
    > assumed people would realise that I was working with RPM files
    > (something I believe doesn't exist in Windows). I forgot Firefox was
    > also available in Windows, but I'd have thought the menus were the same,
    > sorry.
    >
    > Andy J.


    The menu options are assigned due to conventions adopted by the various
    OS makers (or controllers)

    In Windows, MS like prefereance to be in the Tools menu (tho it often
    breaks its own guidelines anyway)
    On Apple, they belong in the <application name> menu
    In Linux, GNU (or someone like that) says they should be in the Edit menu

    I.e.
    Firefox-->Preferences-->General on the mac is the same as
    Tools-->Options-->General on windows and
    Edit-->Preferences-->General on Linux
     
    Moz Champion, Sep 19, 2005
    #8
  9. Andy J. wrote:
    > Leonidas Jones wrote:
    >> GWTC wrote:
    >>
    >>> Andy J. wrote:
    >>>
    >>>> Doug G wrote:
    >>>>
    >>>>> Andy J. wrote:
    >>>>>
    >>>>>> When I use Firefox to access ftp archives and click on a .RPM file,
    >>>>>> rather than opening a 'save' dialog Firefox switches to a media
    >>>>>> player. I've had a look around in the preferences but can't find
    >>>>>> anything about file extensions. How do I stop it trying to play a
    >>>>>> .RPM and just let me save it?
    >>>>>>
    >>>>>> Andy J.
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>> Look in Tools > Options > Downloads > File Types.
    >>>>>
    >>>>> Click "Save Link As" on the link's context (right click) menu.
    >>>>
    >>>>
    >>>>
    >>>> Not quite, but you've sent me the right direction and it's now
    >>>> working. Edit -> Preferences -> Downloads and there's a File Types
    >>>> section with a 'Plug-Ins' button. I found one plug-in associated to
    >>>> RPMs, no idea how it got there but I disabled it and can now save
    >>>> RPMs, cheers all.
    >>>>
    >>>> Andy J.
    >>>
    >>> Maybe I missed something, but Edit, Preferences is a Mozilla the
    >>> Suite option, and you were asking about Firefox.

    >>
    >>
    >> On Windows, yes. On Linux versions, the options for both Firefox and
    >> Thunderbird are in Edit>>Preferences.
    >>
    >> Lee

    >
    > And I am indeed using Linux. Sorry, but I didn't explain that as I
    > assumed people would realise that I was working with RPM files
    > (something I believe doesn't exist in Windows). I forgot Firefox was
    > also available in Windows, but I'd have thought the menus were the same,
    > sorry.
    >
    > Andy J.


    For the record, on Mac OSX, the prefs are in
    Firefox(Thunderbird)>>Preferences.

    Three OS's, three locations.

    Lee
     
    Leonidas Jones, Sep 19, 2005
    #9
  10. On 2005-09-18, Andy J. <> wrote:

    > And I am indeed using Linux. Sorry, but I didn't explain that as I
    > assumed people would realise that I was working with RPM files
    > (something I believe doesn't exist in Windows).


    RealPlayer uses the .rpm extension for certain Real Player Media files;
    that's why it tries to open them when you download a file with an RPM
    extension.

    --

    John ()
     
    John Thompson, Sep 21, 2005
    #10
  11. On 2005-09-18, GWTC <> wrote:

    > Andy J. wrote:
    >
    >> Not quite, but you've sent me the right direction and it's now working.
    >> Edit -> Preferences -> Downloads and there's a File Types section with a
    >> 'Plug-Ins' button. I found one plug-in associated to RPMs, no idea how
    >> it got there but I disabled it and can now save RPMs, cheers all.


    > Maybe I missed something, but Edit, Preferences is a Mozilla the Suite
    > option, and you were asking about Firefox.


    It's also in Firefox-X11 (linux,*BSD, etc.)

    --

    John ()
     
    John Thompson, Sep 21, 2005
    #11
  12. John Thompson wrote:
    > On 2005-09-18, Andy J. <> wrote:
    >
    >> And I am indeed using Linux. Sorry, but I didn't explain that as I
    >> assumed people would realise that I was working with RPM files
    >> (something I believe doesn't exist in Windows).

    >
    > RealPlayer uses the .rpm extension for certain Real Player Media files;
    > that's why it tries to open them when you download a file with an RPM
    > extension.
    >


    Should it be doing that on a Linux install though?

    Le
     
    Leonidas Jones, Sep 21, 2005
    #12
  13. Andy J.

    gwtc Guest

    John Thompson wrote:

    > On 2005-09-18, GWTC <> wrote:
    >
    >
    >>Andy J. wrote:
    >>
    >>
    >>>Not quite, but you've sent me the right direction and it's now working.
    >>>Edit -> Preferences -> Downloads and there's a File Types section with a
    >>>'Plug-Ins' button. I found one plug-in associated to RPMs, no idea how
    >>>it got there but I disabled it and can now save RPMs, cheers all.

    >
    >
    >>Maybe I missed something, but Edit, Preferences is a Mozilla the Suite
    >>option, and you were asking about Firefox.

    >
    >
    > It's also in Firefox-X11 (linux,*BSD, etc.)
    >

    Sorry, I just ASSUMED that FF/Moz the Suite, for Win, Mac, Linux, etc
    were all set up the same way. I just thought that if I told someone
    to go to Tools, Options or Edit, Preferences, that it would be the
    same for all platforms

    oh, just learned something new
     
    gwtc, Sep 21, 2005
    #13
  14. On 2005-09-21, gwtc <> wrote:
    > John Thompson wrote:
    >
    >> It's also in Firefox-X11 (linux,*BSD, etc.)


    > Sorry, I just ASSUMED that FF/Moz the Suite, for Win, Mac, Linux, etc
    > were all set up the same way. I just thought that if I told someone
    > to go to Tools, Options or Edit, Preferences, that it would be the
    > same for all platforms
    >
    > oh, just learned something new


    For a long time it was the same, then somewhere around 0.9 or it became
    different. Go figure.

    --

    John ()
     
    John Thompson, Sep 22, 2005
    #14
  15. On 2005-09-21, Leonidas Jones <> wrote:

    > John Thompson wrote:
    >> On 2005-09-18, Andy J. <> wrote:
    >>
    >>> And I am indeed using Linux. Sorry, but I didn't explain that as I
    >>> assumed people would realise that I was working with RPM files
    >>> (something I believe doesn't exist in Windows).

    >>
    >> RealPlayer uses the .rpm extension for certain Real Player Media files;
    >> that's why it tries to open them when you download a file with an RPM
    >> extension.
    >>

    >
    > Should it be doing that on a Linux install though?


    Why not? Realplayer on linux plays the same media types as Realplayer on
    other platforms, and not all linux distributions use ".rpm" files for
    software packaging.


    --

    John ()
     
    John Thompson, Sep 22, 2005
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chaos Master

    Firefox tries to download .PHP pages?

    Chaos Master, Aug 8, 2004, in forum: Firefox
    Replies:
    0
    Views:
    939
    Chaos Master
    Aug 8, 2004
  2. Mr Dolphin
    Replies:
    0
    Views:
    381
    Mr Dolphin
    Feb 13, 2006
  3. Geoff Pearson

    Transferring 78 rpm disks

    Geoff Pearson, Jun 11, 2004, in forum: Computer Support
    Replies:
    7
    Views:
    604
  4. NBN

    5400 RPM

    NBN, Sep 3, 2004, in forum: Computer Support
    Replies:
    30
    Views:
    1,440
    Jimi D
    Sep 5, 2004
  5. Voltardo

    Burning 78 rpm disk to CDROM

    Voltardo, Sep 24, 2004, in forum: Computer Support
    Replies:
    6
    Views:
    656
    Gary G. Taylor
    Sep 25, 2004
Loading...

Share This Page