Firefox slow to close.

Discussion in 'Firefox' started by Spamlet, Sep 23, 2010.

  1. Spamlet

    Spamlet Guest

    Don't know if this is anything to do with the 'bloat' complained of in
    another thread but I notice Firefox it hanging on in my cpu for quite a time
    after I have supposedly shut it. As this is on an old Inspiron 2600 without
    a lot of memory to spare I wonder if there is anything wrong, and if there
    is anything I can do to speed Firefoxes shutdown. (Can't win: I swapped
    from Internet Explorer because it took forever to open!

    I have XP Home, all up to date; Avast; Tea Timer; and a hosts file.

    The slowness seems to have coincided with me noticing 'interrupts' taking up
    loads of the cpu too.
    No idea what to do about those either.

    Cheers for any useful tips.

    S
    Spamlet, Sep 23, 2010
    #1
    1. Advertising

  2. Spamlet

    Ralph Fox Guest

    On Thu, 23 Sep 2010 04:36:26 +0100, in message <i7ei00$pqa$-september.org>
    Spamlet wrote:

    > Don't know if this is anything to do with the 'bloat' complained of in
    > another thread but I notice Firefox it hanging on in my cpu for quite a time
    > after I have supposedly shut it. As this is on an old Inspiron 2600 without
    > a lot of memory to spare I wonder if there is anything wrong, and if there
    > is anything I can do to speed Firefoxes shutdown.



    A. In my own experience, problems with Firefox not closing
    are usually caused by a misbehaving plug-in which is not
    shutting down quickly.

    Try this

    1. Close all but one Firefox tab & window.
    2. Set the remaining tab/window to a blank page by going to the URL
    about:blank
    That URL is just about:blank and not http://about:blank
    3. Now close Firefox.

    Does Firefox shut down quickly after this?


    B. If you start Firefox in Firefox's "Safe Mode", does the
    problem still occur?
    Start menu >> Programs >> Mozilla Firefox >> Mozilla Firefox (Safe Mode)


    > (Can't win: I swapped
    > from Internet Explorer because it took forever to open!
    >
    > I have XP Home, all up to date; Avast; Tea Timer; and a hosts file.


    Can you tell us which version of Firefox are you using?


    > The slowness seems to have coincided with me noticing 'interrupts' taking up
    > loads of the cpu too.
    > No idea what to do about those either.


    What identified this as 'interrupts'?
    Real "interrupts" probably means some hardware device and/or the
    hardware device's driver is responsible.


    > Cheers for any useful tips.


    --
    Regards
    Ralph
    Ralph Fox, Sep 23, 2010
    #2
    1. Advertising

  3. Spamlet

    Spamlet Guest

    "Ralph Fox" <> wrote in message
    news:...
    > On Thu, 23 Sep 2010 04:36:26 +0100, in message
    > <i7ei00$pqa$-september.org>
    > Spamlet wrote:
    >
    >> Don't know if this is anything to do with the 'bloat' complained of in
    >> another thread but I notice Firefox it hanging on in my cpu for quite a
    >> time
    >> after I have supposedly shut it. As this is on an old Inspiron 2600
    >> without
    >> a lot of memory to spare I wonder if there is anything wrong, and if
    >> there
    >> is anything I can do to speed Firefoxes shutdown.

    >
    >
    > A. In my own experience, problems with Firefox not closing
    > are usually caused by a misbehaving plug-in which is not
    > shutting down quickly.
    >
    > Try this
    >
    > 1. Close all but one Firefox tab & window.
    > 2. Set the remaining tab/window to a blank page by going to the URL
    > about:blank
    > That URL is just about:blank and not http://about:blank
    > 3. Now close Firefox.
    >
    > Does Firefox shut down quickly after this?


    Thanks Ralph:

    I do have Firefox (3.6.10) set to 'show a blank page'; which shows as
    'about:blank' as the 'home page' and '(untitled)' on the tab itself. Rather
    confusing that they have three different names for the same thing: and now
    you tell me there is and actual URL of that name too!

    Why can't I have a blank page without going to any URL? (It was this that
    made me change to Firefox. When IE8 was set to 'about blank' it just shows
    a tab saying 'connecting' for ages, so I don't use it.)

    Before doing any serious browsing today, I've opened and closed a few times,
    with just the blank, and then with the BBC site, and it has made a liar of
    me by closing straight away! Thus it seems it may be something which
    accumulates with the length of time the browser is open and in use.


    >
    > B. If you start Firefox in Firefox's "Safe Mode", does the
    > problem still occur?
    > Start menu >> Programs >> Mozilla Firefox >> Mozilla Firefox (Safe
    > Mode)
    >
    >
    >> (Can't win: I swapped
    >> from Internet Explorer because it took forever to open!
    >>
    >> I have XP Home, all up to date; Avast; Tea Timer; and a hosts file.

    >
    > Can you tell us which version of Firefox are you using?


    3.6.10

    >
    >
    >> The slowness seems to have coincided with me noticing 'interrupts' taking
    >> up
    >> loads of the cpu too.
    >> No idea what to do about those either.

    >
    > What identified this as 'interrupts'?
    > Real "interrupts" probably means some hardware device and/or the
    > hardware device's driver is responsible.


    The interrupts are shown in Microsoft's Process Explorer. Unfortunately it
    lumps them all together and there seems to be no way of identifying the
    process or hardware device responsible. I did ask a question about it on
    the xp.general forum:
    <http://groups.google.com/group/microsoft.public.windowsxp.general/browse_thread/thread/79c17f993abfde38/1220c0d7490d7aba?lnk=gst&q=interrupts+%2Bspamlet#1220c0d7490d7aba>

    But, as you can read, it developed into a technical discussion that was over
    my head, and left me still unable to know how to identify the problem.

    I notice that, searching for my thread on interrupts, Google has turned up
    more, so I will have a look at them too. I did, recently fit a new WD hard
    drive, and it seemed to be very fast after that for a while.

    Coincidentally, or not, I only noticed the interrupts after I had deleted
    Microsoft Update and returned to Windows Update, because it had been that
    process which took up most of the processor for a long time. Now the
    interrupts can take up most of the processor instead. Just can't win!

    Thanks very much for your interest.

    S
    Spamlet, Sep 23, 2010
    #3
  4. Spamlet

    Spamlet Guest

    "Spamlet" <> wrote in message
    news:i7frad$9a1$-september.org...
    >
    > "Ralph Fox" <> wrote in message
    > news:...
    >> On Thu, 23 Sep 2010 04:36:26 +0100, in message
    >> <i7ei00$pqa$-september.org>
    >> Spamlet wrote:
    >>
    >>> Don't know if this is anything to do with the 'bloat' complained of in
    >>> another thread but I notice Firefox it hanging on in my cpu for quite a
    >>> time
    >>> after I have supposedly shut it. As this is on an old Inspiron 2600
    >>> without
    >>> a lot of memory to spare I wonder if there is anything wrong, and if
    >>> there
    >>> is anything I can do to speed Firefoxes shutdown.

    >>
    >>
    >> A. In my own experience, problems with Firefox not closing
    >> are usually caused by a misbehaving plug-in which is not
    >> shutting down quickly.
    >>
    >> Try this
    >>
    >> 1. Close all but one Firefox tab & window.
    >> 2. Set the remaining tab/window to a blank page by going to the URL
    >> about:blank
    >> That URL is just about:blank and not http://about:blank
    >> 3. Now close Firefox.
    >>
    >> Does Firefox shut down quickly after this?

    >
    > Thanks Ralph:
    >
    > I do have Firefox (3.6.10) set to 'show a blank page'; which shows as
    > 'about:blank' as the 'home page' and '(untitled)' on the tab itself.
    > Rather confusing that they have three different names for the same thing:
    > and now you tell me there is and actual URL of that name too!
    >
    > Why can't I have a blank page without going to any URL? (It was this that
    > made me change to Firefox. When IE8 was set to 'about blank' it just
    > shows a tab saying 'connecting' for ages, so I don't use it.)
    >
    > Before doing any serious browsing today, I've opened and closed a few
    > times, with just the blank, and then with the BBC site, and it has made a
    > liar of me by closing straight away! Thus it seems it may be something
    > which accumulates with the length of time the browser is open and in use.
    >
    >
    >>
    >> B. If you start Firefox in Firefox's "Safe Mode", does the
    >> problem still occur?
    >> Start menu >> Programs >> Mozilla Firefox >> Mozilla Firefox (Safe
    >> Mode)
    >>
    >>
    >>> (Can't win: I swapped
    >>> from Internet Explorer because it took forever to open!
    >>>
    >>> I have XP Home, all up to date; Avast; Tea Timer; and a hosts file.

    >>
    >> Can you tell us which version of Firefox are you using?

    >
    > 3.6.10
    >
    >>
    >>
    >>> The slowness seems to have coincided with me noticing 'interrupts'
    >>> taking up
    >>> loads of the cpu too.
    >>> No idea what to do about those either.

    >>
    >> What identified this as 'interrupts'?
    >> Real "interrupts" probably means some hardware device and/or the
    >> hardware device's driver is responsible.

    >
    > The interrupts are shown in Microsoft's Process Explorer. Unfortunately
    > it lumps them all together and there seems to be no way of identifying the
    > process or hardware device responsible. I did ask a question about it on
    > the xp.general forum:
    > <http://groups.google.com/group/microsoft.public.windowsxp.general/browse_thread/thread/79c17f993abfde38/1220c0d7490d7aba?lnk=gst&q=interrupts+%2Bspamlet#1220c0d7490d7aba>
    >
    > But, as you can read, it developed into a technical discussion that was
    > over my head, and left me still unable to know how to identify the
    > problem.
    >
    > I notice that, searching for my thread on interrupts, Google has turned up
    > more, so I will have a look at them too. I did, recently fit a new WD
    > hard drive, and it seemed to be very fast after that for a while.
    >
    > Coincidentally, or not, I only noticed the interrupts after I had deleted
    > Microsoft Update and returned to Windows Update, because it had been that
    > process which took up most of the processor for a long time. Now the
    > interrupts can take up most of the processor instead. Just can't win!
    >
    > Thanks very much for your interest.
    >
    > S


    Thanks to your prompting Ralph, I had a wider read on interrupts threads and
    discovered the settings of the IDE channels:

    Taking the suggestions together I found that my IDE channels seemed to have
    got mixed up somehow. The primary one was set to 'DMA if available' but was
    running as PIO. The secondary one was on 'Ultra DMA Mode 2'.

    When I uninstalled the primary and restarted, the 'found new hardware' pop
    up came up. And on restarting again, the hard drive had been installed on
    the primary and was then set on 'Ultra DMA Mode 5' (!?). - which I'd never
    heard of.

    When I did the same trick for the secondary channel, it reset itself to
    POI - both 'if available' and 'currently'. However, reselecting 'DMA if
    available', after a few minutes it reset itself to 'currently' 'Multi-Word
    DMA Mode 2'. Which I also have no idea what it means. I though it was just
    POI or DMA, dot all these different sorts of DMA!

    (I have to say, I have no idea what is meant by these various modes.)

    So it looks like both controllers had got mixed up, and I never would have
    found this out without your help asking what I meant by interrupts.

    I still notice interrupts, but so far they have only gone up to around 2%

    So fingers crossed: things may be fixed.

    Many thanks,

    Spamlet.
    Spamlet, Sep 23, 2010
    #4
  5. Spamlet

    Spamlet Guest

    "Brian Gregory [UK]" <> wrote in message
    news:...
    > "Spamlet" <> wrote in message
    > news:i7gj5m$g50$-september.org...
    >>
    >> "Spamlet" <> wrote in message
    >> news:i7frad$9a1$-september.org...
    >>>
    >>> "Ralph Fox" <> wrote in message
    >>> news:...
    >>>> On Thu, 23 Sep 2010 04:36:26 +0100, in message
    >>>> <i7ei00$pqa$-september.org>
    >>>> Spamlet wrote:
    >>>>
    >>>>> Don't know if this is anything to do with the 'bloat' complained of in
    >>>>> another thread but I notice Firefox it hanging on in my cpu for quite
    >>>>> a time
    >>>>> after I have supposedly shut it. As this is on an old Inspiron 2600
    >>>>> without
    >>>>> a lot of memory to spare I wonder if there is anything wrong, and if
    >>>>> there
    >>>>> is anything I can do to speed Firefoxes shutdown.
    >>>>
    >>>>
    >>>> A. In my own experience, problems with Firefox not closing
    >>>> are usually caused by a misbehaving plug-in which is not
    >>>> shutting down quickly.
    >>>>
    >>>> Try this
    >>>>
    >>>> 1. Close all but one Firefox tab & window.
    >>>> 2. Set the remaining tab/window to a blank page by going to the URL
    >>>> about:blank
    >>>> That URL is just about:blank and not http://about:blank
    >>>> 3. Now close Firefox.
    >>>>
    >>>> Does Firefox shut down quickly after this?
    >>>
    >>> Thanks Ralph:
    >>>
    >>> I do have Firefox (3.6.10) set to 'show a blank page'; which shows as
    >>> 'about:blank' as the 'home page' and '(untitled)' on the tab itself.
    >>> Rather confusing that they have three different names for the same
    >>> thing: and now you tell me there is and actual URL of that name too!
    >>>
    >>> Why can't I have a blank page without going to any URL? (It was this
    >>> that made me change to Firefox. When IE8 was set to 'about blank' it
    >>> just shows a tab saying 'connecting' for ages, so I don't use it.)
    >>>
    >>> Before doing any serious browsing today, I've opened and closed a few
    >>> times, with just the blank, and then with the BBC site, and it has made
    >>> a liar of me by closing straight away! Thus it seems it may be
    >>> something which accumulates with the length of time the browser is open
    >>> and in use.
    >>>
    >>>
    >>>>
    >>>> B. If you start Firefox in Firefox's "Safe Mode", does the
    >>>> problem still occur?
    >>>> Start menu >> Programs >> Mozilla Firefox >> Mozilla Firefox
    >>>> (Safe Mode)
    >>>>
    >>>>
    >>>>> (Can't win: I swapped
    >>>>> from Internet Explorer because it took forever to open!
    >>>>>
    >>>>> I have XP Home, all up to date; Avast; Tea Timer; and a hosts file.
    >>>>
    >>>> Can you tell us which version of Firefox are you using?
    >>>
    >>> 3.6.10
    >>>
    >>>>
    >>>>
    >>>>> The slowness seems to have coincided with me noticing 'interrupts'
    >>>>> taking up
    >>>>> loads of the cpu too.
    >>>>> No idea what to do about those either.
    >>>>
    >>>> What identified this as 'interrupts'?
    >>>> Real "interrupts" probably means some hardware device and/or the
    >>>> hardware device's driver is responsible.
    >>>
    >>> The interrupts are shown in Microsoft's Process Explorer. Unfortunately
    >>> it lumps them all together and there seems to be no way of identifying
    >>> the process or hardware device responsible. I did ask a question about
    >>> it on the xp.general forum:
    >>> <http://groups.google.com/group/microsoft.public.windowsxp.general/browse_thread/thread/79c17f993abfde38/1220c0d7490d7aba?lnk=gst&q=interrupts+%2Bspamlet#1220c0d7490d7aba>
    >>>
    >>> But, as you can read, it developed into a technical discussion that was
    >>> over my head, and left me still unable to know how to identify the
    >>> problem.
    >>>
    >>> I notice that, searching for my thread on interrupts, Google has turned
    >>> up more, so I will have a look at them too. I did, recently fit a new
    >>> WD hard drive, and it seemed to be very fast after that for a while.
    >>>
    >>> Coincidentally, or not, I only noticed the interrupts after I had
    >>> deleted Microsoft Update and returned to Windows Update, because it had
    >>> been that process which took up most of the processor for a long time.
    >>> Now the interrupts can take up most of the processor instead. Just
    >>> can't win!
    >>>
    >>> Thanks very much for your interest.
    >>>
    >>> S

    >>
    >> Thanks to your prompting Ralph, I had a wider read on interrupts threads
    >> and discovered the settings of the IDE channels:
    >>
    >> Taking the suggestions together I found that my IDE channels seemed to
    >> have got mixed up somehow. The primary one was set to 'DMA if available'
    >> but was running as PIO. The secondary one was on 'Ultra DMA Mode 2'.
    >>
    >> When I uninstalled the primary and restarted, the 'found new hardware'
    >> pop up came up. And on restarting again, the hard drive had been
    >> installed on the primary and was then set on 'Ultra DMA Mode 5' (!?). -
    >> which I'd never heard of.
    >>
    >> When I did the same trick for the secondary channel, it reset itself to
    >> POI - both 'if available' and 'currently'. However, reselecting 'DMA if
    >> available', after a few minutes it reset itself to 'currently'
    >> 'Multi-Word DMA Mode 2'. Which I also have no idea what it means. I
    >> though it was just POI or DMA, dot all these different sorts of DMA!
    >>
    >> (I have to say, I have no idea what is meant by these various modes.)
    >>
    >> So it looks like both controllers had got mixed up, and I never would
    >> have found this out without your help asking what I meant by interrupts.
    >>
    >> I still notice interrupts, but so far they have only gone up to around 2%
    >>
    >> So fingers crossed: things may be fixed.
    >>
    >> Many thanks,
    >>
    >> Spamlet.

    >
    > No modern computer should be using PIO for it's hard or optical drives,
    > It's very inefficient.
    >
    > Even my Pentium 4 Windows XP system I built in 2002 uses UDMA mode 5 for
    > the hard drives (and lower UDMA modes for the optical drives).
    >
    > --
    >
    > Brian Gregory. (In the UK)


    Yes, I think we established that (bit by bit) thanks Brian.

    The hard part is *noticing* that the setting has reverted, and then finding
    out how to get it back.
    If I had not been using Process Explorer routinely, and, if I had not had
    the - common - problem with slow MS Updates and then noticed the 'interrupt
    storms' this was masking, and then found Firefox was slow to close and asked
    about that; I would never even have heard of DMA or PIO and the tendency of
    XP to revert to the old PIOs. Then I would not have solved the problem with
    slow to open email... which has gone since resetting the IDE controllers.

    Anyone not using PE would probably never even hear about interrupts and
    their significance. I've been reading the news groups for a number of years
    and have heard next to nothing about them before.

    Anyhow, I'm very pleased to know about interrupts; DMA and PIO now, and I
    hope that in future, people looking for reasons their computers may be
    running slow, are routinely advised to do this simple check on their IDE
    settings: it can make drastic improvements at one stroke!

    Cheers,

    S
    Spamlet, Sep 26, 2010
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    623
    Expert lino fitter
    Dec 10, 2008
  2. Expert lino fitter

    Re: slow slow slow!

    Expert lino fitter, Dec 10, 2008, in forum: Computer Support
    Replies:
    5
    Views:
    624
    Expert lino fitter
    Dec 12, 2008
  3. Beauregard T. Shagnasty

    Re: slow slow slow!

    Beauregard T. Shagnasty, Dec 10, 2008, in forum: Computer Support
    Replies:
    2
    Views:
    644
    Shel-hed
    Dec 10, 2008
  4. chuckcar

    Re: slow slow slow!

    chuckcar, Dec 10, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    515
    chuckcar
    Dec 10, 2008
  5. General Patron

    Re: slow slow slow!

    General Patron, Dec 11, 2008, in forum: Computer Support
    Replies:
    0
    Views:
    494
    General Patron
    Dec 11, 2008
Loading...

Share This Page