Firefox 0.8 insists on Quicktime for MPG files

Discussion in 'Firefox' started by Noozer, May 3, 2004.

  1. Noozer

    Noozer Guest

    Firefox 0.8 insists on using Quicktime to display MPG files on the web.

    Windows XP Pro SP1 plays MPG files in MediaPlayer by default.

    Settings in Firefox 0.8 Downloads section has MPEG files opening with
    WMPLAYER.EXE. There is no entry for "MPG" files.

    How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG files????
     
    Noozer, May 3, 2004
    #1
    1. Advertising

  2. Noozer

    Moz Champion Guest

    Noozer wrote:

    > Firefox 0.8 insists on using Quicktime to display MPG files on the web.
    >
    > Windows XP Pro SP1 plays MPG files in MediaPlayer by default.
    >
    > Settings in Firefox 0.8 Downloads section has MPEG files opening with
    > WMPLAYER.EXE. There is no entry for "MPG" files.
    >
    > How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG files????
    >
    >
    >


    Do you have the QuickTime Plug in? It would appear you do. Change the QuickTime settings so that it doesnt invoke itself for MPGs then.

    Its not Firefox that is setting the default, its the plug in and QuickTime is notorious (on Windows) for switching all types to itself when installed. Once you get it trained tho, you can have differing types open with the preferred player or plug in of your choice.

    --
    Mozilla Champion
    UFAQ - http://www.UFAQ.org
    Mozilla Champions - http://mozillachampions.mozdev.org
    Mozilla Manual - http://mozmanual.mozdev.org/
     
    Moz Champion, May 3, 2004
    #2
    1. Advertising

  3. Noozer

    Noozer Guest

    "Moz Champion" <> wrote in message
    news:pMzlc.29279$...
    > Noozer wrote:
    >
    > > Firefox 0.8 insists on using Quicktime to display MPG files on the web.
    > >
    > > Windows XP Pro SP1 plays MPG files in MediaPlayer by default.
    > >
    > > Settings in Firefox 0.8 Downloads section has MPEG files opening with
    > > WMPLAYER.EXE. There is no entry for "MPG" files.
    > >
    > > How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG

    files????

    > Do you have the QuickTime Plug in? It would appear you do. Change the

    QuickTime settings so that it doesnt invoke itself for MPGs then.
    >
    > Its not Firefox that is setting the default, its the plug in and QuickTime

    is notorious (on Windows) for switching all types to itself when installed.
    Once you get it trained tho, you can have differing types open with the
    preferred player or plug in of your choice.

    So why does Mediaplayer play the files if I save them to my hard drive and
    double click them?
     
    Noozer, May 4, 2004
    #3
  4. Noozer

    Moz Champion Guest

    Noozer wrote:

    > "Moz Champion" <> wrote in message
    > news:pMzlc.29279$...
    >
    >>Noozer wrote:
    >>
    >>
    >>>Firefox 0.8 insists on using Quicktime to display MPG files on the web.
    >>>
    >>>Windows XP Pro SP1 plays MPG files in MediaPlayer by default.
    >>>
    >>>Settings in Firefox 0.8 Downloads section has MPEG files opening with
    >>>WMPLAYER.EXE. There is no entry for "MPG" files.
    >>>
    >>>How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG

    >
    > files????
    >
    >
    >>Do you have the QuickTime Plug in? It would appear you do. Change the

    >
    > QuickTime settings so that it doesnt invoke itself for MPGs then.
    >
    >>Its not Firefox that is setting the default, its the plug in and QuickTime

    >
    > is notorious (on Windows) for switching all types to itself when installed.
    > Once you get it trained tho, you can have differing types open with the
    > preferred player or plug in of your choice.
    >
    > So why does Mediaplayer play the files if I save them to my hard drive and
    > double click them?
    >
    >


    Because your browser isnt in charge then <g>

    When Firefox encounters a file with a mime type, it first checks to see if it can handle the file itself.
    If it cant, then it checks the plug ins to see if they can handle the file type
    If no plug in claims the type, then Firefox checks the Helper Applications to see if you have a setting there.

    When you launch from your hard drive, Firefox isnt even involved, so your system settings are used.

    In this scenario, Firefox 'sees' the audio/mpeg mime type, and since it cant handle it internally, checks the plug ins, and it finds QuickTime as claiming such, so it invokese QuickTime of course. So to prevent it, tell QuickTime NOT to play mpegs.


    --
    Mozilla Champion
    UFAQ - http://www.UFAQ.org
    Mozilla Champions - http://mozillachampions.mozdev.org
    Mozilla Manual - http://mozmanual.mozdev.org/
     
    Moz Champion, May 5, 2004
    #4
  5. Noozer

    Noozer Guest

    "Moz Champion" <> wrote in message
    news:2BZlc.20194$...
    > Noozer wrote:
    >
    > > "Moz Champion" <> wrote in message
    > > news:pMzlc.29279$...
    > >
    > >>Noozer wrote:
    > >>
    > >>
    > >>>Firefox 0.8 insists on using Quicktime to display MPG files on the web.
    > >>>
    > >>>Windows XP Pro SP1 plays MPG files in MediaPlayer by default.
    > >>>
    > >>>Settings in Firefox 0.8 Downloads section has MPEG files opening with
    > >>>WMPLAYER.EXE. There is no entry for "MPG" files.
    > >>>
    > >>>How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG

    > >
    > > files????
    > >
    > >
    > >>Do you have the QuickTime Plug in? It would appear you do. Change the

    > >
    > > QuickTime settings so that it doesnt invoke itself for MPGs then.
    > >
    > >>Its not Firefox that is setting the default, its the plug in and

    QuickTime
    > >
    > > is notorious (on Windows) for switching all types to itself when

    installed.
    > > Once you get it trained tho, you can have differing types open with the
    > > preferred player or plug in of your choice.
    > >
    > > So why does Mediaplayer play the files if I save them to my hard drive

    and
    > > double click them?
    > >
    > >

    >
    > Because your browser isnt in charge then <g>
    >
    > When Firefox encounters a file with a mime type, it first checks to see if

    it can handle the file itself.
    > If it cant, then it checks the plug ins to see if they can handle the file

    type
    > If no plug in claims the type, then Firefox checks the Helper Applications

    to see if you have a setting there.
    >
    > When you launch from your hard drive, Firefox isnt even involved, so your

    system settings are used.
    >
    > In this scenario, Firefox 'sees' the audio/mpeg mime type, and since it

    cant handle it internally, checks the plug ins, and it finds QuickTime as
    claiming such, so it invokese QuickTime of course. So to prevent it, tell
    QuickTime NOT to play mpegs.


    I've done that. QTime is currently set NOT to play any filetypes.
    I've told FireFox to use mplayer for MPEG filetypes.
    They still play in Qtime.
     
    Noozer, May 5, 2004
    #5
  6. Noozer

    Moz Champion Guest

    Noozer wrote:
    > "Moz Champion" <> wrote in message
    > news:2BZlc.20194$...
    >
    >>Noozer wrote:
    >>
    >>
    >>>"Moz Champion" <> wrote in message
    >>>news:pMzlc.29279$...
    >>>
    >>>
    >>>>Noozer wrote:
    >>>>
    >>>>
    >>>>
    >>>>>Firefox 0.8 insists on using Quicktime to display MPG files on the web.
    >>>>>
    >>>>>Windows XP Pro SP1 plays MPG files in MediaPlayer by default.
    >>>>>
    >>>>>Settings in Firefox 0.8 Downloads section has MPEG files opening with
    >>>>>WMPLAYER.EXE. There is no entry for "MPG" files.
    >>>>>
    >>>>>How can I tell Firefox 0.8 to use Windows Mediaplayer to show MPG
    >>>
    >>>files????
    >>>
    >>>
    >>>
    >>>>Do you have the QuickTime Plug in? It would appear you do. Change the
    >>>
    >>>QuickTime settings so that it doesnt invoke itself for MPGs then.
    >>>
    >>>
    >>>>Its not Firefox that is setting the default, its the plug in and

    >
    > QuickTime
    >
    >>>is notorious (on Windows) for switching all types to itself when

    >
    > installed.
    >
    >>>Once you get it trained tho, you can have differing types open with the
    >>>preferred player or plug in of your choice.
    >>>
    >>>So why does Mediaplayer play the files if I save them to my hard drive

    >
    > and
    >
    >>>double click them?
    >>>
    >>>

    >>
    >>Because your browser isnt in charge then <g>
    >>
    >>When Firefox encounters a file with a mime type, it first checks to see if

    >
    > it can handle the file itself.
    >
    >>If it cant, then it checks the plug ins to see if they can handle the file

    >
    > type
    >
    >>If no plug in claims the type, then Firefox checks the Helper Applications

    >
    > to see if you have a setting there.
    >
    >>When you launch from your hard drive, Firefox isnt even involved, so your

    >
    > system settings are used.
    >
    >>In this scenario, Firefox 'sees' the audio/mpeg mime type, and since it

    >
    > cant handle it internally, checks the plug ins, and it finds QuickTime as
    > claiming such, so it invokese QuickTime of course. So to prevent it, tell
    > QuickTime NOT to play mpegs.
    >
    >
    > I've done that. QTime is currently set NOT to play any filetypes.
    > I've told FireFox to use mplayer for MPEG filetypes.
    > They still play in Qtime.
    >
    >
    >


    If QuickTime is currently set NOT to play any filetypes, then remove it from your system. Once again, it isnt a Firefox problem per se, but one that has to do with QuickTime and the way it 'takes' over on Windows systems.

    --
    Mozilla Champion
    UFAQ - http://www.UFAQ.org
    Mozilla Champions - http://mozillachampions.mozdev.org
    Mozilla Manual - http://mozmanual.mozdev.org/
     
    Moz Champion, May 5, 2004
    #6
  7. Noozer

    bhd

    Joined:
    May 17, 2006
    Messages:
    1
    I'm having this very annoying issue as well.

    Quicktime must be installed for me to use iTunes. But no matter what I do, It still takes over mpg files when I click on mpg links in my browser. I've tried every piece of advice, from removing the mime type and file type associations, restarting computer, etc, nothing works.

    I'm ready to get into some heavy duty registry hacking if I have to on this one, the current setup is really, really pissing me off.
     
    bhd, May 17, 2006
    #7
  8. Noozer

    jonnycracked

    Joined:
    Dec 14, 2007
    Messages:
    1
    it's a pain but here is how

    i was searching for an easier way to do this but this is how i do it.. its a long process and i hate doing it every time i reinstall and configure my pc but it works so here is how...

    pull down the tools menu
    select options
    click content
    under file types click the manage button
    then look for MPG under the extensions list
    it should say (if you've installed quicktime) under the actions list
    that its handled with quick time
    so select/highlight it and click on change action
    then select the open the with the default application or
    if youd like to use a different application there is that option too

    its a real pain but it works..
    hope this helps you.
     
    jonnycracked, Dec 14, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. fredcromer

    Msn messenger6.1 insists 'a newer 1 is available'

    fredcromer, Apr 14, 2004, in forum: Computer Information
    Replies:
    4
    Views:
    2,551
    Pepperoni
    Apr 15, 2004
  2. English Patient

    How do I crop/trim a widescreen mpg into a 4:3 mpg ?

    English Patient, Nov 22, 2005, in forum: Computer Support
    Replies:
    4
    Views:
    670
    John Inzer
    Nov 22, 2005
  3. justin tyme

    Do not want IE7 -MS "insists"..

    justin tyme, Nov 8, 2006, in forum: Computer Support
    Replies:
    12
    Views:
    673
  4. Giuen
    Replies:
    0
    Views:
    1,451
    Giuen
    Sep 12, 2008
  5. Brian

    Windows insists on connecting to wireless network

    Brian, Dec 7, 2008, in forum: Wireless Networking
    Replies:
    3
    Views:
    907
Loading...

Share This Page