extremely basic router question

Discussion in 'Cisco' started by John Scholvin, Dec 3, 2004.

  1. I'm setting up a 2801 router. ADSL WIC to connect to the internet and I'm
    using one of the fastethernet ports to connect to my LAN.

    The good news is I have the ADSL config working fine. From the router I can
    ping the outside world and be pinged on my public IP. Exciting.

    The bad news is that I can't ping my fastethernet interface, either from
    within the router or from the LAN.

    I'm at home right now and don't have access to the full config, which I
    could probably post that tomorrow when I get in. But for now, two questions:

    1) Should I be able to ping the fastethernet IP address from "inside" the
    router? I would think so but I'm willing to be educated.

    2) If so, are there any obvious gotchas I should be looking for in the
    interface config? or somewhere else?

    Thanks...
    --
    John Scholvin -- -- an E7b5#9 man in an F major world
     
    John Scholvin, Dec 3, 2004
    #1
    1. Advertising

  2. John Scholvin

    Paul Cocker Guest

    Don't suppose you've missed off the 'no shut' command have you? Sorry if
    this is too basic.

    "John Scholvin" <> wrote in message
    news:coojev$4hb$...
    > I'm setting up a 2801 router. ADSL WIC to connect to the internet and I'm
    > using one of the fastethernet ports to connect to my LAN.
    >
    > The good news is I have the ADSL config working fine. From the router I
    > can
    > ping the outside world and be pinged on my public IP. Exciting.
    >
    > The bad news is that I can't ping my fastethernet interface, either from
    > within the router or from the LAN.
    >
    > I'm at home right now and don't have access to the full config, which I
    > could probably post that tomorrow when I get in. But for now, two
    > questions:
    >
    > 1) Should I be able to ping the fastethernet IP address from "inside" the
    > router? I would think so but I'm willing to be educated.
    >
    > 2) If so, are there any obvious gotchas I should be looking for in the
    > interface config? or somewhere else?
    >
    > Thanks...
    > --
    > John Scholvin -- -- an E7b5#9 man in an F major world
     
    Paul Cocker, Dec 3, 2004
    #2
    1. Advertising

  3. In article <coojev$4hb$>,
    John Scholvin <> wrote:

    > I'm setting up a 2801 router. ADSL WIC to connect to the internet and I'm
    > using one of the fastethernet ports to connect to my LAN.
    >
    > The good news is I have the ADSL config working fine. From the router I can
    > ping the outside world and be pinged on my public IP. Exciting.
    >
    > The bad news is that I can't ping my fastethernet interface, either from
    > within the router or from the LAN.
    >
    > I'm at home right now and don't have access to the full config, which I
    > could probably post that tomorrow when I get in. But for now, two questions:
    >
    > 1) Should I be able to ping the fastethernet IP address from "inside" the
    > router? I would think so but I'm willing to be educated.


    Yes.

    > 2) If so, are there any obvious gotchas I should be looking for in the
    > interface config? or somewhere else?


    Make sure the interface isn't shutdown, i.e. do:

    #config t
    (conf)#interface fa0
    (conf)#no shutdown
    (conf)#Control-z
    #write

    If that's not it, post your config to the group.

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
     
    Barry Margolin, Dec 3, 2004
    #3
  4. In article <>,
    Barry Margolin <> wrote:
    >In article <coojev$4hb$>,
    > John Scholvin <> wrote:
    >> The bad news is that I can't ping my fastethernet interface, either from
    >> within the router or from the LAN.

    >
    >Make sure the interface isn't shutdown, i.e. do:
    >
    >#config t
    >(conf)#interface fa0
    >(conf)#no shutdown
    >(conf)#Control-z
    >#write
    >
    >If that's not it, post your config to the group.


    That wasn't it. Interestingly, in the config dump I'm going to post, there
    is no "no shutdown" on this interface, but if I do a "show inter fa 0/0" it
    tells me the interface is up.

    Here's the config, thanks for the help!

    Building configuration...

    Current configuration : 5214 bytes
    !
    version 12.3
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname router01
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 debugging
    logging console critical
    enable secret 5 <removed>
    !
    username <removed> privilege 15 secret 5 <removed>
    clock timezone CT -6
    clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    no ip source-route
    ip cef
    !
    !
    ip tcp synwait-time 10
    ip dhcp bootp ignore
    !
    !
    no ip bootp server
    ip domain name <removed>.com
    ip name-server 206.141.192.60
    ip name-server 151.164.1.8
    no ftp-server write-enable
    !
    !
    !
    !
    interface FastEthernet0/0
    description <removed>
    ip address 196.168.200.1 255.255.255.0
    ip information-reply
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    no cdp enable
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    shutdown
    duplex auto
    speed auto
    no cdp enable
    no mop enabled
    !
    interface ATM0/1/0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0/1/0.1 point-to-point
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    !
    interface Dialer0
    description SBC
    ip address <removed> 255.255.255.248
    ip access-group ACL_DIALER0_IN in
    ip access-group ACL_DIALER0_OUT out
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip nat outside
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname <removed>
    ppp chap password 7 <removed>
    ppp pap sent-username <removed> password 7 <removed>
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http authentication local
    ip nat inside source list 1 interface Dialer0 overload
    !
    ip access-list extended ACL_DIALER0_IN
    <acl details removed>
    ip access-list extended ACL_DIALER0_OUT
    <acl details removed>
    !
    logging trap debugging
    access-list 1 remark INSIDE_IF=FastEthernet0/0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.0.0 0.0.255.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    control-plane
    !
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 20000 1000
    end

    --
    John Scholvin -- -- an E7b5#9 man in an F major world
     
    John Scholvin, Dec 3, 2004
    #4
  5. In article <copsl2$7kd$>,
    John Scholvin <> wrote:

    > In article <>,
    > Barry Margolin <> wrote:
    > >In article <coojev$4hb$>,
    > > John Scholvin <> wrote:
    > >> The bad news is that I can't ping my fastethernet interface, either from
    > >> within the router or from the LAN.

    > >
    > >Make sure the interface isn't shutdown, i.e. do:
    > >
    > >#config t
    > >(conf)#interface fa0
    > >(conf)#no shutdown
    > >(conf)#Control-z
    > >#write
    > >
    > >If that's not it, post your config to the group.

    >
    > That wasn't it. Interestingly, in the config dump I'm going to post, there
    > is no "no shutdown" on this interface, but if I do a "show inter fa 0/0" it
    > tells me the interface is up.


    "no shutdown" is the default, so it doesn't show up in configurations.

    I don't see anything obviously wrong in the configuration. Maybe
    there's a problem with the cable or hub that the fastethernet interface
    is connected to, although then I'd expect "show interface" to say
    "interface is up, line protocol is down".

    Try looking at the log to see if there are any complaints about
    FastEthernet 0/0.

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
     
    Barry Margolin, Dec 4, 2004
    #5
  6. John Scholvin

    Erik Freitag Guest

    On Fri, 03 Dec 2004 14:19:14 +0000, John Scholvin wrote:

    > In article <>,
    > Barry Margolin <> wrote:
    >>In article <coojev$4hb$>,
    >> John Scholvin <> wrote:
    >>> The bad news is that I can't ping my fastethernet interface, either from
    >>> within the router or from the LAN.

    >>
    >>Make sure the interface isn't shutdown, i.e. do:
    >>
    >>#config t
    >>(conf)#interface fa0
    >>(conf)#no shutdown
    >>(conf)#Control-z
    >>#write
    >>
    >>If that's not it, post your config to the group.

    >
    > That wasn't it. Interestingly, in the config dump I'm going to post, there
    > is no "no shutdown" on this interface, but if I do a "show inter fa 0/0" it
    > tells me the interface is up.
    >
    > Here's the config, thanks for the help!
    >
    > Building configuration...
    >


    This is probably a stupid question, but I couldn't find the answer earlier
    in this thread. If you do a "show ip int brief" does interface fa 0 show
    up/up or up/down?
     
    Erik Freitag, Dec 4, 2004
    #6
  7. In article <>,
    Barry Margolin <> wrote:

    >I don't see anything obviously wrong in the configuration. Maybe
    >there's a problem with the cable or hub that the fastethernet interface
    >is connected to, although then I'd expect "show interface" to say
    >"interface is up, line protocol is down".


    Agreed. It says up/up anyhow, and all 3 LED's are steady green.

    >Try looking at the log to see if there are any complaints about
    >FastEthernet 0/0.


    Nothing. Bummer. Tomorrow I may try 0/1 just to see if it's different, for
    laughs.

    Thanks for the help so far...

    John

    --
    John Scholvin -- -- an E7b5#9 man in an F major world
     
    John Scholvin, Dec 5, 2004
    #7
  8. In article <>,
    Erik Freitag <> wrote:

    >This is probably a stupid question, but I couldn't find the answer earlier
    >in this thread. If you do a "show ip int brief" does interface fa 0 show
    >up/up or up/down?


    There are no stupid questions, only stupid routers. :)

    It says up/up.



    --
    John Scholvin -- -- an E7b5#9 man in an F major world
     
    John Scholvin, Dec 5, 2004
    #8
  9. In article <cou040$foh$>,
    John Scholvin <> wrote:

    >There are no stupid questions, only stupid routers. :)


    And apparently, stupid router admins.

    The problem was outrageously simple: I had typo'ed the IP address in the
    config, using 196.168.200.1 instead of 192.168.200.1 for the interface. So
    pinging the 192.168 address wasn't going to work...it wasn't there.

    Thanks to everyone who offered advice.

    --
    John Scholvin -- -- an E7b5#9 man in an F major world
     
    John Scholvin, Dec 6, 2004
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jaime
    Replies:
    2
    Views:
    594
    Jaime
    Sep 20, 2003
  2. DrFunkenstien

    An Extremely Easy To Answer Question

    DrFunkenstien, Dec 13, 2004, in forum: MCSD
    Replies:
    1
    Views:
    436
    Tony Meier
    Dec 13, 2004
  3. Jimmy Dean
    Replies:
    3
    Views:
    1,245
    Duane Arnold
    Jul 25, 2005
  4. Basic Router Question

    , Oct 4, 2005, in forum: Computer Support
    Replies:
    2
    Views:
    605
  5. Sharp Dressed Man

    TurboTax Basic vs. Taxcut Basic?

    Sharp Dressed Man, Jan 10, 2009, in forum: Computer Support
    Replies:
    1
    Views:
    696
    Sharp Dressed Man
    Jan 12, 2009
Loading...

Share This Page