Etherchannel problem

Discussion in 'Cisco' started by thejayman, Apr 27, 2006.

  1. thejayman

    thejayman Guest

    Hi group.
    I have an issue whilst trying to set up an etherchannel between a 6513
    and 6509. As soon as the Channel is up and bonded a switch in an
    external office (Cat.3650) goes off line and only a reboot of this
    external switch will bring it back with the Port Channel shutdown. The
    default gateway of the remote netowrk sits on the 6513, the external
    switch is just in default setup with ports set to cisco-desktop macro.

    Port Channel set up below:
    6513:
    ..........
    !
    interface Port-channel1
    switchport
    switchport access vlan 4
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet13/1
    switchport
    switchport access vlan 4
    switchport mode trunk
    channel-group 1 mode desirable non-silent
    .........

    6509:
    ........
    interface Port-channel1
    no ip address
    switchport
    switchport access vlan 4
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    no ip address
    switchport
    switchport access vlan 4
    switchport mode trunk
    channel-group 1 mode desirable non-silent
    ....

    Any ideas?

    Thanks
    J
    thejayman, Apr 27, 2006
    #1
    1. Advertising

  2. thejayman

    Merv Guest

    Is the connection a trunk or not ?

    If is is then lose the "switchport access vlan 4" command and get rid
    of DTP - configure the trunk as nonegotiate
    Merv, Apr 27, 2006
    #2
    1. Advertising

  3. thejayman

    thejayman Guest

    Thank for the prompt reply.
    I am assuming it should be a trunk, I was just trying to allow the
    channel to pass only traffic on that vlan.

    So should i enter:

    no switchport access vlan 4
    switchport mode trunk nonegotiate

    Thanks
    J
    thejayman, Apr 27, 2006
    #3
  4. thejayman

    thejayman Guest

    Thank for the prompt reply.
    I am assuming it should be a trunk, I was just trying to allow the
    channel to pass only traffic on that vlan.

    So should i enter:

    no switchport access vlan 4
    switchport mode trunk nonegotiate

    Thanks
    J
    thejayman, Apr 27, 2006
    #4
  5. thejayman

    URB Guest

    What is the status of the 3560 port that is connected to the network?
    Is it err-disabled? If so, what is the cause?

    If you only want vlan 4 on the trunk use switchport trunk allowed vlan
    otherwise use switch trun native vlan or something like that.

    URB

    On 27 Apr 2006 10:56:56 -0700, "thejayman"
    <> wrote:

    >Hi group.
    >I have an issue whilst trying to set up an etherchannel between a 6513
    >and 6509. As soon as the Channel is up and bonded a switch in an
    >external office (Cat.3650) goes off line and only a reboot of this
    >external switch will bring it back with the Port Channel shutdown. The
    >default gateway of the remote netowrk sits on the 6513, the external
    >switch is just in default setup with ports set to cisco-desktop macro.
    >
    >Port Channel set up below:
    >6513:
    >.........
    >!
    >interface Port-channel1
    > switchport
    > switchport access vlan 4
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    >!
    >interface GigabitEthernet13/1
    > switchport
    > switchport access vlan 4
    > switchport mode trunk
    > channel-group 1 mode desirable non-silent
    >........
    >
    >6509:
    >.......
    >interface Port-channel1
    > no ip address
    > switchport
    > switchport access vlan 4
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    >!
    >no ip address
    >switchport
    >switchport access vlan 4
    >switchport mode trunk
    >channel-group 1 mode desirable non-silent
    >...
    >
    >Any ideas?
    >
    >Thanks
    >J
    URB, Apr 27, 2006
    #5
  6. thejayman

    Merv Guest

    try




    ! 6513 port channel configuration


    no int po 1
    no int gi 13/1


    interface Port-channel 1
    description trunk between 6513 and 6509
    no ip address
    load-interval 30
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport nonegotiate
    switchport trunk allowed vlan 4 ! permit only vlan 4 traffic
    across trunk
    no shutdown




    interface GigabitEthernet 13/1
    description trunk between 6513 and 6509
    no ip address
    load-interval 30
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport nonegotiate
    switchport trunk allowed vlan 4
    channel-group 1 mode on
    no shutdown
    Merv, Apr 27, 2006
    #6
  7. thejayman

    thejayman Guest

    Thanks for this. Works a charm. I am trying to understand the load
    balancing aspect. I have many hosts going to few servers. From my
    reading it looks like
    port-channel load-balance src-dst-mac would work best.

    Do you agree?
    Thanks again
    thejayman, Apr 28, 2006
    #7
  8. thejayman

    Merv Guest

    I am not sure of the best load balancing algorithm as I have never
    tested.

    You can configure load-interval 30 on each of teh interface you place
    in a port-channel to be able to get a better idea of their instanteious
    utilization
    Merv, Apr 28, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Roland Waidhas

    Etherchannel 4006

    Roland Waidhas, Jul 13, 2003, in forum: Cisco
    Replies:
    0
    Views:
    2,077
    Roland Waidhas
    Jul 13, 2003
  2. Todd Richert
    Replies:
    3
    Views:
    2,471
    Hansang Bae
    Jan 10, 2004
  3. TJ
    Replies:
    1
    Views:
    643
    Andrey Tarasov
    Feb 7, 2005
  4. Who knows?
    Replies:
    4
    Views:
    646
  5. Ivana

    etherchannel problem

    Ivana, Jul 26, 2006, in forum: Cisco
    Replies:
    3
    Views:
    9,372
    mos33
    Aug 15, 2008
Loading...

Share This Page