Equal cost paths from separate OSPF Processes

Discussion in 'Cisco' started by mosfet, Mar 3, 2006.

  1. mosfet

    mosfet Guest

    I came across a quirk in 12.0(23) where OSPF will permit the installation of
    equal cost routes (default in this case) from two separate processes &
    areas. You can see in a couple of places that all interfaces encompassed by
    the network statements are valid in all OSPF processes. 12.2(12a) does not
    behave in the same manner. Assuming this was either a 'feature' in 12.0, or
    perhaps a defect?

    In this lab 0.0.0.0/0 is originated from two hops away from the access
    router (two routers in the core, the distribution layer router are adjacent
    to the access router).

    Is there a way to toggle this behaviour in 12.2+? Comparison of the
    behaviours below (same router & config, different images).

    Thx
    mosfet


    interface Serial0.300 point-to-point
    description p2p pvc to dist router 1 ospf test
    bandwidth 2000
    ip address 192.168.4.2 255.255.255.240
    no ip redirects
    no ip directed-broadcast
    ip ospf authentication-key 7 12345678
    ip ospf priority 0
    frame-relay interface-dlci 300
    !
    interface Serial0.301 point-to-point
    description p2p pvc to dist router 2 ospf test
    bandwidth 2000
    ip address 192.168.5.2 255.255.255.240
    no ip redirects
    ip directed-broadcast
    ip ospf authentication-key 7 12345678
    ip ospf priority 0
    frame-relay interface-dlci 301
    !
    router ospf 5
    log-adjacency-changes
    area 192.168.4.0 authentication
    redistribute connected subnets
    redistribute static subnets
    network 192.168.4.0 0.0.0.15 area 192.168.4.0
    distribute-list permit-default in
    !
    router ospf 10
    log-adjacency-changes
    area 192.168.5.0 authentication
    redistribute connected subnets
    redistribute static subnets
    network 192.168.5.0 0.0.0.15 area 192.168.5.0
    distribute-list permit-default in
    !
    ip access-list standard permit-default
    permit 0.0.0.0
    deny any


    router#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) 2500 Software (C2500-I-L), Version 12.0(23), RELEASE SOFTWARE (fc1)
    ...

    router#sh ip ospf neigh

    Neighbor ID Pri State Dead Time Address Interface
    172.21.254.154 99 FULL/ - 00:00:30 192.168.4.1
    Serial0.300
    172.21.254.153 99 FULL/ - 00:00:33 192.168.5.1
    Serial0.301

    router#sh ip route ospf
    O*E1 0.0.0.0/0 [110/76] via 192.168.4.1, 00:02:34, Serial0.300
    [110/76] via 192.168.5.1, 00:02:42, Serial0.301

    router#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
    Known via "ospf 5", distance 110, metric 76, candidate default path
    Tag 5, type extern 1
    Redistributing via ospf 5
    Last update from 192.168.4.1 on Serial0.300, 00:08:15 ago
    Routing Descriptor Blocks:
    * 192.168.4.1, from 172.21.254.156, 00:08:15 ago, via Serial0.300
    Route metric is 76, traffic share count is 1
    192.168.5.1, from 172.21.254.156, 00:08:24 ago, via Serial0.301
    Route metric is 76, traffic share count is 1

    router#sh ip ospf 5 nei de
    Neighbor 172.21.254.154, interface address 192.168.4.1
    In the area 192.168.4.0 via interface Serial0.300
    Neighbor priority is 99, State is FULL, 6 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 66
    Dead timer due in 00:00:35
    Neighbor 172.21.254.153, interface address 192.168.5.1
    In the area 192.168.5.0 via interface Serial0.301
    Neighbor priority is 99, State is FULL, 12 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 66
    Dead timer due in 00:00:34

    router#sh ip ospf 10 nei de
    Neighbor 172.21.254.154, interface address 192.168.4.1
    In the area 192.168.4.0 via interface Serial0.300
    Neighbor priority is 99, State is FULL, 6 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 66
    Dead timer due in 00:00:34
    Neighbor 172.21.254.153, interface address 192.168.5.1
    In the area 192.168.5.0 via interface Serial0.301
    Neighbor priority is 99, State is FULL, 12 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options 66
    Dead timer due in 00:00:34

    router#sh ip ospf
    Routing Process "ospf 10" with ID 192.168.5.2
    Supports only single TOS(TOS0) routes
    It is an autonomous system boundary router
    Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution
    <snip>
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 192.168.5.0
    Number of interfaces in this area is 1
    Area has simple password authentication
    SPF algorithm executed 5 times
    <snip>

    Routing Process "ospf 5" with ID 172.21.254.155
    Supports only single TOS(TOS0) routes
    It is an autonomous system boundary router
    Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution
    <snip>
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Area 192.168.4.0
    Number of interfaces in this area is 1
    Area has simple password authentication
    SPF algorithm executed 4 times
    <snip>


    router#ping ip
    Target IP address: 192.168.2.5
    Repeat count [5]: 2
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface:
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]: R
    Number of hops [ 9 ]:
    Loose, Strict, Record, Timestamp, Verbose[RV]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 192.168.2.5, timeout is 2 seconds:
    Packet has IP options: Total option bytes= 39, padded length=40
    Record route: <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)

    Reply to request 0 (8 ms). Received packet has options
    Total option bytes= 40, padded length=40
    Record route:
    (192.168.4.2)
    (192.168.2.6)
    (192.168.2.5)
    (192.168.2.5)
    (192.168.4.1)
    (192.168.4.2) <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    End of list

    Reply to request 1 (12 ms). Received packet has options
    Total option bytes= 40, padded length=40
    Record route:
    (192.168.5.2)
    (192.168.2.2)
    (192.168.2.5)
    (192.168.2.1)
    (192.168.5.1)
    (192.168.5.2) <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    End of list

    Success rate is 100 percent (2/2), round-trip min/avg/max = 8/10/12 ms


    --


    router#sh ver | inc IOS
    IOS (tm) 2500 Software (C2500-JS-L), Version 12.2(12a), RELEASE SOFTWARE
    (fc1)

    router#sh ip ospf neigh

    Neighbor ID Pri State Dead Time Address Interface
    172.21.254.153 99 FULL/ - 00:00:37 192.168.5.1
    Serial0.301
    172.21.254.154 99 FULL/ - 00:00:38 192.168.4.1
    Serial0.300

    router#sh ip route ospf
    O*E1 0.0.0.0/0 [110/76] via 192.168.4.1, 00:00:10, Serial0.300

    router#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
    Known via "ospf 5", distance 110, metric 76, candidate default path
    Tag 5, type extern 1
    Last update from 192.168.4.1 on Serial0.300, 00:03:39 ago
    Routing Descriptor Blocks:
    * 192.168.4.1, from 172.21.254.156, 00:03:39 ago, via Serial0.300
    Route metric is 76, traffic share count is 1

    router#sh ip ospf 5 nei de
    Neighbor 172.21.254.154, interface address 192.168.4.1
    In the area 192.168.4.0 via interface Serial0.300
    Neighbor priority is 99, State is FULL, 6 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options is 0x42
    Dead timer due in 00:00:31
    Neighbor is up for 00:01:48
    Index 1/1, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

    router#sh ip ospf 10 nei de
    Neighbor 172.21.254.153, interface address 192.168.5.1
    In the area 192.168.5.0 via interface Serial0.301
    Neighbor priority is 99, State is FULL, 6 state changes
    DR is 0.0.0.0 BDR is 0.0.0.0
    Options is 0x42
    Dead timer due in 00:00:36
    Neighbor is up for 00:01:53
    Index 1/1, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

    router#sh ip ospf
    Routing Process "ospf 10" with ID 192.168.5.2
    Supports only single TOS(TOS0) routes
    Supports opaque LSA
    It is an autonomous system boundary router
    Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution
    <snip>
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    External flood list length 0
    Area 192.168.5.0
    Number of interfaces in this area is 1
    Area has simple password authentication
    SPF algorithm executed 3 times
    <snip>

    Routing Process "ospf 5" with ID 172.21.254.155
    Supports only single TOS(TOS0) routes
    Supports opaque LSA
    It is an autonomous system boundary router
    Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution
    <snip>
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    External flood list length 0
    Area 192.168.4.0
    Number of interfaces in this area is 1
    Area has simple password authentication
    SPF algorithm executed 3 times
    <snip>

    router#ping ip
    Target IP address: 192.168.2.5
    Repeat count [5]: 2
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface:
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]: R
    Number of hops [ 9 ]:
    Loose, Strict, Record, Timestamp, Verbose[RV]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 2, 100-byte ICMP Echos to 192.168.2.5, timeout is 2 seconds:
    Packet has IP options: Total option bytes= 39, padded length=40
    Record route: <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)

    Reply to request 0 (12 ms). Received packet has options
    Total option bytes= 40, padded length=40
    Record route:
    (192.168.4.2)
    (192.168.2.6)
    (192.168.2.5)
    (192.168.2.5)
    (192.168.4.1)
    (192.168.4.2) <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    End of list

    Reply to request 1 (12 ms). Received packet has options
    Total option bytes= 40, padded length=40
    Record route:
    (192.168.4.2)
    (192.168.2.6)
    (192.168.2.5)
    (192.168.2.5)
    (192.168.4.1)
    (192.168.4.2) <*>
    (0.0.0.0)
    (0.0.0.0)
    (0.0.0.0)
    End of list

    Success rate is 100 percent (2/2), round-trip min/avg/max = 12/12/12 ms
     
    mosfet, Mar 3, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Aaron Woody
    Replies:
    0
    Views:
    885
    Aaron Woody
    Oct 20, 2003
  2. Robertas
    Replies:
    6
    Views:
    688
    Hansang Bae
    Aug 12, 2004
  3. BigAndy

    Separate Tabs, Separate Sessions

    BigAndy, May 9, 2007, in forum: Firefox
    Replies:
    0
    Views:
    626
    BigAndy
    May 9, 2007
  4. BigAndy

    Separate Tabs, Separate Sessions

    BigAndy, May 9, 2007, in forum: Firefox
    Replies:
    0
    Views:
    630
    BigAndy
    May 9, 2007
  5. =?Utf-8?B?TkpU?=

    Internet Sharing: Equal upload speeds but un-equal download speeds

    =?Utf-8?B?TkpU?=, Sep 14, 2007, in forum: Wireless Networking
    Replies:
    3
    Views:
    1,024
    =?Utf-8?B?TkpU?=
    Sep 15, 2007
Loading...

Share This Page