Enabling wireless internet access for the Guest account

Discussion in 'Wireless Networking' started by =?Utf-8?B?TWF0dA==?=, Jan 24, 2006.

  1. Hello, I recently purchased a Gateway laptop with a built in Broadcom
    wireless network card. In order to connect to my university's network, I
    needed to install the Broadcom wireless configuration tool, and then click
    the checkbox to "allow this tool to manage my network settings".

    So here is my dilemma: I would like to have 2 accounts on this laptop, my
    administrator account, and a Guest account (usable by my family and friends
    if I'm not around). I do NOT want anyone else but me to be installing
    programs, but I do wan't them to be able to use previously installed programs
    and the internet. I tried turning on the built-in Guest account, but
    whenever I log on as Guest, I cannot access the wireless network. The only
    way I have seen to get around this is to first log on as my administrator
    account, and then switch to the Guest account from there. Unfortunately, I
    won't always be around to log in, and I still want my family to be able to
    use it. How can I allow the Guest account to access the wireless network?
     
    =?Utf-8?B?TWF0dA==?=, Jan 24, 2006
    #1
    1. Advertising

  2. =?Utf-8?B?TWF0dA==?=

    Lem Guest

    Matt wrote:

    > Hello, I recently purchased a Gateway laptop with a built in Broadcom
    > wireless network card. In order to connect to my university's network, I
    > needed to install the Broadcom wireless configuration tool, and then click
    > the checkbox to "allow this tool to manage my network settings".
    >
    > So here is my dilemma: I would like to have 2 accounts on this laptop, my
    > administrator account, and a Guest account (usable by my family and friends
    > if I'm not around). I do NOT want anyone else but me to be installing
    > programs, but I do wan't them to be able to use previously installed programs
    > and the internet. I tried turning on the built-in Guest account, but
    > whenever I log on as Guest, I cannot access the wireless network. The only
    > way I have seen to get around this is to first log on as my administrator
    > account, and then switch to the Guest account from there. Unfortunately, I
    > won't always be around to log in, and I still want my family to be able to
    > use it. How can I allow the Guest account to access the wireless network?


    I'm not entirely sure (and I can't check on the machine I'm currently using), but
    I believe that the built-in Guest account is more restricted that an ordinary
    limited User account. Try creating a new user account, name it whatever you want
    (e.g., MattsGuests), and see if that works.

    See http://support.microsoft.com/kb/300489/en-us "When you use the Guest account
    to log on ...You cannot access the applications that have already been installed
    on the computer."
     
    Lem, Jan 24, 2006
    #2
    1. Advertising

  3. I actually have my accounts set up how you mentioned. Instead of using the
    Guest account, I created a new account called GuestUser (as a member of the
    Users group). I thought that would help, but I still can't get access to the
    wireless network. Also, I have two icons in the system tray related to the
    wireless network, the one for Windows wireless settings, and one for the
    Broadcom utility that I installed. I noticed that when I open the Broadcom
    utility, the "let this tool manage my wireless settings" checkbox is no
    longer checked. However, if I check it, it goes away the next time I open
    the tool. Also, when I click on the windows network icon in the system tray,
    a security message pops up that says I don't have the necessary priviliges to
    change some of the items on this screen.

    All I want is a second account that can use the internet, but can't install
    programs. I honestly don't care how its done, or what the account is named.
    Its a little aggravating that this is so difficult to accomplish.

    "Lem" wrote:

    > I'm not entirely sure (and I can't check on the machine I'm currently using), but
    > I believe that the built-in Guest account is more restricted that an ordinary
    > limited User account. Try creating a new user account, name it whatever you want
    > (e.g., MattsGuests), and see if that works.
    >
    > See http://support.microsoft.com/kb/300489/en-us "When you use the Guest account
    > to log on ...You cannot access the applications that have already been installed
    > on the computer."
    >
    >
     
    =?Utf-8?B?TWF0dA==?=, Jan 24, 2006
    #3
  4. =?Utf-8?B?TWF0dA==?=

    Lem Guest

    Matt wrote:

    > I actually have my accounts set up how you mentioned. Instead of using the
    > Guest account, I created a new account called GuestUser (as a member of the
    > Users group). I thought that would help, but I still can't get access to the
    > wireless network. Also, I have two icons in the system tray related to the
    > wireless network, the one for Windows wireless settings, and one for the
    > Broadcom utility that I installed. I noticed that when I open the Broadcom
    > utility, the "let this tool manage my wireless settings" checkbox is no
    > longer checked. However, if I check it, it goes away the next time I open
    > the tool. Also, when I click on the windows network icon in the system tray,
    > a security message pops up that says I don't have the necessary priviliges to
    > change some of the items on this screen.
    >
    > All I want is a second account that can use the internet, but can't install
    > programs. I honestly don't care how its done, or what the account is named.
    > Its a little aggravating that this is so difficult to accomplish.
    >
    > "Lem" wrote:
    >
    > > I'm not entirely sure (and I can't check on the machine I'm currently using), but
    > > I believe that the built-in Guest account is more restricted that an ordinary
    > > limited User account. Try creating a new user account, name it whatever you want
    > > (e.g., MattsGuests), and see if that works.
    > >
    > > See http://support.microsoft.com/kb/300489/en-us "When you use the Guest account
    > > to log on ...You cannot access the applications that have already been installed
    > > on the computer."
    > >
    > >


    From an account with administrative privileges:

    In Network Connections, right-click on the wireless connection, select properties,
    select the wireless networks tab, and make sure the "Use Windows to configure ..." box
    is UN checked.

    Disable Windows' Wireless Zero Configuration service: open the Administrative Tools
    control panel and choose Services. Scroll down the list of services and double-click
    Wireless Zero Configuration. Click Stop to end the service now. Select Manual (or
    Disabled) for the Startup Type. [http://www.ifelix.co.uk/tech/2000.html]

    reboot.
     
    Lem, Jan 24, 2006
    #4
  5. I tried disabling the windows wireless zero configuration service, rebooted,
    and logged on as GuestUser, but I still couldn't access the network. I think
    I might just get rid of the GuestUser account, since its pretty much useless.
    I guess no one will use my laptop but me.

    "Lem" wrote:

    >
    > From an account with administrative privileges:
    >
    > In Network Connections, right-click on the wireless connection, select properties,
    > select the wireless networks tab, and make sure the "Use Windows to configure ..." box
    > is UN checked.
    >
    > Disable Windows' Wireless Zero Configuration service: open the Administrative Tools
    > control panel and choose Services. Scroll down the list of services and double-click
    > Wireless Zero Configuration. Click Stop to end the service now. Select Manual (or
    > Disabled) for the Startup Type. [http://www.ifelix.co.uk/tech/2000.html]
    >
    > reboot.
     
    =?Utf-8?B?TWF0dA==?=, Jan 25, 2006
    #5
  6. I use a wireless acount all the time on my XPSP2 laptop from a user
    (non-admin) account, so this should work. However I use the native Windows
    wireless support, no Broadcom extensions. You may want to give that a try.

    You originally said your university required the Broadcom wireless
    configuration tool-- why is that? Does the university have a publicly
    accessible website discussing this?

    thanks

    --
    Frank Schwieterman [MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Matt" <> wrote in message
    news:...
    >I tried disabling the windows wireless zero configuration service,
    >rebooted,
    > and logged on as GuestUser, but I still couldn't access the network. I
    > think
    > I might just get rid of the GuestUser account, since its pretty much
    > useless.
    > I guess no one will use my laptop but me.
    >
    > "Lem" wrote:
    >
    >>
    >> From an account with administrative privileges:
    >>
    >> In Network Connections, right-click on the wireless connection, select
    >> properties,
    >> select the wireless networks tab, and make sure the "Use Windows to
    >> configure ..." box
    >> is UN checked.
    >>
    >> Disable Windows' Wireless Zero Configuration service: open the
    >> Administrative Tools
    >> control panel and choose Services. Scroll down the list of services and
    >> double-click
    >> Wireless Zero Configuration. Click Stop to end the service now. Select
    >> Manual (or
    >> Disabled) for the Startup Type. [http://www.ifelix.co.uk/tech/2000.html]
    >>
    >> reboot.
     
    Frank Schwieterman [MSFT], Jan 25, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?U3ViYmFyYXl1ZHU=?=

    Enabling Internet Access for 'Limited Account' users

    =?Utf-8?B?U3ViYmFyYXl1ZHU=?=, Sep 5, 2004, in forum: Wireless Networking
    Replies:
    11
    Views:
    5,996
    Filippo
    Oct 30, 2008
  2. Netorius77
    Replies:
    1
    Views:
    955
    Jack \(MVP-Networking\).
    May 4, 2008
  3. Fantine

    Wireless Internet Access for Guest Account

    Fantine, Jul 7, 2008, in forum: Wireless Networking
    Replies:
    3
    Views:
    1,119
    smlunatick
    Jul 7, 2008
  4. Giuen
    Replies:
    0
    Views:
    1,012
    Giuen
    Sep 12, 2008
  5. (PeteCresswell)

    "Guest" Account w/o Access To Local Network?

    (PeteCresswell), Jan 15, 2011, in forum: Wireless Networking
    Replies:
    2
    Views:
    3,148
    (PeteCresswell)
    Jan 25, 2011
Loading...

Share This Page