enable 3500 snmp agent

Discussion in 'Cisco' started by sydneypuente@yahoo.com, Mar 21, 2009.

  1. Guest

    Hello,

    Have to give a demo tomorrow - switch has been power cycled and lost
    its IP and also the config for snmp agent.
    Managed to hack around and IP has come back <phew>.
    It only listening on port 23 and 80 tho.
    Please how to enable agent? So a mib-browser can walk the tree.

    TIA

    Syd
     
    , Mar 21, 2009
    #1
    1. Advertising

  2. writes:
    >Have to give a demo tomorrow - switch has been power cycled and lost
    >its IP and also the config for snmp agent.
    >Managed to hack around and IP has come back <phew>.
    >It only listening on port 23 and 80 tho.
    >Please how to enable agent? So a mib-browser can walk the tree.


    The most basic would be

    snmp-server community mycommunity
     
    Doug McIntyre, Mar 21, 2009
    #2
    1. Advertising

  3. Guest

    On 21 Mar, 00:56, Doug McIntyre <> wrote:
    > writes:
    > >Have to give a demo tomorrow - switch has been power cycled and lost
    > >its IP and also the config for snmp agent.
    > >Managed to hack around and IP has come back <phew>.
    > >It only listening on port 23 and 80 tho.
    > >Please how to enable agent? So a mib-browser can walk the tree.

    >
    > The most basic would be
    >
    > snmp-server community mycommunity

    thanks. snmp-server seems to be missing!

    WV11BB-351#snmp-server community fred
    ^
    % Invalid input detected at '^' marker.

    show running
    ...
    snmp-server engineID local xxxxxxx
    snmp-server community xxxxx RW 2
    snmp-server community xxxx RO 3
    snmp-server community public RO
    snmp-server location Warehouse
    snmp-server contact xxxx xxx xxx
    snmp-server system-shutdown
    snmp-server enable traps snmp authentication linkdown linkup coldstart
    snmp-server enable traps vlan-membership
    snmp-server enable traps config
    snmp-server enable traps entity
    snmp-server enable traps hsrp
    snmp-server enable traps c2900
    snmp-server enable traps mac-notification
    snmp-server enable traps vtp
    snmp-server enable traps cluster
    ....

    strange!
    Any obvious explanation?
    TIA
     
    , Mar 23, 2009
    #3
  4. writes:
    >On 21 Mar, 00:56, Doug McIntyre <> wrote:
    >> writes:
    >> >Have to give a demo tomorrow - switch has been power cycled and lost
    >> >its IP and also the config for snmp agent.
    >> >Managed to hack around and IP has come back <phew>.
    >> >It only listening on port 23 and 80 tho.
    >> >Please how to enable agent? So a mib-browser can walk the tree.

    >>
    >> The most basic would be
    >>
    >> snmp-server community mycommunity

    >thanks. snmp-server seems to be missing!


    >WV11BB-351#snmp-server community fred
    > ^
    >% Invalid input detected at '^' marker.



    Yes, its a configuration, not a command. You type commands into the
    basic prompt. You type configurations in config mode (ie. config term).


    >show running
    >..
    >snmp-server engineID local xxxxxxx
    >snmp-server community xxxxx RW 2
    >snmp-server community xxxx RO 3
    >snmp-server community public RO
    >snmp-server location Warehouse
    >snmp-server contact xxxx xxx xxx
    >snmp-server system-shutdown
    >snmp-server enable traps snmp authentication linkdown linkup coldstart
    >snmp-server enable traps vlan-membership
    >snmp-server enable traps config
    >snmp-server enable traps entity
    >snmp-server enable traps hsrp
    >snmp-server enable traps c2900
    >snmp-server enable traps mac-notification
    >snmp-server enable traps vtp
    >snmp-server enable traps cluster
    >...


    >strange!
    >Any obvious explanation?


    Umm, you were trying to type in a configuration in at the command promptÂ?

    But, as your config shows, you already have SNMP configured and
    running on the box.
     
    Doug McIntyre, Mar 23, 2009
    #4
  5. Guest

    On 23 Mar, 12:30, Doug McIntyre <> wrote:
    > writes:
    > >On 21 Mar, 00:56, Doug McIntyre <> wrote:
    > >> writes:
    > >> >Have to give a demo tomorrow - switch has been power cycled and lost
    > >> >its IP and also the config for snmp agent.
    > >> >Managed to hack around and IP has come back <phew>.
    > >> >It only listening on port 23 and 80 tho.
    > >> >Please how to enable agent? So a mib-browser can walk the tree.

    >
    > >> The most basic would be

    >
    > >> snmp-server community mycommunity

    > >thanks. snmp-server seems to be missing!
    > >WV11BB-351#snmp-server community fred
    > >            ^
    > >% Invalid input detected at '^' marker.

    >
    > Yes, its a configuration, not a command. You type commands into the
    > basic prompt. You type configurations in config mode (ie. config term).
    >
    >
    >
    > >show running
    > >..
    > >snmp-server engineID local xxxxxxx
    > >snmp-server community xxxxx RW 2
    > >snmp-server community xxxx RO 3
    > >snmp-server community public RO
    > >snmp-server location Warehouse
    > >snmp-server contact xxxx xxx xxx
    > >snmp-server system-shutdown
    > >snmp-server enable traps snmp authentication linkdown linkup coldstart
    > >snmp-server enable traps vlan-membership
    > >snmp-server enable traps config
    > >snmp-server enable traps entity
    > >snmp-server enable traps hsrp
    > >snmp-server enable traps c2900
    > >snmp-server enable traps mac-notification
    > >snmp-server enable traps vtp
    > >snmp-server enable traps cluster
    > >...
    > >strange!
    > >Any obvious explanation?

    >
    > Umm, you were trying to type in a configuration in at the command promptÂ?
    >
    > But, as your config shows, you already have SNMP configured and
    > running on the box.

    yes I was trying to type a config in at the command prompt -silly me!
    It might be up and running but I dont get any response from a mib
    browser - and the only ports that are said to be open with an nmap
    scan are 23 and 80.
    Please any suggestions on what to do next?

    Syd
     
    , Mar 23, 2009
    #5
  6. bod43 Guest

    On 23 Mar, 13:18, wrote:
    > On 23 Mar, 12:30, Doug McIntyre <> wrote:
    >
    >
    >
    > > writes:
    > > >On 21 Mar, 00:56, Doug McIntyre <> wrote:
    > > >> writes:
    > > >> >Have to give a demo tomorrow - switch has been power cycled and lost
    > > >> >its IP and also the config for snmp agent.
    > > >> >Managed to hack around and IP has come back <phew>.
    > > >> >It only listening on port 23 and 80 tho.
    > > >> >Please how to enable agent? So a mib-browser can walk the tree.

    >
    > > >> The most basic would be

    >
    > > >> snmp-server community mycommunity
    > > >thanks. snmp-server seems to be missing!
    > > >WV11BB-351#snmp-server community fred
    > > >            ^
    > > >% Invalid input detected at '^' marker.

    >
    > > Yes, its a configuration, not a command. You type commands into the
    > > basic prompt. You type configurations in config mode (ie. config term).

    >
    > > >show running
    > > >..
    > > >snmp-server engineID local xxxxxxx
    > > >snmp-server community xxxxx RW 2
    > > >snmp-server community xxxx RO 3
    > > >snmp-server community public RO
    > > >snmp-server location Warehouse
    > > >snmp-server contact xxxx xxx xxx
    > > >snmp-server system-shutdown
    > > >snmp-server enable traps snmp authentication linkdown linkup coldstart
    > > >snmp-server enable traps vlan-membership
    > > >snmp-server enable traps config
    > > >snmp-server enable traps entity
    > > >snmp-server enable traps hsrp
    > > >snmp-server enable traps c2900
    > > >snmp-server enable traps mac-notification
    > > >snmp-server enable traps vtp
    > > >snmp-server enable traps cluster
    > > >...
    > > >strange!
    > > >Any obvious explanation?

    >
    > > Umm, you were trying to type in a configuration in at the command promptÂ?

    >
    > > But, as your config shows, you already have SNMP configured and
    > > running on the box.

    >
    > yes I was trying to type a config in at the command prompt -silly me!
    > It might be up and running but I dont get any response from a mib
    > browser - and the only ports that are said to be open with an nmap
    > scan are 23 and 80.
    > Please any suggestions on what to do next?
    >


    You might have an interface access-list blocking the traffic.
    You *have* access lists 2 and 3 configured for some of your
    community strings.

    Have you tried the community string - public

    You will need routing configured for your traffic.
    Start with the basics:)
    Can you ping or otherwise communicate with the router?

    You might try
    debug snmp requests
    debug snmp packets
    to see if the traffic is reaching the router - and more.
     
    bod43, Mar 23, 2009
    #6
  7. Guest

    On 23 Mar, 13:34, bod43 <> wrote:
    > On 23 Mar, 13:18, wrote:
    >
    >
    >
    > > On 23 Mar, 12:30, Doug McIntyre <> wrote:

    >
    > > > writes:
    > > > >On 21 Mar, 00:56, Doug McIntyre <> wrote:
    > > > >> writes:
    > > > >> >Have to give a demo tomorrow - switch has been power cycled and lost
    > > > >> >its IP and also the config for snmp agent.
    > > > >> >Managed to hack around and IP has come back <phew>.
    > > > >> >It only listening on port 23 and 80 tho.
    > > > >> >Please how to enable agent? So a mib-browser can walk the tree.

    >
    > > > >> The most basic would be

    >
    > > > >> snmp-server community mycommunity
    > > > >thanks. snmp-server seems to be missing!
    > > > >WV11BB-351#snmp-server community fred
    > > > >            ^
    > > > >% Invalid input detected at '^' marker.

    >
    > > > Yes, its a configuration, not a command. You type commands into the
    > > > basic prompt. You type configurations in config mode (ie. config term).

    >
    > > > >show running
    > > > >..
    > > > >snmp-server engineID local xxxxxxx
    > > > >snmp-server community xxxxx RW 2
    > > > >snmp-server community xxxx RO 3
    > > > >snmp-server community public RO
    > > > >snmp-server location Warehouse
    > > > >snmp-server contact xxxx xxx xxx
    > > > >snmp-server system-shutdown
    > > > >snmp-server enable traps snmp authentication linkdown linkup coldstart
    > > > >snmp-server enable traps vlan-membership
    > > > >snmp-server enable traps config
    > > > >snmp-server enable traps entity
    > > > >snmp-server enable traps hsrp
    > > > >snmp-server enable traps c2900
    > > > >snmp-server enable traps mac-notification
    > > > >snmp-server enable traps vtp
    > > > >snmp-server enable traps cluster
    > > > >...
    > > > >strange!
    > > > >Any obvious explanation?

    >
    > > > Umm, you were trying to type in a configuration in at the command promptÂ?

    >
    > > > But, as your config shows, you already have SNMP configured and
    > > > running on the box.

    >
    > > yes I was trying to type a config in at the command prompt -silly me!
    > > It might be up and running but I dont get any response from a mib
    > > browser - and the only ports that are said to be open with an nmap
    > > scan are 23 and 80.
    > > Please any suggestions on what to do next?

    >
    > You might have an interface access-list blocking the traffic.
    > You *have* access lists 2 and 3 configured for some of your
    > community strings.
    >
    > Have you tried the community string  - public
    >
    > You will need routing configured for your traffic.
    > Start with the basics:)
    > Can you ping or otherwise communicate with the router?
    >
    > You might try
    >   debug snmp requests
    >   debug snmp packets
    > to see if the traffic is reaching the router - and more.

    Thanks ! It works now - I set the community string to public and it
    works.
    No sure why tho.
    Thanks again!
     
    , Mar 23, 2009
    #7
  8. writes:
    >It might be up and running but I dont get any response from a mib
    >browser - and the only ports that are said to be open with an nmap
    >scan are 23 and 80.
    >Please any suggestions on what to do next?


    Note, SNMP is transfered over UDP, unlike the TCP ports 23 and 80.
    You'd have to have NMAP specificly do a UDP scan to try to find it.

    But it looks like you just weren't using the correct SNMP community
    (password) from your later post.
     
    Doug McIntyre, Mar 23, 2009
    #8
  9. bod43 Guest

    On 23 Mar, 15:30, wrote:
    > On 23 Mar, 13:34, bod43 <> wrote:
    >
    >
    >
    > > On 23 Mar, 13:18, wrote:

    >
    > > > On 23 Mar, 12:30, Doug McIntyre <> wrote:

    >
    > > > > writes:
    > > > > >On 21 Mar, 00:56, Doug McIntyre <> wrote:
    > > > > >> writes:
    > > > > >> >Have to give a demo tomorrow - switch has been power cycled and lost
    > > > > >> >its IP and also the config for snmp agent.
    > > > > >> >Managed to hack around and IP has come back <phew>.
    > > > > >> >It only listening on port 23 and 80 tho.
    > > > > >> >Please how to enable agent? So a mib-browser can walk the tree.

    >
    > > > > >> The most basic would be

    >
    > > > > >> snmp-server community mycommunity
    > > > > >thanks. snmp-server seems to be missing!
    > > > > >WV11BB-351#snmp-server community fred
    > > > > >            ^
    > > > > >% Invalid input detected at '^' marker.

    >
    > > > > Yes, its a configuration, not a command. You type commands into the
    > > > > basic prompt. You type configurations in config mode (ie. config term).

    >
    > > > > >show running
    > > > > >..
    > > > > >snmp-server engineID local xxxxxxx
    > > > > >snmp-server community xxxxx RW 2
    > > > > >snmp-server community xxxx RO 3
    > > > > >snmp-server community public RO
    > > > > >snmp-server location Warehouse
    > > > > >snmp-server contact xxxx xxx xxx
    > > > > >snmp-server system-shutdown
    > > > > >snmp-server enable traps snmp authentication linkdown linkup coldstart
    > > > > >snmp-server enable traps vlan-membership
    > > > > >snmp-server enable traps config
    > > > > >snmp-server enable traps entity
    > > > > >snmp-server enable traps hsrp
    > > > > >snmp-server enable traps c2900
    > > > > >snmp-server enable traps mac-notification
    > > > > >snmp-server enable traps vtp
    > > > > >snmp-server enable traps cluster
    > > > > >...
    > > > > >strange!
    > > > > >Any obvious explanation?

    >
    > > > > Umm, you were trying to type in a configuration in at the command promptÂ?

    >
    > > > > But, as your config shows, you already have SNMP configured and
    > > > > running on the box.

    >
    > > > yes I was trying to type a config in at the command prompt -silly me!
    > > > It might be up and running but I dont get any response from a mib
    > > > browser - and the only ports that are said to be open with an nmap
    > > > scan are 23 and 80.
    > > > Please any suggestions on what to do next?

    >
    > > You might have an interface access-list blocking the traffic.
    > > You *have* access lists 2 and 3 configured for some of your
    > > community strings.

    >
    > > Have you tried the community string  - public

    >
    > > You will need routing configured for your traffic.
    > > Start with the basics:)
    > > Can you ping or otherwise communicate with the router?

    >
    > > You might try
    > >   debug snmp requests
    > >   debug snmp packets
    > > to see if the traffic is reaching the router - and more.

    >
    > Thanks ! It works now - I set the community string to public and it
    > works.
    > No sure why tho.


    The other community strings you listed have access
    restrictions by client ip address - if access-lists
    "2" or "3" are defined.

    snmp-server community xxxxx RW 2
    snmp-server community xxxx RO 3


    sh access-list

    will list them, or of course they will be in the config.
     
    bod43, Mar 23, 2009
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Craig B.

    Change enable password via SNMP

    Craig B., Oct 5, 2004, in forum: Cisco
    Replies:
    1
    Views:
    8,413
    Andrej Brkic
    Oct 15, 2004
  2. John Oliver

    Enable SNMP on PIX 515?

    John Oliver, May 17, 2006, in forum: Cisco
    Replies:
    5
    Views:
    14,719
    John Oliver
    May 17, 2006
  3. Vimokh
    Replies:
    3
    Views:
    5,946
    Vimokh
    Sep 6, 2006
  4. Frisbee®
    Replies:
    0
    Views:
    480
    Frisbee®
    Feb 8, 2007
  5. Replies:
    4
    Views:
    820
Loading...

Share This Page