EIGRP on Lanlink interfaces

Discussion in 'Cisco' started by andre.wisniewski@gmx.de, Dec 14, 2006.

  1. Guest

    Hello all

    I am runnning two Cisco 2801 with IOS 12.3(8)T6. Both Routers are
    connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
    and EIGRP are configured this way

    Router A

    interface FastEthernet0/0
    ip address 10.10.10.3 255.255.255.0
    speed 100
    full-duplex
    standby 150 ip 10.10.10.5
    standby 150 timers 1 3
    standby 150 priority 110
    standby 150 preempt
    standby 150 track FastEthernet0/1

    interface FastEthernet0/1
    ip address 170.11.1.253 255.255.255.0
    standby 152 ip 170.11.1.1
    standby 152 timers 1 3
    standby 152 priority 110
    standby 152 preempt
    standby 152 track FastEthernet0/0

    router eigrp 150
    redistribute static
    network 10.0.0.0
    network 170.11.0.0
    no auto-summary

    ip route 0.0.0.0 0.0.0.0 10.10.10.1
    ip route 172.19.70.0 255.255.255.0 170.11.1.4
    ip route 172.25.11.0 255.255.255.0 170.11.1.4

    Router B

    interface FastEthernet0/0
    ip address 10.10.10.4 255.255.255.0
    speed 100
    full-duplex
    standby 150 ip 10.10.10.5
    standby 150 timers 1 3
    standby 150 priority 105
    standby 150 preempt
    standby 150 track FastEthernet0/1

    interface FastEthernet0/1
    ip address 170.11.1.254 255.255.255.0
    standby 152 ip 170.11.1.1
    standby 152 timers 1 3
    standby 152 priority 105
    standby 152 preempt
    standby 152 track FastEthernet0/0

    router eigrp 150
    redistribute static
    network 10.0.0.0
    network 170.11.0.0
    no auto-summary

    ip route 0.0.0.0 0.0.0.0 10.10.10.1
    ip route 172.19.70.0 255.255.255.0 170.11.1.4
    ip route 172.25.11.0 255.255.255.0 170.11.1.4

    Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
    fa0/0 is connected to a switch on local side.
    If Lanlink on Router A fails interface fa0/1 stays up because
    connection to modem is still ok but remote network is not reachable any
    more via this interface.
    HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
    eigrp".
    What can i do to fix this issue?

    Thanks in advance.

    Andre Wisniewski
     
    , Dec 14, 2006
    #1
    1. Advertising

  2. stephen Guest

    <> wrote in message
    news:...
    > Hello all
    >
    > I am runnning two Cisco 2801 with IOS 12.3(8)T6. Both Routers are
    > connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
    > and EIGRP are configured this way
    >
    > Router A
    >
    > interface FastEthernet0/0
    > ip address 10.10.10.3 255.255.255.0
    > speed 100
    > full-duplex
    > standby 150 ip 10.10.10.5
    > standby 150 timers 1 3
    > standby 150 priority 110
    > standby 150 preempt
    > standby 150 track FastEthernet0/1
    >
    > interface FastEthernet0/1
    > ip address 170.11.1.253 255.255.255.0
    > standby 152 ip 170.11.1.1
    > standby 152 timers 1 3
    > standby 152 priority 110
    > standby 152 preempt
    > standby 152 track FastEthernet0/0
    >
    > router eigrp 150
    > redistribute static
    > network 10.0.0.0
    > network 170.11.0.0
    > no auto-summary
    >
    > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > ip route 172.25.11.0 255.255.255.0 170.11.1.4
    >
    > Router B
    >
    > interface FastEthernet0/0
    > ip address 10.10.10.4 255.255.255.0
    > speed 100
    > full-duplex
    > standby 150 ip 10.10.10.5
    > standby 150 timers 1 3
    > standby 150 priority 105
    > standby 150 preempt
    > standby 150 track FastEthernet0/1
    >
    > interface FastEthernet0/1
    > ip address 170.11.1.254 255.255.255.0
    > standby 152 ip 170.11.1.1
    > standby 152 timers 1 3
    > standby 152 priority 105
    > standby 152 preempt
    > standby 152 track FastEthernet0/0
    >
    > router eigrp 150
    > redistribute static
    > network 10.0.0.0
    > network 170.11.0.0
    > no auto-summary
    >
    > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > ip route 172.25.11.0 255.255.255.0 170.11.1.4
    >
    > Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
    > fa0/0 is connected to a switch on local side.
    > If Lanlink on Router A fails interface fa0/1 stays up because
    > connection to modem is still ok but remote network is not reachable any
    > more via this interface.
    > HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
    > eigrp".
    > What can i do to fix this issue?


    i am not sure i understand your topology - are the 2801 on the same or
    different sites?

    use "object tracking" to let HSRP switch based on access to an address or
    routing table contents.
    http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801d2d74.html

    maybe the 2 routers should be exchanging routes over the HSRP interface, so
    they should have a routed path between them - that will also "fix" some
    transitional forwarding black holes when the network topology changes.

    personally i would use OSPF instead - at least you can predict what it will
    do :)

    >
    > Thanks in advance.
    >
    > Andre Wisniewski
    >

    --
    Regards

    - replace xyz with ntl
     
    stephen, Dec 14, 2006
    #2
    1. Advertising

  3. Andre Guest

    On 14 Dez., 22:23, "stephen" <> wrote:
    > <> wrote in messagenews:...
    >
    >
    >
    > > Hello all

    >
    > > I am runnning two Cisco 2801 with IOS 12.3(8)T6. Both Routers are
    > > connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
    > > and EIGRP are configured this way

    >
    > > Router A

    >
    > > interface FastEthernet0/0
    > > ip address 10.10.10.3 255.255.255.0
    > > speed 100
    > > full-duplex
    > > standby 150 ip 10.10.10.5
    > > standby 150 timers 1 3
    > > standby 150 priority 110
    > > standby 150 preempt
    > > standby 150 track FastEthernet0/1

    >
    > > interface FastEthernet0/1
    > > ip address 170.11.1.253 255.255.255.0
    > > standby 152 ip 170.11.1.1
    > > standby 152 timers 1 3
    > > standby 152 priority 110
    > > standby 152 preempt
    > > standby 152 track FastEthernet0/0

    >
    > > router eigrp 150
    > > redistribute static
    > > network 10.0.0.0
    > > network 170.11.0.0
    > > no auto-summary

    >
    > > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > > ip route 172.25.11.0 255.255.255.0 170.11.1.4

    >
    > > Router B

    >
    > > interface FastEthernet0/0
    > > ip address 10.10.10.4 255.255.255.0
    > > speed 100
    > > full-duplex
    > > standby 150 ip 10.10.10.5
    > > standby 150 timers 1 3
    > > standby 150 priority 105
    > > standby 150 preempt
    > > standby 150 track FastEthernet0/1

    >
    > > interface FastEthernet0/1
    > > ip address 170.11.1.254 255.255.255.0
    > > standby 152 ip 170.11.1.1
    > > standby 152 timers 1 3
    > > standby 152 priority 105
    > > standby 152 preempt
    > > standby 152 track FastEthernet0/0

    >
    > > router eigrp 150
    > > redistribute static
    > > network 10.0.0.0
    > > network 170.11.0.0
    > > no auto-summary

    >
    > > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > > ip route 172.25.11.0 255.255.255.0 170.11.1.4

    >
    > > Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
    > > fa0/0 is connected to a switch on local side.
    > > If Lanlink on Router A fails interface fa0/1 stays up because
    > > connection to modem is still ok but remote network is not reachable any
    > > more via this interface.
    > > HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
    > > eigrp".
    > > What can i do to fix this issue?i am not sure i understand your topology - are the 2801 on the same or

    > different sites?

    They are on the same site.
    >
    > use "object tracking" to let HSRP switch based on access to an address or
    > routing table contents.http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_featu...
    >

    OK. I will have a look at it
    > maybe the 2 routers should be exchanging routes over the HSRP interface, so
    > they should have a routed path between them - that will also "fix" some
    > transitional forwarding black holes when the network topology changes.
    >
    > personally i would use OSPF instead - at least you can predict what it will
    > do :)

    It's worth thinking about it. Thanks so far.
    >
    >
    >
    > > Thanks in advance.

    >
    > > Andre Wisniewski--

    > Regards
    >
    > - replace xyz with ntl
     
    Andre, Dec 15, 2006
    #3
  4. Andre Guest

    On 14 Dez. 2006, 22:23, "stephen" <> wrote:
    > <> wrote in messagenews:...
    >
    >
    >
    > > Hello all

    >
    > > I am runnning two Cisco 2801 with IOS 12.3(8)T6. Both Routers are
    > > connected (fa0/0) to network 10.10.10.0 and 170.11.1.0 (fa0/1). HSRP
    > > and EIGRP are configured this way

    >
    > > Router A

    >
    > > interface FastEthernet0/0
    > > ip address 10.10.10.3 255.255.255.0
    > > speed 100
    > > full-duplex
    > > standby 150 ip 10.10.10.5
    > > standby 150 timers 1 3
    > > standby 150 priority 110
    > > standby 150 preempt
    > > standby 150 track FastEthernet0/1

    >
    > > interface FastEthernet0/1
    > > ip address 170.11.1.253 255.255.255.0
    > > standby 152 ip 170.11.1.1
    > > standby 152 timers 1 3
    > > standby 152 priority 110
    > > standby 152 preempt
    > > standby 152 track FastEthernet0/0

    >
    > > router eigrp 150
    > > redistribute static
    > > network 10.0.0.0
    > > network 170.11.0.0
    > > no auto-summary

    >
    > > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > > ip route 172.25.11.0 255.255.255.0 170.11.1.4

    >
    > > Router B

    >
    > > interface FastEthernet0/0
    > > ip address 10.10.10.4 255.255.255.0
    > > speed 100
    > > full-duplex
    > > standby 150 ip 10.10.10.5
    > > standby 150 timers 1 3
    > > standby 150 priority 105
    > > standby 150 preempt
    > > standby 150 track FastEthernet0/1

    >
    > > interface FastEthernet0/1
    > > ip address 170.11.1.254 255.255.255.0
    > > standby 152 ip 170.11.1.1
    > > standby 152 timers 1 3
    > > standby 152 priority 105
    > > standby 152 preempt
    > > standby 152 track FastEthernet0/0

    >
    > > router eigrp 150
    > > redistribute static
    > > network 10.0.0.0
    > > network 170.11.0.0
    > > no auto-summary

    >
    > > ip route 0.0.0.0 0.0.0.0 10.10.10.1
    > > ip route 172.19.70.0 255.255.255.0 170.11.1.4
    > > ip route 172.25.11.0 255.255.255.0 170.11.1.4

    >
    > > Interfaces fa0/1 are connected to a switch via Lanlink on remote side,
    > > fa0/0 is connected to a switch on local side.
    > > If Lanlink on Router A fails interface fa0/1 stays up because
    > > connection to modem is still ok but remote network is not reachable any
    > > more via this interface.
    > > HSRP doesn't switch of course. I can't see any eigrp route "sh ip route
    > > eigrp".
    > > What can i do to fix this issue?i am not sure i understand your topology - are the 2801 on the same or

    > different sites?
    >
    > use "object tracking" to let HSRP switch based on access to an address or
    > routing table contents.http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_featu...


    Very helpful answer. Thanks a lot.
    Here is my solution.

    I added ...

    track 100 rtr 1 reachability
    delay down 3 up 3

    interface FastEthernet0/0
    standby 150 track 100 decrement 50

    ip sla 1
    icmp-echo 170.11.1.23
    request-data-size 512
    timeout 1000
    threshold 2
    frequency 3

    ip sla schedule 1 life forever start-time now

    >
    > maybe the 2 routers should be exchanging routes over the HSRP interface, so
    > they should have a routed path between them - that will also "fix" some
    > transitional forwarding black holes when the network topology changes.
    >
    > personally i would use OSPF instead - at least you can predict what it will
    > do :)
    >
    >
    >
    > > Thanks in advance.

    >
    > > Andre Wisniewski--

    > Regards
    >
    > - replace xyz with ntl
     
    Andre, Jan 9, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Kenny D
    Replies:
    1
    Views:
    1,232
    Alois Heilmaier
    Jul 14, 2003
  2. Sam Soh
    Replies:
    5
    Views:
    8,020
    Sam Soh
    Aug 15, 2003
  3. Hansang Bae

    Re: EiGRP authentication question

    Hansang Bae, Oct 14, 2003, in forum: Cisco
    Replies:
    3
    Views:
    1,187
    Hansang Bae
    Oct 16, 2003
  4. Ghazan Haider

    EIGRP fails on nonbroadcast interfaces

    Ghazan Haider, Jan 1, 2004, in forum: Cisco
    Replies:
    10
    Views:
    2,703
    scott enwright
    Jan 3, 2004
  5. BG
    Replies:
    3
    Views:
    6,744
Loading...

Share This Page