EIGRP for failover

Discussion in 'Cisco' started by Jaime Blanco, Jul 12, 2004.

  1. Jaime Blanco

    Jaime Blanco Guest

    I am trying to set up EIGRP to get failover o a second link. Below is
    the topology of my network and partial configurations. The problem is
    that when the link thru the service provider goes down the Switch
    3512G keeps seeing the route to 192.168.241.0 as a directly connected
    route and does not failover thru the router 3661 and the serial links.
    The Router 3661 keeps seeing the route 192.168.241.0 thru the Switch
    3512G. If I shut the VLAN 767 down then the SW3512G sees the route
    192.168.241.0 thru the router 3661 and the serial links.

    On the router 3661 I can see the neighbors 192.168.251.6 and
    172.16.2.7. On the SW 3512G I can see the neighbors 172.16.2.2 and
    192.168.251.6.

    Any help is appreciate.

    Thanks.
    Jaime
    PCs at:
    192.168.241.0
    Gateway:
    192.168.241.6
    / PCs
    _____________ :192.168.241.6 ____________ /
    | 2610 Router |e0__________________|3512 Switch |__
    |_____________| |____________|\
    |S0: 192.168.251.6 | \ PCs
    | |
    | ________________
    | / \
    | | Service Provider |
    | \ ________________/
    |
    | |
    | |
    | |
    |S0: 192.168.251.5 |VlAN767: 192.168.241.1
    _____________ ____|_______
    | Router 3661 |____________________|Switch 3512G|
    |_____________| |____________|
    FE0/0: 172.16.2.2 VLAN1: 172.16.2.7



    ROUTER 3661 AT HEADQUARTERS

    interface FastEthernet0/0
    ip address 172.16.0.2 255.255.254.0 secondary
    ip address 172.16.2.2 255.255.254.0
    speed 100
    full-duplex

    router eigrp 100
    network 172.16.0.0
    network 192.168.241.0
    auto-summary
    !
    ip default-gateway 192.168.250.17
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.250.17
    ip route 10.1.1.0 255.255.255.0 FastEthernet0/0.10
    ip route 10.1.2.0 255.255.255.0 172.16.2.7
    ip route 172.16.0.0 255.255.254.0 FastEthernet0/0
    ip route 192.168.0.32 255.255.255.224 172.16.2.7
    ip route 192.168.0.64 255.255.255.224 172.16.2.7
    ip route 192.168.0.96 255.255.255.224 172.16.2.7
    ip route 192.168.0.128 255.255.255.224 172.16.2.7
    ip route 192.168.0.160 255.255.255.224 172.16.2.5
    ip route 192.168.0.192 255.255.255.224 172.16.2.7
    ip route 192.168.1.0 255.255.255.0 172.16.2.7
    ip route 192.168.240.0 255.255.255.0 172.16.2.7
    ip route 192.168.241.0 255.255.255.0 172.16.2.7
    ip route 192.168.241.0 255.255.255.0 192.168.251.6 2
    ip route 192.205.0.0 255.255.255.0 172.16.2.7



    SWITCH 3512G AT HEADQUARTERS

    interface Vlan767
    description BRACH OFFICE
    bandwidth 1024
    ip address 192.168.241.1 255.255.255.0

    interface GigabitEthernet0/11
    description LINK TO SERVICE PROVIDER
    switchport trunk encapsulation dot1q
    switchport mode trunk
    bandwidth 4096
    duplex full
    speed 10
    mls qos trust cos
    auto qos voip trust
    wrr-queue bandwidth 20 1 80 1
    wrr-queue queue-limit 80 1 20 1
    wrr-queue cos-map 1 0 1 2 4
    wrr-queue cos-map 3 3 6 7
    wrr-queue cos-map 4 5
    priority-queue out

    router eigrp 100
    network 192.168.241.0
    network 172.16.0.0
    no auto-summary


    ROUTER 2610 at BRANCH OFFICE

    interface Ethernet0/0
    ip address 192.168.241.6 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    description REDUNDANT LINK TO HEADQUARTERS
    bandwidth 256
    ip address 192.168.251.6 255.255.255.252
    !
    router eigrp 100
    network 192.168.241.0
    network 192.168.251.0
    no auto-summary
    !
    ip default-gateway 192.168.241.1
    ip kerberos source-interface any
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.241.1
    ip route 0.0.0.0 0.0.0.0 192.168.251.5 150
    Jaime Blanco, Jul 12, 2004
    #1
    1. Advertising

  2. Jaime Blanco

    PES Guest

    You will have to disconnect the ethernet cable to lose the route. Otherwise
    you could implement a routing protocol between the 3512G and the service
    provider.

    One other alternative would be ping based tracking with PBR in the 3661.
    This would require a static route for the gw at the provider to be
    configured as a host route in the routing table of the 3661 pointing at the
    3512G. If the 3661 cannot ping the address, policy routing will not forward
    the traffic to the 3512G. Please note that I have not done this before. If
    I understand it correctly, it will not modify the routing table or process.
    Therefore, it would be a route-map configured on a per interface basis.
    Therefore if you have multiple remote sites that you would like to redirect
    as well, scalability is going to be an issue.

    For configuration examples look at:

    http://tinyurl.com/2dhte


    "Jaime Blanco" <> wrote in message
    news:...
    > I am trying to set up EIGRP to get failover o a second link. Below is
    > the topology of my network and partial configurations. The problem is
    > that when the link thru the service provider goes down the Switch
    > 3512G keeps seeing the route to 192.168.241.0 as a directly connected
    > route and does not failover thru the router 3661 and the serial links.
    > The Router 3661 keeps seeing the route 192.168.241.0 thru the Switch
    > 3512G. If I shut the VLAN 767 down then the SW3512G sees the route
    > 192.168.241.0 thru the router 3661 and the serial links.
    >
    > On the router 3661 I can see the neighbors 192.168.251.6 and
    > 172.16.2.7. On the SW 3512G I can see the neighbors 172.16.2.2 and
    > 192.168.251.6.
    >
    > Any help is appreciate.
    >
    > Thanks.
    > Jaime
    > PCs at:
    > 192.168.241.0
    > Gateway:
    > 192.168.241.6
    > / PCs
    > _____________ :192.168.241.6 ____________ /
    > | 2610 Router |e0__________________|3512 Switch |__
    > |_____________| |____________|\
    > |S0: 192.168.251.6 | \ PCs
    > | |
    > | ________________
    > | / \
    > | | Service Provider |
    > | \ ________________/
    > |
    > | |
    > | |
    > | |
    > |S0: 192.168.251.5 |VlAN767: 192.168.241.1
    > _____________ ____|_______
    > | Router 3661 |____________________|Switch 3512G|
    > |_____________| |____________|
    > FE0/0: 172.16.2.2 VLAN1: 172.16.2.7
    >
    >
    >
    > ROUTER 3661 AT HEADQUARTERS
    >
    > interface FastEthernet0/0
    > ip address 172.16.0.2 255.255.254.0 secondary
    > ip address 172.16.2.2 255.255.254.0
    > speed 100
    > full-duplex
    >
    > router eigrp 100
    > network 172.16.0.0
    > network 192.168.241.0
    > auto-summary
    > !
    > ip default-gateway 192.168.250.17
    > ip http server
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.250.17
    > ip route 10.1.1.0 255.255.255.0 FastEthernet0/0.10
    > ip route 10.1.2.0 255.255.255.0 172.16.2.7
    > ip route 172.16.0.0 255.255.254.0 FastEthernet0/0
    > ip route 192.168.0.32 255.255.255.224 172.16.2.7
    > ip route 192.168.0.64 255.255.255.224 172.16.2.7
    > ip route 192.168.0.96 255.255.255.224 172.16.2.7
    > ip route 192.168.0.128 255.255.255.224 172.16.2.7
    > ip route 192.168.0.160 255.255.255.224 172.16.2.5
    > ip route 192.168.0.192 255.255.255.224 172.16.2.7
    > ip route 192.168.1.0 255.255.255.0 172.16.2.7
    > ip route 192.168.240.0 255.255.255.0 172.16.2.7
    > ip route 192.168.241.0 255.255.255.0 172.16.2.7
    > ip route 192.168.241.0 255.255.255.0 192.168.251.6 2
    > ip route 192.205.0.0 255.255.255.0 172.16.2.7
    >
    >
    >
    > SWITCH 3512G AT HEADQUARTERS
    >
    > interface Vlan767
    > description BRACH OFFICE
    > bandwidth 1024
    > ip address 192.168.241.1 255.255.255.0
    >
    > interface GigabitEthernet0/11
    > description LINK TO SERVICE PROVIDER
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    > bandwidth 4096
    > duplex full
    > speed 10
    > mls qos trust cos
    > auto qos voip trust
    > wrr-queue bandwidth 20 1 80 1
    > wrr-queue queue-limit 80 1 20 1
    > wrr-queue cos-map 1 0 1 2 4
    > wrr-queue cos-map 3 3 6 7
    > wrr-queue cos-map 4 5
    > priority-queue out
    >
    > router eigrp 100
    > network 192.168.241.0
    > network 172.16.0.0
    > no auto-summary
    >
    >
    > ROUTER 2610 at BRANCH OFFICE
    >
    > interface Ethernet0/0
    > ip address 192.168.241.6 255.255.255.0
    > half-duplex
    > !
    > interface Serial0/0
    > description REDUNDANT LINK TO HEADQUARTERS
    > bandwidth 256
    > ip address 192.168.251.6 255.255.255.252
    > !
    > router eigrp 100
    > network 192.168.241.0
    > network 192.168.251.0
    > no auto-summary
    > !
    > ip default-gateway 192.168.241.1
    > ip kerberos source-interface any
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.241.1
    > ip route 0.0.0.0 0.0.0.0 192.168.251.5 150
    PES, Jul 12, 2004
    #2
    1. Advertising

  3. Jaime Blanco

    Jaime Blanco Guest

    What about to use GRE tunneling?

    Any other alternative?

    Thanks in advance.
    Jaime


    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message news:<40f25968$>...
    > You will have to disconnect the ethernet cable to lose the route. Otherwise
    > you could implement a routing protocol between the 3512G and the service
    > provider.
    >
    > One other alternative would be ping based tracking with PBR in the 3661.
    > This would require a static route for the gw at the provider to be
    > configured as a host route in the routing table of the 3661 pointing at the
    > 3512G. If the 3661 cannot ping the address, policy routing will not forward
    > the traffic to the 3512G. Please note that I have not done this before. If
    > I understand it correctly, it will not modify the routing table or process.
    > Therefore, it would be a route-map configured on a per interface basis.
    > Therefore if you have multiple remote sites that you would like to redirect
    > as well, scalability is going to be an issue.
    >
    > For configuration examples look at:
    >
    > http://tinyurl.com/2dhte
    >
    >
    > "Jaime Blanco" <> wrote in message
    > news:...
    > > I am trying to set up EIGRP to get failover o a second link. Below is
    > > the topology of my network and partial configurations. The problem is
    > > that when the link thru the service provider goes down the Switch
    > > 3512G keeps seeing the route to 192.168.241.0 as a directly connected
    > > route and does not failover thru the router 3661 and the serial links.
    > > The Router 3661 keeps seeing the route 192.168.241.0 thru the Switch
    > > 3512G. If I shut the VLAN 767 down then the SW3512G sees the route
    > > 192.168.241.0 thru the router 3661 and the serial links.
    > >
    > > On the router 3661 I can see the neighbors 192.168.251.6 and
    > > 172.16.2.7. On the SW 3512G I can see the neighbors 172.16.2.2 and
    > > 192.168.251.6.
    > >
    > > Any help is appreciate.
    > >
    > > Thanks.
    > > Jaime
    > > PCs at:
    > > 192.168.241.0
    > > Gateway:
    > > 192.168.241.6
    > > / PCs
    > > _____________ :192.168.241.6 ____________ /
    > > | 2610 Router |e0__________________|3512 Switch |__
    > > |_____________| |____________|\
    > > |S0: 192.168.251.6 | \ PCs
    > > | |
    > > | ________________

    > | / \
    > > | | Service Provider |
    > > | \ ________________/
    > > |
    > > | |
    > > | |
    > > | |
    > > |S0: 192.168.251.5 |VlAN767: 192.168.241.1

    > _____________ ____|_______
    > > | Router 3661 |____________________|Switch 3512G|
    > > |_____________| |____________|
    > > FE0/0: 172.16.2.2 VLAN1: 172.16.2.7
    > >
    > >
    > >
    > > ROUTER 3661 AT HEADQUARTERS
    > >
    > > interface FastEthernet0/0
    > > ip address 172.16.0.2 255.255.254.0 secondary
    > > ip address 172.16.2.2 255.255.254.0
    > > speed 100
    > > full-duplex
    > >
    > > router eigrp 100
    > > network 172.16.0.0
    > > network 192.168.241.0
    > > auto-summary
    > > !
    > > ip default-gateway 192.168.250.17
    > > ip http server
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 192.168.250.17
    > > ip route 10.1.1.0 255.255.255.0 FastEthernet0/0.10
    > > ip route 10.1.2.0 255.255.255.0 172.16.2.7
    > > ip route 172.16.0.0 255.255.254.0 FastEthernet0/0
    > > ip route 192.168.0.32 255.255.255.224 172.16.2.7
    > > ip route 192.168.0.64 255.255.255.224 172.16.2.7
    > > ip route 192.168.0.96 255.255.255.224 172.16.2.7
    > > ip route 192.168.0.128 255.255.255.224 172.16.2.7
    > > ip route 192.168.0.160 255.255.255.224 172.16.2.5
    > > ip route 192.168.0.192 255.255.255.224 172.16.2.7
    > > ip route 192.168.1.0 255.255.255.0 172.16.2.7
    > > ip route 192.168.240.0 255.255.255.0 172.16.2.7
    > > ip route 192.168.241.0 255.255.255.0 172.16.2.7
    > > ip route 192.168.241.0 255.255.255.0 192.168.251.6 2
    > > ip route 192.205.0.0 255.255.255.0 172.16.2.7
    > >
    > >
    > >
    > > SWITCH 3512G AT HEADQUARTERS
    > >
    > > interface Vlan767
    > > description BRACH OFFICE
    > > bandwidth 1024
    > > ip address 192.168.241.1 255.255.255.0
    > >
    > > interface GigabitEthernet0/11
    > > description LINK TO SERVICE PROVIDER
    > > switchport trunk encapsulation dot1q
    > > switchport mode trunk
    > > bandwidth 4096
    > > duplex full
    > > speed 10
    > > mls qos trust cos
    > > auto qos voip trust
    > > wrr-queue bandwidth 20 1 80 1
    > > wrr-queue queue-limit 80 1 20 1
    > > wrr-queue cos-map 1 0 1 2 4
    > > wrr-queue cos-map 3 3 6 7
    > > wrr-queue cos-map 4 5
    > > priority-queue out
    > >
    > > router eigrp 100
    > > network 192.168.241.0
    > > network 172.16.0.0
    > > no auto-summary
    > >
    > >
    > > ROUTER 2610 at BRANCH OFFICE
    > >
    > > interface Ethernet0/0
    > > ip address 192.168.241.6 255.255.255.0
    > > half-duplex
    > > !
    > > interface Serial0/0
    > > description REDUNDANT LINK TO HEADQUARTERS
    > > bandwidth 256
    > > ip address 192.168.251.6 255.255.255.252
    > > !
    > > router eigrp 100
    > > network 192.168.241.0
    > > network 192.168.251.0
    > > no auto-summary
    > > !
    > > ip default-gateway 192.168.241.1
    > > ip kerberos source-interface any
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 192.168.241.1
    > > ip route 0.0.0.0 0.0.0.0 192.168.251.5 150
    Jaime Blanco, Jul 13, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. David
    Replies:
    0
    Views:
    2,486
    David
    Nov 12, 2003
  2. Michael Letchworth

    EIGRP failover problems

    Michael Letchworth, Mar 21, 2005, in forum: Cisco
    Replies:
    2
    Views:
    2,204
    Hansang Bae
    Mar 22, 2005
  3. Replies:
    1
    Views:
    1,420
    Vincent C Jones
    Jul 6, 2005
  4. BG
    Replies:
    3
    Views:
    6,565
  5. Giuen
    Replies:
    0
    Views:
    667
    Giuen
    Sep 12, 2008
Loading...

Share This Page