EIGRP fails on nonbroadcast interfaces

Discussion in 'Cisco' started by Ghazan Haider, Jan 1, 2004.

  1. I have a reasonably complex network where EIGRP apparently fails to
    see neighbors on nonbroadcast interfaces despite the 'neighbor
    x.x.x.x' specification. This works perfect with IGRP. (yeah I know
    routing protocols dont broadcast on nonbroadcast interfaces and
    neighbor has to be specified).

    'sh ip eig nei' shows no neighbors on routers with X25 interfaces
    only, and only shows ethernet/tr neighbors on routers with such
    connections.

    I have been studying using the sybex CCNP BSCI book, and it shows
    configs of EIGRP on serial interfaces that should 'work' normal... as
    in conf t, router eigrp 100, network 10.0.10.0, neighbor 10.0.10.3,
    etc... and my configs arent too different from it. Heres one routers
    config. Routers connected on all its interfaces have EIGRP of the same
    AS:

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname twenty
    !
    !
    ip subnet-zero
    !
    !
    !
    interface Serial0
    ip address 10.0.20.20 255.255.255.0
    no ip directed-broadcast
    encapsulation x25
    no ip mroute-cache
    no keepalive
    x25 address 200
    x25 map ip 10.0.20.10 100
    clockrate 4000000
    no cdp enable
    !
    interface Serial1
    ip address 10.0.22.20 255.255.255.0
    no ip directed-broadcast
    encapsulation x25 dce
    no ip mroute-cache
    x25 address 201
    x25 map ip 10.0.22.40 401
    no cdp enable
    !
    interface TokenRing0
    ip address 10.0.10.20 255.255.255.0
    no ip directed-broadcast
    ring-speed 16
    no cdp enable
    !
    interface TokenRing1
    ip address 10.0.13.20 255.255.255.0
    no ip directed-broadcast
    ring-speed 16
    no cdp enable
    !
    router eigrp 100
    network 10.0.0.0
    neighbor 10.0.22.40
    neighbor 10.0.20.10
    !
    ip classless
    !
    no cdp run
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    login
    !
    end

    twenty#




    ================
    And heres the output of

    twenty#sh ip eigrp ne
    IP-EIGRP neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q
    Seq
    (sec) (ms) Cnt
    Num
    0 10.0.10.10 To0 10 00:16:16 446 2676 0 2
    twenty#


    which shows the only neighbor seen across the tokenring hub.

    Any ideas?
    Ghazan Haider, Jan 1, 2004
    #1
    1. Advertising

  2. Ghazan,

    Configuration looks ok from what I can tell. I'd be very interested in
    seeing the output from the commands:

    ping 10.0.22.40
    ping 10.0.20.10
    debug ip eigrp 100
    debug ip eigrp neighbor 100 10.0.22.40
    debug ip eigrp neighbor 100 10.0.20.10
    debug eigrp packets

    Regards,

    Scott.

    "Ghazan Haider" <> wrote in message
    news:...
    > I have a reasonably complex network where EIGRP apparently fails to
    > see neighbors on nonbroadcast interfaces despite the 'neighbor
    > x.x.x.x' specification. This works perfect with IGRP. (yeah I know
    > routing protocols dont broadcast on nonbroadcast interfaces and
    > neighbor has to be specified).
    >
    > 'sh ip eig nei' shows no neighbors on routers with X25 interfaces
    > only, and only shows ethernet/tr neighbors on routers with such
    > connections.
    >
    > I have been studying using the sybex CCNP BSCI book, and it shows
    > configs of EIGRP on serial interfaces that should 'work' normal... as
    > in conf t, router eigrp 100, network 10.0.10.0, neighbor 10.0.10.3,
    > etc... and my configs arent too different from it. Heres one routers
    > config. Routers connected on all its interfaces have EIGRP of the same
    > AS:
    >
    > Current configuration:
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname twenty
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > interface Serial0
    > ip address 10.0.20.20 255.255.255.0
    > no ip directed-broadcast
    > encapsulation x25
    > no ip mroute-cache
    > no keepalive
    > x25 address 200
    > x25 map ip 10.0.20.10 100
    > clockrate 4000000
    > no cdp enable
    > !
    > interface Serial1
    > ip address 10.0.22.20 255.255.255.0
    > no ip directed-broadcast
    > encapsulation x25 dce
    > no ip mroute-cache
    > x25 address 201
    > x25 map ip 10.0.22.40 401
    > no cdp enable
    > !
    > interface TokenRing0
    > ip address 10.0.10.20 255.255.255.0
    > no ip directed-broadcast
    > ring-speed 16
    > no cdp enable
    > !
    > interface TokenRing1
    > ip address 10.0.13.20 255.255.255.0
    > no ip directed-broadcast
    > ring-speed 16
    > no cdp enable
    > !
    > router eigrp 100
    > network 10.0.0.0
    > neighbor 10.0.22.40
    > neighbor 10.0.20.10
    > !
    > ip classless
    > !
    > no cdp run
    > !
    > line con 0
    > transport input none
    > line aux 0
    > line vty 0 4
    > login
    > !
    > end
    >
    > twenty#
    >
    >
    >
    >
    > ================
    > And heres the output of
    >
    > twenty#sh ip eigrp ne
    > IP-EIGRP neighbors for process 100
    > H Address Interface Hold Uptime SRTT RTO Q
    > Seq
    > (sec) (ms) Cnt
    > Num
    > 0 10.0.10.10 To0 10 00:16:16 446 2676 0 2
    > twenty#
    >
    >
    > which shows the only neighbor seen across the tokenring hub.
    >
    > Any ideas?
    scott enwright, Jan 1, 2004
    #2
    1. Advertising

  3. Ghazan Haider

    Tosh Guest

    > Any ideas?

    Maybe is a summarization issue.
    Have you tried to disable it with:
    "no eigrp auto-summary"?
    Bye,
    Tosh.
    Tosh, Jan 1, 2004
    #3
  4. > Configuration looks ok from what I can tell. I'd be very interested in
    > seeing the output from the commands:
    >
    > ping 10.0.22.40
    > ping 10.0.20.10
    > debug ip eigrp 100
    > debug ip eigrp neighbor 100 10.0.22.40
    > debug ip eigrp neighbor 100 10.0.20.10
    > debug eigrp packets
    >


    The following is what you asked for. Particularly interesting is sh ip
    eigrp nei, which only shows one neighbor across a tokenring hub but
    none across the serial links (all pingable), and yet the config that I
    printed at the end specifies the individual neighbors. Also check the
    routing table, which shows links across the tokenring only. I can see
    HELLO packets from the TR hub, but not serial ports.


    twenty#
    twenty#ping 10.0.22.40

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.22.40, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
    twenty#ping 10.0.20.10

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.0.20.10, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
    twenty#debug ip eigrp 100
    % Incomplete command.

    twenty#
    twenty#debug ip ei
    twenty#debug ip eigrp
    IP-EIGRP Route Events debugging is on
    twenty#no debug all
    All possible debugging has been turned off
    twenty#debug ip eigrp nei 100 10.0.20.10
    First enable IP-EIGRP Route Events or EIGRP packet debug
    twenty#no debug all
    All possible debugging has been turned off
    twenty#debug ip eigrp
    IP-EIGRP Route Events debugging is on
    twenty#debug ip eigrp nei 100 10.0.20.10
    IP Neighbor target enabled on AS 100 for 10.0.20.10
    IP-EIGRP Neighbor Target Events debugging is on
    twenty#
    twenty#
    twenty#! 3 minutes later..
    twenty#no debug all
    All possible debugging has been turned off
    twenty#sh ip proto
    Routing Protocol is "eigrp 100"
    Outgoing update filter list for all interfaces is
    Incoming update filter list for all interfaces is
    Default networks flagged in outgoing updates
    Default networks accepted from incoming updates
    EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    EIGRP maximum hopcount 100
    EIGRP maximum metric variance 1
    Redistributing: eigrp 100
    Automatic network summarization is in effect
    Routing for Networks:
    10.0.0.0
    Routing Information Sources:
    Gateway Distance Last Update
    10.0.10.10 90 19:48:50
    Distance: internal 90 external 170

    twenty#sh ip eigrp nei
    twenty#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q
    Seq
    (sec) (ms) Cnt
    Num
    0 10.0.10.10 To0 11 19:49:05 446 2676 0 2
    twenty#
    twenty#wr t
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname twenty
    !
    !
    ip subnet-zero
    !
    !
    !
    interface Serial0
    ip address 10.0.20.20 255.255.255.0
    no ip directed-broadcast
    encapsulation x25
    no ip mroute-cache
    no keepalive
    x25 address 200
    x25 map ip 10.0.20.10 100
    clockrate 4000000
    no cdp enable
    !
    interface Serial1
    ip address 10.0.22.20 255.255.255.0
    no ip directed-broadcast
    encapsulation x25 dce
    no ip mroute-cache
    x25 address 201
    x25 map ip 10.0.22.40 401
    no cdp enable
    !
    interface TokenRing0
    ip address 10.0.10.20 255.255.255.0
    no ip directed-broadcast
    ring-speed 16
    no cdp enable
    !
    interface TokenRing1
    ip address 10.0.13.20 255.255.255.0
    no ip directed-broadcast
    ring-speed 16
    no cdp enable
    !
    router eigrp 100
    network 10.0.0.0
    neighbor 10.0.22.40
    neighbor 10.0.20.10
    !
    ip classless
    !
    no cdp run
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    login
    !
    end

    twenty#
    twenty#sh ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
    BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
    candidate default
    U - per-user static route, o - ODR

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    C 10.0.10.0 is directly connected, TokenRing0
    D 10.0.11.0 [90/297728] via 10.0.10.10, 19:50:54, TokenRing0
    C 10.0.22.0 is directly connected, Serial1
    C 10.0.20.0 is directly connected, Serial0
    D 10.0.21.0 [90/2185984] via 10.0.10.10, 19:50:54, TokenRing0
    twenty#
    Ghazan Haider, Jan 2, 2004
    #4
  5. "Tosh" <> wrote in message news:<bt1irn$2ccop$-berlin.de>...
    > > Any ideas?

    >
    > Maybe is a summarization issue.
    > Have you tried to disable it with:
    > "no eigrp auto-summary"?
    > Bye,
    > Tosh.


    Well I should at least be able to see the neighbors and see their
    HELLO packets in that case. the EIGRP engine completely disregards
    communication across nonbroadcast links for some reason, and it works
    well with IGRP.
    Ghazan Haider, Jan 2, 2004
    #5
  6. Ghazan Haider

    John Agosta Guest

    Try adding a 'broadcast' argument to the x25 map
    statements....



    "scott enwright" <0spam.net.au> wrote in
    message news:tJWIb.73217$...
    > Ghazan,
    >
    > Configuration looks ok from what I can tell. I'd be very interested in
    > seeing the output from the commands:
    >
    > ping 10.0.22.40
    > ping 10.0.20.10
    > debug ip eigrp 100
    > debug ip eigrp neighbor 100 10.0.22.40
    > debug ip eigrp neighbor 100 10.0.20.10
    > debug eigrp packets
    >
    > Regards,
    >
    > Scott.
    >
    > "Ghazan Haider" <> wrote in message
    > news:...
    > > I have a reasonably complex network where EIGRP apparently fails to
    > > see neighbors on nonbroadcast interfaces despite the 'neighbor
    > > x.x.x.x' specification. This works perfect with IGRP. (yeah I know
    > > routing protocols dont broadcast on nonbroadcast interfaces and
    > > neighbor has to be specified).
    > >
    > > 'sh ip eig nei' shows no neighbors on routers with X25 interfaces
    > > only, and only shows ethernet/tr neighbors on routers with such
    > > connections.
    > >
    > > I have been studying using the sybex CCNP BSCI book, and it shows
    > > configs of EIGRP on serial interfaces that should 'work' normal... as
    > > in conf t, router eigrp 100, network 10.0.10.0, neighbor 10.0.10.3,
    > > etc... and my configs arent too different from it. Heres one routers
    > > config. Routers connected on all its interfaces have EIGRP of the same
    > > AS:
    > >
    > > Current configuration:
    > > !
    > > version 12.0
    > > service timestamps debug uptime
    > > service timestamps log uptime
    > > no service password-encryption
    > > !
    > > hostname twenty
    > > !
    > > !
    > > ip subnet-zero
    > > !
    > > !
    > > !
    > > interface Serial0
    > > ip address 10.0.20.20 255.255.255.0
    > > no ip directed-broadcast
    > > encapsulation x25
    > > no ip mroute-cache
    > > no keepalive
    > > x25 address 200
    > > x25 map ip 10.0.20.10 100
    > > clockrate 4000000
    > > no cdp enable
    > > !
    > > interface Serial1
    > > ip address 10.0.22.20 255.255.255.0
    > > no ip directed-broadcast
    > > encapsulation x25 dce
    > > no ip mroute-cache
    > > x25 address 201
    > > x25 map ip 10.0.22.40 401
    > > no cdp enable
    > > !
    > > interface TokenRing0
    > > ip address 10.0.10.20 255.255.255.0
    > > no ip directed-broadcast
    > > ring-speed 16
    > > no cdp enable
    > > !
    > > interface TokenRing1
    > > ip address 10.0.13.20 255.255.255.0
    > > no ip directed-broadcast
    > > ring-speed 16
    > > no cdp enable
    > > !
    > > router eigrp 100
    > > network 10.0.0.0
    > > neighbor 10.0.22.40
    > > neighbor 10.0.20.10
    > > !
    > > ip classless
    > > !
    > > no cdp run
    > > !
    > > line con 0
    > > transport input none
    > > line aux 0
    > > line vty 0 4
    > > login
    > > !
    > > end
    > >
    > > twenty#
    > >
    > >
    > >
    > >
    > > ================
    > > And heres the output of
    > >
    > > twenty#sh ip eigrp ne
    > > IP-EIGRP neighbors for process 100
    > > H Address Interface Hold Uptime SRTT RTO Q
    > > Seq
    > > (sec) (ms) Cnt
    > > Num
    > > 0 10.0.10.10 To0 10 00:16:16 446 2676 0 2
    > > twenty#
    > >
    > >
    > > which shows the only neighbor seen across the tokenring hub.
    > >
    > > Any ideas?

    >
    >
    John Agosta, Jan 2, 2004
    #6
  7. Ghazan Haider

    Hansang Bae Guest

    In article <>,
    says...
    > Well I should at least be able to see the neighbors and see their
    > HELLO packets in that case. the EIGRP engine completely disregards
    > communication across nonbroadcast links for some reason, and it works
    > well with IGRP.


    There were (are?) versions of IOS that completely disregarded the
    "NEIGHBOR" statement when used under EIGRP.


    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Jan 2, 2004
    #7
  8. Hello Hansang...

    I have:
    11.0
    12.0
    11.1
    ....for 2500 routers and

    12.1 for 1600.

    It is the 2500 routers, all 5 of em that exhibit that prob. I did
    think of the IOS version, but can this problem be on 3 different IOS
    versions? I was sure I must have been missing something, or have
    something in the configs, or perhaps theres something particular that
    is required for X25 and EIGRP to work.

    By the way, RIP, IGRP, OSPF and ISIS all work fine across X25 using
    neighbor on the 2500 routers.. just checked.



    Hansang Bae <> wrote in message news:<>...
    > In article <>,
    > says...
    > > Well I should at least be able to see the neighbors and see their
    > > HELLO packets in that case. the EIGRP engine completely disregards
    > > communication across nonbroadcast links for some reason, and it works
    > > well with IGRP.

    >
    > There were (are?) versions of IOS that completely disregarded the
    > "NEIGHBOR" statement when used under EIGRP.
    >
    >
    > --
    >
    > hsb
    >
    > "Somehow I imagined this experience would be more rewarding" Calvin
    > *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    > ********************************************************************
    > Due to the volume of email that I receive, I may not not be able to
    > reply to emails sent to my account. Please post a followup instead.
    > ********************************************************************
    Ghazan Haider, Jan 2, 2004
    #8
  9. John,

    You hit the nail on the head! I've just run the configuration supplied up
    on several routers and before adding the 'broadcast' option the following is
    displayed during EIGRP connectivity:

    00:22:57: IP: s=10.0.20.20 (local), d=224.0.0.10 (Serial0), len 60, sending
    broad/multicast
    00:22:57: IP: s=10.0.20.20 (local), d=224.0.0.10 (Serial0), len 60,
    encapsulation failed

    After adding the braodcast option the routes show up just fine.

    twenty#sh ip ro
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
    default
    U - per-user static route, o - ODR

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    C 10.0.10.0 is directly connected, Ethernet0
    C 10.0.13.0 is directly connected, Loopback1
    D 10.99.99.0 [90/2297856] via 10.0.20.10, 00:06:35, Serial0
    D 10.88.88.0 [90/2195456] via 10.0.20.10, 00:07:55, Serial0
    C 10.0.20.0 is directly connected, Serial0

    Regards,

    Scott.
    \|/
    (o o)
    ---------------------oOOO--(_)--OOOo----------------------
    Out the 100Base-T, off the firewall, through the router, down
    the T1, over the leased line, off the bridge, nothing but Net.
    (Use ROT13 to see my email address)
    .oooO Oooo.
    ----------------------( )---( )-----------------------
    \ ( ) /
    \_) (_/


    "John Agosta" <j_agosta@remove_wideopenwest.kom> wrote in message
    news:...
    > Try adding a 'broadcast' argument to the x25 map
    > statements....
    >
    >
    >
    > "scott enwright" <0spam.net.au> wrote in
    > message news:tJWIb.73217$...
    > > Ghazan,
    > >
    > > Configuration looks ok from what I can tell. I'd be very interested in
    > > seeing the output from the commands:
    > >
    > > ping 10.0.22.40
    > > ping 10.0.20.10
    > > debug ip eigrp 100
    > > debug ip eigrp neighbor 100 10.0.22.40
    > > debug ip eigrp neighbor 100 10.0.20.10
    > > debug eigrp packets
    > >
    > > Regards,
    > >
    > > Scott.
    > >
    > > "Ghazan Haider" <> wrote in message
    > > news:...
    > > > I have a reasonably complex network where EIGRP apparently fails to
    > > > see neighbors on nonbroadcast interfaces despite the 'neighbor
    > > > x.x.x.x' specification. This works perfect with IGRP. (yeah I know
    > > > routing protocols dont broadcast on nonbroadcast interfaces and
    > > > neighbor has to be specified).
    > > >
    > > > 'sh ip eig nei' shows no neighbors on routers with X25 interfaces
    > > > only, and only shows ethernet/tr neighbors on routers with such
    > > > connections.
    > > >
    > > > I have been studying using the sybex CCNP BSCI book, and it shows
    > > > configs of EIGRP on serial interfaces that should 'work' normal... as
    > > > in conf t, router eigrp 100, network 10.0.10.0, neighbor 10.0.10.3,
    > > > etc... and my configs arent too different from it. Heres one routers
    > > > config. Routers connected on all its interfaces have EIGRP of the same
    > > > AS:
    > > >
    > > > Current configuration:
    > > > !
    > > > version 12.0
    > > > service timestamps debug uptime
    > > > service timestamps log uptime
    > > > no service password-encryption
    > > > !
    > > > hostname twenty
    > > > !
    > > > !
    > > > ip subnet-zero
    > > > !
    > > > !
    > > > !
    > > > interface Serial0
    > > > ip address 10.0.20.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > encapsulation x25
    > > > no ip mroute-cache
    > > > no keepalive
    > > > x25 address 200
    > > > x25 map ip 10.0.20.10 100
    > > > clockrate 4000000
    > > > no cdp enable
    > > > !
    > > > interface Serial1
    > > > ip address 10.0.22.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > encapsulation x25 dce
    > > > no ip mroute-cache
    > > > x25 address 201
    > > > x25 map ip 10.0.22.40 401
    > > > no cdp enable
    > > > !
    > > > interface TokenRing0
    > > > ip address 10.0.10.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > ring-speed 16
    > > > no cdp enable
    > > > !
    > > > interface TokenRing1
    > > > ip address 10.0.13.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > ring-speed 16
    > > > no cdp enable
    > > > !
    > > > router eigrp 100
    > > > network 10.0.0.0
    > > > neighbor 10.0.22.40
    > > > neighbor 10.0.20.10
    > > > !
    > > > ip classless
    > > > !
    > > > no cdp run
    > > > !
    > > > line con 0
    > > > transport input none
    > > > line aux 0
    > > > line vty 0 4
    > > > login
    > > > !
    > > > end
    > > >
    > > > twenty#
    > > >
    > > >
    > > >
    > > >
    > > > ================
    > > > And heres the output of
    > > >
    > > > twenty#sh ip eigrp ne
    > > > IP-EIGRP neighbors for process 100
    > > > H Address Interface Hold Uptime SRTT RTO Q
    > > > Seq
    > > > (sec) (ms) Cnt
    > > > Num
    > > > 0 10.0.10.10 To0 10 00:16:16 446 2676 0 2
    > > > twenty#
    > > >
    > > >
    > > > which shows the only neighbor seen across the tokenring hub.
    > > >
    > > > Any ideas?

    > >
    > >

    >
    >
    scott enwright, Jan 2, 2004
    #9
  10. Ghazan Haider

    Hansang Bae Guest

    In article <>,
    says...
    > Hello Hansang...
    >
    > I have:
    > 11.0
    > 12.0
    > 11.1
    > ...for 2500 routers and
    >
    > 12.1 for 1600.
    >
    > It is the 2500 routers, all 5 of em that exhibit that prob. I did
    > think of the IOS version, but can this problem be on 3 different IOS
    > versions? I was sure I must have been missing something, or have
    > something in the configs, or perhaps theres something particular that
    > is required for X25 and EIGRP to work.
    >
    > By the way, RIP, IGRP, OSPF and ISIS all work fine across X25 using
    > neighbor on the 2500 routers.. just checked.



    Well, then as a last ditch effort, you could try adding the keyword
    "broadcast" on your x25 map statement (as John suggested). The neighbor
    keyword is supposed to use unicast, so I wouldn't think you would need
    it, but who knows. I guess if you can afford to run debug, you can see
    what packets are going out there.



    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Jan 2, 2004
    #10
  11. John,

    You hit the nail on the head! I've just run the configuration supplied up
    on several routers and before adding the 'broadcast' option the following is
    displayed during EIGRP connectivity:

    00:22:57: IP: s=10.0.20.20 (local), d=224.0.0.10 (Serial0), len 60, sending
    broad/multicast
    00:22:57: IP: s=10.0.20.20 (local), d=224.0.0.10 (Serial0), len 60,
    encapsulation failed

    After adding the braodcast option the routes show up just fine.

    twenty#sh ip ro
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
    default
    U - per-user static route, o - ODR

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 5 subnets
    C 10.0.10.0 is directly connected, Ethernet0
    C 10.0.13.0 is directly connected, Loopback1
    D 10.99.99.0 [90/2297856] via 10.0.20.10, 00:06:35, Serial0
    D 10.88.88.0 [90/2195456] via 10.0.20.10, 00:07:55, Serial0
    C 10.0.20.0 is directly connected, Serial0

    Regards,

    Scott.
    \|/
    (o o)
    ---------------------oOOO--(_)--OOOo----------------------
    Out the 100Base-T, off the firewall, through the router, down
    the T1, over the leased line, off the bridge, nothing but Net.
    (Use ROT13 to see my email address)
    .oooO Oooo.
    ----------------------( )---( )-----------------------
    \ ( ) /
    \_) (_/


    "John Agosta" <j_agosta@remove_wideopenwest.kom> wrote in message
    news:...
    > Try adding a 'broadcast' argument to the x25 map
    > statements....
    >
    >
    >
    > "scott enwright" <0spam.net.au> wrote in
    > message news:tJWIb.73217$...
    > > Ghazan,
    > >
    > > Configuration looks ok from what I can tell. I'd be very interested in
    > > seeing the output from the commands:
    > >
    > > ping 10.0.22.40
    > > ping 10.0.20.10
    > > debug ip eigrp 100
    > > debug ip eigrp neighbor 100 10.0.22.40
    > > debug ip eigrp neighbor 100 10.0.20.10
    > > debug eigrp packets
    > >
    > > Regards,
    > >
    > > Scott.
    > >
    > > "Ghazan Haider" <> wrote in message
    > > news:...
    > > > I have a reasonably complex network where EIGRP apparently fails to
    > > > see neighbors on nonbroadcast interfaces despite the 'neighbor
    > > > x.x.x.x' specification. This works perfect with IGRP. (yeah I know
    > > > routing protocols dont broadcast on nonbroadcast interfaces and
    > > > neighbor has to be specified).
    > > >
    > > > 'sh ip eig nei' shows no neighbors on routers with X25 interfaces
    > > > only, and only shows ethernet/tr neighbors on routers with such
    > > > connections.
    > > >
    > > > I have been studying using the sybex CCNP BSCI book, and it shows
    > > > configs of EIGRP on serial interfaces that should 'work' normal... as
    > > > in conf t, router eigrp 100, network 10.0.10.0, neighbor 10.0.10.3,
    > > > etc... and my configs arent too different from it. Heres one routers
    > > > config. Routers connected on all its interfaces have EIGRP of the same
    > > > AS:
    > > >
    > > > Current configuration:
    > > > !
    > > > version 12.0
    > > > service timestamps debug uptime
    > > > service timestamps log uptime
    > > > no service password-encryption
    > > > !
    > > > hostname twenty
    > > > !
    > > > !
    > > > ip subnet-zero
    > > > !
    > > > !
    > > > !
    > > > interface Serial0
    > > > ip address 10.0.20.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > encapsulation x25
    > > > no ip mroute-cache
    > > > no keepalive
    > > > x25 address 200
    > > > x25 map ip 10.0.20.10 100
    > > > clockrate 4000000
    > > > no cdp enable
    > > > !
    > > > interface Serial1
    > > > ip address 10.0.22.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > encapsulation x25 dce
    > > > no ip mroute-cache
    > > > x25 address 201
    > > > x25 map ip 10.0.22.40 401
    > > > no cdp enable
    > > > !
    > > > interface TokenRing0
    > > > ip address 10.0.10.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > ring-speed 16
    > > > no cdp enable
    > > > !
    > > > interface TokenRing1
    > > > ip address 10.0.13.20 255.255.255.0
    > > > no ip directed-broadcast
    > > > ring-speed 16
    > > > no cdp enable
    > > > !
    > > > router eigrp 100
    > > > network 10.0.0.0
    > > > neighbor 10.0.22.40
    > > > neighbor 10.0.20.10
    > > > !
    > > > ip classless
    > > > !
    > > > no cdp run
    > > > !
    > > > line con 0
    > > > transport input none
    > > > line aux 0
    > > > line vty 0 4
    > > > login
    > > > !
    > > > end
    > > >
    > > > twenty#
    > > >
    > > >
    > > >
    > > >
    > > > ================
    > > > And heres the output of
    > > >
    > > > twenty#sh ip eigrp ne
    > > > IP-EIGRP neighbors for process 100
    > > > H Address Interface Hold Uptime SRTT RTO Q
    > > > Seq
    > > > (sec) (ms) Cnt
    > > > Num
    > > > 0 10.0.10.10 To0 10 00:16:16 446 2676 0 2
    > > > twenty#
    > > >
    > > >
    > > > which shows the only neighbor seen across the tokenring hub.
    > > >
    > > > Any ideas?

    > >
    > >

    >
    >




    --
    Regards,

    Scott.
    \|/
    (o o)
    ---------------------oOOO--(_)--OOOo----------------------
    Out the 100Base-T, off the firewall, through the router, down
    the T1, over the leased line, off the bridge, nothing but Net.
    (Use ROT13 to see my email address)
    .oooO Oooo.
    ----------------------( )---( )-----------------------
    \ ( ) /
    \_) (_/


    "Ghazan Haider" <> wrote in message
    news:...
    > Hello Hansang...
    >
    > I have:
    > 11.0
    > 12.0
    > 11.1
    > ...for 2500 routers and
    >
    > 12.1 for 1600.
    >
    > It is the 2500 routers, all 5 of em that exhibit that prob. I did
    > think of the IOS version, but can this problem be on 3 different IOS
    > versions? I was sure I must have been missing something, or have
    > something in the configs, or perhaps theres something particular that
    > is required for X25 and EIGRP to work.
    >
    > By the way, RIP, IGRP, OSPF and ISIS all work fine across X25 using
    > neighbor on the 2500 routers.. just checked.
    >
    >
    >
    > Hansang Bae <> wrote in message

    news:<>...
    > > In article <>,
    > > says...
    > > > Well I should at least be able to see the neighbors and see their
    > > > HELLO packets in that case. the EIGRP engine completely disregards
    > > > communication across nonbroadcast links for some reason, and it works
    > > > well with IGRP.

    > >
    > > There were (are?) versions of IOS that completely disregarded the
    > > "NEIGHBOR" statement when used under EIGRP.
    > >
    > >
    > > --
    > >
    > > hsb
    > >
    > > "Somehow I imagined this experience would be more rewarding" Calvin
    > > *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    > > ********************************************************************
    > > Due to the volume of email that I receive, I may not not be able to
    > > reply to emails sent to my account. Please post a followup instead.
    > > ********************************************************************
    scott enwright, Jan 3, 2004
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Kenny D
    Replies:
    1
    Views:
    1,200
    Alois Heilmaier
    Jul 14, 2003
  2. Sam Soh
    Replies:
    5
    Views:
    7,968
    Sam Soh
    Aug 15, 2003
  3. Hansang Bae

    Re: EiGRP authentication question

    Hansang Bae, Oct 14, 2003, in forum: Cisco
    Replies:
    3
    Views:
    1,164
    Hansang Bae
    Oct 16, 2003
  4. BG
    Replies:
    3
    Views:
    6,568
  5. Replies:
    3
    Views:
    838
    Andre
    Jan 9, 2007
Loading...

Share This Page