EasyVPN with two Cisco Pix 501

Discussion in 'Cisco' started by Hunv, May 20, 2010.

  1. Hunv

    Hunv

    Joined:
    May 20, 2010
    Messages:
    1
    Hi,

    since a few days I configure my Pixes to connect them with a VPN. I try to do this with EasyVPN. (BTW: I am an absolute Newbee)
    At the moment I try this:
    Each Pix in an own subnet.
    Finally I want this:
    Both Pixes connected via VPN, inside Interfaces are in the same Network.
    But at the moment I try the first one.

    I used this help to configure the pixes:
    cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a008019e6d7.shtml

    In my test environment I have the following configuration
    Pix 1, EasyVPN Server:
    Outside: 192.168.0.240 (one static network IP)
    Inside: 192.168.90.220

    Pix 2, EasyVPN Remote Client:
    Outside: 192.168.0.245
    Inside: 192.168.128.220

    The Problem is, that the second Pix does not connect to the first Pix. With the Software Cisco VPN Client I am able to connect to the first Pix from a PC. From there I cannot ping anything in the 90er network but that is the next problem ;)

    Maybe someone see my mistake(s) and may answer.
    Thanks!

    Here are my configs:
    Pix1:
    Code:
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname kr01icr02
    domain-name testcenter.home
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 110 permit ip 192.168.90.0 255.255.255.0 192.168.128.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.0.240 255.255.255.0
    ip address inside 192.168.90.220 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool ippool 192.168.90.10-192.168.90.99
    pdm location 192.168.90.0 255.255.255.0 inside
    pdm location 192.168.0.0 255.255.255.0 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list 110
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 192.168.0.250 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.0.0 255.255.255.0 outside
    http 192.168.90.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set myset esp-des esp-md5-hmac
    crypto dynamic-map dynmap 10 set transform-set myset
    crypto map mymap 10 ipsec-isakmp dynamic dynmap
    crypto map mymap interface outside
    isakmp enable outside
    isakmp identity address
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption des
    isakmp policy 10 hash md5
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    vpngroup mygroup address-pool ippool
    vpngroup mygroup dns-server 192.168.90.1
    vpngroup mygroup wins-server 192.168.90.1
    vpngroup mygroup default-domain testcenter.home
    vpngroup mygroup split-tunnel 110
    vpngroup mygroup idle-time 1800
    vpngroup mygroup password ********
    telnet 192.168.0.0 255.255.255.0 outside
    telnet 192.168.90.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.0.0 255.255.255.0 outside
    ssh 192.168.90.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    username admin password OEUgP/2bvWvSS4qQ encrypted privilege 15
    terminal width 80
    
    Pix2:
    Code:
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname kr01icr03
    domain-name testcenter.home
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 192.168.0.245 255.255.255.0
    ip address inside 192.168.128.220 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.128.0 255.255.255.0 inside
    pdm location 192.168.0.0 255.255.255.0 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.0.0 255.255.255.0 outside
    http 192.168.128.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 192.168.0.0 255.255.255.0 outside
    telnet 192.168.128.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.0.0 255.255.255.0 outside
    ssh 192.168.128.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    username admin password OEUgP/2bvWvSS4qQ encrypted privilege 15
    vpnclient server 192.168.0.240
    vpnclient mode network-extension-mode
    vpnclient vpngroup mygroup password ********
    vpnclient enable
    terminal width 80
    
    Last edited: May 20, 2010
    Hunv, May 20, 2010
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Squigs
    Replies:
    3
    Views:
    4,001
    Squigs
    Aug 24, 2004
  2. John Balch
    Replies:
    3
    Views:
    731
    John Balch
    Sep 24, 2004
  3. Mark Lawrence

    Easyvpn Client + Concentrator 3000

    Mark Lawrence, Mar 15, 2005, in forum: Cisco
    Replies:
    0
    Views:
    554
    Mark Lawrence
    Mar 15, 2005
  4. nicough@gmail.com

    Cisco PIX EasyVPN site2site - Restrict traffic

    nicough@gmail.com, Dec 6, 2006, in forum: Cisco
    Replies:
    0
    Views:
    444
    nicough@gmail.com
    Dec 6, 2006
  5. tingcomic

    setup easyVPN beind NAT

    tingcomic, Feb 15, 2008, in forum: Cisco
    Replies:
    0
    Views:
    497
    tingcomic
    Feb 15, 2008
Loading...

Share This Page