Dual NAT of Port 80?

Discussion in 'Cisco' started by Peter Rowe, Nov 5, 2003.

  1. Peter Rowe

    Peter Rowe Guest

    Hi there,

    I have a 2 interface router with 2 Internet compliant IP addresses on the Eth0 interface (lets say int1 and int2) and a single private IP on the FastEthernet Interface.

    I have tried to use NAT ie

    IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable

    and

    IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable

    But it doesn't work when accessing http://**int2** , however Http://**int1** works OK, can anyone tell me how to accomplish the NAT to 2 different internal IP's?

    Thanks,

    Peter.
    Peter Rowe, Nov 5, 2003
    #1
    1. Advertising

  2. Peter Rowe

    Peter Rowe Guest

    OK forget it, I was doing something stupid. It's working no problem now.

    p.

    >>> Peter Rowe<> 05/11/2003 12:07:41 >>>

    Hi there,

    I have a 2 interface router with 2 Internet compliant IP addresses on the Eth0 interface (lets say int1 and int2) and a single private IP on the FastEthernet Interface.

    I have tried to use NAT ie

    IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable

    and

    IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable

    But it doesn't work when accessing http://**int2** , however http://**int1** works OK, can anyone tell me how to accomplish the NAT to 2 different internal IP's?

    Thanks,

    Peter.
    Peter Rowe, Nov 5, 2003
    #2
    1. Advertising

  3. Peter Rowe

    Geert Nijs Guest

    You are trying to 'dual home' your web server to two ISPs. This is possible
    in newer IOS versions.
    You need NAT and route-maps for this.

    A sample configuration:
    Enabling Static NAT Route Mapping Example
    The following example shows the use of route mapping with static NAT
    translations:

    interface Ethernet3
    ip address 172.68.1.100 255.255.255.0
    ip nat outside
    media-type 10BaseT
    !
    interface Ethernet4
    ip address 192.68.1.100 255.255.255.0
    ip nat outside
    media-type 10BaseT
    !
    interface Ethernet5
    ip address 11.1.1.100 255.255.255.0
    ip nat inside
    media-type 10BaseT
    !
    router rip
    network 172.68.0.0
    network 192.68.1.0
    !
    ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
    ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
    ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
    ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
    access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
    access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
    !
    route-map isp2 permit 10
    match ip address 102
    set ip next-hop 192.68.1.1
    !
    route-map isp1 permit 10
    match ip address 101
    set ip next-hop 172.68.1.1


    You can find more at:

    http://www.cisco.com/en/US/partner/...9/products_feature_guide09186a0080087bac.html


    "Peter Rowe" <> schreef in bericht
    news:boap6g$qfe$...
    > Hi there,
    >
    > I have a 2 interface router with 2 Internet compliant IP addresses on the

    Eth0 interface (lets say int1 and int2) and a single private IP on the
    FastEthernet Interface.
    >
    > I have tried to use NAT ie
    >
    > IP NAT INSIDE SOURCE STATIC TCP 192.168.0.1 80 **Int1** 80 Extendable
    >
    > and
    >
    > IP NAT INSIDE SOURCE STATIC TCP 192.168.0.13 80 **int2** 80 Extendable
    >
    > But it doesn't work when accessing http://**int2** , however

    Http://**int1** works OK, can anyone tell me how to accomplish the NAT to
    2 different internal IP's?
    >
    > Thanks,
    >
    > Peter.
    Geert Nijs, Nov 5, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dennis Breithaupt
    Replies:
    9
    Views:
    10,060
    andrewned
    Aug 21, 2007
  2. Toby
    Replies:
    65
    Views:
    1,612
    Michael-NC
    Apr 22, 2004
  3. Paul
    Replies:
    0
    Views:
    685
  4. Replies:
    1
    Views:
    1,035
    News Reader
    Jul 30, 2008
  5. Martin Gallagher
    Replies:
    0
    Views:
    508
    Martin Gallagher
    Nov 27, 2012
Loading...

Share This Page