DTMF problem

Discussion in 'UK VOIP' started by Malcolm Loades, Mar 14, 2012.

  1. I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    but suddenly have a problem with DTMF tones not being recognised when
    I'm offered menu options on the number I've dialled.

    Ideas please.

    Malcolm
    Malcolm Loades, Mar 14, 2012
    #1
    1. Advertising

  2. Malcolm Loades

    Graham. Guest

    On Wed, 14 Mar 2012 20:13:40 +0000, Malcolm Loades <>
    wrote:

    >I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    >but suddenly have a problem with DTMF tones not being recognised when
    >I'm offered menu options on the number I've dialled.
    >
    >Ideas please.
    >
    >Malcolm


    Try setting the DTMF mode on the Fritz! to INBAND

    --
    Graham.
    %Profound_observation%
    Graham., Mar 14, 2012
    #2
    1. Advertising

  3. In message <>, Graham.
    <> writes
    >On Wed, 14 Mar 2012 20:13:40 +0000, Malcolm Loades <>
    >wrote:
    >
    >>I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    >>but suddenly have a problem with DTMF tones not being recognised when
    >>I'm offered menu options on the number I've dialled.
    >>
    >>Ideas please.
    >>
    >>Malcolm

    >
    >Try setting the DTMF mode on the Fritz! to INBAND
    >

    A google done before posting suggested this but I can't find anywhere in
    the Fritzbox settings to do this. Is it possible to do this with a
    Fritzbox?

    Malcolm
    Malcolm Loades, Mar 14, 2012
    #3
  4. Malcolm Loades

    Roger Guest

    On 14/03/2012 20:13, Malcolm Loades wrote:
    > I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    > but suddenly have a problem with DTMF tones not being recognised when
    > I'm offered menu options on the number I've dialled.
    >
    > Ideas please.
    >
    > Malcol

    On your fritzbox edit the internet telephone number and change the DTMF
    transmission to in-band . If that doesnt work try the other options in
    the list.
    Roger, Mar 14, 2012
    #4
  5. Malcolm Loades

    Roger Guest

    On 14/03/2012 20:44, Malcolm Loades wrote:
    > In message <>, Graham.
    > <> writes
    >> On Wed, 14 Mar 2012 20:13:40 +0000, Malcolm Loades <>
    >> wrote:
    >>
    >>> I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    >>> but suddenly have a problem with DTMF tones not being recognised when
    >>> I'm offered menu options on the number I've dialled.
    >>>
    >>> Ideas please.
    >>>
    >>> Malcolm

    >>
    >> Try setting the DTMF mode on the Fritz! to INBAND
    >>

    > A google done before posting suggested this but I can't find anywhere in
    > the Fritzbox settings to do this. Is it possible to do this with a
    > Fritzbox?
    >
    > Malcolm

    on my 7170 its

    Settings -> Telephony -> Internet Telephony

    then click on the edit icon (pencil and paper) next to the line you want
    to change the settings on
    Roger, Mar 14, 2012
    #5
  6. In message <Aq78r.164903$2>, Roger
    <> writes
    >On 14/03/2012 20:13, Malcolm Loades wrote:
    >> I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    >> but suddenly have a problem with DTMF tones not being recognised when
    >> I'm offered menu options on the number I've dialled.
    >>
    >> Ideas please.
    >>
    >> Malcol

    >On your fritzbox edit the internet telephone number and change the DTMF
    >transmission to in-band . If that doesnt work try the other options in
    >the list.
    >

    There is no such option on the edit internet telephone number. See
    www.http://loades.net/fritz.jpg

    I'm not sure which Fritzbox model I have. The label on the bottom of it
    doesn't give a 7170 type model number - it says AVM02046. I bought it
    from Sipgate in the UK about 5 years ago, it is wireless with a single
    antenna, 2 analogue phone ports and 1 network cable port - no ISDN. The
    Overview screen is headed "FRITZ!Box Fon WLAN Annex A, Firmware version
    08.04.26".

    Malcolm
    Malcolm Loades, Mar 15, 2012
    #6
  7. In message <gCacpuB$>, Malcolm Loades
    <> writes
    >In message <Aq78r.164903$2>, Roger
    ><> writes
    >>On 14/03/2012 20:13, Malcolm Loades wrote:
    >>> I've been using a Fritzbox in conjunction with JustVoip for 4 years now
    >>> but suddenly have a problem with DTMF tones not being recognised when
    >>> I'm offered menu options on the number I've dialled.
    >>>
    >>> Ideas please.
    >>>
    >>> Malcol

    >>On your fritzbox edit the internet telephone number and change the
    >>DTMF transmission to in-band . If that doesnt work try the other
    >>options in the list.
    >>

    >There is no such option on the edit internet telephone number. See
    >www.http://loades.net/fritz.jpg


    Ooops! That should read www.loades.net/fritz.jpg

    >I'm not sure which Fritzbox model I have. The label on the bottom of
    >it doesn't give a 7170 type model number - it says AVM02046. I bought
    >it from Sipgate in the UK about 5 years ago, it is wireless with a
    >single antenna, 2 analogue phone ports and 1 network cable port - no
    >ISDN. The Overview screen is headed "FRITZ!Box Fon WLAN Annex A,
    >Firmware version 08.04.26".


    But I've now solved the problem!

    I suddenly remembered that in one of my occasional bouts of rate
    checking and updating of dialling rules (if something is cheaper from
    another provider) Sipgate were some parts of a penny cheaper for 0845
    calls. So I changed the dialling rule for 0845 calls to go through
    Sipgate rather than JustVoip which I'd been using for 4+ years. I
    experimented with a switch back to JustVoip and DTMF tones are now
    recognised in menu options!

    Can anyone think why Sipgate should handle DTMF tones differently to
    JustVoip?

    Malcolm
    Malcolm Loades, Mar 15, 2012
    #7
  8. On Thu, 2012-03-15 at 16:26 +0000, Malcolm Loades wrote:
    > Can anyone think why Sipgate should handle DTMF tones differently to
    > JustVoip?


    One issue I had with AQL was that they asked for DTMF info in a
    different payload type to the one that the SIP client requested — so it
    was asymmetric. My Gigaset C475IP was broken and didn't cope with this;
    it sent the DTMF with the payload type that it expected to *receive* it
    in, not the type is should have been *sending* it with.

    A packet capture of the traffic between you and Sipgate would probably
    give a clue whether it's a similar problem, or something else.

    (Siemens never did offer an updated firmware for the C475. After months
    of chasing them, they did eventually replace it with an N300IP which
    means I no longer have a 'mute' button on the handsets, annoyingly. I
    hate closed-source crap that I can't fix.)

    Inband might work if you have a good network, but sending DTMF
    out-of-band is generally much more reliable — which is why it was
    designed to work that way.
    David Woodhouse, Mar 17, 2012
    #8
  9. On Sat, 17 Mar 2012 22:45:06 +0000, David Woodhouse <>
    wrote:

    > (Siemens never did offer an updated firmware for the C475. After months
    > of chasing them, they did eventually replace it with an N300IP which
    > means I no longer have a 'mute' button on the handsets, annoyingly. I
    > hate closed-source crap that I can't fix.)


    That must be a limitation of whichever handset type you chose. The Gigaset
    C610H cordless handset has a dedicated mute key below the # key.
    Anthony R. Gold, Apr 9, 2012
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Reza
    Replies:
    0
    Views:
    5,622
  2. Jim Brunetti
    Replies:
    0
    Views:
    543
    Jim Brunetti
    Jul 8, 2004
  3. acmoz
    Replies:
    0
    Views:
    478
    acmoz
    Sep 8, 2004
  4. Kyler Laird

    solved my BroadVoice DTMF problem

    Kyler Laird, Nov 1, 2004, in forum: VOIP
    Replies:
    0
    Views:
    1,521
    Kyler Laird
    Nov 1, 2004
  5. Replies:
    0
    Views:
    1,831
Loading...

Share This Page