DSL Line dropping, need cable pull for ATM interface to come alive

Discussion in 'Cisco' started by Dave, Dec 30, 2005.

  1. Dave

    Dave Guest

    Hi all,

    We've recently changed our WAN to use ADSL and SDSL circuits rather
    than a combination of leased lines and ISDN dialup systems.

    All seems well apart form one circuit where the installed Cisco 828
    keeps falling over. There are intermittent problems on the circuit and
    the router simply stops responding until the SDSL cable is physically
    pulled. About 30 seconds after the cable is reconnected the router
    connects and all is well again.

    It would appear that even though the circuit is ready it requires a
    cable pull or router restart to get the device going again.

    If left the router will recover but only after a 5 minute period. When
    debugging the router without any connections present the following
    messages are sent every 5 mins:

    *Mar 1 01:20:16.171: (Func: startup_timer_event, Line: 683) startup
    timer expired. 300000
    *Mar 1 01:20:16.171: %GSHDSL-6-ACTIVATION: Interface ATM0, the line is
    still not activated.
    *Mar 1 01:20:16.191: (Func: gshdsl_softreset, Line: 153) soft reset
    over

    Clearly there is a periodic timer for reactivating the ATM interface.
    Does anyone know how to change the period on this timer or have ideas
    as to how to recover from temporary circuit outages?

    Never had any such problems when using ISDN or leased line
    technologies!

    Many thanks,

    Dave

    Config as below:

    Router#show start
    Using 2106 out of 131072 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 100000 debugging
    no logging console
    no logging monitor
    enable secret *
    !
    username Router password *
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 10.1.0.1 10.1.254.254
    !
    ip dhcp pool CLIENT
    import all
    network 10.1.0.0 255.255.0.0
    default-router 10.1.0.1
    lease 0 2
    !
    ip dhcp pool CLINET
    !
    !
    !
    !
    interface Ethernet0
    * Ethernet Interface 10.1.0.1 255.255.0.0
    ip address 10.1.0.1 255.255.0.0
    ip tcp adjust-mss 1452
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    atm vc-per-vp 64
    atm ilmi-keepalive 30
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    hold-queue 224 in
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer remote-name redback
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname *
    ppp chap password *
    ppp pap sent-username * password *
    ppp ipcp dns request
    ppp ipcp wins request
    hold-queue 224 in
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    !
    logging 10.1.1.120
    dialer-list 1 protocol ip permit
    snmp-server enable traps snmp authentication linkdown linkup coldstart
    warmstart
    snmp-server enable traps tty
    !
    line con 0
    exec-timeout 120 0
    transport preferred all
    transport output all
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    login local
    length 0
    transport preferred all
    transport input all
    transport output all
    !
    scheduler max-task-time 5000
    !
    end

    Router#
     
    Dave, Dec 30, 2005
    #1
    1. Advertising

  2. Dave

    Merv Guest

    You should open a case with the Cisco TAC
     
    Merv, Dec 31, 2005
    #2
    1. Advertising

  3. Dave

    nazgulero Guest

    Hello,

    5 minutes, or 300 seconds, sounds like the VC idle-disconnect timer,
    which defaults to 300 seconds. I am not 100% sure where this timer can
    be set, try it under the pvc...I keep looking and will post if I find
    something...

    Regards,

    Naz
     
    nazgulero, Jan 2, 2006
    #3
  4. Dave

    Dave Guest

    Thanks for the replies chaps. No support contract on this device with
    Cisco so they won't let me open a TAC!

    I will have a look into the VC idle-disconnect timer. However, I'm
    thinking that the timer involved is some sort of activation timer (what
    ever that might be!) Seems to be looking to activate the interface
    every 300 seconds rather than disconnect it! Will change the VC and
    post results if the message frequency changes.

    Thanks again, Dave
     
    Dave, Jan 3, 2006
    #4
  5. Dave

    Guest

    > interface ATM0
    > atm ilmi-keepalive 30
    > dsl equipment-type CPE
    > dsl operating-mode GSHDSL symmetric annex B
    > dsl linerate AUTO


    I have only used ADSL.

    I don't understand why however I always use:

    no atm ilmi-keepalive

    Maybe a lack of response to the keepalive is dropping the line?

    One of the following should get it back

    clear int d 1
    clear int atm 0

    conf t
    int xxx !<--- d 1 or atm0 try it.
    shut
    no shut
    end
     
    , Jan 3, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. AM
    Replies:
    0
    Views:
    479
  2. hlep
    Replies:
    0
    Views:
    2,921
  3. jmgconsultants

    Kids Eye View About To Come Alive!

    jmgconsultants, Oct 2, 2006, in forum: UK VOIP
    Replies:
    21
    Views:
    937
    Ivor Jones
    Oct 12, 2006
  4. Smitha
    Replies:
    0
    Views:
    369
    Smitha
    May 28, 2007
  5. Giuen
    Replies:
    0
    Views:
    1,255
    Giuen
    Sep 12, 2008
Loading...

Share This Page